Subject: [xmpp] service name registration (was: Fwd: Re: [apps-discuss] [port-srv-reg] New Version Notification for draft-gudmundsson-dnsext-srv-clarify-00)

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 01 Jul 2010 10:54:34 -0600

This still seems to be an open issue for 3920bis.

/psa

-------- Original Message --------
Subject: Re: [apps-discuss] [port-srv-reg] New Version Notification	for
draft-gudmundsson-dnsext-srv-clarify-00
Date: Thu, 01 Jul 2010 10:52:19 -0600
From: Peter Saint-Andre <[email-masked]>
To: Joe Touch <[email-masked]>
CC: Ben Campbell <[email-masked]>, Alfred � <[email-masked]>,
[email-masked], [email-masked], [email-masked],
[email-masked]

A point of clarification...

On 6/30/10 4:01 PM, Joe Touch wrote:

> "xmpp" is does not have an Assigned Number, and is not being used 'locally', and
> was never registered with the SRV registry either. Yes, there appear to be a few
> other uses of SRV records other than for the kind of services indicated in the
> IANA ports tale or the SRV registry.

XMPP does have two registered ports (5222 and 5269) but the XMPP WG has
been waiting for the service registry issue to be settled before adding
the appropriate service name registration to the IANA considerations for
draft-ietf-xmpp-3920bis, which is currently in WGLC.

See for instance:

http://www.ietf.org/mail-archive/web/xmpp/current/msg00313.html

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Ben Campbell <[email-masked]>
Date: Wed, 7 Jul 2010 10:31:40 -0500

> This still seems to be an open issue for 3920bis.

 Is draft-ietf-tsvwg-iana-ports-06 actually in WGLC? The latest mention I can find on TSVWG is http://www.ietf.org/mail-archive/web/tsvwg/current/msg10060.html

Is every draft that registers services blocking on this?

> <Attached Message Part.txt>_______________________________________________
> xmpp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xmpp

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 07 Jul 2010 16:52:12 +0100

Hi Ben,

>Is draft-ietf-tsvwg-iana-ports-06 actually in WGLC? The latest mention I can find on TSVWG is http://www.ietf.org/mail-archive/web/tsvwg/current/msg10060.html
I can check with Lars.

>Is every draft that registers services blocking on this?
No, but there are some inconvenient restrictions on what can currently 
be registered, for example one can't register a service name with no 
port number. But this is not an issue for XMPP.