Subject: [xmpp] 3921bis - OPTIONAL threads.

From: Kevin Smith <[email-masked]>
Date: Wed, 21 Jul 2010 16:22:49 +0100

In 5.2.5, we say that threads are OPTIONAL. Earlier (5.1), we say
they're a SHOULD in the context of chats. Should we make reference to
5.1's SHOULD in 5.2.5's OPTIONAL?

/K

---

From: Peter Saint-Andre <[email-masked]>
Date: Sat, 24 Jul 2010 05:27:15 -0600

> 5.1's SHOULD in 5.2.5's OPTIONAL?

I've provisionally modified Section 5.1 to state:

   The inclusion of the <thread/> element is OPTIONAL for messages of
   type "normal", "headline", and "groupchat", and RECOMMENDED for
   messages of type "chat".

/psa