Subject: [xmpp] Consensus on dialback (was Re: dialback in 3920bis?)

From: Ben Campbell <[email-masked]>
Date: Thu, 1 Jul 2010 16:35:19 -0500

[as-chair]

Based on the conversation so far, I think it pretty safe to say that we do not have a consensus, rough or otherwise, to move dialback back into 3920bis. 

Thanks!

Ben.

On Jun 30, 2010, at 11:34 AM, Curtis King wrote:

> 
> On 2010-06-29, at 4:24 PM, Matthew Wild wrote:
> 
>> 2010/6/29 Ben Campbell <[email-masked]>:
>>> [as co-chair]
>>> 
>>> On Jun 28, 2010, at 12:48 AM, Jehan Pagès wrote:
>>> 
>>>>> 1. Have clear list consensus that such is the right approach
>>>>> 
>>>> 
>>>> I think we don't really have it.
>>> 
>>> I'm not seeing seeing such a consensus from list discussion so far. Does anyone think we _do_?
>>> 
>> 
>> I'm not in favour of moving dialback into the core spec.
> 
> +1
> 
>> We know we
>> need to move away from it (in its current form at least), it's still
>> undergoing changes (we can update it more easily as a XEP) and finally
>> I don't subscribe to the "all in one place" view - implementors (like
>> me) may be stupid, but I'm honestly capable of clicking links in
>> documents :)
> 
> +1
> 
> I found it much easier to implement rfc3920 without dailback in it and dailback itself as standalone spec.
> 
> ck
> 
> _______________________________________________
> xmpp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xmpp

---

From: Justin Karneges <[email-masked]>
Date: Thu, 1 Jul 2010 16:28:09 -0700

On Thursday 01 July 2010 14:35:19 Ben Campbell wrote:
> [as-chair]
>
> Based on the conversation so far, I think it pretty safe to say that we do
> not have a consensus, rough or otherwise, to move dialback back into
> 3920bis.

Indeed, we do not have consensus.

However, the primary reasons cited to leave dialback out of the RFC are 1) 
dialback is being deprecated, and 2) dialback is a moving target.  Not only 
are these premises amusingly in conflict, they are both false.  If we're 
going to leave it out, I think we need to work on our rationale.

-Justin

---

From: Dave Cridland <[email-masked]>
Date: Fri, 02 Jul 2010 23:54:08 +0100

> going to leave it out, I think we need to work on our rationale.

1) Traditional dialback should be deprecated - in an ideal world, we  
should be using X.509, and this is practical if underused.

2) Non-traditional forms of dialback, like "Dialback Without  
Dialback", are certainly a moving target. These may yet "undeprecate"  
dialback.

No, I think if presented accurately and precisely, the rationale  
holds just fine. FWIW, dialback's future has never been so unclear.  
:-)

Dave.
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade