Subject: [xmpp] Followup WGLC of draft-ietf-xmpp-3920bis-10

From: Ben Campbell <[email-masked]>
Date: Tue, 13 Jul 2010 14:55:59 -0500

This is a Working Group Last Call of draft-ietf-xmpp-3920bis-10. 

*** This is a followup to the previous WGLC on the same draft. If you sent previous feedback, please comment as to whether you believe your comments have been resolved. ***

The draft is available at the following URL:

http://tools.ietf.org/html/draft-ietf-xmpp-3920bis-10

The WGLC will conclude on 27 July, 2010. Please send your comments, including nits and "this is ready to go" type comments, to the authors and the working group. 

Please note that this WGLC will end during the week of IETF 78. Although it does end prior to the scheduled XMPP meeting on that Thursday, it would be extremely helpful if reviewers send feedback as early in the WGLC cycle as they can. Given the author's other life as an Apps AD, I expect he will be extremely busy during the week of the IETF meeting.

Thanks!

Ben.

---

From: Florian Zeitz <[email-masked]>
Date: Tue, 13 Jul 2010 23:43:49 +0200

> Please note that this WGLC will end during the week of IETF 78. Although it does end prior to the scheduled XMPP meeting on that Thursday, it would be extremely helpful if reviewers send feedback a…

Hi,
all my previous feedback seems to have been incorporated.
I'm a bit uneasy about the new text in section 4.4.1 though:
" If the stream peer is idle at the XMPP application layer, it is
appropriate for the entity to simply close the stream using the
handshake described under Section 4.3."
Is this really supposed to apply to both s2s and c2s streams?
I don't think it's wise to ever close a c2s stream just because it's
idle. It'll in most cases just lead to the client logging back in anyway
and might annoy the people who wanted to write a message from their
toaster, which they had forgotten does XMPP for 2 days, the moment it's
disconnected.

--
Florian Zeitz

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 13 Jul 2010 16:53:36 -0600

On 7/13/10 1:55 PM, Ben Campbell wrote:
> *** This is a followup to the previous WGLC on the same draft. If you
> sent previous feedback, please comment as to whether you believe your
> comments have been resolved. ***
> 
> The WGLC will conclude on 27 July, 2010. Please send your comments,
> including nits and "this is ready to go" type comments, to the
> authors and the working group.

Needless to say, I'm looking forward to getting this one finished!

> Please note that this WGLC will end during the week of IETF 78.
> Although it does end prior to the scheduled XMPP meeting on that
> Thursday, it would be extremely helpful if reviewers send feedback as
> early in the WGLC cycle as they can. Given the author's other life as
> an Apps AD, I expect he will be extremely busy during the week of the
> IETF meeting.

Nah, those ADs are slackers! ;-)

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 14 Jul 2010 16:35:04 -0600

> all my previous feedback seems to have been incorporated.

Excellent.

> toaster, which they had forgotten does XMPP for 2 days, the moment it's

This text is not intended to recommend or mandate closing the stream if
the peer is idle. Instead, we are trying to say that if the peer is idle
then it is acceptable for the other party to close the stream (in
accordance with local service policies or resource usage constraints or
whatever); and in this case just close the stream and don't return an error.

Perhaps there is a better way to express that thought, or perhaps you
disagree that in a c2s scenario it is ever acceptable for the server to
close the stream if the client is idle...

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Florian Zeitz <[email-masked]>
Date: Thu, 15 Jul 2010 10:52:11 +0200

On 2010-07-15 00:35 AM, Peter Saint-Andre wrote:
> > idle. It'll in most cases just lead to the client logging back in
> > anyway and might annoy the people who wanted to write a message from
> > their toaster, which they had forgotten does XMPP for 2 days, the
> > moment it's disconnected.
> 
Side note: I'm not a native speaker, so I might be very wrong, but "acceptable" is quite different from "appropriate" to me. Appropriate to me means "It's fine and normal to do this" and acceptable "It's fine to do this, but usually you don't".
Should the reason be a resource constraint sending a resource-constraint error seems more appropriate to me as it tells the client that reconnecting right away is probably not going to work...

> close the stream if the client is idle...
Frankly I don't see a situation that would make it appropriate to disconnect a client without error. Anybody feel free to convince me otherwise though.
However I'd also be fine with a rewording to the effect of your explanation above.

--
Florian Zeitz

---

From: Ben Campbell <[email-masked]>
Date: Tue, 20 Jul 2010 16:39:52 -0500

Reminder--we are half-way through this WGLC, and I've only seen a few responses.

Thanks!

Ben.

On Jul 13, 2010, at 2:55 PM, Ben Campbell wrote:

> _______________________________________________
> xmpp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xmpp