Subject: [xmpp] Fwd: [precis] spaces at end of nickname

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 01 Nov 2012 09:02:41 -0600

Feedback appreciated, on or off list.

- -------- Original Message --------
Subject: [precis] spaces at end of nickname
Date: Thu, 01 Nov 2012 08:41:55 -0600
From: Peter Saint-Andre <[email-masked]>
To: [email-masked] <[email-masked]>

In the context of groupchat rooms, most applications show a room
roster of the participants. One way to spoof nicknames is to simply
add one or more space characters at the end, because the spaces don't
show up in the interface (thus "stpeter", "stpeter " with one space at
the end, and "stpeter  " with two spaces at the end would all appear
to be the same person). This seems like an obvious hole that we can
plug by disallowing trailing (and perhaps leading) spaces in
nicknames. I'll forward this message to the SIMPLE WG and XMPP WG for
their feedback, and also raise this issue during the PRECIS WG session
next week.

Peter

_______________________________________________
precis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/precis

---

From: Kevin Smith <[email-masked]>
Date: Thu, 1 Nov 2012 15:07:47 +0000

> their feedback, and also raise this issue during the PRECIS WG session

Disallowing trailing, or leading, whitespace in any sort of identifier
seems sensible to me.

/K

---

From: Kim Alvefur <[email-masked]>
Date: Thu, 01 Nov 2012 16:39:48 +0100

> Disallowing trailing, or leading, whitespace in any sort of identifier

+1

Maybe even multiple consecutive spaces within the identifier.

Regards,
Kim "Zash" Alvefur

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 01 Nov 2012 10:58:55 -0600

On 11/1/12 9:39 AM, Kim Alvefur wrote:
>> Disallowing trailing, or leading, whitespace in any sort of
>> identifier seems sensible to me.
> 
> +1
> 

This was suggested on the SIMPLE WG list, too. I think it's a good idea.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/