Subject: [xmpp] I-D Action: draft-ietf-xmpp-dna-10.txt

From: [email-masked]
Date: Tue, 24 Mar 2015 08:50:49 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Extensible Messaging and Presence Protocol Working Group of the IETF.

        Title           : Domain Name Associations (DNA) in the Extensible Messaging and Presence Protocol (XMPP)
        Authors         : Peter Saint-Andre
                          Matthew Miller
                          Philipp Hancke
	Filename        : draft-ietf-xmpp-dna-10.txt
	Pages           : 20
	Date            : 2015-03-24

Abstract:
   This document improves the security of the Extensible Messaging and
   Presence Protocol (XMPP) in two ways.  First, it specifies how to
   establish a strong association between a domain name and an XML
   stream, using the concept of "prooftypes".  Second, it describes how
   to securely delegate a service domain name (e.g., example.com) to a
   target server host name (e.g., hosting.example.net), which is
   especially important in multi-tenanted environments where the same
   target server hosts a large number of domains.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-xmpp-dna/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-xmpp-dna-10

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-xmpp-dna-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: ⌘ Matt Miller <[email-masked]>
Date: Tue, 24 Mar 2015 10:53:05 -0500

This revision should address all of the feedback we've received.
Thanks again everyone!

- -- 
- - m&m

Matt Miller < [email-masked] >
Cisco Systems, Inc.
On 3/24/15 10:50 AM, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Extensible Messaging
> and Presence Protocol Working Group of the IETF.
> 
> Title           : Domain Name Associations (DNA) in the Extensible
> Messaging and Presence Protocol (XMPP) Authors         : Peter
> Saint-Andre Matthew Miller Philipp Hancke Filename        :
> draft-ietf-xmpp-dna-10.txt Pages           : 20 Date            :
> 2015-03-24
> 
> Abstract: This document improves the security of the Extensible
> Messaging and Presence Protocol (XMPP) in two ways.  First, it
> specifies how to establish a strong association between a domain
> name and an XML stream, using the concept of "prooftypes".  Second,
> it describes how to securely delegate a service domain name (e.g.,
> example.com) to a target server host name (e.g.,
> hosting.example.net), which is especially important in
> multi-tenanted environments where the same target server hosts a
> large number of domains.
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> _______________________________________________ I-D-Announce
> mailing list [email-masked] 
> https://www.ietf.org/mailman/listinfo/i-d-announce Internet-Draft
> directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>