Subject: Re: [xrblock] I-D Action: draft-asaeda-xrblock-rtcp-xr-synchronization-00.txt

From: Colin Perkins <[email-masked]>
Date: Thu, 9 Jun 2011 14:07:46 +0100

On 17 May 2011, at 05:39, [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : RTCP XR Blocks for Synchronization Delay and Offset Metrics Reporting
> 	Author(s)       : Hitoshi Asaeda
>                          Rachel Huang
>                          Qin Wu
> 	Filename        : draft-asaeda-xrblock-rtcp-xr-synchronization-00.txt
> 	Pages           : 8
> 	Date            : 2011-05-16
> 
>   This document defines an RTCP XR Report Block and associated SDP
>   parameters that allows the reporting of synchronization delay and
>   offset metrics for use in a range of RTP applications.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-asaeda-xrblock-rtcp-xr-synchronization-00.txt

This draft takes the synchronisation metric defined in draft-wu-xrblock-rtcp-xr-quality-monitoring-01, and breaks it out into a separate draft. This separation into a separate draft is appropriate.

However, when compared to the equivalent metric in draft-wu-xrblock-rtcp-xr-quality-monitoring-01, this draft combines the Initial Synchronisation Delay report block and the General Synchronisation Offset Metrics Block into one block type, with the new sdotype field being used to distinguish the two meanings. The previous definition seems cleaner to me, since each block type had a single clear definition.

This draft also adds an I bit to signal if interval or cumulative metrics are being used. It’s not clear this is meaningful for the synchronisation metrics, since they can't be readily combined to give a cumulative value.

The measurement tag field may be redundant, depending on the results of the discussion regarding the monarch draft. 

-- 
Colin Perkins
http://csperkins.org/

---

From: Hitoshi Asaeda <[email-masked]>
Date: Fri, 10 Jun 2011 19:35:51 +0900 (JST)

Hi Colin,

> This draft takes the synchronisation metric defined in
> draft-wu-xrblock-rtcp-xr-quality-monitoring-01, and breaks it out
> into a separate draft. This separation into a separate draft is
> appropriate.

Thanks.

> However, when compared to the equivalent metric in
> draft-wu-xrblock-rtcp-xr-quality-monitoring-01, this draft combines
> the Initial Synchronisation Delay report block and the General
> Synchronisation Offset Metrics Block into one block type, with the
> new sdotype field being used to distinguish the two meanings. The
> previous definition seems cleaner to me, since each block type had a
> single clear definition.

The initial motivation to merge two report blocks into one is to save
the block type space.
However, I agree that Initial Synchronisation Delay report block and
the General Synchronisation Offset Metrics Block will be separated in
the revised draft.

> This draft also adds an I bit to signal if interval or cumulative
> metrics are being used. It’s not clear this is meaningful for the
> synchronisation metrics, since they can't be readily combined to
> give a cumulative value.

Right.
An I bit is redundant and will be removed in the revised draft.

> The measurement tag field may be redundant, depending on the results
> of the discussion regarding the monarch draft. 

I see.
We'll remove the tag field in the revised draft and reserve a space
for future extension.

Thanks.
Regards,
--
Hitoshi Asaeda

---

From: Hitoshi Asaeda <[email-masked]>
Date: Wed, 22 Jun 2011 01:41:53 +0900 (JST)

Hi folks,

We've submitted the revised version of our synchronization metric draft.

http://tools.ietf.org/html/draft-asaeda-xrblock-rtcp-xr-synchronization-01

This address the comments Colin pointed out.

Comments are very welcome.
Regards,
--
Hitoshi Asaeda

---

From: Colin Perkins <[email-masked]>
Date: Tue, 21 Jun 2011 18:24:53 +0100

> This address the comments Colin pointed out.

Thanks - this addresses my comments.

-- 
Colin Perkins
http://csperkins.org/