Subject: Re: [xrblock] [AVTCORE] Open issue- identity info repetition indraft-ietf-avtcore-monarch

From: Peter Musgrave <[email-masked]>
Date: Sun, 5 Jun 2011 15:01:55 -0400

Hi Qin, Colin,

I agree with Colin that the case for reducing identity inefficiency is not
very compelling. These kinds of blocks are not sent as frequently as e.g.
the RTP payload and in general a number of XR blocks can be stacked in one
MTU with ease. Hence I would suggest we not incur the protocol and
implementation complexity of having identity blocks and references to them
etc.

Regards,

Peter Musgrave

(I hope this threads properly - I have changed email address in the middle
of this exchange. Apologies for not having the rest of the exchange below).

---

From: Qin Wu <[email-masked]>
Date: Fri, 10 Jun 2011 17:49:00 +0800

Hi, Peter:
Thank for your comments. Please see my following question below.
  ----- Original Message ----- 
  From: Peter Musgrave 
  To: [email-masked] ; [email-masked] ; [email-masked] 
  Sent: Monday, June 06, 2011 3:01 AM
  Subject: Re: [AVTCORE] [xrblock] Open issue- identity info repetition indraft-ietf-avtcore-monarch

  Hi Qin, Colin, 

  I agree with Colin that the case for reducing identity inefficiency is not very compelling. These kinds of blocks are not sent as frequently as e.g. the RTP payload and in general a number of XR blocks can be stacked in one MTU with ease. 

  [Qin]: Yes, such block is not sent frequently. Suppose we separate identity block out from each metric block 
  and allow identity block only being sent once at the start of session, is it compelling to have such independent identity block?

  Hence I would suggest we not incur the protocol and implementation complexity of having identity blocks and references to them etc. 

  [Qin]: I agree that it is not compelling to let each small metric block to reference the independent identity block with identity information included if
  each metric block already have SSRC and support such reference. However it looks to me measure information defined in measurement identity 
  block of draft-ietf-avt-rtcp-xr-meas-identity-02 contain more than SSRC which could be used as the key to look up other application specific 
  information, e.g., diagonose information. So it will be good to still have identity block.

  Regards, 

  Peter Musgrave

  (I hope this threads properly - I have changed email address in the middle of this exchange. Apologies for not having the rest of the exchange below).

---

From: Colin Perkins <[email-masked]>
Date: Tue, 14 Jun 2011 11:25:17 +0100

Qin,

On 10 Jun 2011, at 10:49, Qin Wu wrote:
> [Qin]: Yes, such block is not sent frequently. Suppose we separate identity block out from each metric block and allow identity block only being sent once at the start of session, is it compelling to have such independent identity block?

I don't think so. If we have an identity block, it should be sent following the usual RTCP schedule.

> [Qin]: I agree that it is not compelling to let each small metric block to reference the independent identity block with identity information included if each metric block already have SSRC and support such reference. However it looks to me measure information defined in measurement identity block of draft-ietf-avt-rtcp-xr-meas-identity-02 contain more than SSRC which could be used as the key to look up other application specific information, e.g., diagonose information. So it will be good to still have identity block.

It might be good to have some of the other information contained in the Identity Block, and a new block type could be defined to convey that. The identity block, and the idea of a tag to correlate it with other blocks, doesn't seem useful though.

-- 
Colin Perkins
http://csperkins.org/