Subject: [xrblock] Discussion about common boilerplate, order to approach the drafts

From: "David A. Bryan" <[email-masked]>
Date: Fri, 9 Sep 2011 17:07:25 -0700

Hi all,

So with the change in chairs and the desire to start spinning up and getting
some work moving in this group now that the monitoring architecture draft is
nearing completion, Charles and I wanted to start a few discussions. There
are two discussions we really would like to have in order to get things
rolling.

First, in talking with Roni and Peter, one thing that came up was that it
was possible that many of the drafts in this group -- both the current
milestones and the new individual drafts -- could share some common text.
This would be some explanation of the problem, basic structure of the new
report blocks, etc.

So, what do folks think? Is there a set of common text that we could work to
quickly abstract out and agree on, which would then make the individual
report blocks simpler to write and review? Are they too different from one
another to do that? What things would we want in any possible common text?
Should we quickly work on this common text before we work on the drafts?

Second, we have 11 milestones, which other than Measurement Identity, are in
alphabetical order (http://datatracker.ietf.org/wg/xrblock/charter/). We
also have a number of new drafts that have been submitted as individual
drafts. While this kind of discussion is always likely to be contentious,
and often the answer is "my draft", we would like to discuss which ones
people think are most important. This could be because others will depend on
it, or because we simply think users need these first. We'd like to have
this discussion to re-prioritize the milestones and get to work on some of
the drafts.

So...comments please. The more we can discuss on list and resolve quickly,
the more time we can spend getting the drafts completed.

Thanks,

David and Charles (as chairs)

---

From: Glen Zorn <[email-masked]>
Date: Sat, 10 Sep 2011 13:16:53 +0700

On 9/10/2011 7:07 AM, David A. Bryan wrote:

> Hi all,
> 
> So with the change in chairs and the desire to start spinning up and
> getting some work moving in this group now that the monitoring
> architecture draft is nearing completion, Charles and I wanted to start
> a few discussions. There are two discussions we really would like to
> have in order to get things rolling.
> 
> First, in talking with Roni and Peter, one thing that came up was that
> it was possible that many of the drafts in this group -- both the
> current milestones and the new individual drafts -- could share some
> common text. This would be some explanation of the problem, basic
> structure of the new report blocks, etc.
> 
> So, what do folks think? Is there a set of common text that we could
> work to quickly abstract out and agree on, which would then make the
> individual report blocks simpler to write and review? Are they too
> different from one another to do that? What things would we want in any
> possible common text? Should we quickly work on this common text before
> we work on the drafts?

This seems like a pretty much total waste of time to me.  Many protocol
documents have this characteristic (PPP, EAP, ...); the time-honored
solution for people beginning new EAP drafts, for example, is to
cut-and-paste the relevant text from an existing document.  I see no
reason why this approach is invalid for xrblock drafts.

> 
> Second, we have 11 milestones, which other than Measurement Identity,
> are in alphabetical order
> (http://datatracker.ietf.org/wg/xrblock/charter/). We also have a number
> of new drafts that have been submitted as individual drafts. While this
> kind of discussion is always likely to be contentious, and often the
> answer is "my draft", we would like to discuss which ones people think
> are most important. This could be because others will depend on it, or
> because we simply think users need these first. We'd like to have this
> discussion to re-prioritize the milestones and get to work on some of
> the drafts.
> 
> So...comments please. The more we can discuss on list and resolve
> quickly, the more time we can spend getting the drafts completed.

We have been "getting ready to do something" for some months now.  How
about this: instead of continuing this, just _do_ something?  For
example, none of those 11 milestones have any documents attached to
them; how about we do that?  Or at least start mapping existing
documents to milestones?  BTW, if nobody's interested in submitting
drafts related to the official milestones, this says a lot about the
milestones themselves...

> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock

---

From: "David A. Bryan" <[email-masked]>
Date: Mon, 12 Sep 2011 06:59:12 -0700

Inline.

> reason why this approach is invalid for xrblock drafts.

Anyone else have thoughts?

> drafts related to the official milestones, this says a lot about the

...hence this discussion. We can throw out milestones if no one is
interested. I'm a bit concerned that Glen is the only one who responded.
Others? Which (if any) of these milestones are people interested in
continuing? Simply blindly working on 11 milestones in the (alphabetical)
order they were selected months ago seems counter-productive, so what do
people think?

David

---

From: Varun Singh <[email-masked]>
Date: Mon, 12 Sep 2011 18:28:49 +0300

Hi,

Comments inline

> Anyone else have thoughts?

I don't see how a broiler plate can help in cases where the drafts
have been around for some time. Some of the drafts may already be
mature enough to continue through the process. As an author of a
draft, I would like to make progress on the draft. We originally
submitted the discard draft[1] in Dec 2008. It was re-submitted after
the formation of XR block.

[1](http://tools.ietf.org/html/draft-ott-avt-rtcp-xt-discard-metrics)

> order they were selected months ago seems counter-productive, so what do

As mentioned before, we would like to make progress on the draft (Run
Length Encoding of Discarded Packets).

Thanks,
Varun

>snip!

-- 
http://www.netlab.tkk.fi/~varun/

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 12 Sep 2011 19:25:43 +0200

I agree some alignment of the text between different documents would be appropriate, but the work doesn't have to proceed in sequence. If a boilerplate comes out of it then fine - but the boilerplate certainly does not need to be a formal document. Certainly you (as WG chairs) should charge all editors you appoint to consider textual alignment in their development process.

For example, maybe someone could start just by reviewing any existing documents and saying, "you need at least these sections in each document, and it makes sense to put them in this order".

It is also be dependent on the volunteers.

Regards

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of David A. Bryan
Sent: 12 September 2011 14:59
To: Glen Zorn
Cc: [email-masked]
Subject: Re: [xrblock] Discussion about common boilerplate, order to approach the drafts

Inline.

On Fri, Sep 9, 2011 at 11:16 PM, Glen Zorn <[email-masked]<mailto:[email-masked]>> wrote:

...hence this discussion. We can throw out milestones if no one is interested. I'm a bit concerned that Glen is the only one who responded. Others? Which (if any) of these milestones are people interested in continuing? Simply blindly working on 11 milestones in the (alphabetical) order they were selected months ago seems counter-productive, so what do people think?

David

> [email-masked]<mailto:[email-masked]>

---

From: Kevin Gross <[email-masked]>
Date: Mon, 12 Sep 2011 11:12:36 -0600

I think you have to work on the milestones in the order that people step
forward to do the work. If no one steps forward, you have to eventually
abandon them. That's the nature of volunteer participation.

Same goes for a common template. I don't have enough IETF experience to
judge whether or not this is a good idea. I will suggest that until someone
steps forward interested in doing the work, there's not much point in
discussing it in great detail.

Kevin Gross
AVA Networks

---

From: Qin Wu <[email-masked]>
Date: Mon, 19 Sep 2011 18:06:41 +0800

Hi,
Sorry for late feedback.
  ----- Original Message ----- 
  From: David A. Bryan 
  To: Glen Zorn 
  Cc: [email-masked] 
  Sent: Monday, September 12, 2011 9:59 PM
  Subject: Re: [xrblock] Discussion about common boilerplate, order to approach the drafts

  Inline.

  [Qin]: I agree and understand what Glen said. Frank to say, it is more straightfoward to take on
  some works to catch up milestone rather than building comming boilerplate.
  The similar boilerplate I can point to you is RTP Payload Format Template defined in draft-ietf-avt-rtp-howto-06.
  I am not sure this is similar thing you are looking for. However I think comparing to RTP Payload Format,
  XR Block Format is more simple forwat, does it worth taking time to build a common boilerplate template?
  Why not just follow the rules or guideline defined in RFC5968, draft-ietf-pmol-metrics-framework  and 
  draft-ietf-avtcore-monarch and go ahead directly.

  [Qin]:  It looks  we can take out Measurement Identity milestone from the charter, since following the discussing on the monitoring architecture, there is rough consesus to use SDES packet to carry addional identity information.

  Another suggestion is we already have had more than 11 draft documents that is available in XRBlock and AVT Working group repository. Why not take action by mapping them one by one and determine which one is in high priority and which is low.

  Also as an author of quality monitoring draft, I have split it into four different draft to get align with the rules defined in monitoring archtiecture document. I think it is under enough review and discussion in the past two IETF meeting and it is ready for chair review and moving forward.

  David

------------------------------------------------------------------------------

---

From: Qin Wu <[email-masked]>
Date: Wed, 21 Sep 2011 14:07:04 +0800

Fair.
Additional thought is if there is some potential new work items that are not covered by existing milestones, however were reviewed and discussed as valuable work in the past meeting, I would like to
suggest to take them on following consesus and people's interests, it is not reasonable to say, in my opinion ,"hey, we need to clear our table first,  new work come back later". 

Regards!
-Qin
  ----- Original Message ----- 
  From: Kevin Gross 
  To: [email-masked] 
  Sent: Tuesday, September 13, 2011 1:12 AM
  Subject: Re: [xrblock] Discussion about common boilerplate, order to approach the drafts

  I think you have to work on the milestones in the order that people step forward to do the work. If no one steps forward, you have to eventually abandon them. That's the nature of volunteer participation.

  Same goes for a common template. I don't have enough IETF experience to judge whether or not this is a good idea. I will suggest that until someone steps forward interested in doing the work, there's not much point in discussing it in great detail.

  Kevin Gross
  AVA Networks

    Inline.

     

    David

---

From: Hitoshi Asaeda <[email-masked]>
Date: Wed, 21 Sep 2011 16:04:03 +0900 (JST)

Hi,

> Fair.
> Additional thought is if there is some potential new work items that
> are not covered by existing milestones, however were reviewed and
> discussed as valuable work in the past meeting, I would like to
> suggest to take them on following consesus and people's interests,
> it is not reasonable to say, in my opinion ,"hey, we need to clear
> our table first,  new work come back later". 

In fact, there was quite a lot of interests to
draft-asaeda-xrblock-rtcp-xr-synchronization-02 derived from
draft-wu-avt-rtcp-xr-quliaty-monitoring in the past meetings.
As an author of this draft, may I ask the chairs to review and take it
as a work item?

Regards,
--
Hitoshi Asaeda

---

From: Qin Wu <[email-masked]>
Date: Wed, 21 Sep 2011 15:43:54 +0800

Agree. 
I remembered Peter in the past suggested to use performance metric template specified in the draft-ietf-pmol-metrics-framework on the list. However it was not clear to me that all the elements listed in this template can be justified as part of common boilerplate. e.g., Measurement timing, I think XRBlock should more look at report timing, rather than measurement timing. Regarding measurement method, I think this should be defined somewhere else, e.g., in other working group or other SDO rather than in this WG.  So the common text different document may share includes metric name, metric descrption, metric format, use and application. However this does not look to worth a document.

Just my 2 cents.

Regards!
-Qin
  ----- Original Message ----- 
  From: DRAGE, Keith (Keith) 
  To: David A. Bryan ; Glen Zorn 
  Cc: [email-masked] 
  Sent: Tuesday, September 13, 2011 1:25 AM
  Subject: Re: [xrblock] Discussion about common boilerplate, order to approach the drafts

  Regards

  Keith

  Inline.

  David