Subject: Re: [xrblock] request adoption of the merged QoE metric Reporting draft

From: [email-masked]
Date: Mon, 19 Dec 2011 17:04:54 +0800 (CST)

I have read the last version (-06)

http://tools.ietf.org/html/draft-wu-xrblock-rtcp-xr-quality-monitoring-06

and like to see this merging draft bing adopted. I also have a few comments below.

Firstly I agree it is a good idea to define three segment types and only allow segments associated with one segement type present in one QoE XR Block. In these three segment types, my impression is single stream segment and multi-layer segment are two more general segments.

Secondly I think if QoE XR Block carry single stream segment, only one single stream sgment should be carried in one QoE XR Block. If QoE XR Block carry multi-layer segment, multiple multi-layer segment can be carried in one QoE XR Block. Also multi-layer segment should not only apply to video but also audio.

Thirdly, I think multiple channel segment is more like audio codec dependent segment. Therefore video related MOS Type and MOS algorithm shouldn't be applied to multiple channel segment.

Regards!

ZhaoJing

Shanghai Research Institution of China Telecom

---------------------------------------------------------------------------------

----- Original Message -----

From: "Qin Wu"

To:

Sent: Tuesday, December 13, 2011 9:37 PM

Subject: [xrblock] request adoption of the merged QoE metric Reporting draft

> Hi, all:

> Just let you know, we have submitted a new update of draft on QoE metric reporting.

> This version (-05) is a merging draft by combining draft-wu-xrblock-rtcp-xr-quality-monitoring

> with draft-clark-xrblock-rtcp-xr-qoe.

> The key issue we have addressed is how to support both the case where multiple elementary streams

> or components(e.g.,channel of audios or multiple view) are carried in the same RTP stream

> and the case where multiple elementary streams (e.g.,audio and video) are carried in the different RTP stream

> Our proposal is to define three segement type to carry single Stream segement, multi-channel segment and multi-view segement.

> The segement type is quite similar to chunk type specified in the RFC3611.

> The single stream segment include the metrics defined in draft-wu-xrblock-rtcp-xr-quality-monitoring, also I add MOS algorithm field,

> move MOS Type to this segement. This segement is used to support the case where multiple elementary streams (e.g.,audio and video)

> are carried in the different RTP stream.

> The multile channel audio segment and multi view segement include metrics defined in draft-calrk-xrblock-rtcp-xr-qoe.

> we use channel ID and Sub stream ID to identify each channel or each view. These two segements are used to support the case where

> multiple elementary streams or components(e.g.,channel of audios or multiple view) are carried in the same RTP stream

> The Diff is

https://datatracker.ietf.org/doc/draft-wu-xrblock-rtcp-xr-quality-monitoring/history/

> We believe this version combing two draft can well address the issues we raised on the list and in the meeting. It is a good starting point

> as the baseline draft. It will be good to see it being taken on as wg draft.

> Regards!

> -Qin

> ----- Original Message -----

> From:

> To:

> Sent: Tuesday, December 13, 2011 9:07 PM

> Subject: I-D Action: draft-wu-xrblock-rtcp-xr-quality-monitoring-05.txt

>> A New Internet-Draft is available from the on-line Internet-Drafts directories.

>> Title : RTCP XR Blocks for QoE metric reporting

>> Author(s) : Geoff Hunt

>> Alan Clark

>> Qin Wu

>> Roland Schott

>> Glen Zorn

>> Filename : draft-wu-xrblock-rtcp-xr-quality-monitoring-05.txt

>> Pages : 15

>> Date : 2011-12-13

>> This document defines an RTCP XR Report Block and associated SDP

>> parameters that allow the reporting of QoE metrics for use in a range

>> of RTP applications.

>> A URL for this Internet-Draft is:

http://www.ietf.org/internet-drafts/draft-wu-xrblock-rtcp-xr-quality-monitoring-05.txt

>> Internet-Drafts are also available by anonymous FTP at:

>> ftp://ftp.ietf.org/internet-drafts/

>> This Internet-Draft can be retrieved at:

>> ftp://ftp.ietf.org/internet-drafts/draft-wu-xrblock-rtcp-xr-quality-monitoring-05.txt

>> _______________________________________________

>> I-D-Announce mailing list

>> [email-masked]

https://www.ietf.org/mailman/listinfo/i-d-announce

>> Internet-Draft directories:
http://www.ietf.org/shadow.html

>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

> _______________________________________________

> xrblock mailing list

> [email-masked]

https://www.ietf.org/mailman/listinfo/xrblock

---

From: Qin Wu <[email-masked]>
Date: Mon, 19 Dec 2011 17:58:03 +0800

Hi, Jing:
Thank for your review. I agree with your comments, especially the third point.
I will add a sentence to the multiple channel segement section to make it clear that
video related MoS Type and algrithm does not apply to multiple channel segment.
Hope this addresses your comment.

Regards!
-Qin

  ----- Original Message ----- 
  From: [email-masked] 
  To: xrblock ; bill.wu 
  Sent: Monday, December 19, 2011 5:04 PM
  Subject: Re: [xrblock] request adoption of the merged QoE metric Reporting draft

   

  Regards! 
  ZhaoJing 
  ----- Original Message ----- 
  From: "Qin Wu" 
  To: 
  Sent: Tuesday, December 13, 2011 9:37 PM 
  Subject: [xrblock] request adoption of the merged QoE metric Reporting draft 

  >> Internet-Draft directories: http://www.ietf.org/shadow.html