Subject: [xrblock] I-D Action: draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-01.txt

From: [email-masked]
Date: Fri, 09 Dec 2011 07:04:25 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Metric Blocks for use with RTCP's Extended Report Framework Working Group of the IETF.

	Title           : Real-time Transport Control Protocol (RTCP) Extension Report (XR) for Run Length Encoding of Discarded Packets
	Author(s)       : Joerg Ott
                          Varun Singh
                          Igor D.D. Curcio
	Filename        : draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-01.txt
	Pages           : 11
	Date            : 2011-12-09

   The Real-time Transport Control Protocol (RTCP) is used in
   conjunction with the Real-time Transport Protocol (RTP) in to provide
   a variety of short-term and long-term reception statistics.  The
   available reporting may include aggregate information across longer
   periods of time as well as individual packet reporting.  This
   document specifies a per-packet report metric capturing individual
   packets discarded from the jitter buffer after successful reception.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-01.txt

---

From: Varun Singh <[email-masked]>
Date: Fri, 9 Dec 2011 17:14:41 +0200

Hi,

After the IETF82, I added the measurement ID tag in the bytes discarded
report block but this is not required anymore and therefore it has been
removed. For detailed diff:
http://tools.ietf.org/rfcdiff?url2=draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-01.txt.
The
document has no open issues and is ready to be reviewed by the WG and move
forward.

Cheers,
Varun

On Fri, Dec 9, 2011 at 17:04, <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Metric Blocks for use with
> RTCP's Extended Report Framework Working Group of the IETF.
>
>        Title           : Real-time Transport Control Protocol (RTCP)
> Extension Report (XR) for Run Length Encoding of Discarded Packets
>        Author(s)       : Joerg Ott
>                          Varun Singh
>                          Igor D.D. Curcio
>        Filename        :
> draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-01.txt
>        Pages           : 11
>        Date            : 2011-12-09
>
> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock
>

-- 
http://www.netlab.tkk.fi/~varun/

---

From: Qin Wu <[email-masked]>
Date: Mon, 12 Dec 2011 12:04:17 +0800

Hi, Varun:
Just have a quick check, you did remove the text that  related to measurement ID tag but you didn't free the 3bit for tag field in the figure 2.
Additinal comment  it is not clear to me how you are going to use Bytes Discarded Report?

Regards!
-Qin
  ----- Original Message ----- 
  From: Varun Singh 
  To: [email-masked] 
  Sent: Friday, December 09, 2011 11:14 PM
  Subject: Re: [xrblock] I-D Action:draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-01.txt

  Hi,

  After the IETF82, I added the measurement ID tag in the bytes discarded report block but this is not required anymore and therefore it has been removed. For detailed diff: http://tools.ietf.org/rfcdiff?url2=draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-01.txt. The document has no open issues and is ready to be reviewed by the WG and move forward.

  Cheers,
  Varun

------------------------------------------------------------------------------

---

From: Varun Singh <[email-masked]>
Date: Mon, 12 Dec 2011 13:42:52 +0200

Comments inline

On Mon, Dec 12, 2011 at 06:04, Qin Wu <[email-masked]> wrote:

> **
> Hi, Varun:
> Just have a quick check, you did remove the text that  related to
> measurement ID tag but you didn't free the 3bit for tag field in the figure
> 2.
>

will remove that, thanks.

> Additinal comment  it is not clear to me how you are going to use Bytes

Packets may get discarded due to overuse (congestion), at that point, the
receiver can signal the overuse by signaling:
1. Number of packets discarded in an interval
2. Bytes discarded in an interval
3. Which packets got discarded (RLE)

Number of packets may be useful if the packet sizes are equal or roughly
similar. However, with video this is not the case and the number of packets
may not give the correct idea on the scale of congestion. If the sender is
looking at the pattern of discards to make the decision then RLE gives that
information, furthermore, if the sender keeps a history of packets sent it
can also calculate the bytes discarded. But doing RLE calculations is
computationally intensive if the sender just wants to know how many bytes
got discarded.

I hope this clarifies.

Regards,
Varun

> *From:* Varun Singh <[email-masked]>
> *To:* [email-masked]
> *Sent:* Friday, December 09, 2011 11:14 PM
> *Subject:* Re: [xrblock] I-D
> Action:draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-01.txt
>
> Hi,
>
> http://tools.ietf.org/rfcdiff?url2=draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-01.txt. The
> ------------------------------
>