Subject: [xrblock] Fw: I-D Action: draft-ietf-xrblock-rtcp-xr-discard-01.txt

From: Qin Wu <[email-masked]>
Date: Mon, 12 Dec 2011 12:04:11 +0800

Hi, Varun:
Thank for your careful review.
please see my comments inline.
----- Original Message ----- 
From: Varun Singh 
To: [email-masked] 
Sent: Friday, December 09, 2011 7:58 PM
Subject: Re: [xrblock] I-D Action: draft-ietf-xrblock-rtcp-xr-discard-01.txt

Hi,

Comments about the draft:

>Number of packets discarded over the period (Interval or
>      Cumulative) covered by this report.
"Sampled" should also be mentioned if Interval and cumulative are mentioned. Or say: Number of packets discarded in the period defined in the Interval metric flag (I) [Qin]: That's fair. I forgot to update this into the document and will mentinon this in the new update.>      Note that the number of packets expected in the period covered by
>      the metric (whether interval or cumulative) is available from the
>      difference between a pair of extended sequence numbers in the
>      Measurement Identity block, so need not be repeated in this block.
My understanding is that the measurement identity is only associated to the sampled interval (I=01). 

If a measurement identity interval is exactly equal to the cumulative interval or last RTCP interval then shouldn't the reports blocks use the sampled metric flag (I=01) instead of saying they are cumulative (I=11) or interval metrics (I=10)?

[Qin]: My understanding is No. Sample metric can share the same interval as interval or cumulative
metric, the only diffence between them is for sample metric, a number of
samples is only collected and measured at the end of such interval. You may check our 
discussion with Alan regarding sample metric on the list to see that.

On Fri, Dec 9, 2011 at 11:47, <[email-masked]> wrote:

  A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Metric Blocks for use with RTCP's Extended Report Framework Working Group of the IETF.

         Title           : RTCP XR Report Block for Discard metric Reporting
         Author(s)       : Geoff Hunt
                           Alan Clark
                           Glen Zorn
                           Qin Wu
         Filename        : draft-ietf-xrblock-rtcp-xr-discard-01.txt
         Pages           : 13
         Date            : 2011-12-09

    This document defines an RTCP XR Report Block that allows the
    reporting of a simple discard count metric for use in a range of RTP
    applications.

  A URL for this Internet-Draft is:
  http://www.ietf.org/internet-drafts/draft-ietf-xrblock-rtcp-xr-discard-01.txt

  Internet-Drafts are also available by anonymous FTP at:
  ftp://ftp.ietf.org/internet-drafts/

  This Internet-Draft can be retrieved at:
  ftp://ftp.ietf.org/internet-drafts/draft-ietf-xrblock-rtcp-xr-discard-01.txt

  _______________________________________________
  xrblock mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/xrblock

-- 
http://www.netlab.tkk.fi/~varun/

--------------------------------------------------------------------------------

_______________________________________________
xrblock mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/xrblock

---

From: Varun Singh <[email-masked]>
Date: Mon, 12 Dec 2011 14:15:11 +0200

Hi Qin,

Comments inline

On Mon, Dec 12, 2011 at 06:04, Qin Wu <[email-masked]> wrote:

> **
> *From:* Varun Singh <[email-masked]>
> *To:* [email-masked]
> *Sent:* Friday, December 09, 2011 7:58 PM
> *Subject:* Re: [xrblock] I-D Action:
> draft-ietf-xrblock-rtcp-xr-discard-01.txt
>
> Hi,
>
> "Sampled" should also be mentioned if Interval and cumulative are mentioned.
>
> Or say: Number of packets discarded in the period defined in the Interval metric flag (I)
>
>
>
> [Qin]: That's fair. I forgot to update this into the document and will mentinon this in the new update.
>
>
>
> >      Note that the number of packets expected in the period covered by>      the metric (whether interval or cumulative) is available from the>      difference between a pair of extended sequence numbers in the>      Measurement Identity block, so need not be repeated in this block.
>
>
> If a measurement identity interval is exactly equal to the cumulative
> interval or last RTCP interval then shouldn't the reports blocks use the
> sampled metric flag (I=01) instead of saying they are cumulative (I=11) or
> interval metrics (I=10)?
>
> My question is not so much related to sampled metric itself but it is ---
when to use the measurement identity?

My understanding was that the measurement identity is related to the
sampled metric and does not apply to the Interval and Cumulative Metrics
because it explicitly defines the interval over which the calculation is
done (namely, the First and Last Sequence Numbers). While the interval and
cumulative metrics are implicitly defined. Interval metric is the last RTCP
RR interval and the cumulative metric is from the beginning of the session
and therefore do not require an associated measurement identity block.

If they (cumulative, interval metrics) did require a measurement block,
then couldn't the receiver just send them as sampled metrics and associate
the interval explicitly in the measurement block?

Regards,
Varun