Subject: [xrblock] I-D Action: draft-ietf-xrblock-rtcp-xr-discard-01.txt

From: [email-masked]
Date: Fri, 09 Dec 2011 01:47:52 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Metric Blocks for use with RTCP's Extended Report Framework Working Group of the IETF.

	Title           : RTCP XR Report Block for Discard metric Reporting
	Author(s)       : Geoff Hunt
                          Alan Clark
                          Glen Zorn
                          Qin Wu
	Filename        : draft-ietf-xrblock-rtcp-xr-discard-01.txt
	Pages           : 13
	Date            : 2011-12-09

   This document defines an RTCP XR Report Block that allows the
   reporting of a simple discard count metric for use in a range of RTP
   applications.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-xrblock-rtcp-xr-discard-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-xrblock-rtcp-xr-discard-01.txt

---

From: Varun Singh <[email-masked]>
Date: Fri, 9 Dec 2011 13:58:04 +0200

Hi,

Comments about the draft:

>Number of packets discarded over the period (Interval or
>      Cumulative) covered by this report.

"Sampled" should also be mentioned if Interval and cumulative are mentioned.

Or say: Number of packets discarded in the period defined in the
Interval metric flag (I)

>      Note that the number of packets expected in the period covered by>      the metric (whether interval or cumulative) is available from the>      difference between a pair of extended sequence numbers in the>      Measurement Identity block, so need not be repeated in this block.

My understanding is that the measurement identity is only associated to the
sampled interval (I=01).

If a measurement identity interval is exactly equal to the cumulative
interval or last RTCP interval then shouldn't the reports blocks use the
sampled metric flag (I=01) instead of saying they are cumulative (I=11) or
interval metrics (I=10)?

On Fri, Dec 9, 2011 at 11:47, <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Metric Blocks for use with
> RTCP's Extended Report Framework Working Group of the IETF.
>
> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock
>

-- 
http://www.netlab.tkk.fi/~varun/