Subject: Re: [xrblock] Fw: Fw: I-D Action: draft-ietf-xrblock-rtcp-xr-discard-01.txt (Clarifying Measurement Identity)

From: Varun Singh <[email-masked]>
Date: Tue, 13 Dec 2011 14:06:09 +0200

Hi Qin,

Changed the subject to clarifying measurement identity, so that it is
easier to find.

Comments inline.

On Tue, Dec 13, 2011 at 05:01, Qin Wu <[email-masked]> wrote:

> **
> Hi, Varun:
> Firstly, Discard metric can not be sample metric.
> How do you know how many packets are discarded if you just sample a few
> packets at the end
> of measurement Interval for sample metric rather than collect all the
> packets during the measurement Interval.
>
>

Copying from the monarch-draft (
http://tools.ietf.org/html/draft-ietf-avtcore-monarch-08):
>Sampled metrics
>
>      It is referred to as the metrics of which the reported values only
>      apply to the value of a continuously measured or calculated that
>      has been sampled at end of the interval.

The above definition is a bit confusing. Continuously measured gave me the
idea that it was defined as the Measurement Interval in the measurement
identity block. Perhaps the definition should be clarified to mean that the
values are based on a sampling algorithm which is run at the end of each
reporting interval. Or the receiver resamples the observed values in the
measurement interval.

>  Sample metric only apply to a few metric measurement,e.g., PDV metric.
> This has been discussed on the list for a long time.
>
>
Thanks for clarifying. Is this sample duration indicated in the PDV metric?

> Secondly The measurement interval for a metric may be different from the
> RTCP
> reporting interval. In this case, you still need a measurment information
> block.
>
>

Yes and in those cases the endpoint must rely on the measurement block.

>  Thirdly, it is difficult to locate the *start* of the RTP session
> (sequence number of 1st packet, duration of interval applicable to
> cumulative measurements) using only RR. Also it is difficult to locate
> the start of the RTP session( extended first sequence number,extended last
> sequence number,
> duration of interval appilcable to interval measurements) using only RR.
>
>

Yes this is true if the report is sent to a monitoring device. However if
the messages are sent to the media sender, then the sender knows:
The first packet it sent at the start of the cumulative session.
The HSN in the previous RR packet is start of the interval report
The HSN in the current RR packet gives the end of the cumulative and
interval report.
Problems may occur if a RR is lost, then the sender may incorrectly
identify the interval. This may affect the interpretation of the indicated
value.

Especially, for the discard drafts (RLE, num of discards, bytes
discarded). The sender can act upon the information, then I do not see why
these messages cannot be sent to the sender. The question then in this
cases is: does the receiver really need to send the measurement identity?

Fouth, before sampled metric is introduced recently, measurement identity
> block is originally used
> to report the additional measurement information that is not present in
> the RTCP RR, e.g.,extended
> first sequence number,extended last sequence number.
>

I agree, the extended first sequence number (FSN) is important to correctly
identify the start of the reporting interval. However, Last Sequence Number
is only useful if it different from the HSN reported in the RR. If so: I
have a clarifying question on how is the measurement interval calculated?
is it the difference between RTP timestamps (or reception timestamps) of
Extended First Sequence Number and Extended Last Sequence Number?

Regards,
Varun

 Hope this clarifies.
>
> Regards!
> -Qin
> ----- Original Message -----
>  *From:* Varun Singh <[email-masked]>
> *To:* Qin Wu <[email-masked]>
> *Cc:* [email-masked]
> *Sent:* Monday, December 12, 2011 8:15 PM
> *Subject:* Re: Fw: [xrblock] I-D Action:
> draft-ietf-xrblock-rtcp-xr-discard-01.txt
>
> Hi Qin,
>
> Comments inline
>
> On Mon, Dec 12, 2011 at 06:04, Qin Wu <[email-masked]> wrote:
>
>> **
>> Hi, Varun:
>> Thank for your careful review.
>> please see my comments inline.
>>  ----- Original Message -----
>> *From:* Varun Singh <[email-masked]>
>> *To:* [email-masked]
>> *Sent:* Friday, December 09, 2011 7:58 PM
>> *Subject:* Re: [xrblock] I-D Action:
>> draft-ietf-xrblock-rtcp-xr-discard-01.txt
>>
>> Hi,
>>
>> Comments about the draft:
>>
>>  >Number of packets discarded over the period (Interval or
>> >      Cumulative) covered by this report.
>>
>>
>> "Sampled" should also be mentioned if Interval and cumulative are mentioned.
>>
>> Or say: Number of packets discarded in the period defined in the Interval metric flag (I)
>>
>>
>>
>> [Qin]: That's fair. I forgot to update this into the document and will mentinon this in the new update.
>>
>>
>>
>> >      Note that the number of packets expected in the period covered by>      the metric (whether interval or cumulative) is available from the>      difference between a pair of extended sequence numbers in the>      Measurement Identity block, so need not be repeated in this block.
>>
>>
>>  My understanding is that the measurement identity is only associated to
>> the sampled interval (I=01).
>>
>> If a measurement identity interval is exactly equal to the cumulative
>> interval or last RTCP interval then shouldn't the reports blocks use the
>> sampled metric flag (I=01) instead of saying they are cumulative (I=11) or
>> interval metrics (I=10)?
>>
>>  [Qin]: My understanding is No. Sample metric can share the same
>> interval as interval or cumulative
>> metric, the only diffence between them is for sample metric, a number of
>> samples is only collected and measured at the end of such interval. You
>> may check our
>> discussion with Alan regarding sample metric on the list to see that.
>>
>> My question is not so much related to sampled metric itself but it is ---
> when to use the measurement identity?
>
> My understanding was that the measurement identity is related to the
> sampled metric and does not apply to the Interval and Cumulative Metrics
> because it explicitly defines the interval over which the calculation is
> done (namely, the First and Last Sequence Numbers). While the interval and
> cumulative metrics are implicitly defined. Interval metric is the last RTCP
> RR interval and the cumulative metric is from the beginning of the session
> and therefore do not require an associated measurement identity block.
>
> If they (cumulative, interval metrics) did require a measurement block,
> then couldn't the receiver just send them as sampled metrics and associate
> the interval explicitly in the measurement block?
>
>
> Regards,
> Varun
>
>

-- 
http://www.netlab.tkk.fi/~varun/

---

From: Qin Wu <[email-masked]>
Date: Wed, 14 Dec 2011 10:29:21 +0800

Hi, Varun:
----- Original Message ----- 
From: Varun Singh 
To: Qin Wu 
Cc: [email-masked] 
Sent: Tuesday, December 13, 2011 11:51 PM
Subject: Re: Fw: Fw: Fw: [xrblock] I-D Action: draft-ietf-xrblock-rtcp-xr-discard-01.txt (Clarifying Measurement Identity)

Hi Qin,

Answers inline.

On Tue, Dec 13, 2011 at 15:38, Qin Wu <[email-masked]> wrote:

  Hi, Varun:
  ----- Original Message ----- 
  From: Varun Singh 
  To: Qin Wu 
  Cc: [email-masked] 
  Sent: Tuesday, December 13, 2011 8:06 PM
  Subject: Re: Fw: Fw: [xrblock] I-D Action: draft-ietf-xrblock-rtcp-xr-discard-01.txt (Clarifying Measurement Identity)

  Hi Qin, 

  Changed the subject to clarifying measurement identity, so that it is easier to find.

  Comments inline.

    Hi, Varun:
    Firstly, Discard metric can not be sample metric. 
    How do you know how many packets are discarded if you just sample a few packets at the end 
    of measurement Interval for sample metric rather than collect all the packets during the measurement Interval.

  >      has been sampled at end of the interval.

  The above definition is a bit confusing. Continuously measured gave me the idea that it was defined as the Measurement Interval in the measurement identity block. Perhaps the definition should be clarified to mean that the values are based on a sampling algorithm which is run at the end of each reporting interval. Or the receiver resamples the observed values in the measurement interval.

  [Qin]: This definition is based on Alan's proposal on sampled metric on the list before Taipei meeting. But I think your suggestion looks reasonable to me.
  will see how to reflect this in the new update.

Ok.

    Sample metric only apply to a few metric measurement,e.g., PDV metric. This has been discussed on the list for a long time.

  Thanks for clarifying. Is this sample duration indicated in the PDV metric?
    Secondly The measurement interval for a metric may be different from the RTCP
    reporting interval. In this case, you still need a measurment information block.

    the start of the RTP session( extended first sequence number,extended last sequence number,

  Yes this is true if the report is sent to a monitoring device. However if the messages are sent to the media sender, then the sender knows:
  The first packet it sent at the start of the cumulative session.
  The HSN in the previous RR packet is start of the interval report 
  The HSN in the current RR packet gives the end of the cumulative and interval report. 
  Problems may occur if a RR is lost, then the sender may incorrectly identify the interval. This may affect the interpretation of the indicated value.

  Especially, for the discard drafts (RLE, num of discards, bytes discarded). The sender can act upon the information, then I do not see why these messages cannot be sent to the sender. The question then in this cases is: does the receiver really need to send the measurement identity? 

  [Qin]: My view is:
  In this case when the message are sent to the media sender, if RR is not present, the receiver may still need to send measurement information block. Otherwise, you should discard the metric that rely on 
  the RR if RR is not sent.

So, in summary:
In a compound packet (RR is present) sent to a media sender there is no need of the measurement information block if the implied duration is between successive RTCP reports or is cumulative from start of session. In all other cases, the measurement block is needed. 

[Qin]: Yes, that is my understanding.

    Fouth, before sampled metric is introduced recently, measurement identity block is originally used
    to report the additional measurement information that is not present in the RTCP RR, e.g.,extended 
    first sequence number,extended last sequence number. 

  I agree, the extended first sequence number (FSN) is important to correctly identify the start of the reporting interval. However, Last Sequence Number is only useful if it different from the HSN reported in the RR. If so: I have a clarifying question on how is the measurement interval calculated? is it the difference between RTP timestamps (or reception timestamps) of Extended First Sequence Number and Extended Last Sequence Number?

  [Qin]: One reason to carry Last sequence number is measurement interval may be different from the RTCP
  reporting interval, therefore RR may be not present when you receiver  measurement information block.

Ok, so the reports can be sent non-compound. 

[Qin]:Yes.

  Regarding measurement Interval calculation, I think the measurement interval can be calculated by user endpoint 
  based on receiving RTP media packets.

I think this should be mentioned somewhere in the measurement identity draft. 

[Qin]: That makes sense.

Regards,
Varun

  Regards,
  Varun

    Hope this clarifies.

    Regards!
    -Qin
    ----- Original Message ----- 
    From: Varun Singh 
    To: Qin Wu 
    Cc: [email-masked] 
    Sent: Monday, December 12, 2011 8:15 PM
    Subject: Re: Fw: [xrblock] I-D Action: draft-ietf-xrblock-rtcp-xr-discard-01.txt

    Hi Qin, 

    Comments inline

      Hi, Varun:
      ----- Original Message ----- 
      From: Varun Singh 
      To: [email-masked] 
      Sent: Friday, December 09, 2011 7:58 PM
      Subject: Re: [xrblock] I-D Action: draft-ietf-xrblock-rtcp-xr-discard-01.txt

      Hi, 

>      Cumulative) covered by this report.
"Sampled" should also be mentioned if Interval and cumulative are mentioned. Or say: Number of packets discarded in the period defined in the Interval metric flag (I)  [Qin]: That's fair. I forgot to update this into the document and will mentinon this in the new update. >      Note that the number of packets expected in the period covered by
>      the metric (whether interval or cumulative) is available from the
>      difference between a pair of extended sequence numbers in the
>      Measurement Identity block, so need not be repeated in this block.
My understanding is that the measurement identity is only associated to the sampled interval (I=01). 

      If a measurement identity interval is exactly equal to the cumulative interval or last RTCP interval then shouldn't the reports blocks use the sampled metric flag (I=01) instead of saying they are cumulative (I=11) or interval metrics (I=10)?

      [Qin]: My understanding is No. Sample metric can share the same interval as interval or cumulative
      metric, the only diffence between them is for sample metric, a number of
      samples is only collected and measured at the end of such interval. You may check our 
      discussion with Alan regarding sample metric on the list to see that.

    My question is not so much related to sampled metric itself but it is --- when to use the measurement identity? 

    My understanding was that the measurement identity is related to the sampled metric and does not apply to the Interval and Cumulative Metrics because it explicitly defines the interval over which the calculation is done (namely, the First and Last Sequence Numbers). While the interval and cumulative metrics are implicitly defined. Interval metric is the last RTCP RR interval and the cumulative metric is from the beginning of the session and therefore do not require an associated measurement identity block. 

    If they (cumulative, interval metrics) did require a measurement block, then couldn't the receiver just send them as sampled metrics and associate the interval explicitly in the measurement block?

    Regards,
    Varun