Subject: [xrblock] Fw: ISSUE: Early vs Late discard

From: Qin Wu <[email-masked]>
Date: Thu, 22 Dec 2011 08:43:39 +0800

Hi, Varun:
----- Original Message ----- 
From: Varun Singh 
To: Qin Wu 
Cc: [email-masked] ; xrblock 
Sent: Wednesday, December 21, 2011 8:24 PM
Subject: Re: [xrblock] ISSUE: Early vs Late discard

Hi Qin,

Comment inline.

Regards,
Varun

On Wed, Dec 21, 2011 at 04:00, Qin Wu <[email-masked]> wrote:

  Hi,Jing:
  Your suggestion make sense to me. That is to say the total of discard due to early arrival and discard due to late arrival are used to calculate
  the fraction of packets discarded during gaps (i.e.,gap discard rate) specified in the burst-gap-discard draft. Therefore we should support
  reporting such total discard during the measurement interval.

  My proprosal to fix this is to allocate two bits for "Early Indication Flag" and redefine "Ealry Indication Flag" in draft-ietf-xrblock-rtcp-xr-discard as follows:
  OLD TEXT
  "
     Early indication flag (E): 1bit

        This field is used to indicate whether packets are discarded due
        to early arrival or due to late arrival.  This field MUST be set
        to '1' if packets are discarded due to too early arrival and MUST
        be set to '0' otherwise.

  "
  NEW TEXT
  "
     Early indication flag (E): 2bits

        This field is used to indicate whether packets are discarded due
        to early arrival or due to late arrival or due to both.  This field MUST be set
        to '1' if packets are discarded due to too early arrival and MUST
        be set to '2' if packets are discarded due to late arrival. If packets are discarded
        due to both early arrival and late arrival, this field MUST be set to '3'.

  "
  In this case, we can support three following cases using this 2 bit flag:
  case 1: report the number of discarded packets due to early arrival
  case 2: report the number of dicarded packets due to late arrival
  case 3: report the total number of dicarded packets.

  Does this address your comment?

Will this prohibit reporting both early and late discards in the same reporting interval?

[Qin]: My understanding is no or not necessary, you can report early discard in one XR Block and report the late discard in another XR Block using the same block type
in the same reporting interval. I can make this clear in the text if you think this addresses your comment.

  Regards!
  -Qin
    ----- Original Message ----- 
    From: [email-masked] 
    To: xrblock 
    Sent: Tuesday, December 20, 2011 10:35 AM
    Subject: [xrblock] ISSUE: Early vs Late discard

    Hi, 
    Following the early Alan's comment  on the list regarding early vs late discard, on October,30 
    http://www.ietf.org/mail-archive/web/xrblock/current/msg00113.html 
    His comment only applies to draft-ietf-xrblock-rtcp-xr-discard. 
    It was agreed that distinguishing early discard from late discard is a useful feature on the list. Therefore it is worth 
    having this implemented into the draft-ietf-xrblock-rtcp-xr-discard when we disccussed burst gap related drafts in IETF82 meeting. 
    In the Tapei meeting, Charles also had one comment relate to this issue: i.e., how to report both Early and late in the same interval? 
    That is to say if we distinguish early discard from late discard, do we need to discard due to both early arrival and late arrival. 
    After re-reading the draft-ietf-xrblock-rtcp-xr-discard, I believe the early motivation to write draft-ietf-xrblock-rtcp-xr-discard is to only report the discard due to both early discard and late discard, i.e., number of packets discarded, this parameter will be used to calculate the Gap discard rate specifed in the section 3.3 of draft-ietf-xrblock-rtcp-xr-burst-gap-discard and draft-zorn-xrblock-rtcp-xr-al-stat. 
    In the recent update of draft-xrblock-rtcp-xr-discard, it only support reporting early discard or late discard, but does not support reporting discard due to both early arrival and late arrival. Therefore I suggest to update draft-xrblock-rtcp-xr-discard to support reporting discard due to both early arrival and late arrival. 
    Also I believe the feature to distinguish Ealry vs late discard does not apply to draft-ietf-rtcp-xr-burst-gap-discard. Since this draft relies on discard due to both early and late arrival described in the draft-ietf-xrblock-rtcp-xr-discard rather than discard to due to either early arrival or late arrival. 
    Regards! 
    ZhaoJing 
    Shanghai Research Institution of China Telecom 

----------------------------------------------------------------------------

    _______________________________________________
    xrblock mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/xrblock

  _______________________________________________
  xrblock mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/xrblock

-- 
http://www.netlab.tkk.fi/~varun/

---

From: Varun Singh <[email-masked]>
Date: Thu, 22 Dec 2011 09:08:27 +0200

Hi Qin,

On Thu, Dec 22, 2011 at 02:43, Qin Wu <[email-masked]> wrote:

> **
> *From:* Varun Singh <[email-masked]>
> *To:* Qin Wu <[email-masked]>
> *Cc:* [email-masked] ; xrblock <[email-masked]>
> *Sent:* Wednesday, December 21, 2011 8:24 PM
> *Subject:* Re: [xrblock] ISSUE: Early vs Late discard
>
> Hi Qin,
>
> Comment inline.
>
> Regards,
> Varun
>
>> **
>> Your suggestion make sense to me. That is to say the total of discard due
>> to early arrival and discard due to late arrival are used to calculate
>> the fraction of packets discarded during gaps (i.e.,gap discard rate)
>> specified in the burst-gap-discard draft. Therefore we should support
>> My proprosal to fix this is to allocate two bits for "Early Indication
>> Flag" and redefine "Ealry Indication Flag" in
>> draft-ietf-xrblock-rtcp-xr-discard as follows:
>> OLD TEXT
>> "
> [Qin]: My understanding is no or not necessary, you can report early
> discard in one XR Block and report the late discard in another XR Block
> using the same block type
Yes, clarifying that both can be sent separately in a measurement interval
addresses my requirement.