Subject: Re: [xrblock] Fw: I-D Action:draft-asaeda-xrblock-rtcp-xr-synchronization-03.txt

From: [email-masked]
Date: Wed, 8 Feb 2012 12:28:57 +0800 (CST)

Hi,

I think this draft defines useful metric for synchronization. Here is my review to the draft-asaeda-xrblock-rtcp-xr-synchronization.

This draft provides two metric blocks for multimedia session, one is Initial Synchronization Delay

,another is synchronization offset.

1. My comments to the first metric block is:

a.can this metric block be used to deal with the case

where audio stream and video stream are carried in the same RTP stream?

b. How do you calculate this metric?

2. My comments to the second metric block is :

a. Can you give me a use case for this metric block?

b.How this metric deal with intra-media synchronization and inter-media synchronization?

c. what's the difference between synchronization offset and inter-media synchronization or intra-media synchronization?

d. it is better to have a definition of synchronization offset?

Regards!

-ZhaoJing

----- Original Message -----

From: "Qin Wu" <[email-masked]>

To: <[email-masked]>

Sent: Friday, February 03, 2012 3:02 PM

Subject: [xrblock] Fw: I-D Action:draft-asaeda-xrblock-rtcp-xr-synchronization-03.txt

> On 2 February 2012, at 5:13, [email-masked] wrote:

>> A New Internet-Draft is available from the on-line Internet-Drafts directories.

>> Title           : RTCP XR Blocks for Synchronization Delay and Offset Metrics Reporting

>> Author(s)       : Hitoshi Asaeda

>>                          Rachel Huang

>>                          Qin Wu

>> Filename        : draft-asaeda-xrblock-rtcp-xr-synchronization-03.txt

>> Pages           : 10

>> Date            : 2012-02-02

>>   This document defines an RTCP XR Report Block and associated SDP

>>   parameters that allow the reporting of synchronization delay and

>>   offset metrics for use in a range of RTP applications.

>> A URL for this Internet-Draft is:

http://www.ietf.org/internet-drafts/draft-asaeda-xrblock-rtcp-xr-synchronization-03.txt

> A few update to Synchronization Delay and Offset XR Block draft. This draft is used to report

> initial synchronization delay to establish multimedia session and synchronization offset between

> RTP streams that belong to the same multimedia session. We think this draft is well cooked and

> ready for Chairs review and moving forward.

> _______________________________________________

> xrblock mailing list

> [email-masked]

https://www.ietf.org/mailman/listinfo/xrblock

---

From: Qin Wu <[email-masked]>
Date: Tue, 21 Feb 2012 16:27:15 +0800

Hi, Jing:
Sorry for late reply, please see my replies below.
  ----- Original Message ----- 
  From: [email-masked] 
  To: Qin Wu ; xrblock 
  Sent: Wednesday, February 08, 2012 12:28 PM
  Subject: Re: [xrblock] Fw: I-D Action:draft-asaeda-xrblock-rtcp-xr-synchronization-03.txt

  Hi, 
  I think this draft defines useful metric for synchronization. Here is my review to the draft-asaeda-xrblock-rtcp-xr-synchronization.  
  This draft provides two metric blocks for multimedia session, one is Initial Synchronization Delay  
  ,another is synchronization offset. 
  1. My comments to the first metric block is: 
  a.can this metric block be used to deal with the case 
  where audio stream and video stream are carried in the same RTP stream?  
[Qin]: Yes, since this metric is used to report intitial delay to receive all the streams that belong to the same multimedia session. It does not matter
 if audio stream and video stream carried in the same or different RTP stream.
  b. How do you calculate this metric? 
[Qin]: You can measure this metric based on measurement method in RFC6051. The basic rationale is to measure the average time taken to receive the first
 RTCP packet for the RTP multimedia session. 
  2. My comments to the second metric block is : 
  a. Can you give me a use case for this metric block? 
[Qin]:  One typical case if audio and video synchronization in the multimedia session, suppose audio stream and video stream are transmitted in two different RTP streams.
 In some case, audio stream may be transmitted before  video stream for mutiple tens of ms, in some case,
audio may lag video for mutiple tens of ms.
  b.How this metric deal with intra-media synchronization and inter-media synchronization?  
[Qin]:This metric is focusing on deal with inter-media synchronization. This is becos if audio stream and video are carried in the same RTP stream,
 there is no synchronization delay between audio and video.
  c. what's the difference between synchronization offset and inter-media synchronization or intra-media synchronization? 
[Qin]: See above.
  d. it is better to have a definition of synchronization offset? 

[Qin]:Good suggestion, will do this in the update.
   
  Regards! 
  -ZhaoJing