Subject: [xrblock] WGLC for draft-ietf-xrblock-rtcp-xr-burst-gap-loss-06.txt

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 6 Dec 2012 12:20:02 +0000

This is a (second) Working Group Last Call for http://www.ietf.org/id/ draft-ietf-xrblock-rtcp-xr-burst-gap-loss-06.txt.  

Please read and review this document, and send your comments, questions and concerns to the WG list before December 20, 2012. If you read the document, have no comments and you believe that the document is ready for submission to the IESG as a Standards Track document please send a short message as well to help us in determining the level of review and consensus. 

Thanks and Regards,

Dan

---

From: Colin Perkins <[email-masked]>
Date: Tue, 11 Dec 2012 23:15:45 +0100

> Please read and review this document, and send your comments, questions and concerns to the WG list before December 20, 2012. If you read the document, have no comments and you believe that the doc…

This looks to be in good shape, but my comments on the burst-gap-discard draft generally apply here too.

-- 
Colin Perkins
http://csperkins.org/

---

From: Qin Wu <[email-masked]>
Date: Wed, 12 Dec 2012 16:14:59 +0800

Thanks, we will synchronize both draft for the changes proposed.

Regards!
-Qin
----- Original Message ----- 
From: "Colin Perkins" <[email-masked]>
To: "Romascanu, Dan (Dan)" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, December 12, 2012 6:15 AM
Subject: Re: [xrblock] WGLC fordraft-ietf-xrblock-rtcp-xr-burst-gap-loss-06.txt

> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 20 Dec 2012 14:05:19 +0000

Hi,

The document is in good shape. I have however a number of comments and questions, please address them.

1. In Section 1.1, the second sentence in the second paragraph has a broken syntax. I suggest: 

s/ Burst/Gap metrics are typically used in Cumulative reports however MAY be used in Interval reports./ Burst/Gap metrics are typically used in Cumulative reports, however they also MAY be used in Interval reports./

2. It would be good to provide an example or a reference to the 'stream repair means' mentioned in section 1.4.

3. In Section 3.1 at the Interval Metric flag definition - I guess that the last phrase means 'Sampled Value (I=01) MUST not be used.' 

One more thing is missing here - what is the behavior of the receiver when receiving I=01 or I=00 which is undefined? I believe these need to be specified. 

4. The behavior of the receiver if a report with block length different than 5 is received is not defined. Please define. 

5. In the definitions of Sum of Burst Durations, Packets lost in bursts, and Total packets expected in bursts, we have:

      If the measured value exceeds 0xFFFFFD, the value 0xFFFFFE SHOULD
      be reported to indicate an over-range measurement.  If the
      measurement is unavailable, the value 0xFFFFFF SHOULD be reported.  

What is the reasons that these are SHOULD? If there are exceptions, please specify these, if not s/SHOULD/MUST/

6. In the definitions of Number of bursts, we have:

      If the measured value exceeds 0xFFFD, the value 0xFFFE SHOULD
      be reported to indicate an over-range measurement.  If the
      measurement is unavailable, the value 0xFFFF SHOULD be reported.  

What is the reasons that these are SHOULD? If there are exceptions, please specify these, if not s/SHOULD/MUST/

7. In the definitions of Sum of Squares of Burst Durations, we have:

      If the measured value exceeds 0xFFFFFFFD, the value 0xFFFFFFFE SHOULD
      be reported to indicate an over-range measurement.  If the
      measurement is unavailable, the value 0xFFFFFFFF SHOULD be reported.  

What is the reasons that these are SHOULD? If there are exceptions, please specify these, if not s/SHOULD/MUST/

8. In Section 3.3: 

s/These metrics provides information/These metrics provide information/

9. In Section 4 please expand PCM.

Thanks and Regards,

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Romascanu, Dan (Dan)
> Sent: Thursday, December 06, 2012 2:20 PM
> To: [email-masked]
> Subject: [xrblock] WGLC for draft-ietf-xrblock-rtcp-xr-burst-gap-loss-
> 06.txt
> 
> This is a (second) Working Group Last Call for http://www.ietf.org/id/
> draft-ietf-xrblock-rtcp-xr-burst-gap-loss-06.txt.
> 
> Please read and review this document, and send your comments, questions
> and concerns to the WG list before December 20, 2012. If you read the
> document, have no comments and you believe that the document is ready
> for submission to the IESG as a Standards Track document please send a
> short message as well to help us in determining the level of review and
> consensus.
> 
> Thanks and Regards,
> 
> Dan
>

---

From: Qin Wu <[email-masked]>
Date: Fri, 21 Dec 2012 14:10:27 +0800

Thank you, we will fix these in the update.

Regards!
-Qin