Subject: Re: [xrblock] SDP Directorate review of draft-ietf-xrblock-rtcp-xr-discard

From: Qin Wu <[email-masked]>
Date: Tue, 18 Dec 2012 10:20:23 +0800

I guess the reference "RFC3711 section 5" Jonathan mentioned should be corrected as "RFC3611 section 5".
If my understanding is correct, what Jonathan suggested is to have the following change:
OLD TEXT:
"
   RFC 3611 defines the use of SDP (Session Description Protocol)
   [RFC4566] for signaling the use of RTCP XR blocks.  XR blocks MAY be
   used without prior signaling.

"
NEW TEXT:
"
   RFC 3611 defines the use of SDP (Session Description Protocol)
   [RFC4566] for signaling the use of RTCP XR blocks.  However XR blocks MAY be
   used without prior signaling (see section 5 of RFC3611).
"
Please correct me if I am wrong.

Regards!
-Qin
----- Original Message ----- 
From: "Glen Zorn" <[email-masked]>
To: "Jonathan Lennox" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Tuesday, December 18, 2012 9:50 AM
Subject: Re: SDP Directorate review of draft-ietf-xrblock-rtcp-xr-discard

> On 12/17/2012 10:49 PM, Jonathan Lennox wrote:
> 
>> I have been asked to perform  the SDP Directorate review for
> > draft-ietf-xrblock-rtcp-xr-discard. I reviewed the -10 version of the
> > document.
> >
> >
> >
> > Syntactically, the SDP usage in this document seems fine. It is a
> > simple and correct usage of an extension point defined in RFC 3711.
> >
> >
> >
> > However, the statement in Section 4 that "XR blocks MAY be used
> > without explicit signaling" is confusing, as it implies that the
> > entire SDP section is entirely optional. This document should at
> > least reference Section 5 of RFC 3711, which gives guidance as to
> > when SDP signaling of the use of XR blocks is recommended.
> >
> 
> I'm not sure why this is confusing (aside from fact that RFC 3711 is 
> itself confusing: it says "although the use of SDP signaling for XR 
> blocks may be optional, if used, it MUST be used as defined here". /May/ 
> be optional?  Optionality seems pretty black and white to me ;-).  That 
> said, however, it does seem to be relatively clear that the usage of SDP 
> /is/ optional & along with it the section on SDP in this and other 
> similar drafts.  What am I missing?
> 
> ...
>

---

From: Glen Zorn <[email-masked]>
Date: Tue, 18 Dec 2012 10:03:22 +0700

On 12/18/2012 09:20 AM, Qin Wu wrote:

> I guess the reference "RFC3711  section 5" Jonathan mentioned should
 > be corrected as "RFC3611 section 5". If my understanding is correct,
 > what Jonathan suggested is to have the following change: OLD TEXT: "
 > " NEW TEXT: " RFC 3611 defines the use of SDP (Session Description
 > Protocol) [RFC4566] for signaling the use of RTCP XR blocks. However
 > XR blocks MAY be used without prior signaling (see section 5 of
 > RFC3611). " Please correct me if I am wrong.

My comment still stands: the existing text is not confusing & needn't be 
changed.

...

---

From: Jonathan Lennox <[email-masked]>
Date: Tue, 18 Dec 2012 10:18:12 -0500

Yes, that text addition seems reasonable to me.

For people experienced with XRBlocks, Glen's point that this isn't confusing is taken; but I think this addition would be helpful for those (like me) who are coming to this somewhat cold.

Sorry for the typo in the RFC number.

-----Original Message-----
From: Qin Wu [mailto:[email-masked]] 
Sent: Monday, December 17, 2012 9:20 PM
To: Glen Zorn; Jonathan Lennox
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: SDP Directorate review of draft-ietf-xrblock-rtcp-xr-discard

"
NEW TEXT:
"

Regards!
-Qin

---

From: "Qin Wu" <[email-masked]>
Date: Tue, 18 Dec 2012 10:20:23 +0800

I guess the reference "RFC3711 section 5" Jonathan mentioned should be
 corrected as "RFC3611 section 5".
If my understanding is correct, what Jonathan suggested is to have the
 following change:
OLD TEXT:
"
   RFC 3611 defines the use of SDP (Session Description Protocol)
   [RFC4566] for signaling the use of RTCP XR blocks.  XR blocks MAY be
   used without prior signaling.

"
NEW TEXT:
"
   RFC 3611 defines the use of SDP (Session Description Protocol)
   [RFC4566] for signaling the use of RTCP XR blocks.  However XR blocks MAY
 be
   used without prior signaling (see section 5 of RFC3611).
"
Please correct me if I am wrong.

Regards!
-Qin
----- Original Message ----- 
From: "Glen Zorn" <[email-masked]>
To: "Jonathan Lennox" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
 <[email-masked]>
Sent: Tuesday, December 18, 2012 9:50 AM
Subject: Re: SDP Directorate review of draft-ietf-xrblock-rtcp-xr-discard

> similar drafts.  What am I missing?
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic