Subject: [xrblock] Additional PID parameter to PSI dependent Decodability report

From: Qin Wu <[email-masked]>
Date: Mon, 19 Aug 2013 03:40:03 +0000

Hi, All:
During Berlin meeting, one comment raised to PSI dependent Decodability draft
(http://tools.ietf.org/html/draft-bi-xrblock-rtcp-xr-psi-dep-decodability-01) in<http://tools.ietf.org/html/draft-bi-xrblock-rtcp-xr-psi-dep-decodability-01)%20in>
the XRBLOCK Session by Alan was suggesting the addition of the PID to the report.
In the current draft, we have already add PID_error_count under priority two to the report.
PID_error_count is used to report any error when any PID doesn't refer to an actual data stream.

After doing a  little investigation to ETSI TR 101.290 specification, we believe it is
useful to add "unreferenced PID count" to the report.
"Unreferenced PID" is under priority three and is a packet with a PID that is not
listed in the PMT. This parameter is not critical, but it
indicates that packets are being disassociated from the PMT, possibly through
remultiplexing.

Therefore I propose to add "Unreferenced_PID_Count" as one addition to report as follows:
NEW TEXT:
"
Unreferenced_PID_count: 32 bits

A count of the number of Unrerenced_PIDs that occurred in the above
sequence number interval.  A Unreferenced PID is a packet with a PID
that is not listed in the PMT,as defined in the section 5.2.3 of
[ETSI]. It indicates that packets are being disassociated from the
PMT, possibly through remultiplexing.
"

Regards!
-Qin

---

From: Qin Wu <[email-masked]>
Date: Fri, 23 Aug 2013 11:37:06 +0000

Hi, :
In draft-bi-xrblock-rtcp-xr-psi-dep-decodability-01, we use PID_error_count to report
the count of any PID errors when any PID doesn't refer to an actual data stream.
However draft-bi-xrblock-rtcp-xr-psi-dep-decodability-01 doesn't report what PID these errors relate to.

If we choose to report PIDs related to these errors, one issue we need to deal with, i.e.,
How to report multiple PIDs in one report block? since one RTP stream may contain multiple TS stream,
Each TS steam uses different PIDs,

If we report these PIDs in one report block, block content can be variable length.
Alternatively,  we can choose to report each PID in one block, then there will be multiple report blocks in the corresponding RTCP XR report.

Let me know what one is appropriate?
Thanks!

Regards!
-Qin

On 19 Aug 2013, at 04:40, Qin Wu <[email-masked]<mailto:[email-masked]>> wrote:
Hi, All:

that is not listed in the PMT,as defined in the section 5.2.3of

Regards!
-Qin

_______________________________________________
xrblock mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/xrblock

--
Colin Perkins
http://csperkins.org/