Subject: [xrblock] I-D Action: draft-ietf-xrblock-rtcp-xr-post-repair-loss-count-04.txt

From: [email-masked]
Date: Sun, 22 Jun 2014 23:39:22 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Metric Blocks for use with RTCP's Extended Report Framework Working Group of the IETF.

        Title           : RTP Control Protocol (RTCP) Extended Report (XR) for Post-Repair Loss Count Metrics
        Authors         : Rachel Huang
                          Varun Singh
	Filename        : draft-ietf-xrblock-rtcp-xr-post-repair-loss-count-04.txt
	Pages           : 10
	Date            : 2014-06-22

Abstract:
   This document defines an RTP Control Protocol (RTCP) Extended Report
   (XR) Block that allows reporting of post-repair loss count metrics
   for a range of RTP applications.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-xrblock-rtcp-xr-post-repair-loss-count/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-xrblock-rtcp-xr-post-repair-loss-count-04

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-xrblock-rtcp-xr-post-repair-loss-count-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 23 Jun 2014 12:44:56 +0000

Hi,

Does anybody have concerns about submitting this I-D to the IESG? Were all comments made in WGLC addressed by the authors? 

Are there any implementations written, deployed, or planned to be written and deployed? 

Thanks and Regards,

Dan

> -----Original Message-----
> From: xrblock [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Monday, June 23, 2014 9:39 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [xrblock] I-D Action: draft-ietf-xrblock-rtcp-xr-post-repair-loss-
> count-04.txt
> 
> 
>  This draft is a work item of the Metric Blocks for use with RTCP's Extended
> Report Framework Working Group of the IETF.
> 
> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock

---

From: Colin Perkins <[email-masked]>
Date: Mon, 23 Jun 2014 15:15:06 +0100

Hi,

My concerns were mostly addressed, but I still think the sentence “Note that the metrics in this report block MUST NOT be directly compared with the pre-repair loss metric of [RFC3550]” doesn’t belong in the Introduction, and should move into Section 3.

Cheers,
Colin

-- 
Colin Perkins
http://csperkins.org/

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Tue, 24 Jun 2014 00:41:44 +0000

Hi Colin,

Will do.

BR,
Rachel

> From: xrblock [mailto:[email-masked]] On Behalf Of Colin Perkins
> Sent: Monday, June 23, 2014 10:15 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]
> Subject: Re: [xrblock] I-D Action:
> draft-ietf-xrblock-rtcp-xr-post-repair-loss-count-04.txt
> 
> Hi,
> 
> My concerns were mostly addressed, but I still think the sentence "Note that
> the metrics in this report block MUST NOT be directly compared with the
> pre-repair loss metric of [RFC3550]" doesn't belong in the Introduction, and
> should move into Section 3.
> 
> Cheers,
> Colin
> 
> 
> 
> 
> > Does anybody have concerns about submitting this I-D to the IESG? Were all
> comments made in WGLC addressed by the authors?
> >
> >> From: xrblock [mailto:[email-masked]] On Behalf Of
> >> internet- [email-masked]
> >> Subject: [xrblock] I-D Action:
> >> draft-ietf-xrblock-rtcp-xr-post-repair-loss-
> >> count-04.txt
> >>
> >>
> >> This draft is a work item of the Metric Blocks for use with RTCP's
> >> Extended Report Framework Working Group of the IETF.
> >>
> >>        Title           : RTP Control Protocol (RTCP) Extended Report
> (XR) for Post-
> >> Repair Loss Count Metrics
> >>        Authors         : Rachel Huang
> >>                          Varun Singh
> >> https://datatracker.ietf.org/doc/draft-ietf-xrblock-rtcp-xr-post-repa
> >> ir-loss-
> >> count/
> >>
> >> http://tools.ietf.org/html/draft-ietf-xrblock-rtcp-xr-post-repair-los
> >> s-count-
> >> 04
> >>
> >> http://www.ietf.org/rfcdiff?url2=draft-ietf-xrblock-rtcp-xr-post-repa
> >> ir-loss-
> >> count-04
> >>
> >>
> >> Please note that it may take a couple of minutes from the time of
> >> submission until the htmlized version and diff are available at tools.ietf.org.
> >>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 24 Jun 2014 00:45:35 +0000

Can I ask what the "MUST NOT" is meant to convey here.

The reading at first glance would just be to say "is not the same as", which is not really a normative impact on the implementation.

Keith 

> Huangyihong (Rachel)
> Sent: 24 June 2014 01:42
> To: Colin Perkins; Romascanu, Dan (Dan)
> Cc: [email-masked]
> > My concerns were mostly addressed, but I still think the sentence 
> > "Note that the metrics in this report block MUST NOT be directly 
> > compared with the pre-repair loss metric of [RFC3550]" 
> doesn't belong 
> > in the Introduction, and should move into Section 3.
> > 
> > Cheers,
> > Colin
> > 
> > 
> > 
> > 
> > > Are there any implementations written, deployed, or planned to be 
> > > written
> > and deployed?
> > >
> > > Thanks and Regards,
> > >
> > > Dan
> > >
> > >
> > >> A New Internet-Draft is available from the on-line 
> Internet-Drafts
> > directories.
> > >> 	Filename        :

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Tue, 24 Jun 2014 01:12:34 +0000

Hi Keith,

Yes, you're right. Actually this sentence should be deleted from this new version. I forgot to do it. The relationship between the metric from RTCP SR/RR and the metrics in this draft has already been presented in Section 3. There's no need for this sentence now.

BR,
Rachel

> From: DRAGE, Keith (Keith) [mailto:[email-masked]]
> Sent: Tuesday, June 24, 2014 8:46 AM
> To: Huangyihong (Rachel); Colin Perkins; Romascanu, Dan (Dan)
> Cc: [email-masked]
> Subject: RE: [xrblock] I-D Action:
> The reading at first glance would just be to say "is not the same as", which is
> not really a normative impact on the implementation.
> 
> Keith
>