Subject: [xrblock] FW: publish FPWD of Identifiers for WebRTC's Statistics API; respond by 10 Oct 2014.

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 1 Oct 2014 13:57:24 +0000

Please see below the W3C Call for Consensus for the first public draft of the WebRTC stats API. This work is related to the RTCWeb work in XRBLOCK. 

If you wish to discuss aspects related to the XRBLOCK work you are invited to do it here. If you want to send comments or participate in the W3C CfC please send these directly to the W3C mail list. 

Thanks and Regards,

Dan

> -----Original Message-----
> From: Stefan Håkansson LK [mailto:[email-masked]]
> Sent: Wednesday, October 01, 2014 11:50 AM
> To: [email-masked]
> Subject: CfC: publish FPWD of Identifiers for WebRTC's Statistics API; respond
> by 10 Oct 2014.
> 
> Hi all,
> 
> This is a Call for Consensus (CfC)  to publish a FPWD of 'Identifiers for
> WebRTC's Statistics API'.
> 
> The draft is here: http://w3c.github.io/webrtc-stats/
> 
> Please review and note any concerns by responding to this mail. This CfC
> ends next week, Friday, 10 Oct 2014. If you need more time, please indicate
> so.
> 
> Please note that a FPWD is just that, a first public draft, so it need not be
> perfect and subsequent change is possible; publishing this draft should give it
> further review and attention.
> 
> Please respond to this CfC (even a +1 is useful). Silence will be considered
> agreement.
> 
> Thanks
> Stefan
> 
> [1] http://w3c.github.io/webrtc-stats/

---

From: Varun Singh <[email-masked]>
Date: Wed, 1 Oct 2014 10:22:21 -0500

Thank you Dan for forwarding this. Feedback on the spec, metrics is appreciated.

In reference to WG's other work on RTCPXR-statistics, I would like to
hear feedback on setting up a registry, i.e., should we setup a new
one, reuse an IPPM registry. IIRC this was discussed briefly at the
last meeting (Al Morton sent a pointer earlier, details here:
http://www.ietf.org/mail-archive/web/xrblock/current/threads.html#01660).

Cheers,
Varun

On Wed, Oct 1, 2014 at 8:57 AM, Romascanu, Dan (Dan) <[email-masked]> wrote:
> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock

-- 
http://www.netlab.tkk.fi/~varun/

---

From: Colin Perkins <[email-masked]>
Date: Thu, 9 Oct 2014 14:00:13 +0100

Hi Varun,

My impression is that the IPPM metrics registry is broader than what this group would need for WebRTC. I expect draft-ietf-xrblock-rtcweb-rtcp-xr-metrics will need to include a registry of metrics that are exposed via the WebRTC statistics API. That registry might refer to the metrics via the IPPM metrics registry, but I think it’s separate to (and a subset of) the IPPM metrics registry.

Colin

-- 
Colin Perkins
https://csperkins.org/

---

From: Varun Singh <[email-masked]>
Date: Fri, 10 Oct 2014 00:52:53 +0300

Thank you Colin for the feedback. I would like to hear other
participants' opinions as well.

Another thing to note: most metrics proposed in the current draft
report cummulative values, meanwhile the XR metrics can also report
over shorter interval. The IPPM registry combines the same metric with
different measurement intervals under one numerical identifier, while
the xrblock may choose to distinguish between cumulative values and
interval values. For example: totalPacketsLost, intervalPacketsLost.

Cheers,
Varun

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Sat, 11 Oct 2014 09:39:07 +0000

Hi Varun,

Please see inline.

BR,
Rachel

> From: xrblock [mailto:[email-masked]] On Behalf Of Varun Singh
> Sent: Friday, October 10, 2014 5:53 AM
> To: Colin Perkins
> Cc: xrblock
> Subject: Re: [xrblock] publish FPWD of Identifiers for WebRTC's Statistics API;
> respond by 10 Oct 2014.
> 
> Thank you Colin for the feedback. I would like to hear other participants'
> opinions as well.
> 
> Another thing to note: most metrics proposed in the current draft report
> cummulative values, meanwhile the XR metrics can also report over shorter
> interval. The IPPM registry combines the same metric with different
> measurement intervals under one numerical identifier, while the xrblock may
> choose to distinguish between cumulative values and interval values. For
> example: totalPacketsLost, intervalPacketsLost.

[Rachel]: Correct me if I'm wrong. IPPM registry does not distinguish measurement duration. It regards interval or cumulative pattern as the fixed parameters which could be determined and input in the measurement system when needed. I think it makes sense since there's no need to create two different metrics name for different measurement duration. While in our draft, we only consider cumulative values. So I think maybe we should just explicitly say it in the draft that the fixed parameter "I" is set to 11 (Cumulative Duration)?

> > My impression is that the IPPM metrics registry is broader than what this
> group would need for WebRTC. I expect
> draft-ietf-xrblock-rtcweb-rtcp-xr-metrics will need to include a registry of
> metrics that are exposed via the WebRTC statistics API. That registry might
> refer to the metrics via the IPPM metrics registry, but I think it’s separate to
> (and a subset of) the IPPM metrics registry.
> >
> > Colin
> >
> >
> >>> Please see below the W3C Call for Consensus for the first public draft of
> the WebRTC stats API. This work is related to the RTCWeb work in XRBLOCK.
> >>>
> >>> If you wish to discuss aspects related to the XRBLOCK work you are invited
> to do it here. If you want to send comments or participate in the W3C CfC
> please send these directly to the W3C mail list.
> >>>
> >>> Thanks and Regards,
> >>>
> >>> Dan
> >>>
> >>>
> >>>> Subject: CfC: publish FPWD of Identifiers for WebRTC's Statistics
> >>>> API; respond by 10 Oct 2014.
> >>>>
> >>>> Hi all,
> >>>>
> >>>> This is a Call for Consensus (CfC)  to publish a FPWD of
> >>>> 'Identifiers for WebRTC's Statistics API'.
> >>>>
> >>>> Please review and note any concerns by responding to this mail.
> >>>> This CfC ends next week, Friday, 10 Oct 2014. If you need more
> >>>> time, please indicate so.
> >>>>
> >>>> Please note that a FPWD is just that, a first public draft, so it
> >>>> need not be perfect and subsequent change is possible; publishing
> >>>> this draft should give it further review and attention.
> >>>>
> >>>> Please respond to this CfC (even a +1 is useful). Silence will be
> >>>> considered agreement.
> >>>>
> >>>> Thanks
> >>>> Stefan
> >>>>

---

From: Varun Singh <[email-masked]>
Date: Sun, 12 Oct 2014 00:48:28 +0300

Hi Rachel,

Comments are inline.

>> Thank you Colin for the feedback. I would like to hear other
participants'
> [Rachel]: Correct me if I'm wrong. IPPM registry does not distinguish
> measurement duration. It regards interval or cumulative pattern as the
> fixed parameters which could be determined and input in the
> measurement system when needed. I think it makes sense since there's

True, the IPPM registry serves as input to designers, and therefore
combines different measurement intervals into one identifier.

> no need to create two different metrics name for different measurement
> duration. While in our draft, we only consider cumulative values.

If we consider adding RTCP SR and RR metrics, then two metrics fractionLost
and Jitter would not be cumulative, the interval is then inferred from the
reception
timestamp of the corresponding report. In which case our document would have
to explicitly state the measurement interval for each metric.

>So I think maybe we should just explicitly say it in the draft that the
fixed parameter "I" is set to 11 (Cumulative Duration)?

Yes this is possible, but is this sufficient?