Subject: [xrblock] FW: New Version Notification for draft-huang-xrblock-rtcp-xr-video-lc-02.txt

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Mon, 20 Oct 2014 03:07:55 +0000

Dear all,

A new version of video loss concealment draft is available now. Several updates were made based on the consensus from the last IETF meeting :

- Add some use-cases descriptions in Section 1.
- Delete retransmission method. And use one bit to indicate other loss concealment method.
- Change "Loss Concealed Image Duration" metric to " Loss Impaired Video Image Duration"
- Replace "DMBF/CMBF" metrics with "MIFP/MCFP"
- Clarify the measurement points and intervals in Section 4.
- Some minor editorial changes.

Your review and comments are well appreciated.

BR,
Rachel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, October 20, 2014 10:54 AM
To: Alan Clark; Alan Clark; Huangyihong (Rachel); Huangyihong (Rachel)
Subject: New Version Notification for draft-huang-xrblock-rtcp-xr-video-lc-02.txt

A new version of I-D, draft-huang-xrblock-rtcp-xr-video-lc-02.txt
has been successfully submitted by Rachel Huang and posted to the IETF repository.

Name:		draft-huang-xrblock-rtcp-xr-video-lc
Revision:	02
Title:		RTCP XR Report Block for Loss Concealment Metrics Reporting on Video Applications
Document date:	2014-10-20
Group:		Individual Submission
Pages:		10
URL:            http://www.ietf.org/internet-drafts/draft-huang-xrblock-rtcp-xr-video-lc-02.txt
Status:         https://datatracker.ietf.org/doc/draft-huang-xrblock-rtcp-xr-video-lc/
Htmlized:       http://tools.ietf.org/html/draft-huang-xrblock-rtcp-xr-video-lc-02
Diff:           http://www.ietf.org/rfcdiff?url2=draft-huang-xrblock-rtcp-xr-video-lc-02

Abstract:
   This draft defines a new video loss concealment block type to augment
   those defined in [RFC3611] and [i.d-ietf-xrblock-rtcp-xr-loss-
   concealment] for use in a range of RTP video applications.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Tue, 21 Oct 2014 02:47:55 +0000

Hi Colin,

Thanks for the comments. Please see inline.

BR,
Rachel

> From: Colin Perkins [mailto:[email-masked]]
> Sent: Monday, October 20, 2014 9:48 PM
> To: Huangyihong (Rachel)
> Subject: Re: [xrblock] New Version Notification for 
> draft-huang-xrblock-rtcp-xr-video-lc-02.txt
> 
> Rachel,
> 
> This looks to address many of my comments on the earlier versions, 
> thanks! I have some quick comments on this version:
> 
> Replacing retransmission in VLCM with Other Loss Concealment Method is 
> a good change.
> 
> The MIFP and MCFP fields are 8 bits, but use 0xFFFF (a 16 bit value) 
> to indicate an unavailable measurement; this should be 0xFF. You may 
> also consider whether these fields are better expressed as fixed-point 
> binary fractions, like the fraction lost field in RTCP RR packets, 
> rather than percentages, to use the full range of available values.

[Rachel]: Will fix it. Your suggestion makes sense to me.
> 
> Why are both loss free and impaired durations needed? Don't they sum 
> to the total duration of the call, meaning that one is redundant?

[Rachel]: No, there's difference. The metric of 'Loss impaired video image duration' is the duration that still have impaired video pictures after applying loss concealments. It's the time length that actually affects the end user's QoE. We change 'loss concealed image duration' to it because we found that 'Concealed Image Duration' was hard to measure since you don't know if it was concealed or not.
 'Loss impaired video image duration' <= total duration of the call - loss free video image duration.

> 
> The report block includes Impaired Image Duration and Mean Impaired 
> Frame Proportion, which are matching metrics, but Loss Free Image 
> Duration and Mean Concealed Frame Proportion, which don't match. If 
> Mean Concealed Frame Proportion is to be reported, the draft has to 
> report the corresponding Concealed Image Duration for consistency.

[Rachel]: See above. Do we have to keep the metrics consistency?

> 
> Colin
> 
> 
> 
> 
> 
> On 20 Oct 2014, at 04:07, Huangyihong (Rachel) 
> <[email-masked]>
> wrote:
> 
> > Dear all,
> >
> > A new version of video loss concealment draft is available now. 
> > Several
> updates were made based on the consensus from the last IETF meeting :
> >
> > - Delete retransmission method. And use one bit to indicate other 
> > loss
> concealment method.
> > - Change "Loss Concealed Image Duration" metric to " Loss Impaired 
> > Video
> Image Duration"
> > Subject: New Version Notification for
> draft-huang-xrblock-rtcp-xr-video-lc-02.txt
> >
> >
> > has been successfully submitted by Rachel Huang and posted to the 
> > IETF
> repository.
> >
> > URL:
> http://www.ietf.org/internet-drafts/draft-huang-xrblock-rtcp-xr-video-
> lc-02.txt
> > Status:
> https://datatracker.ietf.org/doc/draft-huang-xrblock-rtcp-xr-video-lc/
> > Htmlized:
> http://tools.ietf.org/html/draft-huang-xrblock-rtcp-xr-video-lc-02
> > Diff:
> http://www.ietf.org/rfcdiff?url2=draft-huang-xrblock-rtcp-xr-video-lc-
> 02
> >
> > Abstract:
> > Please note that it may take a couple of minutes from the time of 
> > submission
> until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat
> >
> > _______________________________________________
> > xrblock mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/xrblock
> 
> 
> 
> --
> Colin Perkins
> https://csperkins.org/
> 
> 
>

---

From: Colin Perkins <[email-masked]>
Date: Wed, 22 Oct 2014 18:56:59 -0400

Hi Rachel,

On 20 Oct 2014, at 22:47, Huangyihong (Rachel) <[email-masked]> wrote:
> ‘Loss impaired video image duration' <= total duration of the call - loss free video image duration.

I’m still not sure I understand the difference. Do times when errors were successfully concealed not count towards loss impaired duration?

> [Rachel]: See above. Do we have to keep the metrics consistency?

I do think consistency is important, but perhaps the issue is that I’m not understanding what is meant by the loss impaired metric.

Colin

-- 
Colin Perkins
https://csperkins.org/

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Thu, 23 Oct 2014 06:41:28 +0000

Hi Colin,

Please see inline.

BR,
Rachel

> Sent: Thursday, October 23, 2014 6:57 AM
> To: Huangyihong (Rachel)
> Cc: xrblock
> >> Replacing retransmission in VLCM with Other Loss Concealment Method
> >> is a good change.
> >>
> >> also consider whether these fields are better expressed as
> >> fixed-point binary fractions, like the fraction lost field in RTCP RR
> >> packets, rather than percentages, to use the full range of available values.
> >
> > [Rachel]: No, there's difference. The metric of 'Loss impaired video image
> duration' is the duration that still have impaired video pictures after applying
> loss concealments. It's the time length that actually affects the end user's QoE.
> We change 'loss concealed image duration' to it because we found that
> 'Concealed Image Duration' was hard to measure since you don't know if it was
> concealed or not.
> I'm still not sure I understand the difference. Do times when errors were
> successfully concealed not count towards loss impaired duration?

[Rachel]: Yes. total duration of the call = loss free video image duration + totally concealed loss impaired duration + Loss impaired video image duration
> I do think consistency is important, but perhaps the issue is that I'm not
> understanding what is meant by the loss impaired metric.

[Rachel]: Actually, MIFP and MCFP are not matched to duration metrics. They are calculated in Loss impaired video image duration, so that they could provide more information than just duration metrics for estimation of the concealment quality.
> >>>  This draft defines a new video loss concealment block type to
> >>> augment  those defined in [RFC3611] and
> >>> [i.d-ietf-xrblock-rtcp-xr-loss-  concealment] for use in a range of RTP video
> applications.
> >>>
> >>>
> >>>
> >>>
> >>>

---

From: Colin Perkins <[email-masked]>
Date: Thu, 23 Oct 2014 22:05:03 +0100

Rachel,

> [Rachel]: Yes. total duration of the call = loss free video image duration + totally concealed loss impaired duration + Loss impaired video image duration

Then, I think you need to improve the terminology. It’s not obvious that loss impaired duration excludes impaired duration where the loss was completely concealed.

> [Rachel]: Actually, MIFP and MCFP are not matched to duration metrics. They are calculated in Loss impaired video image duration, so that they could provide more information than just duration metr…

I’m suggesting that the mean duration and the total duration metrics should be paired.

Colin

-- 
Colin Perkins
https://csperkins.org/