Subject: [xrblock] WGLC for draft-ietf-xrblock-rtcweb-rtcp-xr-metrics

From: Shida Schubert <[email-masked]>
Date: Tue, 19 Jan 2016 20:31:53 -0800

All;

This message starts a Working Group Last Call for the draft-ietf-xrblock-rtcweb-rtcp-xr-metrics-02.txt. 

http://tools.ietf.org/id/draft-ietf-xrblock-rtcweb-rtcp-xr-metrics-02.txt <http://tools.ietf.org/id/draft-ietf-xrblock-rtcweb-rtcp-xr-metrics-02.txt>

Even if you have no questions, comments or concern, if you have read the draft and agree that it’s ready for submission to IESG as a Standard Track, please send a message to the list indicating this. 

Obviously if you have any issues or questions please submit it to the list, if you are highlighting issues suggestions to fix the issues is always helpful.

The Working Group Last Call will end on February 4th. 

Shida
As co-chair

---

From: Colin Perkins <[email-masked]>
Date: Mon, 25 Jan 2016 12:51:23 +0000

> On 20 Jan 2016, at 04:31, Shida Schubert <[email-masked]> wrote:
> 

I have two comments:

1) The draft uses RFC 2119 terms in lower case in a number of places. I think it would be clearer if these were changed to upper case where the intent is to use normative language, and rephrased to use alternative terms otherwise. 

2) The draft has a reasonable list of candidate metrics, but does not make a clear recommendation which metrics ought to be implemented. Is the intent that a WebRTC end-point implementor picks an arbitrary subset of these, or that all the metrics are implemented? If a subset is to be implemented, which subset? What are the most important to implement? Adding some further normative language would probably help clarify.

That said, I have no objection to sending this draft to the IESG for publication. It suggests a reasonable set of metrics, and is well enough written. 

-- 
Colin Perkins
https://csperkins.org/

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Thu, 28 Jan 2016 09:13:31 +0000

Hi Colin,

Thank you for your comments. Please see inline.

BR,
Rachel

From: xrblock [mailto:[email-masked]] On Behalf Of Colin Perkins
Sent: Monday, January 25, 2016 8:51 PM
To: Shida Schubert
Cc: xrblock
Subject: Re: [xrblock] WGLC for draft-ietf-xrblock-rtcweb-rtcp-xr-metrics

On 20 Jan 2016, at 04:31, Shida Schubert <[email-masked]<mailto:[email-masked]>> wrote:

http://tools.ietf.org/id/draft-ietf-xrblock-rtcweb-rtcp-xr-metrics-02.txt

I have two comments:

[Rachel]: Okay. I agree. Some “should” and “should not” can be changed to upper case. But not each type of metrics has the RFC2119 terms. I’m wondering if it’s okay to have some of them to use  normative language while others not?

[Rachel]: I think these metrics are all considered optional, and could be picked by implementations based on their own requirements, for example, some of them may need to accurately distinguish loss and discard to evaluate the transport performance, some of them may require to evaluate the performance after concealment…

--
Colin Perkins
https://csperkins.org/