Subject: [xrblock] Liaison Statement to W3C for rtcweb-rtcp-xr-metrics

From: Shida Schubert <[email-masked]>
Date: Tue, 19 Jan 2016 20:32:53 -0800

All;

Below is a draft for liaison statement to W3C for draft-ietf-xrblock-rtcweb-rtcp-xr-metrics. 

Welcoming comments…

*****

W3C,

The XRBLOCK WG in IETF has been working on a draft recommending the type of RTCP XR blocks that would be beneficial for webrtc endpoint, in order to identify any issues regarding media stream(s) and act on to provide better overall user-experience to the end-user. The draft defines a IANA registry with a list of identifiers for the WebRTC's statistics API with a set of RTCP SR, RR, and XR metrics related to the transport of multimedia flows.

http://tools.ietf.org/wg/xrblock/draft-ietf-xrblock-rtcweb-rtcp-xr-metrics.

Gist from the introduction of the draft:  
"The WebRTC Stats API currently lists
 metrics reported in the RTCP Sender and Receiver Report (SR/RR)
 [RFC3550] to fulfill this requirement.  However, the basic metrics
 from RTCP SR/RR are not sufficient for precise quality monitoring, or
 diagnosing potential issues.

 In this document, we provide some guidelines on choosing additional
 RTP metrics for the WebRTC [W3C.WD-webrtc-20150210].  Furthermore, we
 create a registry containing metrics reported in RTCP XR."

Any comments are welcome. 

S. Schubert
Co-chair, XRBLOCK Workgroup

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 20 Jan 2016 15:54:53 +0000

Hi Shida,

Here are a few comments: 

- to avoid extra processing and dispatching time we should send the liaison statement to the WebRTC WG rather than the whole W3C
- use https://datatracker.ietf.org/doc/draft-ietf-xrblock-rtcweb-rtcp-xr-metrics/ as a better reference to the I-D 
- point to the WG mail list for comments (so that they do not feel obliged to respond with a formal liaison) e.g. s/ Any comments are welcome/Comments from the W3C WebRTC WG participants are welcome, they can be provided directly to the WG [email-masked] mail list/

Regards,

Dan

> -----Original Message-----
> From: xrblock [mailto:[email-masked]] On Behalf Of Shida
> Schubert
> Sent: Wednesday, January 20, 2016 6:33 AM
> To: xrblock
> Subject: [xrblock] Liaison Statement to W3C for rtcweb-rtcp-xr-metrics
> 
> 
> All;
> 
> The XRBLOCK WG in IETF has been working on a draft recommending the
> type of RTCP XR blocks that would be beneficial for webrtc endpoint, in order
> to identify any issues regarding media stream(s) and act on to provide better
> overall user-experience to the end-user. The draft defines a IANA registry
> with a list of identifiers for the WebRTC's statistics API with a set of RTCP SR,
> RR, and XR metrics related to the transport of multimedia flows.
> 
> http://tools.ietf.org/wg/xrblock/draft-ietf-xrblock-rtcweb-rtcp-xr-metrics/
> 
>  metrics reported in the RTCP Sender and Receiver Report (SR/RR)  [RFC3550]
> to fulfill this requirement.  However, the basic metrics  from RTCP SR/RR are
> not sufficient for precise quality monitoring, or  diagnosing potential issues.
> 
>  In this document, we provide some guidelines on choosing additional  RTP
> metrics for the WebRTC [W3C.WD-webrtc-20150210].  Furthermore, we

---

From: Shida Schubert <[email-masked]>
Date: Wed, 20 Jan 2016 19:57:12 -0800

Hi Dan, dear co-chair :) 

Much appreciate the comments. 

I will revise it based on your feedback!

Thanks!
Shida

> On Jan 20, 2016, at 7:54 AM, Romascanu, Dan (Dan) <[email-masked]> wrote:
> 
> Hi Shida,
> 
> Here are a few comments: 
>

---

From: Shida Schubert <[email-masked]>
Date: Sun, 24 Jan 2016 16:57:41 -0800

All;

Below is a revised liaison statement reflecting the feedback. 

*****

WebRTC WG,

https://datatracker.ietf.org/doc/draft-ietf-xrblock-rtcweb-rtcp-xr-metrics/

Gist from the introduction of the draft:
"The WebRTC Stats API currently lists metrics reported in the RTCP Sender and Receiver Report (SR/RR)  [RFC3550] to fulfill this requirement.  However, the basic metrics  from RTCP SR/RR are not sufficient for precise quality monitoring, or  diagnosing potential issues.

In this document, we provide some guidelines on choosing additional  RTP metrics for the WebRTC [W3C.WD-webrtc-20150210].  Furthermore, we create a registry containing metrics reported in RTCP XR."

Any comments from the W3C WebRTC WG participants are welcome, they can be provided directly to the WG by sending your comments to [email-masked]. 

S. Schubert