Subject: Re: [xrblock] Genart telechat review of draft-ietf-xrblock-rtcweb-rtcp-xr-metrics-09

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Tue, 1 May 2018 16:15:08 +0000

Hi Robert,

I believe I have responded you in February, if you check the mail archive of xrblock.

Follows was my response before. And I uploaded a new version to reflect that since I didn't get your further email. Sorry for assuming that you received my response.

"
    Hi Robert, 

    Thanks for the comment.

     I propose to change the last paragraph of 5.2.2 from

    "
   The following metrics can also be considered for WebRTC's Statistics
   API: number of discarded key frames, number of lost key frames,
   number of discarded derived frames, number of lost derived frames.
   These metrics can be used to calculate Media Loss Rate (MLR) of MDI.
   Details of the definition of these metrics are described in
   [RFC7003].  Additionally, the metric provides the rendered frame
   rate, an important parameter for quality estimation.
    "

    To

    "
     The metrics in this category includes
    : number of discarded key frames, number of lost key frames,
   number of discarded derived frames, number of lost derived frames.
   These metrics can be used to calculate Media Loss Rate (MLR) of MDI.
   Details of the definition of these metrics are described in
   [RFC7003].  Additionally, the metric provides the rendered frame
   rate, an important parameter for quality estimation.
    "

    This change is to just talk about the metrics itself, so as to avoid any confusion that readers may have. The fact is that the W3C has already included the metrics, and made an informational reference to this document.

    If the proposal looks good to you, we'll reflect it in the new version.

"

BR,
Rachel

-----邮件原件-----
发件人: Robert Sparks [mailto:[email-masked]] 
发送时间: 2018年5月2日 0:04
收件人: [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]
主题: Genart telechat review of draft-ietf-xrblock-rtcweb-rtcp-xr-metrics-09

Reviewer: Robert Sparks
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair. Please wait for direction from your document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-xrblock-rtcweb-rtcp-xr-metrics-09
Reviewer: Robert Sparks
Review Date: 2018-05-01
IETF LC End Date: 2018-02-23
IESG Telechat date: 2018-05-24

Summary: Ready for publication as an Informational RFC, but with nits to consider before publication

Note that this is identical to my last call review, which I don't think I've seen a response to.

The document argues to include things in the W3C statistics API in the last paragraph of 5.2.2. Section 7 seems to say those have been included already. It would be good to rework both of these mentions to reflect what's true at the time of the publication of the RFC, in a way that the text will make sense when read years from now.

---

From: Robert Sparks <[email-masked]>
Date: Tue, 1 May 2018 11:21:39 -0500

Sorry for not seeing your earlier response (and for not spotting the 
change in the diff correctly).

Yes, this change is sufficient to address my comments.

RjS

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 18 May 2018 12:59:11 -0400

Robert, thanks for your review. Rachel, thanks for the edit. I have entered a No Objection ballot.

Alissa

> On May 1, 2018, at 12:15 PM, Huangyihong (Rachel) <[email-masked]> wrote:
> 
> Hi Robert,
> 
> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock