Subject: [yaco-idsubmit-tool] Fwd: Bug report in new IDST

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 26 Apr 2011 14:54:53 +0200

Hi Emilio,

Please see below.  The observation is correct, of course -- the tool
needs to allow posting of correctly dated drafts from any timezone.

Best,

	Henrik

-------- Original Message --------
Subject: Bug report in new IDST
Date: Tue, 26 Apr 2011 06:19:49 -0400
From: Matt Larson <[email-masked]>
To: Henrik Levkowetz <[email-masked]>
CC: Glen Barney <[email-masked]>

Hi Henrik!

We've received a ticket for the new IDST:

> Hi,
> 
> There's a timezone-related bug in the new I-D submission tool,
> which did not exist in the old version.
> 
> It flags a metatdata error thus:
> 
> "Creation date 2011-04-26
> Creation Date must not be set after submission date"
> 
> I am submitting a draft created a few moments ago, just after
> 17:00 (5 pm.) today April 26th, New Zealand Standard Time.
> 
> Oh look, it's still April 25th in California - you guys are
> sooo backward :-)
> 
> The tool needs to have enough tolerance to deal with submissions
> from the other side of the world, like the previous version did.
> 
> (OK, I know the workaround, but this bug needs to be fixed.)
> 
> -- 
> Regards
> Brian Carpenter

Matt

-------------------------------------------
Matthew Larson, Asst. IT Director
Association Management Solutions
Forum Management, Meeting and Event Planning
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
http://www.amsl.com

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Tue, 26 Apr 2011 17:12:28 +0200

Hi Henrik,

    I have solved it just like the old told does by allowing that the 
creation date is three days after or three days before the current 
submission date.

    See http://trac.tools.ietf.org/tools/ietfdb/ticket/652

    Best,

El 26/04/11 14:54, Henrik Levkowetz escribió:
> From: Matt Larson<[email-masked]>
> To: Henrik Levkowetz<[email-masked]>
> CC: Glen Barney<[email-masked]>
>
> Hi Henrik!
>
> _______________________________________________
> yaco-idsubmit-tool mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yaco-idsubmit-tool