Subject: Re: [yam] whither YAM?

From: Alexey Melnikov <[email-masked]>
Date: Wed, 09 Feb 2011 18:34:53 +0000

Hi John,

John C Klensin wrote:

>Tony,
>
>I'd rather make this reappraisal after we see the composition of
>the IESG that should be seated in Prague.  It seems to me that
>the key question is whether the IESG is going to be willing to
>process the documents as originally intended and that might give
>us a clue.  Or not, but certainly we will not have less
>information.
>
>In theory, we should have that information in well under a
>month.  If we do not, I think I'd suggest going ahead and asking
>for a meeting slot on the theory that meetings are much more
>easily cancelled (should that be necessary) than scheduled.
>  
>
I am sorry for not picking up this thread earlier, but let me say I was 
distracted by activities in a couple of my other WGs.

But anyway, now that the new IESG membership is known, I think the poll 
needs to be restarted.

>I certainly wouldn't object to modifying the charter to include
>your item C.
>
That part should be no problems.

>Finding out whether the IESG would be willing to
>approve a revised charter that included them but also included
>the preapproval model for documents that might go from
>Draft->Full would be another way to get some information.
>  
>
I can ask IESG about keeping the old charter, but my personal opinion is 
that the process documented in the charter is more work for both the WG 
and for IESG.

>   john
>
>
>--On Thursday, January 13, 2011 13:53 -0500 Tony Hansen
><[email-masked]> wrote:
>  
>
>>Folks, the time has come to start deciding what to do with the
>>YAM working group. I've been discussing this with my co-chair
>>and our AD, and I see several ways forward:
>>
>>     1) stay on hold -- keep the group in hiatus for another X
>>months
>>         a) we would need to decide on what X is
>>
>>     2) restart work as originally chartered. This means going
>>back and
>>         picking up where we left off on 5321bis, 5322bis and
>>4409bis.
>>
>>     3) shut down
>>
>>     4) recharter (see below)
>>
>>There are several ways we could recharter.
>>
>>     A) We could eliminate or modify the "process experiment"
>>we've been
>>	using (where we publish an I-D that indicates what needs to
>>	change, get IESG approval, and *then* proceed with revising
>>the
>>	RFC).
>>
>>     B) We could review the documents that were in the
>>original YAM
>>	charter. For any that we feel need to be revved no matter what
>>	(for example, 3798 MDN (one of my documents) is in this list),
>>	we can proceed with revising them.
>>
>>     C) We start taking a look at the Proposed Standard
>>mail-related
>>	standards and see what they need to moved forward to the next
>>	status.
>>
>>     D) Do something else.
>>
>>     E) Any combination of the above.
>>
>>Please provide your input. We have exactly one month to come
>>to a consensus, after which it will be too late to schedule a
>>meeting in Prague (should we decide we need one).
>>
>>         Tony Hansen
>>         YAM co-chair
>>

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 09 Feb 2011 18:49:25 +0000

Hi Tony,
With my AD hat on:

Tony Hansen wrote:

> Folks, the time has come to start deciding what to do with the YAM 
> working group. I've been discussing this with my co-chair and our AD, 
> and I see several ways forward:
>
>     1) stay on hold -- keep the group in hiatus for another X months

I am very uncomfortable with letting this WG stay on hold for an 
extended period of time.
I think it is my duty as the outgoing AD to get rid of dead wood and 
simplify life for my successor.

>     2) restart work as originally chartered. This means going back and
>         picking up where we left off on 5321bis, 5322bis and 4409bis.

I suppose the WG can do that, but my personal opinion is that the 
process experiment has failed. IESG is not actually as much of a problem 
as people think it is, and I believe this is going to stay the same 
after March 2011.

>     4) recharter (see below)

These are my two preferred choices. Details of the new charter don't 
matter to me that much, as long as the process experiment part is removed.
My personal (not-as-an-AD) preferences are to do some combination of B) 
and C).

>     A) We could eliminate or modify the "process experiment" we've been
>     change, get IESG approval, and *then* proceed with revising the
>     RFC).
>
>     B) We could review the documents that were in the original YAM
>     C) We start taking a look at the Proposed Standard mail-related
> Please provide your input. We have exactly one month to come to a 
> consensus, after which it will be too late to schedule a meeting in 
> Prague (should we decide we need one).
>
>         Tony Hansen
>         YAM co-chair

Best Regards,
Alexey

-- 
IETF Application Area Director, <http://www.ietf.org/iesg/members.html>
Internet Messaging Team Lead, <http://www.isode.com>
JID: same as my email address

---

From: Dave CROCKER <[email-masked]>
Date: Wed, 09 Feb 2011 12:23:57 -0800

On 2/9/2011 10:49 AM, Alexey Melnikov wrote:
> I am very uncomfortable with letting this WG stay on hold for an extended period
> of time.
> I think it is my duty as the outgoing AD to get rid of dead wood and simplify
> life for my successor.
>
> I suppose the WG can do that, but my personal opinion is that the process
> experiment has failed. IESG is not actually as much of a problem as people think
> it is, and I believe this is going to stay the same after March 2011.

Russ Housley has recruited Eric Burger and me to help produce a new version of 
the two-stage maturity specification.  (It is within epsilon of being issued.)

That causes me to think it highly likely that some form of two-stage model will 
proceed to be adopted.

As such, I do not see any need for YAM.  We should shut down.

I agree that the effort be classed as a failure.  I disagree about the role of 
the IESG.  But that's rendered moot, of course.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: John C Klensin <[email-masked]>
Date: Fri, 11 Feb 2011 14:23:03 -0500

--On Wednesday, February 09, 2011 18:49 +0000 Alexey Melnikov
<[email-masked]> wrote:

>...
> These are my two preferred choices. Details of the new charter
> don't matter to me that much, as long as the process
> experiment part is removed.
> My personal (not-as-an-AD) preferences are to do some
> combination of B) and C).
> 
>...
>>     original YAM charter. For any that we feel need to be
>>     revved no matter what (for example, 3798 MDN (one of my
>>     documents) is in this list), we can proceed with revising
>>     them.
>> 
>>     mail-related standards and see what they need to moved
>>     forward to the next status.

For whatever my opinion is worth, I think it would be worth
taking a look at (C).  If there are documents at Proposed that
would benefit from a review of features and interoperability,
that is useful work regardless of what happens with the
standards process.  For anything else, it would be good to have
two-step sufficiently resolved that we knew what the targets
were that we had to meet (of course, the intent of the process
experiment was precisely to resolve that on a per-document
basis, so, while the experiment may be dead, the need for it is
not... unless we are to conclude that the IESG simply isn't
interested in advancing documents other than on a "guess what we
are likely to want" basis).

   john

---

From: Ned Freed <[email-masked]>
Date: Sun, 13 Feb 2011 10:01:57 -0800 (PST)

> are likely to want" basis).

+1

				Ned