Subject: [yang-doctors] Feedback on options for issue #1 in TE tunnel YANG

From: "Tarek Saad (tsaad)" <[email-masked]>
Date: Thu, 21 Jul 2016 12:59:42 +0000

Hi YANG doctors,

We have a requirement to reuse generic data across multiple technology model instantiations for model we’re driving in draft-ietf-teas-yang-te. For this, we've identified a number of proposals and tried to summarize them in slides 7-10 in the deck @ http://www.ietf.org/proceedings/96/slides/slides-96-teas-3.pptx

We are seeking your expert advice on the best way of the options to proceed with and whether there’s a precedence in other IETF models that have solved similar issues.

Regards,
Tarek (and co-authors)

---

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 22 Jul 2016 09:34:09 +0200

Tarek,

I am not sure I understand all the options you are describing, so maybe would need to understand that. I also do not understand the CON in the first option where you talk about leafrefs being error prone.

Assuming there is some minor clarification required, I would think Option 1 would work for you and is something that is used commonly across YANG models.

Anyway, I am around till noon if you want to help me understand the issue.

Thanks.

> On Jul 21, 2016, at 2:59 PM, Tarek Saad (tsaad) <[email-masked]> wrote:
> 
> Hi YANG doctors,
> 
> We have a requirement to reuse generic data across multiple technology model instantiations for model we’re driving in draft-ietf-teas-yang-te. For this, we've identified a number of proposals and tried to summarize them in slides 7-10 in the deck @http://www.ietf.org/proceedings/96/slides/slides-96-teas-3.pptx <http://www.ietf.org/proceedings/96/slides/slides-96-teas-3.pptx>
> 
> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors

Mahesh Jethanandani
[email-masked]

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 25 Jul 2016 15:38:39 +0200

Hi Tarek,

your analysis of available solutions seems correct and exhaustive. Maybe
I don't fully understand option #3 but I think you could achieve a
reasonable level of "object-orientedness" and separation of
technology-specific data by defining appropriate hierarchy of identities
(possibly with multiple inheritance, which is now possible in YANG 1.1),
and then using conditional augments.

As for option #2, the design of schema mount could perhaps include some
means for refering to data nodes and/or definitions in the parent
schema. This would however make the subschema usable only in a specific
context.

Lada

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C