Subject: [yang-doctors] YANG FAQ

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 21 Jul 2016 17:06:15 +0200

The chairs of NETCONF and NETMOD (Kent Watsen) cannot find the YANG FAQ page. 

A google search of “ietf yang faq” yields several links none of which point to anything that looks like a FAQ. There is no link from the OPS Area Wiki link to the FAQ. The link from NETMOD Wiki page to a FAQ points to an old FAQ that is not the same FAQ. I know it exists, because I have made an entry, but if you ask me I cannot find it.

Can we fix it.

Mahesh Jethanandani
[email-masked]

---

From: Benoit Claise <[email-masked]>
Date: Sun, 24 Jul 2016 18:21:23 +0200

The issue is that there are 2 FAQs: one from NETMOD (which I was not 
aware of), and one the YANG doctors.
Mehmet, can you please reconcile the two lists in one of the location, 
and provide the pointer in the other.

Regards, B.
> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors

---

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Sun, 24 Jul 2016 19:39:14 +0000

OK

Cheers,
Mehmet
(Sent from my iPad)

> Am 24.07.2016 um 21:37 schrieb Benoit Claise <[email-masked]>:
> 
> The issue is that there are 2 FAQs: one from NETMOD (which I was not aware of), and one the YANG doctors.
> Mehmet, can you please reconcile the two lists in one of the location, and provide the pointer in the other.
> 
> Regards, B.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 28 Jul 2016 13:10:59 +0200

So where is the final YANG FAQ going to be located?

https://trac.tools.ietf.org/area/ops/trac/wiki/yang-doctors

This is not the nicest URL since it does not actually indicate that
the document contains a YANG FAQ. Nor is the URL short (but there is
likely not much that can be done about this easily).

https://trac.tools.ietf.org/wg/netmod/trac/wiki/YANG_FAQ

This seems to indicate the FAQ belongs to NETMOD (which I personally
do not have a problem with). It does not seem to have been updated for
a long time.

In both cases, it would be nice if the page could include a last
changed timestamp. I do like the summary table of questions on the
NETMOD FAQ page since it helps to structure things.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Thu, 28 Jul 2016 12:42:51 +0000

Hi Juergen, All,

it seems the main decision we need to take is whether it  belongs under YANG Doctor's Wiki or NETMOD Wiki.
Although I don't mind to put it to NETMOD Wiki my preference is to have it under YANG Doctor's pages.
This is actually the place where we want to collect all YANG related community support and information.

I think the URLs and look&feel can be fixed.
I also agree having a ToC for the FAQ page is useful.
The original FAQ under NETMOD also requires some clean-up and polishing.

In a parallel mail we started discussing a better structure for the FAQ page and how to define categories to sort the Q&As.
Knowing that there is no optimal solution for all I think we should strive for a better structure.

Cheers, 
Mehmet 

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Thursday, July 28, 2016 1:11 PM
To: Ersue, Mehmet (Nokia - DE/Munich) <[email-masked]>
Cc: Benoit Claise <[email-masked]>; YANG Doctors <[email-masked]>
Subject: Re: [yang-doctors] YANG FAQ

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 28 Jul 2016 15:46:36 +0200

> The original FAQ under NETMOD also requires some clean-up and polishing.

Simply merge the useful stuff into the consolidated FAQ and then
remove the other oldish FAQs entirely. (The wiki keeps a history so in
case someone wants to travel backwards in time, there is a way to do
so.)

/js