Subject: Re: [yang-doctors] https://github.com/YangModels/yang/tree/master/standard/ietf/RFC

From: Benoit Claise <[email-masked]>
Date: Mon, 4 Jul 2016 10:53:14 +0200

Hi,

Commit done, with 2 symbolic links.

ls -lrt
total 496
-rw-rw-r-- 1 bclaise bclaise 12711 Jul  1 17:52 
[email-masked]
-rw-rw-r-- 1 bclaise bclaise 83002 Jul  1 17:52 
[email-masked]
-rw-rw-r-- 1 bclaise bclaise 20686 Jul  1 17:52 [email-masked]
-rw-rw-r-- 1 bclaise bclaise 24125 Jul  1 17:52 
[email-masked]
-rw-rw-r-- 1 bclaise bclaise 16772 Jul  1 17:52 
[email-masked]
-rw-rw-r-- 1 bclaise bclaise 15876 Jul  1 17:52 
[email-masked]
lrwxrwxrwx 1 bclaise bclaise    31 Jul  1 17:52 ietf-inet-types -> 
[email-masked]
-rw-rw-r-- 1 bclaise bclaise  2917 Jul  1 17:52 
[email-masked]
-rw-rw-r-- 1 bclaise bclaise 34701 Jul  1 17:52 iana-if-type.yang
-rw-rw-r-- 1 bclaise bclaise  4200 Jul  1 17:52 
[email-masked]
-rw-rw-r-- 1 bclaise bclaise  3900 Jul  1 17:52 
ietf-netconf-with-defaults.yang
-rw-rw-r-- 1 bclaise bclaise  9556 Jul  1 17:52 
[email-masked]
-rw-rw-r-- 1 bclaise bclaise  2013 Jul  1 17:52 
ietf-netconf-partial-lock.yang
-rw-rw-r-- 1 bclaise bclaise 10424 Jul  1 17:52 
ietf-netconf-notifications.yang
-rw-rw-r-- 1 bclaise bclaise 17420 Jul  1 17:52 
[email-masked]
-rw-rw-r-- 1 bclaise bclaise  6636 Jul  1 17:52 ietf-snmp-target.yang
-rw-rw-r-- 1 bclaise bclaise  4378 Jul  1 17:52 ietf-snmp-ssh.yang
-rw-rw-r-- 1 bclaise bclaise  4651 Jul  1 17:52 ietf-snmp-proxy.yang
-rw-rw-r-- 1 bclaise bclaise  6348 Jul  1 17:52 ietf-snmp-notification.yang
-rw-rw-r-- 1 bclaise bclaise  4289 Jul  1 17:52 ietf-snmp-engine.yang
-rw-rw-r-- 1 bclaise bclaise  7463 Jul  1 17:52 ietf-snmp-community.yang
-rw-rw-r-- 1 bclaise bclaise  4916 Jul  1 17:52 ietf-snmp-common.yang
-rw-rw-r-- 1 bclaise bclaise 26634 Jul  1 17:52 [email-masked]
-rw-rw-r-- 1 bclaise bclaise 17863 Jul  1 17:52 
[email-masked]
-rw-rw-r-- 1 bclaise bclaise 15500 Jul  1 17:52 
[email-masked]
lrwxrwxrwx 1 bclaise bclaise    31 Jul  1 17:52 ietf-yang-types -> 
[email-masked]
-rw-rw-r-- 1 bclaise bclaise  4980 Jul  1 17:52 
[email-masked]
-rw-rw-r-- 1 bclaise bclaise  7130 Jul  1 17:52 
[email-masked]
-rw-rw-r-- 1 bclaise bclaise 10990 Jul  1 17:52 ietf-x509-cert-to-name.yang
-rw-rw-r-- 1 bclaise bclaise  2384 Jul  1 17:52 
[email-masked]
-rw-rw-r-- 1 bclaise bclaise 24103 Jul  1 17:52 [email-masked]
-rw-rw-r-- 1 bclaise bclaise  2118 Jul  1 17:52 ietf-snmp.yang
-rw-rw-r-- 1 bclaise bclaise 10248 Jul  1 17:52 ietf-snmp-vacm.yang
-rw-rw-r-- 1 bclaise bclaise  6105 Jul  1 17:52 ietf-snmp-usm.yang
-rw-rw-r-- 1 bclaise bclaise  3199 Jul  1 17:52 ietf-snmp-tsm.yang
-rw-rw-r-- 1 bclaise bclaise  6802 Jul  1 17:52 ietf-snmp-tls.yang

Only 2 symbolic btw, and not all of them.

Regards, B.

> On 6/9/2016 3:14 PM, Rob Shakir wrote:
>>
>>> On Jun 9, 2016, at 04:13, Martin Bjorklund <[email-masked]> wrote:
>>>
>>> However, I usually do not add the revision date to the file name.  You
>>> can't just update the file w/o updating the filename if you do this.
>>
>> This is what I’m sensitive to - I have tooling (e.g., unit tests) 
>> that retrieve the latest version of some IETF modules from the repo 
>> (e.g., [0]). If the name of the file has the revision date in it, 
>> then this means that one needs to list out the files (or get all 
>> files in the directory) and then find the latest version of the 
>> module (given the current absence of the catalogue service).
>>
>> It seems to me that maintaining at least the symlink that Juergen 
>> mentions in the repo would be desirable, since this avoids the issue 
>> above and maintains compatibility for clients that are already 
>> retrieving such files without caring about the revision [1].
> Fine with everybody?
>
> Regards, B.
>>
>> Thanks,
>> r.
>>
>> [0]: 
>> https://github.com/robshakir/pyangbind/blob/master/tests/serialise/juniper-json-examples/run.py#L39-L55
>> [1]: Right now, both the example above and our internal tools that do 
>> the same kind of thing are broken.
>
>
>
> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors

---

From: Rob Shakir <[email-masked]>
Date: Tue, 5 Jul 2016 12:13:18 -0600

Hi Benoit,

Thanks for this. To resolve our internal tools, I had already forked the repository and changed our tooling to not use this one - but I will be interested to track the conclusion. 

Thanks,
r. 

Sent from my iPad

> On Jul 4, 2016, at 02:53, Benoit Claise <[email-masked]> wrote:
> 
> Hi,
> 
> -rw-rw-r-- 1 bclaise bclaise 12711 Jul  1 17:52 [email-masked]
> -rw-rw-r-- 1 bclaise bclaise 83002 Jul  1 17:52 [email-masked]
> -rw-rw-r-- 1 bclaise bclaise 24125 Jul  1 17:52 [email-masked]
> -rw-rw-r-- 1 bclaise bclaise 16772 Jul  1 17:52 [email-masked]
> -rw-rw-r-- 1 bclaise bclaise 15876 Jul  1 17:52 [email-masked]
> lrwxrwxrwx 1 bclaise bclaise    31 Jul  1 17:52 ietf-inet-types -> [email-masked]
> -rw-rw-r-- 1 bclaise bclaise  2917 Jul  1 17:52 [email-masked]
> -rw-rw-r-- 1 bclaise bclaise  4200 Jul  1 17:52 [email-masked]
> -rw-rw-r-- 1 bclaise bclaise  3900 Jul  1 17:52 ietf-netconf-with-defaults.yang
> -rw-rw-r-- 1 bclaise bclaise  9556 Jul  1 17:52 [email-masked]
> -rw-rw-r-- 1 bclaise bclaise  2013 Jul  1 17:52 ietf-netconf-partial-lock.yang
> -rw-rw-r-- 1 bclaise bclaise 10424 Jul  1 17:52 ietf-netconf-notifications.yang
> -rw-rw-r-- 1 bclaise bclaise 17420 Jul  1 17:52 [email-masked]
> -rw-rw-r-- 1 bclaise bclaise 17863 Jul  1 17:52 [email-masked]
> -rw-rw-r-- 1 bclaise bclaise 15500 Jul  1 17:52 [email-masked]
> lrwxrwxrwx 1 bclaise bclaise    31 Jul  1 17:52 ietf-yang-types -> [email-masked]
> -rw-rw-r-- 1 bclaise bclaise  4980 Jul  1 17:52 [email-masked]
> -rw-rw-r-- 1 bclaise bclaise  7130 Jul  1 17:52 [email-masked]
> -rw-rw-r-- 1 bclaise bclaise  2384 Jul  1 17:52 [email-masked]
>>> This is what I’m sensitive to - I have tooling (e.g., unit tests) that retrieve the latest version of some IETF modules from the repo (e.g., [0]). If the name of the file has the revision date in it, then this means that one needs to list out the files (or get all files in the directory) and then find the latest version of the module (given the current absence of the catalogue service). 
>>> 
>>> It seems to me that maintaining at least the symlink that Juergen mentions in the repo would be desirable, since this avoids the issue above and maintains compatibility for clients that are already retrieving such files without caring about the revision [1].
>> Fine with everybody?
>> 
>> Regards, B.
>>> 
>>> Thanks,
>>> r.
>>> 
>>> [0]: https://github.com/robshakir/pyangbind/blob/master/tests/serialise/juniper-json-examples/run.py#L39-L55
>>> [1]: Right now, both the example above and our internal tools that do the same kind of thing are broken.
>> 
>> 
>>