Subject: Re: [yang-doctors] FW: YANG FAQ Page - Module Organization Illustration proposed answer

From: Balazs Lengyel <[email-masked]>
Date: Thu, 28 Jul 2016 17:43:04 +0200

Hello,

Proposed answer to Module
Organization Illustration

As described in RFC6087bis section 4.3 for each YANG module a YANG
Tree representation SHOULD be provided.

The YANG Tree may be generated by the PYANG tool.

The PYANG tool MAY be used to generate an additional jstree format
that is viewable in a web browser. The jstree format provides a
collapsible HTML/JS tree view with additional information.  Both the
tree and the jstree format allows the generation of a tree including
multiple YANG modules.

regards Balazs

On 2016-06-19 22:23, Ersue, Mehmet
(Nokia - DE/Munich) wrote:

Hi All,

it seems we need to extend the
deadline for addressing the FAQ entries below.

Please provide your improvements
and draft answers by June 23, 2016.

1. Deviations versus if-feature? -
Martin Björklund

2. Should NETCONF server export
common YANG models? - Andy Bierman

3. Should Config, State, RPC,
Notifications, etc. for a given protocol be all in one
module, or different ones? (added by Rajiv Asati) - Lada
Lhotka

4. Intended, Applied and Derived
States? (added by Rajiv Asati) - Kent Watsen

5. Module Organization
Illustration? (added by Rajiv Asati, answered by ...) -
Balazs Lengyel

6. Can a leaf exist inside a module
by itself (without a container)? - Carl Moberg

Thank you for your input.

FAQ entries 6, 7 and 8 are now seen
as confirmed.

https://trac.tools.ietf.org/area/ops/trac/wiki/yang-doctors

Cheers,

Mehmet

_____________________________________________

From: Ersue, Mehmet (Nokia - DE/Munich)

Sent: Sunday, June 05, 2016 8:07 PM

To: [email-masked]

Subject: YANG FAQ Page - Assignments of Questions to
answer WAS:FW: YANG FAQ page and Developing of the Answers

Hi All,

This is the very first round of
assignments for the YANG FAQ page clarifications and the
drafting of answers.

So please bear with us and suggest
what you would like to improve.

See the mail below for some details
on the handling.

If for any reason you cannot
provide a draft answer please let me know as soon as
possible.

For some of the questions below
there is an incomplete answer on the wiki page below:

https://trac.tools.ietf.org/area/ops/trac/wiki/yang-doctors

1. Deviations versus if-feature? -
Martin Björklund

2. Should NETCONF server export
common YANG models? - Andy Bierman

3. Should Config, State, RPC,
Notifications, etc. for a given protocol be all in one
module, or different ones? (added by Rajiv Asati) - Lada
Lhotka

4. Intended, Applied and Derived
States? (added by Rajiv Asati) - Kent Watsen

5. Module Organization
Illustration? (added by Rajiv Asati, answered by ...) -
Balazs Lengyel

6. Can a leaf exist inside a module
by itself (without a container)? - Carl Moberg

Thank you for your efforts in
advance.

Mehmet

_____________________________________________

From: Ersue, Mehmet (Nokia - DE/Munich)

Sent: Sunday, June 05, 2016 8:05 PM

To: [email-masked]' <[email-masked]>

Subject: YANG FAQ page and Developing of the Answers

Hi All,

Benoit proposed to update/maintain
the YANG Wiki FAQ page. This is basically to do by

assigning questions to people and
validating the drafted answer text on YANG doctor’s list

(see attached mail).

As a result the Q/A page at https://trac.tools.ietf.org/area/ops/trac/wiki/yang-doctors

will be updated with the validated
answers.

As a starter I will assign the 6
questions currently on the FAQ page to people I assume can
answer it appropriately.

We need to check whether the
current answer on this page is sufficient and improve as
necessary.

If you don’t like the question
formulation you can provide a better one in your draft.

Please send your proposed draft
answer to [email-masked]
for validation and use the answered question in the
subject (at least partly if it is long).

PLMK with a short note if you feel
uncomfortable with the assigned question.

I propose to note the assignments
on the page below as a new category: YANG Questions and
Answers

https://trac.tools.ietf.org/area/ops/trac/wiki/yang-doctors-review-history

Please let us know the questions
you think should be addressed on the FAQ page.

As a reminder the minutes of YANG
editing and advice sessions are attached.

Any other suggestions are welcome.

Many Thanks.

Cheers,

Mehmet

_______________________________________________
yang-doctors mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/yang-doctors

--
Balazs Lengyel Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909 email: [email-masked]

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 28 Jul 2016 09:19:30 -0700

Balazs,

> On Jul 28, 2016, at 8:43 AM, Balazs Lengyel <[email-masked]> wrote:
> 
> The PYANG tool MAY be used to generate an additional jstree format that is viewable in a web browser. The jstree format provides a collapsible HTML/JS tree view with additional information.  Both the tree and the jstree format allows the generation of a tree including multiple YANG modules.

I do not know if Rajiv intended this question for just the FAQ or if he was asking for it in the context of a draft. If the latter, how would you propose a draft could embed the jstree output, specially for a .txt version of the draft? Provide a link? If so, where is the link going to reside?

Mahesh Jethanandani
[email-masked]

---

From: Balazs Lengyel <[email-masked]>
Date: Fri, 29 Jul 2016 12:29:20 +0200

IMHO

tree: SHOULD be in the draft/RFC and anywhere else where needed

jstree: NOT in the draft, anywhere else where needed. Good to know
we have this more advanced capability

Revised text:

As described in RFC6087bis section 4.3 for each YANG module
a YANG Tree representation SHOULD be provided. The YANG tree
representation SHOULD be included in internet draft and RFCs.
The YANG Tree may be generated by the PYANG tool.

The PYANG tool MAY be used to generate an additional
jstree format that is viewable in a web browser. The jstree
format provides a collapsible HTML/JS tree view with
additional information.  While the jstree format is useful it
is not suited for inclusion into drafts/RFCs.

Both the tree and the jstree format allows the generation
of a tree including multiple YANG modules.

regards Balazs

On 2016-07-28 18:19, Mahesh
Jethanandani wrote:

Balazs,

On Jul 28, 2016, at 8:43 AM, Balazs Lengyel
<[email-masked]>
wrote:

The PYANG tool MAY be used to
generate an additional jstree format that is viewable
in a web browser. The jstree format provides a
collapsible HTML/JS tree view with additional
information.  Both the tree and the jstree format
allows the generation of a tree including multiple
YANG modules.

I do not know if Rajiv intended this question for just
the FAQ or if he was asking for it in the context of a
draft. If the latter, how would you propose a draft could
embed the jstree output, specially for a .txt version of the
draft? Provide a link? If so, where is the link going to
reside?

Mahesh Jethanandani

[email-masked]