Subject: [yang-doctors] process question

From: Martin Bjorklund <[email-masked]>
Date: Thu, 12 Oct 2017 16:22:57 +0200 (CEST)

Hi,

Shouldn't all documents be reviewed by the YANG doctors when they go
to LC?  I *think* that currently some documents get an early review,
and then they are not reviewed again.

For example, I just noticed that the lime oam document has been sent
to the IESG.

https://datatracker.ietf.org/doc/draft-ietf-lime-yang-connectionless-oam/

This is now in -11, and the review was for -05.

/martin

---

From: Benoit Claise <[email-masked]>
Date: Thu, 12 Oct 2017 18:24:35 +0200

Hi Martin,

Good question.
Normally, the YANG doctor reviews (like MIB doctor reviews in the past) 
should happen at IETF LC.
To speed up the YANG modules delivery, we put in place the early YANG 
doctor reviews.
When a document enters the IETF LC, the YANG doctor should double-check 
the (YANG module in the) draft.
Most of the time, this is a light process.

It would be good to automatically remind the YANG doctor when "his" 
draft enters the IETF LC.
Mehmet, is this possible from the tool point of view?

Regards, Benoit
> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors
> .
>

---

From: "Mehmet Ersue" <[email-masked]>
Date: Fri, 13 Oct 2017 18:49:21 +0200

Unfortunately the tool has no means of generating a reminder for the
previous reviewer.
Currently we only get a notification if a WG chair requests a (new) review
with the tool.

Actually the tool is more simple than I was originally thinking. E.g. the
well-promised 
round-robin mechanism does not work and I have to maintain such a list with
a table.
The secretary cannot change the deadline set by the requester.

Cheers,
Mehmet

> -----Original Message-----
> From: yang-doctors [mailto:[email-masked]] On Behalf Of
> Benoit Claise
> Sent: Thursday, October 12, 2017 6:25 PM
> To: Martin Bjorklund <[email-masked]>; [email-masked]
> Subject: Re: [yang-doctors] process question
> 
> Hi Martin,
> 
> Good question.

---

From: Benoit Claise <[email-masked]>
Date: Fri, 13 Oct 2017 19:15:36 +0200

Hi Henrik,

> Currently we only get a notification if a WG chair requests a (new) review
Is this something we could improve?
> round-robin mechanism does not work
According to Gunter (for OPS-DIR), it works fine now.

Regards, Benoit
> and I have to maintain such a list with
> a table.

---

From: Andy Bierman <[email-masked]>
Date: Fri, 13 Oct 2017 10:24:09 -0700

Hi,

Why put the burden on the reviewer instead of the WG authors?
Make it part of the AD submission check-list:

   - Submitted version approved by YANG Doctors?  (MUST be yes)

Then it is up to the authors to make sure to ask for a review of the draft.

Andy

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 13 Oct 2017 21:48:09 +0200

Hi Benoit,

> Is this something we could improve?

That sounds like a good idea.  I understand this as a feature request to
make it possible for a reviewer to mark a document for 'notify when
entering last call'.  This might be useful also more generally.

Best regards,

	Henrik

---

From: Benoit Claise <[email-masked]>
Date: Sat, 14 Oct 2017 08:31:36 +0200

>    - Submitted version approved by YANG Doctors?  (MUST be yes)
It is already part of the writeup.
The question here different: in case of early reviews, should the YANG 
modules be doube-checked at IETF LC.
The answer is yes.

Regards, Benoit

> On Fri, Oct 13, 2017 at 10:15 AM, Benoit Claise <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi Henrik,
>
>             From: yang-doctors [mailto:[email-masked]
>             <mailto:[email-masked]>] On Behalf Of
>             Benoit Claise
>             To: Martin Bjorklund <[email-masked]
>             <mailto:[email-masked]>>; [email-masked]
>             <mailto:[email-masked]>
>                 https://datatracker.ietf.org/doc/draft-ietf-lime-yang-connectionless-o
>                 <https://datatracker.ietf.org/doc/draft-ietf-lime-yang-connectionless-o>
>                 am/
>
>                 [email-masked] <mailto:[email-masked]>
>                 <https://www.ietf.org/mailman/listinfo/yang-doctors>
>                 .
>
>             [email-masked] <mailto:[email-masked]>
>             <https://www.ietf.org/mailman/listinfo/yang-doctors>
>
>         .
>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/yang-doctors>
>
>