Subject: [yang-doctors] Defaults and abstract types

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 7 May 2018 22:02:56 +0000

Surgeons of Schema,

Is it possible to have default a “type empty” leaf to default to full? If so, how is it specified?

Similarly, is it possible to default a “presence” container as present? Again, if so, how is it specified?

Thanks,
Acee

---

From: Andy Bierman <[email-masked]>
Date: Mon, 7 May 2018 15:22:10 -0700

> Is it possible to have default a “type empty” leaf to default to full? If

no. There is no "full" value.
There is only present or not present.
You have to use boolean if you want a default for this purpose.

Similarly, is it possible to default a “presence” container as present?
> Again, if so, how is it specified?
>
>
>

no -- the point of the P-con is that the client must provide a value.

> Acee

Andy

>
> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors
>
>