Subject: [yang-doctors] pyang tree formatting doesn't honor line length

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 5 Aug 2019 15:50:06 +0000

One thing really annoying is that “pyang -f tree -–tree-line-length=66” doesn’t seem to honor the maximum line length. Am I doing something wrong or is the line formatting simply best effort?

Thanks,
Acee

---

From: Kent Watsen <[email-masked]>
Date: Mon, 5 Aug 2019 20:15:07 +0000

It's best-effort (for now).

Given that one could generate an arbitrarily nested model, the tree-diagram would have no recourse but to indent for each level of the tree.Sadly, I use `rfcfold` on top of tree-diagrams, which placates idnits, but results in ugly tree diagrams sometimes.  For instance: https://tools.ietf.org/html/draft-ietf-netconf-netconf-client-server-14#appendix-A.1 <https://tools.ietf.org/html/draft-ietf-netconf-netconf-client-server-14#appendix-A.1>.

Kent

> On Aug 5, 2019, at 11:50 AM, Acee Lindem (acee) <[email-masked]> wrote:
> 
> _______________________________________________
> yang-doctors mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/yang-doctors <https://www.ietf.org/mailman/listinfo/yang-doctors>