Subject: [yang-doctors] draft-ietf-i2rs-yang-l2-network-topology

From: "Susan Hares" <[email-masked]>
Date: Wed, 8 Jul 2020 11:11:54 -0400

The following question was asked by Ben Kaduk during IESG review of the
following document: 

https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topology/

     grouping l2-node-attributes {

         [...]

         leaf sys-mac-address {

           type yang:mac-address;

           description

             "System MAC address.";

         }

If there are more than 1 system mac address in a switch, how would this
model handle it. 

My understanding is that most switches have 1 system mac address for network
management.  Therefore, the L2 topology model supports one. 

Question for Yang Doctors: 

1) Is this the normal assumption for yang models? 

2) If not, what is the normal assumption on system mac addresses? 

3) Am I correct that switches with more than 1 system MAC will augment their
basic yang model with the second system MAC Address. 

Thank you, Susan Hares

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 8 Jul 2020 15:27:18 +0000

Hi,

So sys-mac-address is supposed to be the MAC address of the mgmt port, i.e. the device would respond to an ARP request for management-address with sys-mac-address? I think use of term system might be a bit misleading if that’s the case, mgmt-mac-address might be better.

Also, it is odd to have an IP address in an L2 grouping.

Disclaimer: not familiar with that draft at all, just took a look at the L2 grouping.

Regards,
Reshad.

From: yang-doctors <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Wednesday, July 8, 2020 at 11:12 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, 'Benjamin Kaduk' <[email-masked]>
Subject: [yang-doctors] draft-ietf-i2rs-yang-l2-network-topology

The following question was asked by Ben Kaduk during IESG review of the following document:

         [...]

         leaf sys-mac-address {

           type yang:mac-address;

           description

             "System MAC address.";

         }

If there are more than 1 system mac address in a switch, how would this model handle it.

My understanding is that most switches have 1 system mac address for network management.  Therefore, the L2 topology model supports one.

3) Am I correct that switches with more than 1 system MAC will augment their basic yang model with the second system MAC Address.

Thank you, Susan Hares

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 8 Jul 2020 11:47:45 -0400

Reshad: 

Thank you for quick response.   However, I’m confused.   Where do you see the IP address in the Yang snippet I sent?  It is a MAC Address (type yang:mac-address)?  If the system port allows IP, it will respond to the ARP request with the appropriate IP/MAC match in an ARP reply.   

In real implementations I2rs implementers examined, 

·         L2 port with mgmt-mac-address seems to be used to only send LLDP packets, 

·         L2 port with sys-mac-address seems to be used for management using TCP/IP.  

If we swap the names, it did not work with the initial implementers of the yang model.  The  I2RS Topology models are used for operational management of switches and routers as logical units. 

Also, your response does not seem to match my questions: 

3) Am I correct that switches with more than 1 system MAC will augment their basic yang model with the second system MAC Address? 

I’m sorry to bother you but this document is being reviewed by the IESG  tomorrow (Thursday) and 

I am the shepherd.  I do not know how to answer some of the yang related questions regarding multiple system ports to exchange management configuration on.  

I had thought that netconf/restconf would be exchanged over the same ports so the yang doctors would know what the normal custom should be. 

Thanks again! 

Sue  

 

 

From: Reshad Rahman (rrahman) [mailto:[email-masked]] 
Sent: Wednesday, July 8, 2020 11:27 AM
To: Susan Hares; [email-masked]; [email-masked]
Cc: [email-masked]; 'Benjamin Kaduk'
Subject: Re: [yang-doctors] draft-ietf-i2rs-yang-l2-network-topology

Hi,

Regards,

Reshad.

         [...]

         leaf sys-mac-address {

           type yang:mac-address;

           description

             "System MAC address.";

         }

Thank you, Susan Hares

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 8 Jul 2020 18:02:36 +0200

> 1) Is this the normal assumption for yang models?

This is a question for IEEE bridge experts, not yang doctors.
 
> 2) If not, what is the normal assumption on system mac addresses?

This is	a question for IEEE bridge experts, not yang doctors.
 
> 3) Am I correct that switches with more than 1 system MAC will augment their basic yang model with the second system MAC Address? 

It depends on the implementor. If you have more than one address, than
you likely add a *list of addresses instead of a second and then a
third and so fourth.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 8 Jul 2020 16:08:41 +0000

Hi,

I was referring to management-address leaf-list in the same grouping (see below).

I don’t have the expertise to answer your questions below, maybe some YDs do.

Regards,
Reshad.

     grouping l2-node-attributes {
       description
         "L2 node attributes";
       container l2-node-attributes {
         description
           "Contains L2 node attributes.";
<snip>
         leaf-list management-address {
           type inet:ip-address;
           description
             "System management address.";
         }
         leaf sys-mac-address {
           type yang:mac-address;
           description
             "System MAC address.";
         }

From: Susan Hares <[email-masked]>
Date: Wednesday, July 8, 2020 at 11:48 AM
To: "Reshad Rahman (rrahman)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, 'Benjamin Kaduk' <[email-masked]>
Subject: RE: [yang-doctors] draft-ietf-i2rs-yang-l2-network-topology

Reshad:

  *   L2 port with mgmt-mac-address seems to be used to only send LLDP packets,
  *   L2 port with sys-mac-address seems to be used for management using TCP/IP.

Thanks again!

Sue

Hi,

Regards,
Reshad.

         [...]

         leaf sys-mac-address {

           type yang:mac-address;

           description

             "System MAC address.";

         }

Thank you, Susan Hares

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 8 Jul 2020 12:09:42 -0400

Juergen:

This is the answer I expected, but I needed to ask. 

Thank you, Susan Hares 

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Wednesday, July 8, 2020 12:03 PM
To: Susan Hares
Cc: 'Reshad Rahman (rrahman)'; [email-masked]; [email-masked];
[email-masked]; 'Benjamin Kaduk'
Subject: Re: [yang-doctors] draft-ietf-i2rs-yang-l2-network-topology

 

> 3) Am I correct that switches with more than 1 system MAC will augment
their basic yang model with the second system MAC Address? 

It depends on the implementor. If you have more than one address, than you
likely add a *list of addresses instead of a second and then a third and so
fourth.

/js

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 8 Jul 2020 12:15:58 -0400

Reshad: 

Juregen indicates my questions are not for IETF but for IEEE, and that multiple system-macs may be implemented as a list.   

I’m looking at the IEEE  yang model for 802-1Qcp (2018 update to IEEE 802.1Q), but you can get the pre-release draft at (only editorial nits are missing) at: 

http://www.ieee802.org/1/files/private/cp-drafts/d2/802-1Qcp-d2-2.pdf

The reason there are multiple IP addresses is that the single LAN can have multiple IP addresses assigned to it.   

In may routers/switches the single MAC port will have multiple virtual ports.  (cisco started this concept in the 1990s). 

Thanks for the help! 

Sue 

Sent: Wednesday, July 8, 2020 12:09 PM

Hi,

Regards,

Reshad.

       description

         "L2 node attributes";

         description

<snip>

           type inet:ip-address;

           description

         }

         leaf sys-mac-address {

           type yang:mac-address;

           description

             "System MAC address.";

         }

Reshad: 

Thanks again! 

Sue  

 

 

Hi,

Regards,

Reshad.

         [...]

         leaf sys-mac-address {

           type yang:mac-address;

           description

             "System MAC address.";

         }

Thank you, Susan Hares

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 8 Jul 2020 16:19:56 +0000

Thanks Sue. I wasn’t questioning the need for multiple IP addresses, I just found it odd to have IP address(es) in an L2 grouping.

Regards,
Reshad.

Date: Wednesday, July 8, 2020 at 12:16 PM

Reshad:

Thanks for the help!

Sue

Hi,

Regards,
Reshad.

Reshad:

Thanks again!

Sue

Hi,

Regards,
Reshad.

         [...]

         leaf sys-mac-address {

           type yang:mac-address;

           description

             "System MAC address.";

         }

Thank you, Susan Hares

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 8 Jul 2020 12:37:59 -0400

Reshad: 

Ah.. thank you for clarifying the questions.   

The IP addresses are treated as attributes for the port node.  My understanding is that these attributes help store information if the yang model is used stand-alone without the network layer model.  Of course, smart implementations will internally validate these values. 

Sue   

Sent: Wednesday, July 8, 2020 12:20 PM

Regards,

Reshad.

Reshad: 

Thanks for the help! 

Sue 

Hi,

Regards,

Reshad.

       description

         "L2 node attributes";

         description

<snip>

           type inet:ip-address;

           description

         }

         leaf sys-mac-address {

           type yang:mac-address;

           description

             "System MAC address.";

         }

Reshad: 

Thanks again! 

Sue  

 

 

Hi,

Regards,

Reshad.

         [...]

         leaf sys-mac-address {

           type yang:mac-address;

           description

             "System MAC address.";

         }

Thank you, Susan Hares