Subject: [Yang-multicast] The latest draft for IGMP and MLD Snooping based on the Aug 21st meeting. Thank you!

From: Hongji Zhao <[email-masked]>
Date: Wed, 6 Sep 2017 06:24:30 +0000

Hi all,

The draft-zhao-pim-igmp-mld-snooping-yang-03 is the latest draft for IGMP and MLD Snooping based on the Aug 21st meeting. The yang files are also in the attachments.

Please review. Thanks a lot!

BR/Hongji
赵宏吉

From: Anish Peter [mailto:[email-masked]]
Sent: Tuesday, September 05, 2017 7:17 PM
To: Hongji Zhao <[email-masked]>
Cc: Xufeng Liu <[email-masked]>; Liuyisong <[email-masked]>; Xufeng Liu <[email-masked]>; Mahesh Sivakumar (masivaku) <[email-masked]>; yang-multicast <[email-masked]>; Guofeng <[email-masked]>
Subject: Re: recording of 20170821 regular meeting (contain updates comparing with presentation on IETF99 )

Hi Hongji,
 Please email them, to start with.
Thanks,
Anish

On Mon, Sep 4, 2017 at 7:10 AM, Hongji Zhao <[email-masked]<mailto:[email-masked]>> wrote:
Hi Anish,

Ok,  I will publish it as soon as possible.

BR/Hongji
赵宏吉

From: Anish Peter [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Friday, September 01, 2017 5:37 PM
To: Hongji Zhao <[email-masked]<mailto:[email-masked]>>
Cc: Xufeng Liu <[email-masked]<mailto:[email-masked]>>; Liuyisong <[email-masked]<mailto:[email-masked]>>; Xufeng Liu <[email-masked]<mailto:[email-masked]>>; Mahesh Sivakumar (masivaku) <[email-masked]<mailto:[email-masked]>>; yang-multicast <[email-masked]<mailto:[email-masked]>>; Guofeng <[email-masked]<mailto:[email-masked]>>
Subject: Re: recording of 20170821 regular meeting (contain updates comparing with presentation on IETF99 )

Hi Hongji,
 Please publish the latest yang model you showed on the last 21st meeting.
Thanks,
Anish

On Tue, Aug 22, 2017 at 7:40 AM, Hongji Zhao <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

1. We had achieved a new aggreement about the whole structure.
   Here are the updates comparing with presentation on IETF99

                1) Change igmp-snooping-profile into igmp-snooping-instance. Every igmp-snooping-instance could be only used in a bridge domain identified by vlan id.
                One igmp-snooping-instance couldn't be shared with other. This is the difference between profile and instance.

                2) The operational datas are defined in the igmp-snooping-instance. They are read only.

                3) Add attribute "type" to indicate which scenario igmp-snooping-instance is used. bridge? vpls? or evpn?

                4) Reference the ietf-l2vpn module and ietf-evpn module to define the multicast router interface and outgoing interface in VPLS or evpn scenario.
                They are defined in the existing workgroup draft.

                5) Define the reference structure which includes bridge, vpls, and evpn.

2. Learn the NMFDA guidelines and make the necessary update about the draft.

FYI: NMDA guidelines:
https://tools.ietf.org/html/draft-dsdt-nmda-guidelines-01

3. Should ssm-map be included?
   ----It should be included in the igmp-mld model.

The attachments are the latest igmp-snooping yang module and the related yang modules(ietf-evpn, and ietf-l2vpn).  Please review and give comments. Thanks a lot !

BR/Hongji
赵宏吉

From: Xufeng Liu [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, August 21, 2017 11:09 PM
To: Liuyisong <[email-masked]<mailto:[email-masked]>>; Xufeng Liu <[email-masked]<mailto:[email-masked]>>; Mahesh Sivakumar (masivaku) <[email-masked]<mailto:[email-masked]>>; yang-multicast <[email-masked]<mailto:[email-masked]>>; Hongji Zhao <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Guofeng <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Yang-multicast] YANG multicast design meeting reminder

FYI: NMDA guidelines:
https://tools.ietf.org/html/draft-dsdt-nmda-guidelines-01

From: Xufeng Liu
Sent: Friday, August 18, 2017 1:19 PM
To: 'Liuyisong' <[email-masked]<mailto:[email-masked]>>; 'Xufeng Liu' <[email-masked]<mailto:[email-masked]>>; 'Mahesh Sivakumar (masivaku)' <[email-masked]<mailto:[email-masked]>>; 'yang-multicast' <[email-masked]<mailto:[email-masked]>>; 'Hongji Zhao' <[email-masked]<mailto:[email-masked]>>
Cc: 'Guofeng' <[email-masked]<mailto:[email-masked]>>
Subject: [Yang-multicast] YANG multicast design meeting reminder

We continue to have the weekly meeting at

10:45am - 11:45am Eastern Time on Monday.

Hope that everyone can join.

Thanks,

- Xufeng

---

From: Benoit Claise <[email-masked]>
Date: Wed, 6 Sep 2017 11:01:02 +0200

Hi Hongji,

Please make sure that all mistakes at 
http://www.claise.be/IETFYANGPageCompilation.html are solved
And that your module is NMDA compliant.
I'll run my script once you post the new version.

Regards, Benoit
>
> Hi all,
>
> The draft-zhao-pim-igmp-mld-snooping-yang-03 is the latest draft for 
> IGMP and MLD Snooping based on the Aug 21st meeting. The yang files 
> are also in the attachments.
>
> *From:* Anish Peter [mailto:[email-masked]]
> *Sent:* Tuesday, September 05, 2017 7:17 PM
> *To:* Hongji Zhao <[email-masked]>
> *Cc:* Xufeng Liu <[email-masked]>; Liuyisong 
> <[email-masked]>; Xufeng Liu <[email-masked]>; Mahesh 
> Sivakumar (masivaku) <[email-masked]>; yang-multicast 
> <[email-masked]>; Guofeng <[email-masked]>
> *Subject:* Re: recording of 20170821 regular meeting (contain updates 
> comparing with presentation on IETF99 )
>
> Hi Hongji,
>
> On Mon, Sep 4, 2017 at 7:10 AM, Hongji Zhao <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi Anish,
>
>     *From:* Anish Peter [mailto:[email-masked]
>     <mailto:[email-masked]>]
>     *Sent:* Friday, September 01, 2017 5:37 PM
>     *To:* Hongji Zhao <[email-masked]
>     <mailto:[email-masked]>>
>     *Cc:* Xufeng Liu <[email-masked]
>     <mailto:[email-masked]>>; Liuyisong <[email-masked]
>     <mailto:[email-masked]>>; Xufeng Liu
>     <[email-masked] <mailto:[email-masked]>>;
>     Mahesh Sivakumar (masivaku) <[email-masked]
>     <mailto:[email-masked]>>; yang-multicast
>     <[email-masked] <mailto:[email-masked]>>;
>     Guofeng <[email-masked] <mailto:[email-masked]>>
>     *Subject:* Re: recording of 20170821 regular meeting (contain
>     updates comparing with presentation on IETF99 )
>
>     Hi Hongji,
>
>     On Tue, Aug 22, 2017 at 7:40 AM, Hongji Zhao
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>         Hi all,
>
>         1) Change igmp-snooping-profile into igmp-snooping-instance.
>         Every igmp-snooping-instance could be only used in a bridge
>         domain identified by vlan id.
>
>         One igmp-snooping-instance couldn't be shared with other. This
>         is the difference between profile and instance.
>
>         2) The operational datas are defined in the
>         igmp-snooping-instance. They are read only.
>
>         3) Add attribute "type" to indicate which scenario
>         igmp-snooping-instance is used. bridge? vpls? or evpn?
>
>         4) Reference the ietf-l2vpn module and ietf-evpn module to
>         define the multicast router interface and outgoing interface
>         in VPLS or evpn scenario.
>
>         The attachments are the latest igmp-snooping yang module and
>         the related yang modules(ietf-evpn, and ietf-l2vpn).  Please
>         review and give comments. Thanks a lot !
>
>         BR/Hongji
>
>         赵宏吉
>
>         *From:* Xufeng Liu [mailto:[email-masked]
>         <mailto:[email-masked]>]
>         *Sent:* Monday, August 21, 2017 11:09 PM
>         *To:* Liuyisong <[email-masked]
>         <mailto:[email-masked]>>; Xufeng Liu
>         <[email-masked]
>         <mailto:[email-masked]>>; Mahesh Sivakumar
>         (masivaku) <[email-masked] <mailto:[email-masked]>>;
>         yang-multicast <[email-masked]
>         <mailto:[email-masked]>>; Hongji Zhao
>         <[email-masked] <mailto:[email-masked]>>;
>         [email-masked] <mailto:[email-masked]>
>         *Cc:* Guofeng <[email-masked] <mailto:[email-masked]>>
>         *Subject:* RE: [Yang-multicast] YANG multicast design meeting
>         reminder
>
>         FYI: NMDA guidelines:
>
>         *From:* Xufeng Liu
>         *Sent:* Friday, August 18, 2017 1:19 PM
>         *To:* 'Liuyisong' <[email-masked]
>         <mailto:[email-masked]>>; 'Xufeng Liu'
>         <[email-masked]
>         <mailto:[email-masked]>>; 'Mahesh Sivakumar
>         (masivaku)' <[email-masked] <mailto:[email-masked]>>;
>         'yang-multicast' <[email-masked]
>         <mailto:[email-masked]>>; 'Hongji Zhao'
>         <[email-masked] <mailto:[email-masked]>>
>         *Cc:* 'Guofeng' <[email-masked] <mailto:[email-masked]>>
>         *Subject:* [Yang-multicast] YANG multicast design meeting reminder
>
> _______________________________________________
> Yang-multicast mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-multicast

---

From: Hongji Zhao <[email-masked]>
Date: Wed, 6 Sep 2017 09:17:18 +0000

Hi Benoit,

 All mistakes at http://www.claise.be/IETFYANGPageCompilation.html are solved, because the whole structure has changed comparing with the last version.
 And the module is NMDA compliant.  Thank you.

BR/Hongji
赵宏吉

From: Benoit Claise [mailto:[email-masked]]
Sent: Wednesday, September 06, 2017 5:01 PM
To: Hongji Zhao <[email-masked]>; yang-multicast <[email-masked]>
Cc: Xufeng Liu <[email-masked]>; Xufeng Liu <[email-masked]>; Mahesh Sivakumar (masivaku) <[email-masked]>; Guofeng <[email-masked]>; Anish Peter <[email-masked]>; Liuyisong <[email-masked]>
Subject: Re: [Yang-multicast] The latest draft for IGMP and MLD Snooping based on the Aug 21st meeting. Thank you!

Hi Hongji,

Please make sure that all mistakes at http://www.claise.be/IETFYANGPageCompilation.html are solved
And that your module is NMDA compliant.
I'll run my script once you post the new version.

Regards, Benoit
Hi all,

BR/Hongji
赵宏吉

From: Anish Peter [mailto:[email-masked]]
Sent: Tuesday, September 05, 2017 7:17 PM
To: Hongji Zhao <[email-masked]><mailto:[email-masked]>
Cc: Xufeng Liu <[email-masked]><mailto:[email-masked]>; Liuyisong <[email-masked]><mailto:[email-masked]>; Xufeng Liu <[email-masked]><mailto:[email-masked]>; Mahesh Sivakumar (masivaku) <[email-masked]><mailto:[email-masked]>; yang-multicast <[email-masked]><mailto:[email-masked]>; Guofeng <[email-masked]><mailto:[email-masked]>
Subject: Re: recording of 20170821 regular meeting (contain updates comparing with presentation on IETF99 )

Hi Hongji,

BR/Hongji
赵宏吉

Hi Hongji,

FYI: NMDA guidelines:

BR/Hongji
赵宏吉

FYI: NMDA guidelines:

From: Xufeng Liu

Thanks,

- Xufeng

[email-masked]<mailto:[email-masked]>