Subject: [Yang-multicast] draft-ietf-pim-msdp-yang-01

From: Benoit Claise <[email-masked]>
Date: Wed, 6 Sep 2017 10:53:30 +0200

Dear all,

I see that the newly posted draft-ietf-pim-msdp-yang-01 draft is now 
NMDA compliant.
See tree-type "nmda-compatible" at 
https://yangcatalog.org:8443/search/modules/ietf-msdp,2017-08-30,ietf
And there are no more validation errors.

What is the next step now?

Regards, Benoit

---

From: Stig Venaas <[email-masked]>
Date: Wed, 6 Sep 2017 15:29:38 -0700

Hi

We can probably do WGLC on this shortly. However, I would like to do
that for draft-ietf-pim-igmp-mld-yang first. As soon as we get an
update with NMDA support.

Also, we can proceed with the pim model once we get an NMDA version.

There are more or less the same authors for these models and I think
they are working on NMDA versions for all. Or at least I hope so.

Stig

On Wed, Sep 6, 2017 at 1:53 AM, Benoit Claise <[email-masked]> wrote:
> Dear all,
>
> I see that the newly posted draft-ietf-pim-msdp-yang-01 draft is now NMDA
> compliant.

---

From: Guofeng <[email-masked]>
Date: Thu, 7 Sep 2017 03:43:32 +0000

Hi Stig,

We are updating draft-ietf-pim-igmp-mld-yang and will discuss it in multicast design team.

Feng

-----Original Message-----
From: Yang-multicast [mailto:[email-masked]] On Behalf Of Stig Venaas
Sent: Thursday, September 07, 2017 6:30 AM
To: Benoit Claise <[email-masked]>
Cc: [email-masked]; [email-masked]; Alvaro Retana (aretana) <[email-masked]>
Subject: Re: [Yang-multicast] draft-ietf-pim-msdp-yang-01

Hi

We can probably do WGLC on this shortly. However, I would like to do that for draft-ietf-pim-igmp-mld-yang first. As soon as we get an update with NMDA support.

There are more or less the same authors for these models and I think they are working on NMDA versions for all. Or at least I hope so.

Stig

> What is the next step now?

_______________________________________________
Yang-multicast mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/yang-multicast

---

From: Benoit Claise <[email-masked]>
Date: Thu, 7 Sep 2017 10:55:37 +0200

Thank you Feng.
What is the estimated timeframe?

Regards, B.
> .

---

From: Benoit Claise <[email-masked]>
Date: Thu, 7 Sep 2017 11:31:00 +0200

Btw, if that helps, I will attend your next design team call with the 
goal to explain how to master the tools at yangcatalog.org.
They can really help you.
ex: https://www.yangcatalog.org/yang-search/yang-search.php
ex: 
https://www.yangcatalog.org/yang-search/module_details.php?module=ietf-igmp-mld
ex: 
https://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-igmp-mld&modules[]=ietf-msdp&modules[]=ietf-pim-base&modules[]=ietf-pim-rp&modules[]=ietf-pim-dm&modules[]=ietf-pim-bidir&modules[]=ietf-pim-sm&recurse=0&rfcs=1&show_subm=1&show_dir=both
copying Joe, who has been instrumental in developing those tools.

Btw, what is the status of draft-ietf-pim-yang-08.txt? 
<http://datatracker.ietf.org/doc/draft-ietf-pim-yang>

Regards, Benoit

---

From: "Stig Venaas (svenaas)" <[email-masked]>
Date: Thu, 7 Sep 2017 10:06:33 -0700

Hi

> We are updating draft-ietf-pim-igmp-mld-yang and will discuss it in multicast design team.

Thanks. Let me know when it is done. I hope Xufeng (I was in touch with
him earlier) or one of the other authors also will update the pim model
draft so we can continue the publication process.

Stig

---

From: Guofeng <[email-masked]>
Date: Fri, 8 Sep 2017 07:44:38 +0000

Hi,

We are planning to review the revised igmp/mld yang draft on Sept.18th Mcast DT  meeting,  then update it accordingly and hope to discuss it again on the Sept. 25th meeting.

I think It would be great if you introduce the tools and guidelines/experience on NMDA on next DT meeting.

Feng

From: Benoit Claise [mailto:[email-masked]]
Sent: Thursday, September 07, 2017 5:31 PM
To: Guofeng <[email-masked]>; Stig Venaas <[email-masked]>
Cc: [email-masked]; [email-masked]; Alvaro Retana (aretana) <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>
Subject: Re: [Yang-multicast] draft-ietf-pim-msdp-yang-01

Btw, if that helps, I will attend your next design team call with the goal to explain how to master the tools at yangcatalog.org.
They can really help you.
ex: https://www.yangcatalog.org/yang-search/yang-search.php
ex: https://www.yangcatalog.org/yang-search/module_details.php?module=ietf-igmp-mld
ex: https://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-igmp-mld&modules[]=ietf-msdp&modules[]=ietf-pim-base&modules[]=ietf-pim-rp&modules[]=ietf-pim-dm&modules[]=ietf-pim-bidir&modules[]=ietf-pim-sm&recurse=0&rfcs=1&show_subm=1&show_dir=both
copying Joe, who has been instrumental in developing those tools.

Btw, what is the status of draft-ietf-pim-yang-08.txt?<http://datatracker.ietf.org/doc/draft-ietf-pim-yang>

Regards, Benoit
Thank you Feng.

Regards, B.

Hi Stig,

Feng

-----Original Message-----
From: Yang-multicast [mailto:[email-masked]] On Behalf Of Stig Venaas
Sent: Thursday, September 07, 2017 6:30 AM
To: Benoit Claise <[email-masked]><mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Alvaro Retana (aretana) <[email-masked]><mailto:[email-masked]>
Subject: Re: [Yang-multicast] draft-ietf-pim-msdp-yang-01

Hi

Stig

On Wed, Sep 6, 2017 at 1:53 AM, Benoit Claise <[email-masked]><mailto:[email-masked]> wrote:

Dear all,

Regards, Benoit

_______________________________________________
Yang-multicast mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/yang-multicast
.

---

From: Guofeng <[email-masked]>
Date: Fri, 8 Sep 2017 07:45:33 +0000

Hi,

Feng

-----Original Message-----
From: Yang-multicast [mailto:[email-masked]] On Behalf Of Stig Venaas (svenaas)
Sent: Friday, September 08, 2017 1:07 AM
To: Guofeng <[email-masked]>; Stig Venaas <[email-masked]>; Benoit Claise <[email-masked]>
Cc: [email-masked]; [email-masked]; Alvaro Retana (aretana) <[email-masked]>
Subject: Re: [Yang-multicast] draft-ietf-pim-msdp-yang-01

Hi

> We are updating draft-ietf-pim-igmp-mld-yang and will discuss it in multicast design team.

Thanks. Let me know when it is done. I hope Xufeng (I was in touch with him earlier) or one of the other authors also will update the pim model draft so we can continue the publication process.

Stig

---

From: Benoit Claise <[email-masked]>
Date: Mon, 11 Sep 2017 14:01:53 +0200

On 9/8/2017 9:44 AM, Guofeng wrote:
>
> Hi,
>
> We are planning to review the revised igmp/mld yang draft on Sept.18th 
> Mcast DT  meeting,  then update it accordingly and hope to discuss it 
> again on the Sept. 25th meeting.
>
> I think It would be great if you introduce the tools and 
> guidelines/experience on NMDA on next DT meeting.
>
Ok. Send me the call details.
I don't see them in my calendar.

Regards, B.
>
> Feng
>
> *From:*Benoit Claise [mailto:[email-masked]]
> *Sent:* Thursday, September 07, 2017 5:31 PM
> *To:* Guofeng <[email-masked]>; Stig Venaas <[email-masked]>
> *Cc:* [email-masked]; [email-masked]; Alvaro Retana 
> (aretana) <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>
> *Subject:* Re: [Yang-multicast] draft-ietf-pim-msdp-yang-01
>
>         To: Benoit Claise <[email-masked]> <mailto:[email-masked]>
>         Cc: [email-masked] <mailto:[email-masked]>;
>         [email-masked] <mailto:[email-masked]>; Alvaro
>         Retana (aretana) <[email-masked]> <mailto:[email-masked]>
>         We can probably do WGLC on this shortly. However, I would like
>         to do that for draft-ietf-pim-igmp-mld-yang first. As soon as
>         we get an update with NMDA support.
>
>         There are more or less the same authors for these models and I
>         think they are working on NMDA versions for all. Or at least I
>         hope so.
>
>         Stig
>
>
>         On Wed, Sep 6, 2017 at 1:53 AM, Benoit Claise
>         <[email-masked]> <mailto:[email-masked]> wrote:
>
>             Dear all,
>
>         [email-masked] <mailto:[email-masked]>