Subject: [YANG] Status and containment

From: Balazs Lengyel <[email-masked]>
Date: Thu, 21 Feb 2008 09:41:01 +0100

Is it allowed to have a current child in a deprecated or obsolete 
container/list/choice/rpc/notification/etc. I think no.

I would add to 7.17.2.  The status Statement

"If a containing element in a model has the status obsolete, all it's sub-statements are also 
obsolete.

If a containing element in a model has the status deprecated, all it's sub-statements are also 
deprecated, unless they are explicitly stated as obsolete."

Shall I check this in?

Balazs
_______________________________________________
YANG mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/yang

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 21 Feb 2008 11:21:03 -0800

Hi -

> From: "Balazs Lengyel" <[email-masked]>
> To: <[email-masked]>
> Sent: Thursday, February 21, 2008 12:41 AM
> Subject: [YANG] Status and containment
>
...

How would this affect modules that re-use of any of those children?

Randy