Subject: [YANG] config-stmt missing for choice construct

From: Andy Bierman <[email-masked]>
Date: Sat, 02 Feb 2008 10:01:04 -0800

Hi,

It seems the 'config true/false' clause is missing from
the choice-stmt data definition statement.

Without it, there is no way to declare a top-level non-config
choice.  It should be legal to declare a non-config choice nested
within a config node.

Also, 7.17.1, para 2 (config statement) needs to add text that
the 'config' property for the following nodes is hardwired into
the NETCONF architecture:

    rpc/input   --  config true;
                    non-config nodes MUST NOT appear under rpc/input

    rpc/output  --  config false;
                    config nodes MUST NOT appear under rpc/output

    notification -- config false;
                    config nodes MUST NOT appear within a notification

All other nodes follow the rules already defined in this section.

<side-issue>
A top-level RPC method node cannot have config true/false
set, but what about an optional classification field like
(config, exec, monitor, debug, other)?  IMO, this is useful
for operators and access control.
</side-issue>

Andy

_______________________________________________
YANG mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/yang

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sat, 2 Feb 2008 22:08:20 +0100

> All other nodes follow the rules already defined in this section.

Why is rpc/input config?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
_______________________________________________
YANG mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/yang

---

From: Andy Bierman <[email-masked]>
Date: Sat, 02 Feb 2008 13:47:21 -0800

>> All other nodes follow the rules already defined in this section.

Well, all the input parameters are writable.
In YANG, 'config false' is the closest thing to 'max-access read-only'.
Either we should say the config-stmt is ignored for rpc and notifications,
or explicitly define its meaning for these things.

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sat, 2 Feb 2008 23:17:43 +0100

> or explicitly define its meaning for these things.

I think it should be ignored. My understanding of 'config true' is
that it marks data items that belong to the configuration state and
'config false' says data items belongs to the operational state.

The in/out/(error) parameters of operations are in general something
different. And I think the same argument can be made for notifications.

/js