Subject: [Yot] draft-ietf-core-sid updated

From: Michel Veillette <[email-masked]>
Date: Wed, 29 Nov 2017 23:00:05 +0000

Hi Andy, Alexander, Peter, Micheal

"draft-ietf-core-sid" version 3 is available on github for review.
http://core-wg.github.io/yang-cbor/draft-ietf-core-sid-latest.html

The following link show a side by side diff between version 2 and 3.
http://tools.ietf.org/tools/rfcdiff/rfcdiff.pyht?url1=https://www.ietf.org/id/draft-ietf-core-sid-02.txt&url2=http://core-wg.github.io/yang-cbor/draft-ietf-core-sid-latest.txt

The modifications proposed to this draft are mainly about the .sid file format.

  1.  Field 'type' replaced by 'namespace'
  2.  Field 'label' replaced by 'identifier'
  3.  Paths within 'identifier' represented using a canonical representation (YANG 1.1 ABNF  for a schema node identifier, except module names are used instead of prefixes)
  4.  Paths removed from identity
  5.  'namespace' implemented using an enumeration
  6.  'module' and 'submodule' combined within the same 'namespace'  (i.e. module)
  7.  'node', 'notification', 'rpc' and 'action' combined within the same 'namespace' (i.e. data)
I will submit this new version and applies the new format to the registry on Friday.
Unless I received comments.

Regards,
Michel

---

From: peter van der Stok <[email-masked]>
Date: Thu, 30 Nov 2017 08:32:14 +0100

Hi Michel,

I seem to like this better.

Peter

Michel Veillette schreef op 2017-11-30 00:00:
>  	* Field 'type' replaced by 'namespace'
> 	* Field 'label' replaced by 'identifier'
> 	* Paths within 'identifier' represented using a canonical
> representation (YANG 1.1 ABNF  for a schema node identifier, except
> module names are used instead of prefixes)
> 	* Paths removed from identity
> 	* 'namespace' implemented using an enumeration
> 	* 'module' and 'submodule' combined within the same 'namespace'
> (i.e. module)
> 	* 'node', 'notification', 'rpc' and 'action' combined within the same
> 'namespace' (i.e. data)
>