Subject: [Yot] draft-veillette-core-yang-library update

From: Michel Veillette <[email-masked]>
Date: Mon, 22 Jan 2018 20:38:29 +0000

Draft https://datatracker.ietf.org/doc/draft-veillette-core-yang-library/ will expire in two days.
If you have changes to propose to this YANG module, please send them so I can update the draft accordingly.

On the Trilliant side, we propose to add support for a hash as cashing mechanism.
The resulting 'module-set-id' will support the following datatypes.
- uint32, local library content identifier
- identityref, global library content identifier (i.e. SID)
- byte string, global library content identifier (e.g. SHA2)

Do we need to support all these approaches?

  *   The local identifier is easy to manage, compact (~ 1, 2, 3 bytes) but the client need to manage device specific caches
  *   The SID is more complex to manage (i.g. required an interaction with the SID registry), is relatively compact (~ 5 bytes) and allows the implementation of a single cache for all devices.
  *   The hash is easy to manage but not as compact (~20 bytes)

Michel Veillette
System Architecture Director
Trilliant Inc.
Tel: 450-531-3109
https://trilliantinc.com/

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 22 Jan 2018 23:24:48 +0100

I assume you are aware of draft-ietf-netconf-rfc7895bis-03.txt and the
discussions ongoing in NETCONF. The idea is to obsolete the old YANG
library defined in RFC 7895 and to replace it with a new YANG library
that supports NMDA.

/js

> _______________________________________________
> Yot mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yot

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Michel Veillette <[email-masked]>
Date: Tue, 23 Jan 2018 16:51:35 +0000

Thanks for this warning Juergen

I was aware of the NMDA acronym but not about the specific impacts of this approach on protocols and on the yang library.

For now, I will just add a comment to the draft to request an alignment with NMDA and draft-ietf-netconf-rfc7895bis-03. CoMI also need to be reviewed for NMDA support. I assume that draft-dsdt-nmda-guidelines-01, draft-ietf-netconf-rfc7895bis-03 and draft-ietf-netconf-nmda-restconf-02 are the main documents to review before proceeding?

Regards,
Michel

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Monday, January 22, 2018 5:25 PM
To: Michel Veillette <[email-masked]>
Cc: [email-masked]
Subject: Re: [Yot] draft-veillette-core-yang-library update

I assume you are aware of draft-ietf-netconf-rfc7895bis-03.txt and the discussions ongoing in NETCONF. The idea is to obsolete the old YANG library defined in RFC 7895 and to replace it with a new YANG library that supports NMDA.

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 23 Jan 2018 17:58:32 +0100

The main NMDA document is draft-ietf-netmod-revised-datastores-10.txt,
meanwhile in the RFC editor queue. It may be a good idea to follow
NETMOD and NETCONF if people work on new protocols. ;-)

/js