Subject: [104attendees] Topic for 1st April RFC: add telemetry to smart lifts

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 27 Mar 2019 09:51:25 +0000

I guess that I am not the only one being slightly annoyed by those smart lifts. As engineer, we know/hope that it is optimized but we are also somehow lost because we have no way to check whether it is actually optimized.

So, we would need a protocol to ‘see’ on which floor are which lift cars :-) Could be as trivial as the good old floor indicator above the lift doors but this would be too simple for us

OK, back to work now

-éric

---

From: "Border, John" <[email-masked]>
Date: Wed, 27 Mar 2019 10:12:58 +0000

I think they are optimized to save the hotel money (in energy costs)…

From: 104attendees <[email-masked]> On Behalf Of Eric Vyncke (evyncke)
Sent: Wednesday, March 27, 2019 5:51 AM
To: [email-masked]
Subject: [104attendees] Topic for 1st April RFC: add telemetry to smart lifts

WARNING: The sender of this email could not be validated and may not match the person in the "From" field.
CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.

OK, back to work now

-éric

---

From: Olli Vanhoja <[email-masked]>
Date: Wed, 27 Mar 2019 11:32:19 +0100

Sometimes those are also optimized for customer spending. A company I
once worked for optimized room-to-casino lifts for a casino hotel so
their customers would have more time to spend money at the casino.

On Wed, Mar 27, 2019 at 11:13 AM Border, John <[email-masked]> wrote:
> --
> 104attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/104attendees

---

From: Jim Reid <[email-masked]>
Date: Wed, 27 Mar 2019 10:53:00 +0000

> On 27 Mar 2019, at 09:51, Eric Vyncke (evyncke) <[email-masked]> wrote:
> 

OTOH, the absence of any control hooks makes it harder for IETF people to rat-hole on the detail or tinker with things. That's not necessarily a bad thing. :-)

That said, it's a bit unsettling to go into a lift that has no buttons. I think the hotel could have left the panels for selecting floors in each lift even if they weren't connected to anything.

---

From: Bob Hinden <[email-masked]>
Date: Wed, 27 Mar 2019 11:53:25 +0100

Eric,

> On Mar 27, 2019, at 10:51 AM, Eric Vyncke (evyncke) <[email-masked]> wrote:
> 
> I guess that I am not the only one being slightly annoyed by those smart lifts. As engineer, we know/hope that it is

I find the new elevator much better than what was here for the last IETF in Prague.  The problem with the old system, was that the elevator would come and since you couldn’t be looking in three directions at the same time, it was easy to miss it.  The new system tells me which elevator door to wait for my lift.

That said, I wonder if there is some set of buttons to press inside of the elevator to get a menu on the screen with floors :-)

Bob

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 27 Mar 2019 11:01:18 +0000

Hi Bob,

> -----Original Message-----
> From: 104attendees <[email-masked]> On Behalf Of Bob
> Hinden
> Sent: Wednesday, March 27, 2019 11:53 AM
> To: Eric Vyncke (evyncke) <[email-masked]>
> Cc: [email-masked]; Bob Hinden <[email-masked]>
> Subject: Re: [104attendees] Topic for 1st April RFC: add telemetry to smart
> lifts
> 
> Eric,
> 
> > I guess that I am not the only one being slightly annoyed by those smart
> lifts. As engineer, we know/hope that it is
> 
> I find the new elevator much better than what was here for the last IETF in
> Prague.  The problem with the old system, was that the elevator would come
> and since you couldn’t be looking in three directions at the same time, it was
> easy to miss it.  The new system tells me which elevator door to wait for my
> lift.

I remember long email discussions several IETFs ago about elevators. Looks like someone productized the ideas.

> 
> That said, I wonder if there is some set of buttons to press inside of the
> elevator to get a menu on the screen with floors :-)

I suppose it is the new era and now we're supposed to use centralized controllers 😊

Jeffrey

> 
> Bob
> 
> >
> > So, we would need a protocol to ‘see’ on which floor are which lift cars :-)
> Could be as trivial as the good old floor indicator above the lift doors but this
> would be too simple for us
> >
> > OK, back to work now
> >
> > -éric
> > --
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_104attendees&d=DwIGaQ&c=HAkYuh
> 63rsuhr6Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=f7wsLGcfzAWDNS6XNTBZwj_OLAOsZZqdrR2IDAzeZqE
> &m=Np_wxnLFEh9fIMmkdwcTa38UFQbVHCujhgPYEYACUnI&s=iCFJLnnKnW
> wUuqR_vxK8PsVK3lZJbdIus6hT32RYIuc&e=
> 
> --
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_104attendees&d=DwIGaQ&c=HAkYuh
> 63rsuhr6Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=f7wsLGcfzAWDNS6XNTBZwj_OLAOsZZqdrR2IDAzeZqE
> &m=Np_wxnLFEh9fIMmkdwcTa38UFQbVHCujhgPYEYACUnI&s=iCFJLnnKnW
> wUuqR_vxK8PsVK3lZJbdIus6hT32RYIuc&e=

---

From: "David R. Oran" <[email-masked]>
Date: Wed, 27 Mar 2019 12:07:30 +0100

On 27 Mar 2019, at 10:51, Eric Vyncke (evyncke) wrote:

> I guess that I am not the only one being slightly annoyed by those 
> smart lifts. As engineer, we know/hope that it is optimized but we are 
> also somehow lost because we have no way to check whether it is 
> actually optimized.
>
> So, we would need a protocol to ‘see’ on which floor are which 
> lift cars :-) Could be as trivial as the good old floor indicator 
> above the lift doors but this would be too simple for us
>
We could use these as a metaphor for the pitfalls of intent-based 
networking.
:-)

DaveO

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 27 Mar 2019 11:26:58 +0000

> From: 104attendees <[email-masked]> On Behalf Of David R.
> Oran
> Sent: Wednesday, March 27, 2019 12:08
> To: Eric Vyncke <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [104attendees] Topic for 1st April RFC: add telemetry to
> smart lifts
> 

Like it!
I would say of "badly-designed intent systems".
A well-designed one will tell you to take the stairs 😉

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 27 Mar 2019 04:35:59 -0700

Hello Eric,

At minimum, IETF attendees staying at other hotels should be able to use 
the elevators to get to meetings without requiring a hotel card.  Or 
else the IETF registration should hand out restricted-use hotel cards.

Regards,
Charlie P.

On 3/27/2019 2:51 AM, Eric Vyncke (evyncke) wrote:
> So, we would need a protocol to ‘see’ on which floor are which lift 
> cars :-) Could be as trivial as the good old floor indicator above the 
> lift doors but this would be too simple for us
>
> OK, back to work now
>
> -éric
>
>

---

From: Daniel Van Geest <[email-masked]>
Date: Wed, 27 Mar 2019 11:41:17 +0000

I’m not staying at the hotel and haven’t tried using the elevators so I’m trying to imagine the experience. I imagine a higher-tech version of this slightly terrifying classic Prague elevator: https://www.youtube.com/watch?v=erdiS1pE2-Q

On 2019-03-27, 7:27 AM, "104attendees on behalf of Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

-----Original Message-----
From: 104attendees <[email-masked]<mailto:[email-masked]>> On Behalf Of David R.
Oran
Sent: Wednesday, March 27, 2019 12:08
To: Eric Vyncke <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [104attendees] Topic for 1st April RFC: add telemetry to
smart lifts

Like it!

> [email-masked]<mailto:[email-masked]>
DaveO
--
104attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/104attendees
--
104attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/104attendees

---

From: Bill Fenner <[email-masked]>
Date: Wed, 27 Mar 2019 14:55:46 +0100

On Wed, Mar 27, 2019 at 12:37 PM Charlie Perkins <[email-masked]>
wrote:

> the elevators to get to meetings without requiring a hotel card.
>
The advertised operation is that guest floors (other than 8) require a
card.  Are you saying that that's not how they are working?

  Bill

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Wed, 27 Mar 2019 15:25:29 +0100

I think you can move between LL, L and M without a card. You just need 
to activate the screen by touching it.

---

From: Jake Holland <[email-masked]>
Date: Wed, 27 Mar 2019 15:26:41 +0100

My understanding is that there's controlled floors (those with guest rooms)
and uncontrolled floors (Lobby, Mezzanine, Lower Lobby).  If you try to
select a controlled floor, you need a card, but if you select an
uncontrolled floor, you do not.

I think a real-time telemetry that shows the pending requests and proposed
schedule (and perhaps a state transition diagram) for the system would be
quite fascinating to watch, and would happily +1 a RECCOMEND to add it.

-Jake

On Wed, Mar 27, 2019 at 12:37 PM Charlie Perkins <[email-masked]>
wrote:

> the elevators to get to meetings without requiring a hotel card.  Or else
> the IETF registration should hand out restricted-use hotel cards.
>
> Regards,
> Charlie P.
>
>
> lifts. As engineer, we know/hope that it is optimized but we are also
> somehow lost because we have no way to check whether it is actually
> optimized.
>
>
>
> So, we would need a protocol to ‘see’ on which floor are which lift cars
> :-) Could be as trivial as the good old floor indicator above the lift
> doors but this would be too simple for us
>
>
>
> OK, back to work now
>
>
>
> -éric
>
> --

---

From: Maximilian Franke <[email-masked]>
Date: Wed, 27 Mar 2019 15:38:41 +0100

As it happens, I recently created a (terrible) UPAAL model for an elevator controller. I wouldn’t wish it on anyone. 
- Max

> Am 27.03.2019 um 15:26 schrieb Jake Holland <[email-masked]>:
> 
> My understanding is that there's controlled floors (those with guest rooms) and uncontrolled floors (Lobby, Mezzanine, Lower Lobby).  If you try to select a controlled floor, you need a card, but if you select an uncontrolled floor, you do not.
> 
> I think a real-time telemetry that shows the pending requests and proposed schedule (and perhaps a state transition diagram) for the system would be quite fascinating to watch, and would happily +1 a RECCOMEND to add it.
> 
> -Jake
> 
> On Wed, Mar 27, 2019 at 12:37 PM Charlie Perkins <[email-masked] <mailto:[email-masked]>> wrote:
> Hello Eric,
> 
> At minimum, IETF attendees staying at other hotels should be able to use the elevators to get to meetings without requiring a hotel card.  Or else the IETF registration should hand out restricted-use hotel cards.
> 
> Regards,
> Charlie P.
> 
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/104attendees <https://www.ietf.org/mailman/listinfo/104attendees>
> --

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 27 Mar 2019 07:55:54 -0700

Hello Bill,

No, I didn't say that :-).  But I did see people who were not aware that 
they didn't need a card to get to the meetings.  I only meant to 
identify the potential for a problem, not to complain about the access 
at the Hilton.

Regards,
Charlie P.

On 3/27/2019 6:55 AM, Bill Fenner wrote:
> On Wed, Mar 27, 2019 at 12:37 PM Charlie Perkins 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     At minimum, IETF attendees staying at other hotels should be able
>     to use the elevators to get to meetings without requiring a hotel
>     card.
>

---

From: Tale Lawrence <[email-masked]>
Date: Wed, 27 Mar 2019 16:20:14 +0100

> As it happens, I recently created a (terrible) UPAAL model for an elevator controller. I wouldn’t wish it on anyone. 

I know at least one company that uses "design an elevator control system" as an interview
exercise.  It's really kind of a fascinating problem, that the current example is unfortunately
a bad solution thereof.