Subject: [104attendees] Simply adding sessions to calendar?

From: Szilveszter Nadas <[email-masked]>
Date: Sun, 24 Mar 2019 14:11:46 +0000

Is there a simple way to add a session to my calendar (e.g. Outlook or gmail)? There are all different tools @ https://datatracker.ietf.org/meeting/104/agenda , but none results in a meeting format I can easily add. Optimally the meeting file shall also include the agenda at that point.

Szilveszter Nádas
Senior Researcher
Ericsson Research, Traffic Lab
Budapest, Hungary

---

From: Ray Bellis <[email-masked]>
Date: Sun, 24 Mar 2019 15:14:41 +0100

On 24/03/2019 15:11, Szilveszter Nadas wrote:
> Is there a simple way to add a session to my calendar (e.g. Outlook or 
> gmail)? There are all different tools @ 
> https://datatracker.ietf.org/meeting/104/agenda , but none results in a 
> meeting format I can easily add. Optimally the meeting file shall also 
> include the agenda at that point.

This can generate iCal files:

https://tools.ietf.org/agenda/104/calendar

Ray

---

From: Bob Hinden <[email-masked]>
Date: Sun, 24 Mar 2019 15:16:39 +0100

Szilveszter,

> On Mar 24, 2019, at 3:11 PM, Szilveszter Nadas <[email-masked]> wrote:
> 
> Is there a simple way to add a session to my calendar (e.g. Outlook or gmail)? There are all different tools @https://datatracker.ietf.org/meeting/104/agenda , but none results in a meeting format I can easily add. Optimally the meeting file shall also include the agenda at that point.
>  

I use the tools calendar at:

It allows me to select the sessions I want to attend, and then it generates a .ics file I can subscribe to in my calendar program.

Bob

---

From: Szilveszter Nadas <[email-masked]>
Date: Sun, 24 Mar 2019 14:26:20 +0000

Thank you all.

Is it accessible from https://www.ietf.org/how/meetings/104/ by clicking somehow?

Sz.

-----Original Message-----
From: Bob Hinden <[email-masked]> 
Sent: Sunday, March 24, 2019 15:17
To: Szilveszter Nadas <[email-masked]>
Cc: Bob Hinden <[email-masked]>; 104Attendees <[email-masked]>
Subject: Re: [104attendees] Simply adding sessions to calendar?

Szilveszter,

Bob

---

From: Michael Richardson <[email-masked]>
Date: Thu, 28 Mar 2019 10:05:16 +0100

Bob Hinden <[email-masked]> wrote:
    >> gmail)? There are all different tools
    >> @https://datatracker.ietf.org/meeting/104/agenda , but none results in
    >> a meeting format I can easily add. Optimally the meeting file shall
    >> also include the agenda at that point.
    >>

    > It allows me to select the sessions I want to attend, and then it
    > generates a .ics file I can subscribe to in my calendar program.

A "feature" of this is the list of sessions one wants to attend is
embedded in the URL, which means if you want to change the list of sessions,
at least with Google Calendar, you have to remove/add the calendar to
change the URL.

So, I used wget to copy the calendar to a web server, effectively adding a
layer of indirection.

What I'm still looking for is a way, after having imported the calendar, is
to be able to subscribe to the event (as I often have conflicts, and I need
to remember how I resolved that, and I need to remember when I'm busy) such
that I get updates when the room/time changes.

If I "copy to mcr calendar", then I get a copy, and it's not linked.
I'm curious if other calendaring systems have a way to do what I am describing.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Tim Chown <[email-masked]>
Date: Thu, 28 Mar 2019 09:56:29 +0000

Hi,

> On 28 Mar 2019, at 09:05, Michael Richardson <[email-masked]> wrote:
> 
> 

I use the IETF app written by Tom Pusateri, which is really useful, and for which Tom deserves huge credit.

When you select sessions you plan to attend in the app, it will add these to your calendar pretty much immediately.

Tim

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 28 Mar 2019 09:59:18 +0000

>    I use the IETF app written by Tom Pusateri, which is really useful, and for which Tom deserves huge credit.

+1!

>    When you select sessions you plan to attend in the app, it will add these to your calendar pretty much immediately.
  
Where/how?

---

From: Robert Sparks <[email-masked]>
Date: Thu, 28 Mar 2019 11:00:30 +0100

The datatracker also has the ability to customize an ics calendar (that 
does have the group names in the URL).

It's under the "Customize the agenda view..." button near the top of 
https://datatracker.ietf.org/meeting/agenda.

RjS

---

From: Bob Hinden <[email-masked]>
Date: Thu, 28 Mar 2019 11:08:41 +0100

Robert,

> On Mar 28, 2019, at 11:00 AM, Robert Sparks <[email-masked]> wrote:
> 
> The datatracker also has the ability to customize an ics calendar (that does have the group names in the URL).
> 
> It's under the "Customize the agenda view..." button near the top of https://datatracker.ietf.org/meeting/agenda.

Does this include BOFs?   Does it result in a link to subscribe to, or static calendar entries.   Looks like the latter, but I am not sure.

Thanks,
Bob

> 104attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/104attendees

---

From: Robert Sparks <[email-masked]>
Date: Thu, 28 Mar 2019 11:11:31 +0100

On 3/28/19 5:08 AM, Bob Hinden wrote:
> Does this include BOFs?
Yes
>    Does it result in a link to subscribe to,
Yes.
>   or static calendar entries.   Looks like the latter, but I am not sure.
Use your browser to capture the URL for the button for the ics calendar. 
Then subscribe to that URL with your favorite calendaring tool.

---

From: George Michaelson <[email-masked]>
Date: Thu, 28 Mar 2019 11:16:11 +0100

So its clear, my lived experience here is that you get the state of
the iCal file but its not a live subscription, its entries in your
calendar which don't track changes and cancellations.

Is this just me?

---

From: Tim Chown <[email-masked]>
Date: Thu, 28 Mar 2019 10:16:28 +0000

> On 28 Mar 2019, at 09:59, Salz, Rich <[email-masked]> wrote:
> 

Settings (bottom right icon) -> turn on "Add Favourites to Calendar".

It uses by default a separate calendar name 'IETFers'

I turn on 'Use local time' also, but that depends whether you live in the local or your home zone while here.

Tim

---

From: Bob Hinden <[email-masked]>
Date: Thu, 28 Mar 2019 11:27:40 +0100

Robert,

> On Mar 28, 2019, at 11:11 AM, Robert Sparks <[email-masked]> wrote:
> 
> 

Thanks, I missed the text that said "Groups displayed in italics are BOFs.”.  At least on my browser, it’s hard to see the difference.   Different colors (or something else) would make it clearer.  Similar for when you select a session, mine changes from light grey to slightly darker grey.

> Use your browser to capture the URL for the button for the ics calendar. Then subscribe to that URL with your favorite calendaring tool.

Some instruction on this page on how to do that would be helpful.  I had no idea.

Thanks,
Bob

---

From: Dan York <[email-masked]>
Date: Thu, 28 Mar 2019 10:29:16 +0000

Rich (and Nadas and others),

> On Mar 28, 2019, at 10:59 AM, Salz, Rich <[email-masked]> wrote:
> 

Completely agree. I use the app on my iPad to plan out my calendar. When I add something as a “favorite”, it then almost immediately shows up in my calendar on my system. What I like is that I can very easily update the calendar in the app during the IETF week - and my calendar on my laptop and phone keeps up to date without me doing anything.  Very often in advance of a meeting before WG agendas have come out, I’ll add maybe 2 or 3 sessions during a block so that I see them on the calendar… and then as the agendas come out I’ll go in and remove some from Favorites in the app - and they’ll disappear from my calendar.

>>   When you select sessions you plan to attend in the app, it will add these to your calendar pretty much immediately.

If you go to the Settings (upper left), there is a choice “Add Favorites to Calendar”. By default it creates a calendar called “IETFers”, but you can also designate another calendar to which you want the items added. Here’s a screenshot:

https://www.evernote.com/l/AAHbgFUiijJJobyE5tehvFoEojNCdEIs5j4

Now, whenever you go into a session and tap the star icon to make the session a “Favorite”, it will appear on your calendar.

If you are using iCloud, the IETFers calendar gets added to that set of calendars and so it replicates out to your other Apple devices.

I also like that the items get added in the timezone of the meeting location, which is great if you are planning your agenda in advance from another timezone.

Dan

---

From: Robert Sparks <[email-masked]>
Date: Thu, 28 Mar 2019 11:30:06 +0100

> calendar which don't track changes and cancellations.

If you just click on the button, you get an ics file that represents the 
state of the customized agenda at the time you clicked on the button.

Rather than clicking on the button, take the URL that it would go to and 
subscribe and you will get changes and cancellations.

RjS

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 28 Mar 2019 10:31:06 +0000

Seems to not be available on android version. Rats.

---

From: Tim Chown <[email-masked]>
Date: Thu, 28 Mar 2019 10:40:13 +0000

> On 28 Mar 2019, at 10:31, Salz, Rich <[email-masked]> wrote:
> 

That explains it, sadly.  Ping Tom or use the in-app 'Suggest a Feature' option (if Android has that...)

It's really nice as my calendar then just has the sessions I want.

Tim

---

From: Tim Chown <[email-masked]>
Date: Thu, 28 Mar 2019 10:42:17 +0000

Hi,

> On 28 Mar 2019, at 10:29, Dan York <[email-masked]> wrote:
> 

Indeed; so I see the calendar on my phone or laptop.

> I also like that the items get added in the timezone of the meeting location, which is great if you are planning your agenda in advance from another timezone.

There is a separate option for that, lower down in the Settings menu, so you can do it either way.  Though I think the sane way is as you describe :)

Tim