Subject: [104attendees] Wednesday experiment - how is it supposed to work?

From: Lou Berger <[email-masked]>
Date: Sun, 17 Mar 2019 10:02:49 -0400

Hi,

I think this is a question for the IESG, but really am unsure -- but I 
may have missed something.

I'm trying to make the most of the planned experiment and schedule a 
multi-document editing session for a WG - the hope is to have a 3+- 
small groups of authors and anyone else who wishes to join and do full 
up editing sessions to resolve open issues in each of the WG documents. 
(I think this could be of great value to the docs!)  To make this work, 
we really need to plan it so all authors show and that we can publicly 
announce time and location so the discussions are open to any who wish 
to join.

In looking at the side meeting wiki 
<https://trac.ietf.org/trac/ietf/meeting/wiki/104sidemeetings> , all 7 
rooms are taken.  Some of these rooms seat 100 or more people and seem 
to be multiple rooms combined.  Can the rooms be split to allow for more 
parallel meetings? Are you expecting small groups to use the whole 
room?    Is there a lounge that we should just hope has space for for 
any group not signed up for one of the rooms?

To make this experiment work for our aspiration usage we really need to 
have a time and place to announce. Given we/I are too late to get one of 
the 7 rooms, how do you recommend we should proceed?

Thank you!

Lou

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 17 Mar 2019 16:57:49 +0100

On Mar 17, 2019, at 15:02, Lou Berger <[email-masked]> wrote:
> 
> Is there a lounge that we should just hope has space for for any group not signed up for one of the rooms?

I can’t answer for the IESG, but I can say that I have had successful meetings of this kind at a round table in the Code Lounge (which is typically the room that is used for the Hackathon during Sat/Sun; I haven’t checked whether this is the case this time as well).
This works for 8-10 people max.

Essentially, we have the Terminal Room for quiet work, and the Code Lounge for small group work that needs communication.  (I think we should outlaw laughing or other loud noises in the latter, but then I’m a Northern German.)

Grüße, Carsten

---

From: Lars Eggert <[email-masked]>
Date: Mon, 18 Mar 2019 09:02:04 +0200

Hi,

to me personally, this unstructured time experiment would have been useful a few years ago, before we had a large-scale hackathons.

These days, I am arriving Fridays or Saturday mornings, and can meet plenty of people around the hackathon to get side-project stuff done. The downside is that the week becomes very long, and I try to fly out as soon as possible, at the latest, Thursday night. Lengthening the week further by an additional short block of unstructured time in the middle isn't the right trade-off (for me).

If we want to have additional unstructured time during the week, I think we should just kill off 10-20% of the WGs. (Not kidding.)

Lars

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 18 Mar 2019 07:39:21 -0500

Hi, Lars,

And to be extremely clear, I'm not answering for the IESG either ...
because I sure won't be speaking for them next Thursday morning!

On Mon, Mar 18, 2019 at 2:03 AM Lars Eggert <[email-masked]> wrote:

> Hi,
>
> to me personally, this unstructured time experiment would have been useful
> a few years ago, before we had a large-scale hackathons.
>
> These days, I am arriving Fridays or Saturday mornings, and can meet
> plenty of people around the hackathon to get side-project stuff done. The
> downside is that the week becomes very long, and I try to fly out as soon
> as possible, at the latest, Thursday night. Lengthening the week further by
> an additional short block of unstructured time in the middle isn't the
> right trade-off (for me).
>
> If we want to have additional unstructured time during the week, I think
> we should just kill off 10-20% of the WGs. (Not kidding.)
>

I have opinions about the no-meeting-on-Friday experiment in Bangkok, but
the relevant point on that one, was feedback from Hackathon participants
that the Hackathon was really valuable and made for a really long week, for
people who were going to stay to the bitter end of the week. So, the IESG
was trying to shorten the meeting week, and was trying to balance that with
people flying around the world to meet, who didn't show up until Sunday,
and wouldn't have a chance to meet face to face for another four months if
we just turned off the IETF SSIDs and went home. That's what I thought we
were thinking, anyway.

So, that was a bad idea (ignore whether it could have ever been a good idea
until we are in a bar), but where I thought we were, post-Buenos Aires,
with a really late start time because of local customs that included
restaurant opening times, was that having more open time during the week (I
remember Fred saying that he could arrange two pre-session meetings every
day, as one example). The Bangkok experiment was trying to provide
unstructured time, but since it didn't, I convinced myself that "during the
week" was critical, if unstructured time was ever going to be a good idea.

I'm not a Hackathon participant, but I've been responsible for multiple
working groups that rely heavily on Hackathon participation, especially
yours, and one of the reasons I think it works for them, is that we have
something like 200-ish people in the room, and we can do things with 200
people that we can't do when 800-1000 more people show up on Sunday.

So ISTM that it would be good to talk with the incoming IESG about whether
unstructured time is still helpful for anyone, whether the Hackathon is the
right length (at a working group chairs lunch a few years ago, Robert
Sparks asked if it should be longer), and whether our traditional meeting
sessions are still helpful in the way that we schedule them (because many
sessions are still presentations of drafts, rather than issues). Once we
talk through those topics, it would likely be easier for future IESGs to
lay out productive meetings.

Thanks,

Spencer, the outgoing TSV AD (by the way, where does the support group for
former TSV ADs meet? Magnus hasn't told me yet)

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 18 Mar 2019 08:48:07 -0400

Hi Lou,

> On Mar 17, 2019, at 10:02 AM, Lou Berger <[email-masked]> wrote:
> 
> Hi,
> 
> I think this is a question for the IESG, but really am unsure -- but I may have missed something.
> 
> I'm trying to make the most of the planned experiment and schedule a multi-document editing session for a WG - the hope is to have a 3+- small groups of authors and anyone else who wishes to join and do full up editing sessions to resolve open issues in each of the WG documents. (I think this could be of great value to the docs!)  To make this work, we really need to plan it so all authors show and that we can publicly announce time and location so the discussions are open to any who wish to join.
> 
> In looking at the side meeting wiki <https://trac.ietf.org/trac/ietf/meeting/wiki/104sidemeetings> , all 7 rooms are taken. 

Yes, sign-ups started on March 1, so this is unsurprising. Note that the two smaller side meeting rooms are available all week.

> Some of these rooms seat 100 or more people and seem to be multiple rooms combined.  Can the rooms be split to allow for more parallel meetings? Are you expecting small groups to use the whole room?    Is there a lounge that we should just hope has space for for any group not signed up for one of the rooms?

Carsten mentioned the Code Lounge. Sign-ups for that shared space (I believe it will be the Chez Louis room) are available at <https://trac.ietf.org/trac/ietf/meeting/wiki/104codelounge>.

Best,
Alissa

> 
> To make this experiment work for our aspiration usage we really need to have a time and place to announce. Given we/I are too late to get one of the 7 rooms, how do you recommend we should proceed?
> 
> Thank you!
> 
> Lou
>

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 18 Mar 2019 12:50:11 +0000

On 18/03/2019 07:02, Lars Eggert wrote:
> If we want to have additional unstructured time during the week, I
> think we should just kill off 10-20% of the WGs. (Not kidding.)
I'd be +many if you'd said kill off 20% of WG sessions. I don't
think we need to actually kill the WGs, just the formal sessions.

(Here's where I turn into a broken record...:-) Run the hackathon
all week, only have formal meeting sessions in the afternoons and
cut the meeting back to Mon-Thu for a typical attendee.

Cheers,
S.

---

From: Bret Jordan <[email-masked]>
Date: Mon, 18 Mar 2019 12:56:25 +0000

It also seems like this is no longer the 1980s or 1990s, we should be able to have regular monthly meetings over a virtual meeting platform of your choice, there are several solid solutions these days.  I for one think F2F meetings are still critical, but they should focus on dealing with things that can not be done remotely. It should not be about presenting drafts or ideas, that should all be done via a remote conferencing solution.  F2F time should really focus on driving issues to consensus.  

Bret 

Sent from my Commodore 128D

PGP Fingerprint: 63B4 FC53 680A 6B7D 1447  F2C0 74F8 ACAE 7415 0050

> On Mar 18, 2019, at 12:39 PM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Hi, Lars, 
> 
> And to be extremely clear, I'm not answering for the IESG either ... because I sure won't be speaking for them next Thursday morning!
> 
> I have opinions about the no-meeting-on-Friday experiment in Bangkok, but the relevant point on that one, was feedback from Hackathon participants that the Hackathon was really valuable and made for a really long week, for people who were going to stay to the bitter end of the week. So, the IESG was trying to shorten the meeting week, and was trying to balance that with people flying around the world to meet, who didn't show up until Sunday, and wouldn't have a chance to meet face to face for another four months if we just turned off the IETF SSIDs and went home. That's what I thought we were thinking, anyway. 
> 
> So, that was a bad idea (ignore whether it could have ever been a good idea until we are in a bar), but where I thought we were, post-Buenos Aires, with a really late start time because of local customs that included restaurant opening times, was that having more open time during the week (I remember Fred saying that he could arrange two pre-session meetings every day, as one example). The Bangkok experiment was trying to provide unstructured time, but since it didn't, I convinced myself that "during the week" was critical, if unstructured time was ever going to be a good idea.. 
> 
> I'm not a Hackathon participant, but I've been responsible for multiple working groups that rely heavily on Hackathon participation, especially yours, and one of the reasons I think it works for them, is that we have something like 200-ish people in the room, and we can do things with 200 people that we can't do when 800-1000 more people show up on Sunday.
> 
> So ISTM that it would be good to talk with the incoming IESG about whether unstructured time is still helpful for anyone, whether the Hackathon is the right length (at a working group chairs lunch a few years ago, Robert Sparks asked if it should be longer), and whether our traditional meeting sessions are still helpful in the way that we schedule them (because many sessions are still presentations of drafts, rather than issues). Once we talk through those topics, it would likely be easier for future IESGs to lay out productive meetings. 
> 
> Thanks, 
> 
> Spencer, the outgoing TSV AD (by the way, where does the support group for former TSV ADs meet? Magnus hasn't told me yet)
>  
>> Lars
> -- 
> 104attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/104attendees

---

From: tjw ietf <[email-masked]>
Date: Mon, 18 Mar 2019 06:22:17 -0700

I love mr Stephen’s idea. As a WG chair I spend a bit of time during the hackathon banging heads for slides or working some of that ‘rough consensus’. And usually during one of the meetings an idea appears that leads to a possibly better solution. 

Tim. 

From my high tech gadget

> On Mar 18, 2019, at 05:50, Stephen Farrell <[email-masked]> wrote:
> 
> 
> <0x5AB2FAF17B172BEA.asc>

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 18 Mar 2019 06:23:22 -0700

> cut the meeting back to Mon-Thu for a typical attendee.

And to repeat myself: as someone who has been very active in both the
hackthon and several WGs, I think this would be a bad idea, as it would not
significantly improve hackathon effectiveness (people are already tired
after two days and the mornings aren't a great time to work for many) and
would cut badly into needed WG time.

-Ekr

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 18 Mar 2019 10:33:04 -0400

Bret,

Virtual meetings are great in theory, but when you have active WG
participants around the globe, finding meeting times that can allow
everyone to participate on the same call is quite challenging, and having
multiple calls at different times doesn't allow for a full discussion.

Cheers,
Andy

On Mon, Mar 18, 2019 at 8:56 AM Bret Jordan <[email-masked]> wrote:

> It also seems like this is no longer the 1980s or 1990s, we should be able
> to have regular monthly meetings over a virtual meeting platform of your
> choice, there are several solid solutions these days.  I for one think F2F
> meetings are still critical, but they should focus on dealing with things
> that can not be done remotely. It should not be about presenting drafts or
> ideas, that should all be done via a remote conferencing solution.  F2F
> time should really focus on driving issues to consensus.
>
> Bret
>
>> to me personally, this unstructured time experiment would have been
>> useful a few years ago, before we had a large-scale hackathons.
>>
> So, that was a bad idea (ignore whether it could have ever been a good
> idea until we are in a bar), but where I thought we were, post-Buenos
> Aires, with a really late start time because of local customs that included
> week" was critical, if unstructured time was ever going to be a good idea..
>

---

From: Ted Lemon <[email-masked]>
Date: Mon, 18 Mar 2019 11:26:19 -0400

On Mar 18, 2019, at 10:33 AM, Andrew G. Malis <[email-masked]> wrote:
> Virtual meetings are great in theory, but when you have active WG participants around the globe, finding meeting times that can allow everyone to participate on the same call is quite challenging, and having multiple calls at different times doesn't allow for a full discussion.

This may be true, but having them all fly into a common time zone is a pretty heavy-handed solution.   Surely there’s a more lightweight compromise?

---

From: Watson Ladd <[email-masked]>
Date: Mon, 18 Mar 2019 08:58:27 -0700

Its hard to have a conversation outside the meeting with a virtual interim.
Even offlist conversations dont always happen.

Contrast with the virtues of the hallway track.

On Mon, Mar 18, 2019, 8:26 AM Ted Lemon <[email-masked]> wrote:

> This may be true, but having them all fly into a common time zone is a
> pretty heavy-handed solution.   Surely there’s a more lightweight
> compromise?
>
>
> --

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 18 Mar 2019 15:58:51 +0000

Echoing Eric as another Eric :-)

I agree with Ekr, hackathon are great (done many of them) for mature drafts/ideas (and when open source community is interested) but WG meetings/BoF (or even corridor meeting or design team meetings) are also good for new ideas/exploring alternatives/building consensus.

As an individual contributors in hackathon and WG meetings (and associated ‘meetings’), I think both are required

-éric

PS: hackhaton in the _morning_ ? really ?

From: iesg <[email-masked]> on behalf of Eric Rescorla <[email-masked]>
Date: Monday, 18 March 2019 at 14:24
To: Stephen Farrell <[email-masked]>
Cc: Lars Eggert <[email-masked]>, 104 attendees <[email-masked]>, Lou Berger <[email-masked]>, IESG <[email-masked]>
Subject: Re: [104attendees] Wednesday experiment - how is it supposed to work?

On Mon, Mar 18, 2019 at 5:50 AM Stephen Farrell <[email-masked]<mailto:[email-masked]>> wrote:

And to repeat myself: as someone who has been very active in both the hackthon and several WGs, I think this would be a bad idea, as it would not significantly improve hackathon effectiveness (people are already tired after two days and the mornings aren't a great time to work for many) and would cut badly into needed WG time.

-Ekr

Cheers,
S.

---

From: Bret Jordan <[email-masked]>
Date: Mon, 18 Mar 2019 16:00:27 +0000

And just to be clear I am not advocating for stopping face 2 face meetings.  But I think a virtual session is a lot easier and cheaper for people to attend then flying around the world. 

Bret 

> On Mar 18, 2019, at 3:26 PM, Ted Lemon <[email-masked]> wrote:
>

---

From: Tale Lawrence <[email-masked]>
Date: Mon, 18 Mar 2019 12:07:01 -0400

On Mar 18, 2019, at 08:39, Spencer Dawkins at IETF <[email-masked]> wrote:
> but where I thought we were, post-Buenos Aires, with a really late start time because of local customs that included
> restaurant opening times, was that having more open time during the week [was a good thing]

At Buenos Aires I heard significant positive feedback about the meeting schedule, and I personally loved it as well.  I was generally
left with the impression that so many people had liked it that there was serious consideration for making future meeting schedules
more like it.  I've been sad that it all just seemed to go back to business as usual since then.

Yes, I get that the restaurant bit was a big factor in how that schedule came to be for Argentina, but it's not like restaurants in
other cities aren't open at 8pm.

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Mon, 18 Mar 2019 13:18:35 -0300

Hi!

On 18 Mar 2019, at 13:07, Tale Lawrence wrote:

> At Buenos Aires I heard significant positive feedback about the 
> meeting schedule, and I personally loved it as well.  I was generally
> left with the impression that so many people had liked it that there 
> was serious consideration for making future meeting schedules

+1 to this. As far as experiments go (granted, for BA this was a 
“forced experiment” :-) ), the schedule for BA seemed to work well 
for quite a lot of folk. In my case, I actually got a lot done between 
8am and 10am during the BA week.

It seems to be a lot easier to coordinate early morning meetings than it 
is to chase people after WG sessions end.

With a session start time of 10am the meeting gets 10hrs of 
“non-structured time” during the week. For example, meeting rooms 
could be available from 8am to hold these drafting sessions other people 
have mentioned.

This would not be necessarily incompatible with additional 
non-structured time either. The arrangements for Wednesday, if they 
work, could be kept as well.

Cheers!

/Carlos

---

From: Ted Lemon <[email-masked]>
Date: Mon, 18 Mar 2019 12:36:41 -0400

On Mar 18, 2019, at 11:58 AM, Watson Ladd <[email-masked]> wrote:
> Its hard to have a conversation outside the meeting with a virtual interim. Even offlist conversations dont always happen.

Another problem that could be solved, if we wanted to solve it, but won’t be solved, if we don’t!  :)

---

From: Paul Wouters <[email-masked]>
Date: Mon, 18 Mar 2019 18:14:34 +0100

> On Mar 18, 2019, at 13:39, Spencer Dawkins at IETF <[email-masked]> wrote:

>  (because many sessions are still presentations of drafts, rather than issues). 

This is the core issue. We need less presentations of work and more discussions of specific items.

Paul

---

From: Bret Jordan <[email-masked]>
Date: Mon, 18 Mar 2019 17:26:58 +0000

Yes, keeping in the forefront that these are very expensive meetings.  Let us focus on things that can not be done by some other means.

Bret 

> On Mar 18, 2019, at 5:14 PM, Paul Wouters <[email-masked]> wrote:
> 
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 18 Mar 2019 18:56:37 +0100

> This is the core issue. We need less presentations of work and more discussions of specific items.

Here we go again.
(And I’m not addressing anyone specific here.)

There is this mantra being repeated again and again.  
As in, presenting (drafts, work) at IETF meetings is wrong.

Instead, this mantra is wrong.

What *is* wrong is spending WG time without advancing issues.
“Presenting” some work can have two positive effects here:
— reminding people what the issues and the state of their discussion is, getting the discussion going (“impulse talk”);
— drawing in tourists that may bring serendipitous expertise by getting them (somewhat) up to speed for the discussion.

(All this is assuming we do have a healthy discussion during and after the “presentation", of course.)

Actually, the latter item (drawing in tourists) is a major reason to have combined meeting weeks for the entire IETF, so we can draw people in from neighboring areas and get that serendipitous input.

Now different drafts and different stages of work differ with respect to whether these two potential positive effects are significant.  There is no point in “presenting” things where all the issues are well-known or that don’t need to be discussed at all.  “Presenting” does not always need slides; at some stages looking at github issues may be better.  Also, we all have sat through WG meetings that were so crammed with presentations that there was no time for the discussion that should have ensued.  *That* is indeed a waste of time.  But the problem is not the “presentation”, but the misallocation of time that favors presentations over the valuable discussions that should be facilitated by the presentations.

If your WG management (including yours truly) is mismanaging WG meeting time, please tell them so (and if that doesn’t help, ask their management to manage).
Just citing the mantra is not going to help a lot, because WG chairs often know intuitively that it is simply not true.

Grüße, Carsten

---

From: "Aaron Falk" <[email-masked]>
Date: Mon, 18 Mar 2019 14:02:55 -0400

+1 to all of this.

On 18 Mar 2019, at 13:56, Carsten Bormann wrote:

> — reminding people what the issues and the state of their discussion 
> is, getting the discussion going (“impulse talk”);
> — drawing in tourists that may bring serendipitous expertise by 
> getting them (somewhat) up to speed for the discussion.
>
> Actually, the latter item (drawing in tourists) is a major reason to 
> have combined meeting weeks for the entire IETF, so we can draw people 
> in from neighboring areas and get that serendipitous input.
>
> Now different drafts and different stages of work differ with respect 
> to whether these two potential positive effects are significant.  
> There is no point in “presenting” things where all the issues are 
> well-known or that don’t need to be discussed at all.  
> “Presenting” does not always need slides; at some stages looking 
> at github issues may be better.  Also, we all have sat through WG 
> meetings that were so crammed with presentations that there was no 
> time for the discussion that should have ensued.  *That* is indeed a 
> waste of time.  But the problem is not the “presentation”, but the 
> misallocation of time that favors presentations over the valuable 
> discussions that should be facilitated by the presentations.
>
> If your WG management (including yours truly) is mismanaging WG 
> meeting time, please tell them so (and if that doesn’t help, ask 
> their management to manage).
> Just citing the mantra is not going to help a lot, because WG chairs 
> often know intuitively that it is simply not true.
>
> Grüße, Carsten
>
> --

---

From: Lou Berger <[email-masked]>
Date: Mon, 18 Mar 2019 17:26:32 -0400

I think it would be great to start up an implementors (or opensource or 
hackathon) track/area that runs in parallel with our regular sessions -- 
of course making this work would just complicate our space requirements 
and conflicts, but it would certainly help address the 'running code' 
IETF principle...

Lou

On 3/18/2019 11:58 AM, Eric Vyncke (evyncke) wrote:
> I agree with Ekr, hackathon are great (done many of them) for mature 
> drafts/ideas (and when open source community is interested) but WG 
> meetings/BoF (or even corridor meeting or design team meetings) are 
> also good for new ideas/exploring alternatives/building consensus.
>
> As an individual contributors in hackathon and WG meetings (and 
> associated ‘meetings’), I think both are required
>
> -éric
>
> PS: hackhaton in the _/morning/_ ? really ?
>
> *From: *iesg <[email-masked]> on behalf of Eric Rescorla 
> <[email-masked]>
> *Date: *Monday, 18 March 2019 at 14:24
> *To: *Stephen Farrell <[email-masked]>
> *Cc: *Lars Eggert <[email-masked]>, 104 attendees 
> <[email-masked]>, Lou Berger <[email-masked]>, IESG 
> <[email-masked]>
> *Subject: *Re: [104attendees] Wednesday experiment - how is it 
> supposed to work?
>
> On Mon, Mar 18, 2019 at 5:50 AM Stephen Farrell 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>
> hackthon and several WGs, I think this would be a bad idea, as it 
> would not significantly improve hackathon effectiveness (people are 
> already tired after two days and the mornings aren't a great time to 
> work for many) and would cut badly into needed WG time.
>
> -Ekr
>
>
>     Cheers,
>     S.
>
>

---

From: Lou Berger <[email-masked]>
Date: Mon, 18 Mar 2019 17:49:17 -0400

Hi Alissa,

     Thank you for the response. See below.

> Yes, sign-ups started on March 1, so this is unsurprising. Note that the two smaller side meeting rooms are available all week.

Understood, I've been polling the authors to see when else they might be 
available.  Interestingly, I did receive a request to *not* meeting 
during the unstructured time so that the person could attend the deep 
dive.  (BTW this is a great example of what could be on an implementers 
track I mentioned in my previous mail - although I'm sure many/most will 
think it's an unworkable idea...)

> Carsten mentioned the Code Lounge. Sign-ups for that shared space (I believe it will be the Chez Louis room) are available at <https://trac.ietf.org/trac/ietf/meeting/wiki/104codelounge>.

That's great! I was unaware of being able to signup for space in the 
lounge.  How many groups/tables can be accommodated.  -- it doesn't say.

Thank you,

Lou

---

From: Kyle Rose <[email-masked]>
Date: Mon, 18 Mar 2019 18:12:11 -0400

On Mon, Mar 18, 2019 at 1:57 PM Carsten Bormann <[email-masked]> wrote:

> — reminding people what the issues and the state of their discussion is,
> getting the discussion going (“impulse talk”);
>

I do not think this is valuable. WG participants already need to have
context to contribute, which can take the form of reading drafts, reading
the list, and reviewing issues/PRs. F2F time is too valuable to waste on
this.

> — drawing in tourists that may bring serendipitous expertise by getting
> them (somewhat) up to speed for the discussion.
>

This *is* a valuable use of some time, but I suspect that there are more
efficient forums for this purpose, such as HotRFC. There is a huge
opportunity cost across the whole of the IETF (i.e., not limited to a
single WG) when any WG demands an official slot for work that does not need
F2F time. Basically, you have three competing priorities:

1. Make significant progress on work that benefits from F2F interaction
2. Spend substantial F2F time on remedial and/or passively-consumed content
3. Go home on Thursday

Pick 2.

I'm with Stephen that a lot of the WG sessions should be eliminated, and I
might even propose IESG oversight and approval of WG session agendas to
make sure the sessions are being used productively. If a WG has an agenda
that doesn't meet that bar, they can still meet during unstructured time.

Kyle

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 18 Mar 2019 19:20:13 -0500

Hi, Kyle,

> 2. Spend substantial F2F time on remedial and/or passively-consumed content

(cough!) Bangkok ... does anyone really support a four-day IETF week and
believe that won't turn into requests not to meet on Thursday afternoon,
because people will be headed to the airport after Thursday lunch? I'm
curious about how much support there is for that.

> that doesn't meet that bar, they can still meet during unstructured time.

So, one possibility that I've seen come up in conversations with working
group chairs was giving working groups who ask for it a one-hour slot
that's ruthlessly deconflicted, probably scheduled Monday/Tuesday or
Monday/Tuesday/Wednesday, and having the rest of the week scheduled
differently (you can ask for longer slots, but everyone else might be, too,
so it's harder to deconflict).

I won't be the person doing the approving, but I can't see inserting AD
approval of WG agendas as a step toward approving meeting slots, because
I'd assert many/most working groups don't have a solid agenda when the WG
meeting request cutoff happens. So balancing getting earlier agendas as a
gating factor for slot approval would be awesome, but so would giving
everyone a unicorn.

Do people think that's easier than I think it is?

Spencer

---

From: Kyle Rose <[email-masked]>
Date: Mon, 18 Mar 2019 20:54:57 -0400

> curious about how much support there is for that.

Haha... #3 was purposely somewhat glib. Use it to stand in for whatever
else competes for time: shortening the week, allocating more unstructured
time during the meeting week, having fewer sessions per day or starting the
day later, etc. As was pointed out to me earlier today, my prior statement
that attendees should plan not to leave until Friday afternoon often means
that two weekends are consumed by each meeting for those who attend the
hackathon or other events on the opening weekend, which is a lot to ask of
many folks. When there was no hackathon and few organized events before
Monday morning, staying the entire week meant five days. Now it means
seven. I know I'm often fatigued by Thursday morning.

> so it's harder to deconflict).

Interesting suggestion. I would argue that this is functionally similar to
making WGs with highly-conflicted asks meet during unstructured time. I'd
rather have WGs with concrete plans for making progress toward milestones
get the deconflicted time they need.

> gating factor for slot approval would be awesome, but so would giving

It's not clear you need a final agenda; more an outline of how the time is
to be spent. "We'll spend this much time discussing issues we know about,
this much time discussing issues that come up between now and the meeting,
spend 10 minutes talking about this other radical proposal, and spend 7
hours on a single bit" (I kid, I kid...) vs. "We have these 7 talks
scheduled on random topics" or "We're going to have status updates on all
the drafts and argue with recalcitrant remotes on Meetecho over the same
issues for 5 meetings in a row". If there's a plan of action, you get a
slot; if there isn't, you don't. If nothing else, this becomes a forcing
function for deciding in advance how to make the best use of precious
meeting time.

Kyle

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 19 Mar 2019 03:17:29 +0100

Maybe instead or or in addition to bluesheet we could have evaluation
sheets of WG meetings by attendees including evaluations of each
agenda item ?.

I surmise that more than 50% of attendees use IETF for educational
purposes and if the WG meetings became all "inside-baseball" discussions
progressing WG items at max-speed, i wonder if the IETF should then
rightfully have 50% less participants. Which could double IETF ticket
prices for the remaining participants ?

This is a hopefully a wrong wrost case consideration. But there is a
factor that says the event might want to make all the attendees happy
if it wants to keep them, and there is going to be a broad spectrum of
interests. Most participants are silent on this thread, so we need other
means to understand what they want. Hence, see above.

Toerless

On Mon, Mar 18, 2019 at 06:56:37PM +0100, Carsten Bormann wrote:
> (And I???m not addressing anyone specific here.)
> 
> ???Presenting??? some work can have two positive effects here:
> ??? reminding people what the issues and the state of their discussion is, getting the discussion going (???impulse talk???);
> ??? drawing in tourists that may bring serendipitous expertise by getting them (somewhat) up to speed for the discussion.
> 
> (All this is assuming we do have a healthy discussion during and after the ???presentation", of course.)
> 
> Now different drafts and different stages of work differ with respect to whether these two potential positive effects are significant.  There is no point in ???presenting??? things where all the issues are well-known or that don???t need to be discussed at all.  ???Presenting??? does not always need slides; at some stages looking at github issues may be better.  Also, we all have sat through WG meetings that were so crammed with presentations that there was no time for the discussion that should have ensued.  *That* is indeed a waste of time.  But the problem is not the ???presentation???, but the misallocation of time that favors presentations over the valuable discussions that should be facilitated by the presentations.
> 
> If your WG management (including yours truly) is mismanaging WG meeting time, please tell them so (and if that doesn???t help, ask their management to manage).

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 19 Mar 2019 03:20:54 +0100

https://trac.ietf.org/trac/ietf/meeting/wiki/104codelounge

On Mon, Mar 18, 2019 at 05:26:32PM -0400, Lou Berger wrote:
> hackathon) track/area that runs in parallel with our regular sessions -- of
> course making this work would just complicate our space requirements and
> conflicts, but it would certainly help address the 'running code' IETF
> principle...
> 
> Lou
> 
> > meetings/BoF (or even corridor meeting or design team meetings) are also
> > good for new ideas/exploring alternatives/building consensus.
> > 
> > associated ???meetings???), I think both are required
> > 
> > -éric
> > 
> > *Subject: *Re: [104attendees] Wednesday experiment - how is it supposed
> > to work?
> > 
> > hackthon and several WGs, I think this would be a bad idea, as it would
> > not significantly improve hackathon effectiveness (people are already
> > tired after two days and the mornings aren't a great time to work for
> > many) and would cut badly into needed WG time.
> > 
> > -Ekr
> > 
> > 
> >     Cheers,
> >     S.
> > 
> > 
> 
> -- 

-- 
---
[email-masked]

---

From: Stephanie McCammon <[email-masked]>
Date: Tue, 19 Mar 2019 18:35:13 +0100

Hi Lou,

The Code Lounge area is a collection of tables in the IETF lounge (Chez Louis) that is defined by a ‘Code Lounge’ sign. The area is not roped off so it can really be expanded to accommodate as many groups as there are tables in the room if necessary. The lounge seats 150 at round tables for 10.

Thanks,

Stephanie McCammon
IETF Senior Project Manager
5177 Brandin Court
Fremont, CA 94538
T: +1.510.492.4081
F: +1.510.492.4001

Association Management Solutions (AMS)
Forum Management, Meeting, and Event Planning
www.amsl.com

> On Mar 18, 2019, at 10:49 PM, Lou Berger <[email-masked]> wrote:
> 
> Hi Alissa,
> 
> Understood, I've been polling the authors to see when else they might be available.  Interestingly, I did receive a request to *not* meeting during the unstructured time so that the person could attend the deep dive.  (BTW this is a great example of what could be on an implementers track I mentioned in my previous mail - although I'm sure many/most will think it's an unworkable idea...)
> 
> That's great! I was unaware of being able to signup for space in the lounge.  How many groups/tables can be accommodated.  -- it doesn't say.
> 
> Thank you,
> 
> Lou
> 
>> Best,
>> Alissa
>>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 19 Mar 2019 18:49:30 +0100

On Mar 18, 2019, at 22:49, Lou Berger <[email-masked]> wrote:
> 
> so that the person could attend the deep dive

I sure hope there will be a youtube video of that as with all WG/RG meetings.

Will there be one?

Grüße, Carsten

---

From: Wes Hardaker <[email-masked]>
Date: Tue, 19 Mar 2019 13:09:04 -0700

> Another problem that could be solved, if we wanted to solve it, but won’t be

So I've been giving this problem a lot of thought in the past year.
Anyone want to meet during the week to see if we can come up with an
experimental solution to the Many Couches problem (which seems like its
re-surging again)?  We just need to find a blank spot in the agenda to
meet.  When would that be....  oh, Wednesday??

-- 
Wes Hardaker
USC/ISI

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 19 Mar 2019 15:36:13 -0500

Hi, Carsten,

> I sure hope there will be a youtube video of that as with all WG/RG

That is my understanding. It's listed as a BOF, and we do that for all
BOFs. We've even been doing it for Sunday afternoon tutorials for at least
a couple of years now.

Spencer

---

From: Ted Lemon <[email-masked]>
Date: Tue, 19 Mar 2019 18:30:34 -0400

> meet.  When would that be....  oh, Wednesday??

Yes.   I think the reason this failed last time is not that it’s not time, but rather that it was a little bit top-heavy.   It might be worth having a HotRFC talk about it as well, if there’s still room on the agenda.

---

From: Wes Hardaker <[email-masked]>
Date: Wed, 20 Mar 2019 21:45:03 -0700

Ted Lemon <[email-masked]> writes:

> Yes.   I think the reason this failed last time is not that it’s not time,
> but rather that it was a little bit top-heavy.   It might be worth having a
> HotRFC talk about it as well, if there’s still room on the agenda.

That's a good idea too.  Wonder if I could scrape something together
quickly...

-- 
Wes Hardaker
USC/ISI

---

From: Ted Lemon <[email-masked]>
Date: Fri, 22 Mar 2019 07:39:57 -0400

> That's a good idea too.  Wonder if I could scrape something together

I’ve actually done a bit of thinking about this as part of the DOGFOOD BoF proposal and my discussion about it with Alyssa.   I’m planning to prepare a presentation, but if you want to do it instead, I wouldn’t object.   If you’re going to be at the hackathon, maybe we could spend a few minutes talking about it on Saturday?