Subject: Re: [104attendees] [104all] IETF 104 Prague Network Shutdown

From: Portia Wenze-Danley <[email-masked]>
Date: Thu, 28 Mar 2019 14:47:37 +0100

Thanks Jim for all your stellar leadership and support of the IETF.

Your service is greatly appreciated.
________________________________
Portia Wenze-Danley
IETF Administration LLC Executive Director (Interim)
(Formerly IETF Administrative Director (IAD)	
Internet Engineering Task Force (IETF)
[email-masked]

> On Mar 28, 2019, at 2:10 PM, Jim Martin <[email-masked]> wrote:
> 
> Gentlepeople,
> 	As the meeting comes to a close, we wanted to update everyone on the shutdown schedule for the IETF Network. The wireless APs that deliver the main IETF networks in the Hilton meeting rooms will be removed throughout the day tomorrow as sessions come to a close. The help desk and printer in the registration area will remain until 3pm. The wired guest room Internet in the Hilton will revert to the traditional hotel network, and “ietf-hotel” will disappear from the guest rooms and public areas at roughly 14:00. If you’re remaining in the hotel, please feel free to join the HHonors wireless network with the access code “IETF104”.
> 
> 	On a personal note, this will be my last message representing the NOC. Many thanks to the community for all the support and kind words over the years. While I’m leaving, the NOC team is already planning for Montreal and points beyond. You’ll all be in good hands.  
> 
> 	I hope you all have a good trip home and that many of our paths will cross again!
> 
> 	- Jim
> -- 
> 104all mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/104all

---

From: Michael Richardson <[email-masked]>
Date: Thu, 28 Mar 2019 18:08:32 +0100

Jim Martin <[email-masked]> wrote:
    > the traditional hotel network, and “ietf-hotel” will disappear from the
    > guest rooms and public areas at roughly 14:00. If you’re remaining in
    > the hotel, please feel free to join the HHonors wireless network with
    > the access code “IETF104”.

As an aside, the hotel wired network which I experienced in an non-IETF side
meeting on Monday, seems to filter AAAA records out of answers when 8.8.8.8/8.8.4.4
is asked.  I don't know if I was speaking with the "real" 8.8.8.8 (I realize
it's anycast), or if the hotel network was changing traffic.

It did not filter queries directly to my authoritative nameservers.

It will be interesting to confirm if this occurs on the wireless.

We noticed this because we brought up IPv6-over-IPsec tunnels for our
testing, and were surprised when we could not resolve things until we
switching to using different resolvers.  Probably none of you will notice
unless you bring up an IPv6 tunnel, and do not also pass DNS traffic over
IPv6. 

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 29 Mar 2019 07:18:49 +0100

On Thu, Mar 28, 2019 at 06:08:32PM +0100,
 Michael Richardson <[email-masked]> wrote 
 a message of 71 lines which said:

> As an aside, the hotel wired network which I experienced in an
> non-IETF side meeting on Monday, seems to filter AAAA records out of
> answers when 8.8.8.8/8.8.4.4 is asked.

A very good reason why we need deployment of DoH (RFC 8484).

---

From: Jen Linkova <[email-masked]>
Date: Fri, 29 Mar 2019 19:02:56 +1100

On Fri, Mar 29, 2019 at 4:09 AM Michael Richardson
<[email-masked]> wrote:
> is asked.

On Wifi:

furry@Wintermute:~>dig @8.8.8.8 www.google.com aaaa +short

furry@Wintermute:~>dig @8.8.8.8 www.google.com aaaa +short +tcp

2a00:1450:4014:80d::2004

furry@Wintermute:~>

>  I don't know if I was speaking with the "real" 8.8.8.8 (I realize

traceroute shows 8.8.8.8 being 8 hops away.
UDP DNS responses have TTL 64
TCP DNS responses have TTL 64
ICMP port uneach in traceroute shows TTL 56.

If you switch to IETF network, the path to 8.8.8.8 has the same last
few hops, the VIP is 9 hops away.
UDP response has TTL 121, TCP as well.
ICMP port unreach hs TTL 55.

The MOST inetetsting thing on the hotel network is that dig @8.8.8.8
www.google.com aaaa +short
sends one DNS query but receives TWO responses...
One with TTL 64 (no AAAA), another one with TTL 122 with AAAA.
The host uses the first (spoofed) one.

> It will be interesting to confirm if this occurs on the wireless.

Yes.

-- 
SY, Jen Linkova aka Furry

---

From: Chris Morrow <[email-masked]>
Date: Fri, 29 Mar 2019 09:18:40 +0100

Hotel should be ietf network. We weren't messing about with 8.8.8.8, or
other traffic.

Curious!

> > meeting on Monday, seems to filter AAAA records out of answers when

We will have to add this sorry if testing to or next site ☹️

Thanks for the details!

> 104attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/104attendees
>