Subject: [104attendees] Found Visa Card

From: Evangelos Haleplidis <[email-masked]>
Date: Thu, 28 Mar 2019 13:45:36 +0200

Just found a Visa Card with the name "Jun Hu" in the Grand Ballroom.

It was on the floor under a chair. It's  now sitting on the chair where it
was found.
If the owner does not claim it, after the Thursday speaker session i will
return it to the IETF registration desks.

Regards,
Evangelos.

---

From: "Hu, Jun (Nokia - US/Mountain View)" <[email-masked]>
Date: Thu, 28 Mar 2019 12:04:14 +0000

Just got it back, thanks man!

Sent from mobile

________________________________
From: 104attendees <[email-masked]> on behalf of Evangelos Haleplidis <[email-masked]>
Sent: Thursday, March 28, 2019 12:46 PM
To: [email-masked]
Subject: [104attendees] Found Visa Card

It was on the floor under a chair. It's  now sitting on the chair where it was found.
If the owner does not claim it, after the Thursday speaker session i will return it to the IETF registration desks.

Regards,
Evangelos.