Subject: Re: [104attendees] PRG Departures Experience

From: Sandra Murphy <[email-masked]>
Date: Tue, 2 Apr 2019 09:19:28 -0400

A late report, but maybe of interest for next visit.

My flight out was on Brussels Airline at 6:40am to Brussels.  I took a taxi at 4:00am, got to the airport at 4:20.  Many of the counter positions were marked Closed at that hour, though there was a very long line at the Lufthansa positions.  Brussels Airline positions would open at 4:40am.

About 4:45am, two positions opened up for Brussels Airlines.  I was in the bag check-in line until 5:50am.  (The Lufthansa line was just clearing at that time.) Proceeded through the checkpoint and got to my gate at 6:10am (it was a long walk) just as they announced boarding would begin.  I met other IETF-ers who took a 4:30am taxi and beat me to the gate - because they had advanced status with the airline.  Note to self: arriving at PRG 2 hrs before flight is advisable, but more than 2 hrs early may find the counters are not yet open.

We took off about 30 min late because there was a passenger who was “not fit” to travel.  Security and an ambulance were called.  A flight attendant told me that the man was inebriated “to the point of coma”, but he did walk himself off.  (Do not drink and fly?)

I connected to a US flight in Brussels, with a 3 hour lay over, so I was not worried at the delay.

In Brussels, my departing flight was in the B area.  I took the escalator up to the B area, to be met by a long line that doubled back on itself at the top of the escalator, with no view of what awaited at at the end.  The end of the line turned out to be an immigration area with a set of switchback roped lines.  In total, that line took took an hour.

The departure screen said the gate had been changed to B6.  Another long walk to the gate.  Turned out the boarding pass Brussels Airlines gave me was not correct and I got a new one at the transfer desk. The transfer desk also told me the gate had changed to gate B10, and put me through a perfunctory security check which earned me the all important passport stamp.  Then the gate changed to B9.  Then the gate changed back to B6. (An airport game to keep the passengers occupied and out of the bars?)

All in all, the three hour layover at BRU was not overly generous.  There were several other passengers in the immigration line who had much shorter layovers, some of whom started jumping the line in an effort to make their flight.   Note to self:  allow lots of transfer time when leaving the EU.

At landing at IAD, the immigration line took 40 min.

Lots of long lines and long walks.

—Sandy

> On Mar 29, 2019, at 4:21 AM, Chris Morrow <morrowc=[email-masked]> wrote:
> 
> As I checked in about twenty minutes ago... There were folk in line for over 45 minutes they said. (Lufthansa)
> 
> Security too a bit of time as well... Many folk misunderstanding security requirements ;(
> 
> All though in about 30 total minutes to the other side of security.
> 
> On Fri, Mar 29, 2019, 07:15 Michal Krsek <[email-masked]> wrote:
> Please do not underestimate queues that can be very long and happen from time to time. 30 minutes is very good time and can’t be used as “normal in a rush hour”.
> 
> M
> 
> On 29 Mar 2019, at 01:52, Livingood, Jason <[email-masked]> wrote:
> 
>> Just sharing my experience today.
>> 
>>  
>> 
>> To PRG: It took only 30 minutes by car during the morning rush hour, such as it is.
>> 
>> Terminal: I saw only very short lines for ticketing and baggage check areas. The line for security took 10 minutes or less to clear (terminal for travel within the EU), and there were several lines open.
>> 
>>  
>> 
>> It was an overall very fast experience.
>> 
>>  
>> 
>> Jason
>> 
>> -- 
>> 104attendees mailing list
>> 104attendees@ietf..org
>> https://www.ietf.org/mailman/listinfo/104attendees
> -- 
> 104attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/104attendees
> -- 
> 104attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/104attendees

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 2 Apr 2019 09:52:12 -0400

Sandy,

My connection was the opposite of yours. I flew Air France from PRG to CDG
and connected to a flight to Boston. At CDG, the emigration line to leave
the Schengen Area was very short, and we didn't have to go through any
security in order to reach the gates for US flights (by comparison, a few
weeks ago I connected in Munich and had to re-clear security to reach the
US gates). I did have to walk from 2F to 2E-L, but that was fine, it was
all within a single security perimeter. So next time I recommend connecting
at CDG rather than Brussels.

Cheers,.
Andy

On Tue, Apr 2, 2019 at 9:19 AM Sandra Murphy <[email-masked]> wrote:

> My flight out was on Brussels Airline at 6:40am to Brussels.  I took a
> taxi at 4:00am, got to the airport at 4:20.  Many of the counter positions
> were marked Closed at that hour, though there was a very long line at the
> Lufthansa positions.  Brussels Airline positions would open at 4:40am.
>
> About 4:45am, two positions opened up for Brussels Airlines.  I was in the
> bag check-in line until 5:50am.  (The Lufthansa line was just clearing at
> that time.) Proceeded through the checkpoint and got to my gate at 6:10am
> (it was a long walk) just as they announced boarding would begin.  I met
> other IETF-ers who took a 4:30am taxi and beat me to the gate - because
> they had advanced status with the airline.  Note to self: arriving at PRG 2
> hrs before flight is advisable, but more than 2 hrs early may find the
> counters are not yet open.
>
> We took off about 30 min late because there was a passenger who was “not
> fit” to travel.  Security and an ambulance were called.  A flight attendant
> told me that the man was inebriated “to the point of coma”, but he did walk
> himself off.  (Do not drink and fly?)
>
> In Brussels, my departing flight was in the B area.  I took the escalator
> up to the B area, to be met by a long line that doubled back on itself at
> the top of the escalator, with no view of what awaited at at the end.  The
> end of the line turned out to be an immigration area with a set of
> switchback roped lines.  In total, that line took took an hour.
>
> The departure screen said the gate had been changed to B6.  Another long
> walk to the gate.  Turned out the boarding pass Brussels Airlines gave me
> was not correct and I got a new one at the transfer desk. The transfer desk
> also told me the gate had changed to gate B10, and put me through a
> perfunctory security check which earned me the all important passport
> stamp.  Then the gate changed to B9.  Then the gate changed back to B6. (An
> airport game to keep the passengers occupied and out of the bars?)
>
> All in all, the three hour layover at BRU was not overly generous.  There
> were several other passengers in the immigration line who had much shorter
> layovers, some of whom started jumping the line in an effort to make their
> flight.   Note to self:  allow lots of transfer time when leaving the EU.
>
> > Please do not underestimate queues that can be very long and happen from
> time to time. 30 minutes is very good time and can’t be used as “normal in
> a rush hour”.
> >
> > M
> >
> >> Terminal: I saw only very short lines for ticketing and baggage check
> areas. The line for security took 10 minutes or less to clear (terminal for
> travel within the EU), and there were several lines open.
> >>
> >>
> >>

---

From: Michael StJohns <[email-masked]>
Date: Tue, 2 Apr 2019 09:56:16 -0400

On 4/2/2019 9:19 AM, Sandra Murphy wrote:
> ....
When I got to IAD, the normal lines for immigration were as long as I've 
ever seen them - basically ALL the cattle chutes were filled with people 
back to the entry.  My first thought was "Global Entry was the best $100 
I've ever spent".  I was through immigration in about 4 minutes and only 
because the *!%$## machines had problems reading my finger prints.  A 20 
minute wait for my bag and I was out of there.

I can't recommend Global Entry enough.    Start now to get it approved 
for the next trip out of the country.  Once that's done its good for 5 
years and can be renewed over the net with just a fee payment.  (Sorry - 
US and Canadian - via Nexus citizens and permanent residents only).

If you don't have GE, then you might want to try 
https://mobilepassport.us/ - I have no experience with this, but it does 
appear to be a separate and shorter and faster line at Dulles.

Mike

ps - short rant on the GE machines - I've always had problem getting 
them to read my fingerprints.  The height of the reading space is a bit 
smaller than the distance between the top of my middle finger and the 
bottom of the finger pad on my pinky leading to some contortions to fit 
them all in.  Trying to get all 4 fingers to read at the same time is 
problematic.  I usually go through three or four attempts before the 
machine will take them.

---

From: Jim Reid <[email-masked]>
Date: Tue, 2 Apr 2019 15:06:09 +0100

On 2 Apr 2019, at 14:19, Sandra Murphy <[email-masked]> wrote:
> 
> All in all, the three hour layover at BRU was not overly generous.

The same is true at most big airports. Sometimes the transfers are quick and painless, sometimes they’re not. Sorry you lost this time.

FWIW check out EU.261. If you’re on a through ticket, you should be entitled to compensation if you miss a connecting flight in/out of the EU because of airport queues. ie If the airline allowed 2 hours to change planes at LHR or wherever and you missed the connection because it took you 3, it’s the airline’s problem.

> Note to self:  allow lots of transfer time when leaving the EU.

There’s a bunch of useless politicicans in London who badly need that advice.

---

From: Jared Mauch <[email-masked]>
Date: Tue, 2 Apr 2019 10:06:45 -0400

> On Apr 2, 2019, at 9:56 AM, Michael StJohns <[email-masked]> wrote:
> 
> I can't recommend Global Entry enough.    Start now to get it approved for the next trip out of the country.  Once that's done its good for 5 years and can be renewed over the net with just a fee payment.  (Sorry - US and Canadian - via Nexus citizens and permanent residents only).

If you’re a US or CA resident and don’t have NEXUS consider getting it and trying to get an interview while at the upcoming MTL IETF.  It’s well worth it if you can qualify and $50/5y instead of $100/5y, but you must interview at the US-Canada border (airports qualify).  If you interview at a land border they won’t take your eye scan, but if you carry your NEXUS card you get TSA PreCheck like experience leaving Canada.  When arriving in Canada I haven’t had to show my passport, just my nexus card at the machine and didn’t need to talk to anyone.  

Make sure to take your NEXUS card with you if you have it, it is valid ID at the airports as well (so is your GE card).

- Jared

---

From: Darren Kara <[email-masked]>
Date: Tue, 2 Apr 2019 14:10:17 +0000

Michael,

I submitted yesterday!  

Customs for me at IAD on Friday night was 70+ minutes, after an uneventful flight PRG>>FRA>>IAD.  Having to wait was no Bueno.

-darren

On 4/2/19, 9:56 AM, "104attendees on behalf of Michael StJohns" <[email-masked] on behalf of [email-masked]> wrote:

    
    If you don't have GE, then you might want to try 
    https://urldefense.proofpoint.com/v2/url?u=https-3A__mobilepassport.us_&d=DwIGaQ&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=r-4mQAJQLpabHW5aorHPaP19rFWvVEQzDaquJ5ifDCc&m=gqqd3Wv_B9VlmTzfcdOhKuCb9-DzBqTg6PiDkIyXbQU&s=1RVsJ-Dov8JpJIKVFfUTx9fQyEW61jGb1G7hdXvzY84&e= - I have no experience with this, but it does 
    appear to be a separate and shorter and faster line at Dulles.
    
    Mike

    -- 
    104attendees mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_104attendees&d=DwIGaQ&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=r-4mQAJQLpabHW5aorHPaP19rFWvVEQzDaquJ5ifDCc&m=gqqd3Wv_B9VlmTzfcdOhKuCb9-DzBqTg6PiDkIyXbQU&s=faAAqPfKESINIsB3szrJLanaT1zOCeD8UeWAfkBW0r0&e=

---

From: Sandra Murphy <[email-masked]>
Date: Tue, 2 Apr 2019 10:20:42 -0400

> On Apr 2, 2019, at 10:06 AM, Jim Reid <[email-masked]> wrote:
> 

:-)

--Sandy

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Tue, 02 Apr 2019 11:31:30 -0300

I usually enter the US via MIA. Immigration there has become a 
nightmare, so much that I have been avoiding transiting the US as much 
as I can. For us who live in South/Central America PTY, GRU, SCL and BOG 
offer more welcoming and overall nicer transiting experiences.

GRU even has connections to Africa via Addis and JNB and to Asia via 
Dubai/Qatar. Kudos to the 787-9 and the A350XWB for the opening of many 
of these relatively light load but long routes.

It’s been a while since transiting via the US stopped being a must for 
most destinations.

Global Entry would be nice but none of my two passports are eligible.

Clarification: I have nothing against *traveling to* the US, I do it at 
least three times a year and usually have a great time there. But 
*airport international transit in the US* is an unnecessary nightmarish 
experience thanks mostly to broken immigration processing procedures.

On 2 Apr 2019, at 10:56, Michael StJohns wrote:

> When I got to IAD, the normal lines for immigration were as long as 
> I've ever seen them - basically ALL the cattle chutes were filled with 
> people back to the entry.  My first thought was "Global Entry was the 
> best $100 I've ever spent".  I was through immigration in about 4 
> minutes and only because the *!%$## machines had problems reading my 
> finger prints.  A 20 minute wait for my bag and I was out of there.

---

From: Puneet Sood <[email-masked]>
Date: Tue, 2 Apr 2019 11:45:44 -0400

A positive example of connecting flights for me. I flew from New York
to Prague (via Zurich) on Swissair. In both directions I had a ~60
minute layover which was cut short on the way in due to a 10 minute
delayed flight from New York to Zurich. I had to go from terminal E to
terminal A which included a short train ride, a passport control with
a queue and a few minutes of walking. In both directions I made the
connection with 10+ minutes to spare and a pleasant/quick experience
at passport control. My checked-in bag (separate story) also made it
to the final destination on time.

Another useful thing was the entertainment console on the first leg
giving updated info on connecting flights in the next 60 minutes after
landing.

-Puneet

---

From: "Johnson, Alastair (Nokia - US/Mountain View)" <[email-masked]>
Date: Tue, 2 Apr 2019 17:27:06 +0000

I second the recommendation to be aware of EC261/2004 and the protections it offers. But be aware most airlines will go through great gymnastics to find any reason to absolve themselves of responsibility (sometimes legitimate, many times not).

I missed my connection on my way to Prague due to Schengen immigration in Frankfurt being incredibly slow. Lufthansa won't take any responsibility under EC261/2004, as that's the fault of the Bundespolizei, which is outside their control.

On 4/2/19, 7:06 AM, "104attendees on behalf of Jim Reid" <[email-masked] on behalf of [email-masked]> wrote:

---

From: "Black, David" <[email-masked]>
Date: Tue, 2 Apr 2019 18:14:30 +0000

Similar departure experience on Turkish Airlines via Istanbul: PRG-IST-BOS, leaving at ~930a yesterday.  That's not the most direct route, but the airfare was cheap and the service was excellent, plus I think I got enough sleep on the long IST-BOS flight.  No problems in Prague airport, even though the PRG-IST flight was a nearly full Airbus 321 - perhaps 15-20 minutes to check in 2 hours before the flight (5 positions open), almost no lines for passport control or gate security.  Short connection (just over an hour) in Istanbul (old airport) made easier by adjacent arrival and departure gates for my flights, even though gate departure security screening for the flight to Boston took ~30 minutes.  Global Entry was a big win in Boston, although for some reason my checked bag went to the oversize luggage claim area, even though it is definitely not oversized.

NB: Turkish Airlines is moving all operations to the new airport in Istanbul over this coming weekend.  They might need a little time to get things settled and routine in the new airport.

Thanks, --David
p.s. Learn something new every day - Istanbul in ASCII is not the correct Turkish spelling, as the correct Turkish spelling starts with U+0130 (LATIN CAPITAL LETTER I WITH DOT ABOVE). This is because dotted 'I' and dotless 'I' are different letters in Turkish.

> -----Original Message-----
> From: 104attendees <[email-masked]> On Behalf Of Puneet
> Sood
> Sent: Tuesday, April 2, 2019 11:46 AM
> To: Sandra Murphy
> Cc: [email-masked]
> Subject: Re: [104attendees] PRG Departures Experience
> 
> 
> [EXTERNAL EMAIL]
> 
> > My flight out was on Brussels Airline at 6:40am to Brussels.  I took a taxi at
> 4:00am, got to the airport at 4:20.  Many of the counter positions were
> marked Closed at that hour, though there was a very long line at the
> bag check-in line until 5:50am.  (The Lufthansa line was just clearing at that
> time.) Proceeded through the checkpoint and got to my gate at 6:10am (it
> was a long walk) just as they announced boarding would begin.  I met other
> IETF-ers who took a 4:30am taxi and beat me to the gate - because they had
> advanced status with the airline.  Note to self: arriving at PRG 2 hrs before
> flight is advisable, but more than 2 hrs early may find the counters are not yet
> open.
> >
> > We took off about 30 min late because there was a passenger who was
> “not fit” to travel.  Security and an ambulance were called.  A flight attendant
> > In Brussels, my departing flight was in the B area.  I took the escalator up to
> the B area, to be met by a long line that doubled back on itself at the top of
> the escalator, with no view of what awaited at at the end.  The end of the
> line turned out to be an immigration area with a set of switchback roped
> lines.  In total, that line took took an hour.
> >
> walk to the gate.  Turned out the boarding pass Brussels Airlines gave me was
> not correct and I got a new one at the transfer desk. The transfer desk also
> told me the gate had changed to gate B10, and put me through a perfunctory
> security check which earned me the all important passport stamp.  Then the
> gate changed to B9.  Then the gate changed back to B6. (An airport game to
> keep the passengers occupied and out of the bars?)
> >
> > > On Mar 29, 2019, at 4:21 AM, Chris Morrow
> <morrowc=[email-masked]> wrote:
> > >
> > > Please do not underestimate queues that can be very long and happen
> from time to time. 30 minutes is very good time and can’t be used as “normal
> in a rush hour”.
> > >
> > > M
> > >
> areas. The line for security took 10 minutes or less to clear (terminal for travel
> within the EU), and there were several lines open.
> > >>
> > >>
> > >>

---

From: Ralf Weber <[email-masked]>
Date: Tue, 2 Apr 2019 20:27:32 +0200

Moin!

On 2 Apr 2019, at 15:56, Michael StJohns wrote:
> I can't recommend Global Entry enough.    Start now to get it 
> approved for the next trip out of the country.  Once that's done its 
> good for 5 years and can be renewed over the net with just a fee 
> payment.  (Sorry - US and Canadian - via Nexus citizens and permanent 
> residents only).
That is not correct. Some countries (including Germany) offer there 
citizens a promotion to Global Entry on a bilateral basis, so might be 
worth to check if your country allows this. I got it since nearly five 
years now and will certainly re new it. It is absolutely worth it. I’m 
often faster through immigration into the US then coming back home.

So long
-Ralf
—--
Ralf Weber
Principal Architect, Carrier Division

Akamai Technologies GmbH
Parkring 20-22, 85748 Garching
phone: +49.89.9400.6174
mobile: +49.151.22659325

Geschäftsführer: David Matthew McDonald Aitken, Justyna Kalina 
Jankowska
Sitz der Gesellschaft: Garching
Amtsgericht München HRB 129886

---

From: Michael StJohns <[email-masked]>
Date: Tue, 2 Apr 2019 14:36:32 -0400

On 4/2/2019 2:27 PM, Ralf Weber wrote:
>> for the next trip out of the country.  Once that's done its good for 
>> 5 years and can be renewed over the net with just a fee payment.  
>> (Sorry - US and Canadian - via Nexus citizens and permanent residents 
>> only).

Woo hoo!!  Your email caused me to go looking and found this. 
https://www.cbp.gov/travel/trusted-traveler-programs/global-entry/international-arrangements 

Thanks - Mike

> Geschäftsführer: David Matthew McDonald Aitken, Justyna Kalina Jankowska

---

From: Jared Mauch <[email-masked]>
Date: Tue, 2 Apr 2019 14:38:53 -0400

> On Apr 2, 2019, at 2:36 PM, Michael StJohns <[email-masked]> wrote:
> 
> Woo hoo!!  Your email caused me to go looking and found this. https://www.cbp.gov/travel/trusted-traveler-programs/global-entry/international-arrangements 

Also know your program number if you enter it as your trusted traveller number you should get TSA PreCheck as long as all your information matches with supported airlines.

- Jared

---

From: Melinda Shore <[email-masked]>
Date: Tue, 2 Apr 2019 11:00:10 -0800

I have Global Entry but have to say that I am not really
much of a fan of paying the government for privileged
treatment.  Anyway, I usually re-enter the US through Seattle,
which does support Mobile Passport, and frankly it's the clear
winner on getting out of immigration quickly - basically
you pick up your luggage and go straight to customs, as
the immigration receipt is right on your phone.

Melinda

-- 
Melinda Shore
[email-masked]

Software longa, hardware brevis

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 3 Apr 2019 14:54:21 +0200

Well, you can't blame DHS for not experimenting with all its
travel programs. I guess GE is really only worth $15 given how
TSApre alone is $85 and GE (which includes TSApre) is $100
(for five years).

Have not tried mobile passport yet. On my todo list.

---

From: Mike Bishop <[email-masked]>
Date: Wed, 3 Apr 2019 13:09:36 +0000

By that argument, it's a negative value since NEXUS is $50/5 years and includes both GE and PreCheck.

-----Original Message-----
From: 104attendees <[email-masked]> On Behalf Of Toerless Eckert
Sent: Wednesday, April 3, 2019 2:54 PM
To: Melinda Shore <[email-masked]>
Cc: [email-masked]
Subject: Re: [104attendees] PRG Departures Experience

Well, you can't blame DHS for not experimenting with all its travel programs. I guess GE is really only worth $15 given how TSApre alone is $85 and GE (which includes TSApre) is $100 (for five years).

On Tue, Apr 02, 2019 at 11:00:10AM -0800, Melinda Shore wrote:
> I have Global Entry but have to say that I am not really much of a fan 
> of paying the government for privileged treatment.  Anyway, I usually 
> re-enter the US through Seattle, which does support Mobile Passport, 
> and frankly it's the clear winner on getting out of immigration 
> quickly - basically you pick up your luggage and go straight to 
> customs, as the immigration receipt is right on your phone.
> 
> Melinda
> 
> --
> Melinda Shore

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 3 Apr 2019 15:17:34 +0200

Hah. Never really looked up NEXUS because i thought its
only for travel to canada, but right now it looks to me
as if it was a superset of what GE has except that you
probably need to apply at a canadian airport.

Hmm.. Maybe something to consider to do @ietf105 ;-)

-- 
---
[email-masked]

---

From: Mike Bishop <[email-masked]>
Date: Wed, 3 Apr 2019 13:49:30 +0000

Definitely -- we concluded it was the superior value when paying ourselves.  The odd wrinkle that so many credit cards reimburse Global Entry fees and don't reimburse NEXUS twists this a bit.

Enrollment centers are in states/provinces along the border, but not necessarily in airports.  However, where GE uses fingerprints (and US enrollment centers capture fingerprints), NEXUS in Canadian airports uses iris, so if you enroll in the US you won't have those on file.

When I got to Montreal last year, the kiosk directed me to the special services immigration line for lack of biometrics, so I still had to have a human check my passport, but I got to skip the regular line.  (Then I went to the airport's NEXUS office and they put my irises on file for next time.)  Minors also don't have biometrics on file, so we have the same experience when travelling with my son even in the US.

-----Original Message-----
From: Toerless Eckert <[email-masked]> 
Sent: Wednesday, April 3, 2019 3:18 PM
To: Mike Bishop <[email-masked]>
Cc: Melinda Shore <[email-masked]>; [email-masked]
Subject: Re: [104attendees] PRG Departures Experience

Hah. Never really looked up NEXUS because i thought its only for travel to canada, but right now it looks to me as if it was a superset of what GE has except that you probably need to apply at a canadian airport.

On Wed, Apr 03, 2019 at 01:09:36PM +0000, Mike Bishop wrote:
> > I have Global Entry but have to say that I am not really much of a 
> > fan of paying the government for privileged treatment.  Anyway, I 
> > usually re-enter the US through Seattle, which does support Mobile 
> > Passport, and frankly it's the clear winner on getting out of 
> > immigration quickly - basically you pick up your luggage and go 
> > straight to customs, as the immigration receipt is right on your phone.
> > 
> > Melinda
> > 
> > --
> > Melinda Shore

--
---
[email-masked]

---

From: "Maisonneuve, Julien (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 3 Apr 2019 13:58:47 +0000

One of the issues with this sort of "immigration priority lanes" is similar to what's happening with priority lanes for security controls : it helps the happy few, but tends to make things worse for the others.
I've been travelling to the US for 30+ years and the worst queues I had at immigration (1 hour+) were all in the past 3 years. Things are clearly getting worse for the rest of us even as technological progress is supposed to help. </rambling>.
J.

-----Original Message-----
From: Toerless Eckert <[email-masked]>
Sent: Wednesday, April 3, 2019 3:18 PM
To: Mike Bishop <[email-masked]>
Cc: Melinda Shore <[email-masked]>; [email-masked]
Subject: Re: [104attendees] PRG Departures Experience

--
---
[email-masked]

---

From: Sarah Banks <[email-masked]>
Date: Mon, 8 Apr 2019 15:51:28 -0700

Plan ahead if you want to do this for Montreal, - the waits for interviews can be just as long in Canadian airports as it is for US ones. Also, the interview takes (or took me, at least) twice as long because I interviewed with US and Canada at the same time. I don’t know if it’s still done that way or not. In any event, check the schedules; I did my interview in Halifax within 30 days, but would have had to wait 9+ months at Toronto or Vancouver.

/S

> On Apr 3, 2019, at 6:17 AM, Toerless Eckert <[email-masked]> wrote:
>

---

From: Jared Mauch <[email-masked]>
Date: Mon, 8 Apr 2019 20:03:26 -0400

It takes much longer to get cleared than for GE but you likely have time if you do it now. 

Sent from my iCar

> On Apr 8, 2019, at 6:51 PM, Sarah Banks <[email-masked]> wrote:
>

---

From: Mike Bishop <[email-masked]>
Date: Thu, 11 Apr 2019 04:23:44 +0000

It is a double interview, and the wait in Seattle was 7 months because they reportedly only had one Canadian agent there at a time.  When I called, they recommended driving up to Blaine, which has many more Canadian agents plus Saturday hours.  We got an appointment for the following weekend.  I would assume the sparsity of the other country's agents is similar in Canada and roughly tracks distance from the border.

-----Original Message-----
From: Sarah Banks <[email-masked]> 
Sent: Monday, April 8, 2019 6:51 PM
To: Toerless Eckert <[email-masked]>
Cc: Mike Bishop <[email-masked]>; Melinda Shore <[email-masked]>; [email-masked]
Subject: Re: [104attendees] PRG Departures Experience

/S

> Hah. Never really looked up NEXUS because i thought its only for 
> travel to canada, but right now it looks to me as if it was a superset 
> of what GE has except that you probably need to apply at a canadian 
> airport.
>