Subject: [108attendees] Registration Receipt

From: Yoav Nir <[email-masked]>
Date: Fri, 31 Jul 2020 16:43:10 +0300

Hi

When we registered to the meeting, we got back a document entitled “Purchase Confirmation”.  In the past, this was followed after a few weeks by a receipt. 

Is the receipt coming soon?

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 31 Jul 2020 09:47:59 -0400

> Is the receipt coming soon?
I got my receipt the day I registered.

Already submitted under my contract for reimbursement.