Subject: [108attendees] Meetecho participant pics

From: Robert Moskowitz <[email-masked]>
Date: Mon, 27 Jul 2020 09:32:22 -0400

Where is Meetecho getting its few participant pics?

Seems only a few people are showing.

---

From: Jay Daley <[email-masked]>
Date: Tue, 28 Jul 2020 01:35:12 +1200

gravatar

> On 28/07/2020, at 1:32 AM, Robert Moskowitz <[email-masked]> wrote:
> 
> -- 
> 108attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/108attendees
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jonathan Lennox <[email-masked]>
Date: Mon, 27 Jul 2020 09:37:21 -0400

Is it possible to see what e-mail address Meetecho is using to look up my gravatar?  I have a gravatar associated with this e-mail address, but it’s not showing up in Meetecho.

> On Jul 27, 2020, at 9:35 AM, Jay Daley <[email-masked]> wrote:
> 
> gravatar
> 
>> On 28/07/2020, at 1:32 AM, Robert Moskowitz <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> 
> --

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 27 Jul 2020 09:37:28 -0400

They come from a public avatar site.  It is mentioned in the meetecho 
instructions.  I did not choose to registerr there.
Yours,
Joel

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 27 Jul 2020 09:38:12 -0400

https://www.ietf.org/media/documents/Documentation-Meetecho-IETF.pdf

Name and roleYour name and role in the session (e.g. Participant or Chair) will appear in the upperleft hand corner of the Meetecho window. Note that your profile picture is takenfrom the ​Gravatar​ service based on the email used during the login process (ifavailable) and not images from the IETF Datatracker.

http://www.gravatar.com/

> [External Email. Be cautious of content]
> 
> 
> gravatar
> 
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/108attendees__;!!NEt6yMaO-gk!XUi04DVmDtDz6c1FcaCS2LNvAXWwGqxumAIBrTRqgE3Pwj0g0mPSXUS5BZUHEvs$

---

From: Job Snijders <[email-masked]>
Date: Mon, 27 Jul 2020 13:39:06 +0000

> > Seems only a few people are showing.

To add a bit more detail, specifically: https://en.gravatar.com/

The idea of this gravatar website is that you upload an 'avatar' image
there, and it is used across *multiple* web properties (Meetecho,
Github, etc).

This is not an IETF-specific service.

Kind regards,

Job

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 27 Jul 2020 10:12:37 -0400

What is Gravatar?

On 7/27/20 9:35 AM, Jay Daley wrote:
> gravatar
>
>> On 28/07/2020, at 1:32 AM, Robert Moskowitz <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: Jay Daley <[email-masked]>
Date: Tue, 28 Jul 2020 02:15:17 +1200

> On 28/07/2020, at 2:12 AM, Robert Moskowitz <[email-masked]> wrote:
> 
> What is Gravatar?

Sorry, I assumed it was well known.  As explained by Job:

> To add a bit more detail, specifically: https://en.gravatar.com/ <https://en.gravatar.com/>
> 

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Christian Amsüss <[email-masked]>
Date: Mon, 27 Jul 2020 16:17:13 +0200

> What is Gravatar?

It's a company that has become the de facto provider for this kind of
avatar pictures, created by registering there and uploading them.

A more general approach exists[1], but seems not be in use here.

KR
Christian

[1]: https://wiki.libravatar.org/api/

-- 
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom

---

From: Darshak Thakore <[email-masked]>
Date: Mon, 27 Jul 2020 14:18:38 +0000

A gravatar is a globally recognized avatar (as in your profile pic) based on your email address. https://en.gravatar.com

If you have a wordpress.com account (or create one), you can associate different pics with different emails that you can register. Then, depending on which email you use for a particular site/service, the corresponding image associated with the email will become your profile pic (assuming that service is using gravatar).

Darshak

From: 108attendees <[email-masked]> on behalf of Robert Moskowitz <[email-masked]>
Date: Monday, July 27, 2020 at 8:13 AM
To: Jay Daley <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [108attendees] Meetecho participant pics

What is Gravatar?

On 28/07/2020, at 1:32 AM, Robert Moskowitz <[email-masked]<mailto:[email-masked]>> wrote:

--
108attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/108attendees<https://protection.greathorn.com/services/v2/lookupUrl/0f8590b0-d901-4171-991b-19b2220cfe45/327/e6e2a14efd6ed11eb87b19a40089b374e7b6efeb?domain=www.ietf.org&path=/mailman/listinfo/108attendees>

--
Jay Daley
IETF Executive Director
[email-masked]<mailto:[email-masked]>

--
Robert Moskowitz
Owner
HTT Consulting
C:      248-219-2059
F:      248-968-2824
E:      [email-masked]<mailto:[email-masked]>

There's no limit to what can be accomplished if it doesn't matter who gets the credit

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Mon, 27 Jul 2020 11:20:40 -0300

It’s a public avatar service, https://en.gravatar.com/

First create a profile using a Wordpress.com account and after that you 
can add multiple email addresses and associate them with an avatar 
picture.

I had actually forgotten about this until mentioned here.

/Carlos

Carlos M. Martinez
CTO - Gerente de Tecnología
LACNIC

On 27 Jul 2020, at 11:12, Robert Moskowitz wrote:

>>> On 28/07/2020, at 1:32 AM, Robert Moskowitz 
>>> <[email-masked] <mailto:[email-masked]>> wrote:
>>>

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 27 Jul 2020 10:24:03 -0400

An Avatar for IETF, fine.  But globally?  No thank you.

And for Wordpress?  Not there.

I am an old foggy... No social media account (other than Linkedin).

On 7/27/20 10:20 AM, Carlos M. Martinez wrote:
> First create a profile using a Wordpress.com account and after that 
> you can add multiple email addresses and associate them with an avatar 
> picture.
>

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 27 Jul 2020 16:38:58 +0200

Would it be difficult to fall-back to an IETF profile "avatar", if there 
is no gravatar association?

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 27 Jul 2020 10:45:53 -0400

And I asked for a pic to be added to my profile and never got a response 
on that.  That was ~1yr ago.

At least they linked all my old email addresses going back to Chrysler.

On 7/27/20 10:38 AM, Henk Birkholz wrote:
> Would it be difficult to fall-back to an IETF profile "avatar", if 
> there is no gravatar association?
>
>>> you can add multiple email addresses and associate them with an 
>>> avatar picture.
>>>
>>>>>     --     108attendees mailing list
>>>>     --     Jay Daley
>>>     --     Standard Robert Moskowitz
>>>     Owner
>>>     HTT Consulting
>>>     C:248-219-2059
>>>     F:248-968-2824
>>>     --     108attendees mailing list
>>>     [email-masked]

---

From: Christian Huitema <[email-masked]>
Date: Mon, 27 Jul 2020 12:59:36 -0700

What is Gravatar business model? Is this one of those surveillance companies that track you wherever you use the avatar and then sells the data? What is their privacy policy? Has the IETF embraced Internet surveillance?

-- Christian Huitema 

> On Jul 27, 2020, at 7:54 AM, Robert Moskowitz <[email-masked]> wrote:
> 
>  And I asked for a pic to be added to my profile and never got a response on that.  That was ~1yr ago.
> 
>> Would it be difficult to fall-back to an IETF profile "avatar", if there is no gravatar association? 
>> 
>>>> First create a profile using a Wordpress.com account and after that you can add multiple email addresses and associate them with an avatar picture. 
>>>> 
> E:      [email-masked]
>

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Mon, 27 Jul 2020 17:06:19 -0300

As an initiative for World Domination (tm) Gravatar could probably 
feature in a Pinky and the Brain episode.

It’s just a convenience feature you are free to (not) use.

The internet has more info: 
https://www.quora.com/How-does-Gravatar-make-money

/Carlos

Carlos M. Martinez

On 27 Jul 2020, at 16:59, Christian Huitema wrote:

> What is Gravatar business model? Is this one of those surveillance 
> companies that track you wherever you use the avatar and then sells 
> the data? What is their privacy policy? Has the IETF embraced Internet 
> surveillance?
>
> -- Christian Huitema
>
>>>>> First create a profile using a Wordpress.com account and after 
>>>>> that you can add multiple email addresses and associate them with 
>>>>> an avatar picture.
>>>>>
>>>>>     There's no limit to what can be accomplished if it doesn't 
>>>>> matter
>>>>>     who gets the credit
>>>>>

---

From: Bob Hinden <[email-masked]>
Date: Mon, 27 Jul 2020 13:12:42 -0700

Christian,

> On Jul 27, 2020, at 12:59 PM, Christian Huitema <[email-masked]> wrote:
> 

Good questions.

I went to the site and it wanted me to log in with my Wordpress account.   I didn’t want to do that because the stuff I do with Wordpress has nothing to do with my IETF work and didn’t want them associated.   When I said no, it offered to use my Google or Apple credentials.   No thanks.

Bob

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 27 Jul 2020 15:15:09 -0500

+1 to Christian and Bob

On Mon, Jul 27, 2020 at 3:13 PM Bob Hinden <[email-masked]> wrote:

> companies that track you wherever you use the avatar and then sells the
> data? What is their privacy policy? Has the IETF embraced Internet
> surveillance?
>
> Good questions.
>
> I went to the site and it wanted me to log in with my Wordpress account.
>  I didn’t want to do that because the stuff I do with Wordpress has nothing
> to do with my IETF work and didn’t want them associated.   When I said no,
> it offered to use my Google or Apple credentials.   No thanks.
>
> Bob
>
>
>
> >
> > -- Christian Huitema
> >

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 27 Jul 2020 16:22:03 -0400

Exactly my concern.

I don't HAVE a Wordpress account; why do I need one?  I am assuming I 
have a Google account as I have a 5 year old Samsung Galaxy 4; I seem to 
recall I had no choice in the matter.

I really am not interested in having an Avatar connected to them. But I 
do have a pic at Linkedin and if there was a way, I would add one to my 
IETF profile.

Oh, I have not done anything with an Apple device since before the Lisa.

---

From: Dr Clement Genty <[email-masked]>
Date: Mon, 27 Jul 2020 22:23:26 +0200

Le 27.07.2020 22:15, Behcet Sarikaya a écrit :

>> I went to the site and it wanted me to log in with my Wordpress account.   I didn't want to do that because the stuff I do with Wordpress has nothing to do with my IETF work and didn't want them associated.   When I said no, it offered to use my Google or Apple credentials.   No thanks.
>> 
>> Bob
>> 
>>> 
>>> -- Christian Huitema
>>> 
>>>>>>> It's a public avatar service, https://en.gravatar.com/
>>>>>>> 
>>>>>>>>> https://www.ietf.org/mailman/listinfo/108attendees [1]
>>>>>>>>> 
>>>>>>>> 
>>>>>>>> --     Jay Daley
>>>>>>>> IETF Executive Director

+1

-- 
Dr Clement Genty
 Meursault (Côte d'Or) - France 

 www.genty.info [2] 

Links:
------
[1] https://www.ietf..org/mailman/listinfo/108attendees
[2] http://www.genty.info

---

From: "John Levine" <[email-masked]>
Date: 27 Jul 2020 16:36:10 -0400

In article <[email-masked]> you write:
>Exactly my concern.
>
>I don't HAVE a Wordpress account; why do I need one?

A few seconds of clicking reveals that Gravatar is run by Automattic
which is better known as Wordpress.com. That's why you need a
Wordpress account, it *is* Wordpress.

They have a detailed privacy policy here:

https://automattic.com/privacy/

It's pretty reasonable, no sale of info to third parties, the most
evil thing they do is use your profile info to target ads on their
site, which doesn't apply to Gravatar since it's not providing ads,
just mapping hashes of addresses to pictures. I've had my Gravatar set
up for ages including for some addresses that only Wordpress knows and
I've never gotten any unexpected spam to those addresses.

I suspect it wouldn't be terribly hard to use the Datatracker pix instead
but I'd put it pretty low on the list of things to do.

R's,
John

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 27 Jul 2020 17:36:40 -0400

> Wordpress account, it *is* Wordpress.
I am not aware of any business reason for me to get a Wordpress account.

Ergo I will not have a gravatar.

Simple.

Others will undoubtedly have a different calculus.

---

From: Bret Jordan <[email-masked]>
Date: Mon, 27 Jul 2020 15:45:24 -0600

Whether people opt to have a Gravatar or not is about as relevant to the
IETF as if you drink Non-fat, 1%, 2%, 3%, Half-Half, for Full Cream milk or
if you are against people drinking milk all together. Or better yet, if the
toilet paper roll should roll forward or backward.  Gravatar has been
around for a very long time, since early 2007. If you are just finding out
about it now, then, well, sorry.  But it has been around for a long time. A
lot of services and sites on the internet use it, it is a great idea. If
you do not want one, then do not get one. Simple. But it is nice to have a
single place to update your "avatar" and have it work in a lot of places.

We should really have a list called [email-masked] so all of these
discussions and debates can be moved there.

Bret

Sent from my TI-99/4A
PGP Fingerprint: 63B4 FC53 680A 6B7D 1447  F2C0 74F8 ACAE 7415 0050

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 27 Jul 2020 23:57:34 +0200

Isn't "attendees" already an alias for "bike-shed"?

Sorry :-) To be totally honest here, I am not unhappy to see at least 
one lengthy, curious thread on the 108attendees list! Makes this IETF 
experience feel a little bit closer to... the real thing - as long as we 
are civil and we think of Dijkstra if the discussion becomes too circular.

Cheers,

Henk

On 27.07.20 23:45, Bret Jordan wrote:
> IETF as if you drink Non-fat, 1%, 2%, 3%, Half-Half, for Full Cream milk 
> or if you are against people drinking milk all together. Or better yet, 
> if the toilet paper roll should roll forward or backward.  Gravatar has 
> been around for a very long time, since early 2007. If you are just 
> finding out about it now, then, well, sorry.  But it has been around for 
> a long time. A lot of services and sites on the internet use it, it is a 
> great idea. If you do not want one, then do not get one. Simple. But it 
> is nice to have a single place to update your "avatar" and have it work 
> in a lot of places.
> 
> We should really have a list called [email-masked] 
> <mailto:[email-masked]> so all of these discussions and debates can 
> be moved there.
> 
> Bret
> 
> Sent from my TI-99/4A
> On Mon, Jul 27, 2020 at 3:37 PM Robert Moskowitz 
>      > In article
>     <[email-masked]
>     <mailto:[email-masked]>>
>     you write:
>      >> Exactly my concern.
>      >>

---

From: John C Klensin <[email-masked]>
Date: Mon, 27 Jul 2020 18:02:18 -0400

--On Monday, July 27, 2020 16:36 -0400 John Levine
<[email-masked]> wrote:

> In article
> <[email-masked]>
> you write:
>> Exactly my concern.
>> 
> A few seconds of clicking reveals that Gravatar is run by
> Automattic which is better known as Wordpress.com. That's why
> you need a Wordpress account, it *is* Wordpress.
> 
> It's pretty reasonable, no sale of info to third parties, the
> most evil thing they do is use your profile info to target ads
> on their site, which doesn't apply to Gravatar since it's not
> providing ads, just mapping hashes of addresses to pictures.
> I've had my Gravatar set up for ages including for some
> addresses that only Wordpress knows and I've never gotten any
> unexpected spam to those addresses.
> 
> I suspect it wouldn't be terribly hard to use the Datatracker
> pix instead but I'd put it pretty low on the list of things to
> do.

While I share Christian's and Bob's concerns --and your
explanation makes me feel only slightly better-- your last
comment seems key to me.  A very large number of changes were
made to Meetecho since we last used it for IETF 106 in November.
I inferred from comments made during one of the "test sessions"
that most were made at the behest of IETF leadership and staff.
>From my perspective, at least some of those changes (including
the apparent need to queue separately to send audio and video
that was noticed in a couple of sessions today) were steps
backward in UI quality.  Given all of that, getting these
pictures/avatars up was a justified expenditure of programming
time and energy because?  Or, to put it more closely in terms of
your comment, if this wasn't worth doing right (by pulling
pictures from the Datatracker), why was it worth doing at all?

    john

---

From: Bret Jordan <[email-masked]>
Date: Mon, 27 Jul 2020 16:05:11 -0600

I miss hanging out with you Henk.

Bret

Sent from my TI-99/4A

On Mon, Jul 27, 2020 at 3:57 PM Henk Birkholz <
[email-masked]> wrote:

> Automattic

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 27 Jul 2020 18:05:30 -0400

No comments about meeting rooms too cold.  Or wifi in rooms awful.

I mean there has to be SOMETHING to talk about around the cookie table.

Since '07?  Just shows that my attention is on other matters...

On 7/27/20 5:57 PM, Henk Birkholz wrote:
> experience feel a little bit closer to... the real thing - as long as 
> we are civil and we think of Dijkstra if the discussion becomes too 
> circular.
>
> Cheers,
>
> Henk
>
>> Whether people opt to have a Gravatar or not is about as relevant to 
>> the IETF as if you drink Non-fat, 1%, 2%, 3%, Half-Half, for Full 
>> Cream milk or if you are against people drinking milk all together. 
>> Or better yet, if the toilet paper roll should roll forward or 
>> backward.  Gravatar has been around for a very long time, since early 
>> 2007. If you are just finding out about it now, then, well, sorry.  
>> But it has been around for a long time. A lot of services and sites 
>> on the internet use it, it is a great idea. If you do not want one, 
>> then do not get one. Simple. But it is nice to have a single place to 
>> update your "avatar" and have it work in a lot of places.
>>
>> <mailto:[email-masked]> so all of these discussions and debates 
>> can be moved there.
>>
>> Bret
>>
>> Sent from my TI-99/4A
>>      > In article
>>      >> Exactly my concern.
>>      >>
>>      >> I don't HAVE a Wordpress account; why do I need one?
>>      > A few seconds of clicking reveals that Gravatar is run by 
>> Automattic
>>      > which is better known as Wordpress.com. That's why you need a
>>      > Wordpress account, it *is* Wordpress.
>>      >
>>      > They have a detailed privacy policy here:
>>      >
>>      > https://automattic.com/privacy/
>>      >
>>      > It's pretty reasonable, no sale of info to third parties, the 
>> most
>>      > evil thing they do is use your profile info to target ads on 
>> their
>>      > site, which doesn't apply to Gravatar since it's not providing 
>> ads,
>>      > just mapping hashes of addresses to pictures. I've had my
>>     Gravatar set
>>      > up for ages including for some addresses that only Wordpress
>>     knows and
>>      > I've never gotten any unexpected spam to those addresses.
>>      >
>>      > I suspect it wouldn't be terribly hard to use the Datatracker pix
>>     instead
>>      > but I'd put it pretty low on the list of things to do.
>>      >
>>      > R's,
>>      > John
>>      >
>>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 28 Jul 2020 00:07:07 +0200

> Ergo I will not have a gravatar.

I think you are saying people recognizing your face is not a business reason.

It sure was for me when I got my Wordpress account just for that one reason in 2008.

(I think we are really debating how wise it was for the meetecho people to use Gravatar for this function.  I personally think it was brilliant, because it gave them a useful feature for very low effort [gravatar libraries abound].  But, unless you know about automattic [sic], it does trigger our paranoia reflexes; it was interesting to see the lynching mob in this thread.  And the process for getting a gravatar set up really is near-ridiculous, but then $0 is really cheap…)

Grüße, Carsten

---

From: Christian Huitema <[email-masked]>
Date: Mon, 27 Jul 2020 16:49:44 -0700

> (I think we are really debating how wise it was for the meetecho people to use Gravatar for this function.  I personally think it was brilliant, because it gave them a useful feature for very low e…

Nice words you are choosing, Carsten. After the master/slave discussion,
we now see the "lynching mobs"...

-- Christian Huitema

---

From: "John Levine" <[email-masked]>
Date: 27 Jul 2020 20:28:07 -0400

>pictures from the Datatracker), why was it worth doing at all?

I can't speak for Meetecho but my guess is that a) adding the code to
fetch gravatar pictures is extremely simple and probably took about
five minutes to add, and 2) we are not Meetecho's only user and even
within the IETF I wouldn't count on more people having Datatracker pix
than gravatars.

I don't recall whether the gravatar pictures were there in Singapore.
Quite possibly they were and nobody noticed.

R's,
John

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 28 Jul 2020 02:29:02 +0200

On 2020-07-28, at 01:49, Christian Huitema <[email-masked]> wrote:
> 
> Nice words you are choosing, Carsten. After the master/slave discussion, we now see the "lynching mobs"...

As I said, we northern Germans have a slightly more robust relationship to language [1].   I apologize for translating one-to-one.

(The dictionaries I use are actually completely mute about racial lynching.
I’m saying this not trying to justify my transgression there — I should have known better —, but to support the point that we foreign speakers need more support in handling the issue.  Off-topic for this thread, though.)

Grüße, Carsten

[1]: Oxford German Dictionary:
lynchen | ˈlʏnçṇ | 
transitive verb 
lynch (humorous) Lynch kill

---

From: Jay Daley <[email-masked]>
Date: Tue, 28 Jul 2020 13:45:12 +1200

> On 28/07/2020, at 10:02 AM, John C Klensin <[email-masked]> wrote:
> 
> 
> 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> In article

I’m happy to dispel the rumour that the IETF leadership (a nebulously imprecise term if ever there was one) micro-managed Meetecho down to the level of designing the UI - we didn’t.

Jay

> https://www.ietf.org/mailman/listinfo/108attendees <https://www.ietf.org/mailman/listinfo/108attendees>
-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Melinda Shore <[email-masked]>
Date: Mon, 27 Jul 2020 17:50:18 -0800

On 7/27/20 4:28 PM, John Levine wrote:
> five minutes to add,

That's my guess as well.  I think there are some legitimate
privacy concerns and I wish Meetecho had chosen a different
source for the photos, but I'll take a pass on signing up and not
worry about people who do.  We don't *need* photos of ourselves
for Meetecho.

This is, though, a mildly interesting example in the context of
service centralization.

Melinda

-- 
Melinda Shore
[email-masked]

Software longa, hardware brevis

---

From: Christian Huitema <[email-masked]>
Date: Mon, 27 Jul 2020 19:13:33 -0700

> (I think we are really debating how wise it was for the meetecho people to use Gravatar for this function.  I personally think it was brilliant, because it gave them a useful feature for very low e…

I understand the push to add features and use free services. I come from
a different angle, that free services have a hidden cost in terms of
privacy. That's why I asked the question about the Gravatar business
model. From a high altitude observer, adding a Gravatar icon to a blog
or a web site has lots in common with the buttons or icons placed by
Google, Facebook, Twitter and others. These buttons allow third parties
to track who is using what site at what time, i.e., Internet Surveillance.

I read John's message stating that this is a benign service from
Wordpress, a byproduct of their need to identify posters of comments on
their blogging service. That may well be, but this is still a third
party tracker. There is nothing that technically prevent Wordpress to
change the terms and monetize the data in the future. Let's hope that
Meetecho may be able to react quickly in that case.

On the other hand, avatars do have a privacy advantage over actual
pictures. They cannot be used to train a face recognition database.

-- Christian Huitema

---

From: "John Levine" <[email-masked]>
Date: 27 Jul 2020 22:22:43 -0400

>Meetecho may be able to react quickly in that case.

Given that Gravatar has been around for 13 years and is doing exactly
the same thing now that it was 13 years ago, and that Automattic has
an obvious motivation to maintain it and not alienate their paying
Wordpress users, I'm not too worried about it. They never "need"
avatars to identify posters, the pix are tied to the e-mail addresses
that are part of the user's identity.

>pictures. They cannot be used to train a face recognition database.

Gravatar allows you to upload whatever you want.  They're lousy for
training because they're quite small.

R's,
John

---

From: Christian Amsüss <[email-masked]>
Date: Tue, 28 Jul 2020 09:22:40 +0200

On Mon, Jul 27, 2020 at 08:28:07PM -0400, John Levine wrote:
>  even within the IETF I wouldn't count on more people having
>  Datatracker pix than gravatars.

This doesn't need to be an either-or situation.

I can't speak from practicial experience, but from what I can tell from
using libravatar, this should be straightforward to implement by

* Running a libravatar server for IETF (several implementations
  available)
* Exporting the datatracker profile pictures into the libravatar server
* Enabling fallback to gravatar in the server
* On the Meetecho side, all that'd be needed is a way for an
  organization to set its own gravatar-compatible avatar endpoint
  ([1] is what it took to do the same at redmine)

Sounds like a "good first issue" to get started at a code sprint.

Possibly, some of the remaining infrastructure might even want to use
this for profile pictures -- which would give people without profile
pictures their Gravatars where present, and allow them to configure
profile images in their own domains as well.

Kind regards
Christian

[1]: https://www.redmine.org/attachments/22943/avatar_service_url_configuration-v4.patch

---

From: Frode Kileng <[email-masked]>
Date: Tue, 28 Jul 2020 09:48:33 +0200

On 28/07/2020 04:13, Christian Huitema wrote:
>
> ... adding a Gravatar icon to a blog

Yes, and is exactly why EFF's Privacy Badger categorize this as a 
"tracker" and blocks it by default.

frodek

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 28 Jul 2020 06:55:42 -0400

> [1]: https://www.redmine.org/attachments/22943/avatar_service_url_configuration-v4.patch

I would like to see some stats about how many attendees have pics pulled 
from gravatar.  For the sessions that I have been in, it looks like only 
a few images are shown in the list of participants.

It might also be interesting to see the stats broken out by area.

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 28 Jul 2020 07:41:56 -0600

If meetecho was open source, I would submit a PR to use WebFinger (RFC 7033) to get my avatar. That was one of the key uses cases for WebFinger. 

> On Jul 27, 2020, at 7:50 PM, Melinda Shore <[email-masked]> wrote:
>

---

From: "John Levine" <[email-masked]>
Date: 28 Jul 2020 10:23:42 -0400

>the key uses cases for WebFinger. 

You can certainly suggest it to them, they've been very responsive.

What webfinger servers would they use?  The only keys they have are people's
e-mail addresses.

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 28 Jul 2020 08:33:55 -0600

> On Jul 28, 2020, at 8:23 AM, John Levine <[email-masked]> wrote:
> 
> In article <[email-masked] <mailto:[email-masked]>> you write:
>> 

If my email is [email-masked], the point of webfinger is the lookup can be delegated by fluffy.im so I can decide what servers I trust instead of meet echo needing to decide for me.

---

From: "John R. Levine" <[email-masked]>
Date: 28 Jul 2020 11:42:50 -0400

On Tue, 28 Jul 2020, Cullen Jennings wrote:
>>> If meetecho was open source, I would submit a PR to use WebFinger (RFC 7033) to get my avatar. That was one of
>>> the key uses cases for WebFinger. ...

> If my email is [email-masked], the point of webfinger is the lookup can be delegated by fluffy.im so I can decide what servers I trust instead of meet echo needing to decide for me.

So if I use Gmail or Yahoo or Comcast or Verizon or Outlook.com, I'm out 
of luck?

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 28 Jul 2020 12:37:55 -0400

On 7/28/20 11:42 AM, John R. Levine wrote:
>>>> If meetecho was open source, I would submit a PR to use WebFinger 
>>>> (RFC 7033) to get my avatar. That was one of
>> If my email is [email-masked], the point of webfinger is the lookup can 
>> be delegated by fluffy.im so I can decide what servers I trust 
>> instead of meet echo needing to decide for me.
>
> So if I use Gmail or Yahoo or Comcast or Verizon or Outlook.com, I'm 
> out of luck?

Yep.  It would be a nice addition for some.  Datatracker profiles would 
pick up more, but I have not found how to add my pic to my profile...

---

From: tale <[email-masked]>
Date: Tue, 28 Jul 2020 15:16:36 -0400

> pick up more, but I have not found how to add my pic to my profile...

"There are some exceptions, such as photos, which currently require an
email to the Secretariat if you wish to update or remove the
information."
The linked address in the HTML is [email-masked] not
ietf-secretariat fwiw.

-- 
tale