Subject: [110attendees] Meetecho is a resource hog

From: Robert Moskowitz <[email-masked]>
Date: Tue, 9 Mar 2021 08:02:57 -0500

Yesterday I ran Meetecho on my Lenovo e120 duo-core running Win7 and 
current Firefox.

The CPUs were pegged at 100% all the time and the audio was clipped.  
Good thing I did not need to speak, as I don't know how it would have gone.

Today I am using my Lenovo e140 quad-core running Win10 and current Firefox.

CPUs are at 75% and audio is good.

Video was good on the e120 and is good on the e140.

BTW, I use the e120 regularly for my video meetings with Webex, 
Microsoft Meet, Zoom and GotoMeeting amongst others and it works fine.  
All of these have specific Win apps (and why I run them on Win, not 
Fedora).  Well sometimes if I used one program and then needed to switch 
to another, I have learned to reboot, as sometimes they don't let go of 
audio and video...

Google Meet keeps bombing on supposed network problems.  It works fine 
on my e140 running Fedora 32.

Anyway, Meetecho is a hog for me.  Just not kosher....

---

From: Jim Reid <[email-masked]>
Date: Tue, 9 Mar 2021 13:06:51 +0000

> On 9 Mar 2021, at 13:02, Robert Moskowitz <[email-masked]> wrote:
> 
> Anyway, Meetecho is a hog for me.

It’s not for me - unlike some of the other webtrc tools you mentioned.

Apples and oranges...

---

From: Alexandre PETRESCU <[email-masked]>
Date: Tue, 9 Mar 2021 14:10:33 +0100

--
Alexandre Petrescu
[email-masked], tél 0169089223

Le 09/03/2021 à 14:02, Robert Moskowitz a écrit :
> Microsoft Meet, Zoom and GotoMeeting amongst others and it works 
> fine.  All of these have specific Win apps (and why I run them on Win, 
> not Fedora).  Well sometimes if I used one program and then needed to 
> switch to another, I have learned to reboot, as sometimes they don't 
> let go of audio and video...
>

My Dell 2yr old half tablet half laptop turns on the ventilators while 
on meetecho...

I think that is the cost of fast software development process with rich 
functionality.

Alex

---

From: Ingemar Johansson S <[email-masked]>
Date: Tue, 9 Mar 2021 13:18:09 +0000

Hi

It runs at ~17% CPU for me (HP Laptop) with Meetecho in the chrome browser. 
Notice that the video decoding is in the GPU though. Is it possible that your setup does not use hardware acceleration ?

/Ingemar

> -----Original Message-----
> From: 110attendees <[email-masked]> On Behalf Of
> Alexandre PETRESCU
> Sent: den 9 mars 2021 14:11
> To: [email-masked]
> Subject: Re: [110attendees] Meetecho is a resource hog
> 
> 
> --
> Alexandre Petrescu
> fine.
> > Fedora).  Well sometimes if I used one program and then needed to
> My Dell 2yr old half tablet half laptop turns on the ventilators while on
> meetecho...
>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 9 Mar 2021 14:19:00 +0100

+1 on macintosh with chrome.

On Tue, Mar 09, 2021 at 08:02:57AM -0500, Robert Moskowitz wrote:
> Yesterday I ran Meetecho on my Lenovo e120 duo-core running Win7 and current
> Firefox.
> 
> The CPUs were pegged at 100% all the time and the audio was clipped.  Good
> thing I did not need to speak, as I don't know how it would have gone.
> 
> BTW, I use the e120 regularly for my video meetings with Webex, Microsoft
> Meet, Zoom and GotoMeeting amongst others and it works fine.  All of these
> have specific Win apps (and why I run them on Win, not Fedora).  Well
> sometimes if I used one program and then needed to switch to another, I have
> learned to reboot, as sometimes they don't let go of audio and video...
> 
> Google Meet keeps bombing on supposed network problems.  It works fine on my
> e140 running Fedora 32.
> 
> 110attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/110attendees

-- 
---
[email-masked]

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 9 Mar 2021 13:23:09 +0000

> I think that is the cost of fast software development process with rich

I'm on an underpowered Lenovo. I find that if I stop the people video feeds (chairs and presenters) that it's fine. If those videos are on, performance is awful. Each video feed has a pause button, so it's real easy to stop them.
Barbara

---

From: Alexandre PETRESCU <[email-masked]>
Date: Tue, 9 Mar 2021 14:28:12 +0100

Le 09/03/2021 à 14:18, Ingemar Johansson S a écrit :
> Hi
> 
> It runs at ~17% CPU for me (HP Laptop) with Meetecho in the chrome
> browser. Notice that the video decoding is in the GPU though. Is it
> possible that your setup does not use hardware acceleration ?

Yes, it is possible it doesnt use hardware acceleration.

This option is not an option that pops up easily in the eye of a user of
Windows.  It must be hidden somewhere.  I dont even know whether this
notion of acceleration still exists, or what was yesterday an artificial
acceleration is now builtin by default.

Alex

> 
> /Ingemar
> 
>> -----Original Message----- From: 110attendees
>> <[email-masked]> On Behalf Of Alexandre PETRESCU 
>> Sent: den 9 mars 2021 14:11 To: [email-masked] Subject: Re:
>> [110attendees] Meetecho is a resource hog
>> 
>> 
>> -- Alexandre Petrescu [email-masked], tél 0169089223
>> 
>>> Yesterday I ran Meetecho on my Lenovo e120 duo-core running Win7
>>> and current Firefox.
>>> 
>>> The CPUs were pegged at 100% all the time and the audio was
>>> clipped. Good thing I did not need to speak, as I don't know how
>>> it would have gone.
>>> 
>>> All of these have specific Win apps (and why I run them on Win,
>>> not Fedora).  Well sometimes if I used one program and then
>>> needed to switch to another, I have learned to reboot, as
>>> sometimes they don't let go of audio and video...
>>> 
>>> Google Meet keeps bombing on supposed network problems.  It
>>> works
>> fine
>> My Dell 2yr old half tablet half laptop turns on the ventilators
>> while on meetecho...
>> 
>> I think that is the cost of fast software development process with
>> rich functionality.
>> 
>> Alex
>> 
>

---

From: Bob Hinden <[email-masked]>
Date: Tue, 9 Mar 2021 06:10:02 -0800

Bob,

Seems to be fine on my 2018 MacBook Pro.

BTW, in the sessions I have been in so far, Meetecho has been working very well.

Bob

> On Mar 9, 2021, at 5:02 AM, Robert Moskowitz <[email-masked]> wrote:
> 
> Yesterday I ran Meetecho on my Lenovo e120 duo-core running Win7 and current Firefox.
> 
> The CPUs were pegged at 100% all the time and the audio was clipped.  Good thing I did not need to speak, as I don't know how it would have gone.
> 
> BTW, I use the e120 regularly for my video meetings with Webex, Microsoft Meet, Zoom and GotoMeeting amongst others and it works fine.  All of these have specific Win apps (and why I run them on Win, not Fedora).  Well sometimes if I used one program and then needed to switch to another, I have learned to reboot, as sometimes they don't let go of audio and video...
> 
> Google Meet keeps bombing on supposed network problems.  It works fine on my e140 running Fedora 32.
>

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 9 Mar 2021 09:15:31 -0500

> Seems to be fine on my 2018 MacBook Pro.

That is much more current than my e120 which I bought on eBay some 6 
years ago.  The e140s I bought on eBay 2 years ago.  Add 2 years easy to 
how old the design is to get them available cheap on eBay. So I venture 
a guess that your 2018 Pro is much more current hardware....

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 9 Mar 2021 09:36:38 -0500

14% CPU on a 2017 iMac with Firefox.

Cheers,
Andy

On Tue, Mar 9, 2021 at 9:10 AM Bob Hinden <[email-masked]> wrote:

> Microsoft Meet, Zoom and GotoMeeting amongst others and it works fine.  All
> of these have specific Win apps (and why I run them on Win, not Fedora).
> Well sometimes if I used one program and then needed to switch to another,
> I have learned to reboot, as sometimes they don't let go of audio and
> video...
> >

---

From: Chris Morrow <[email-masked]>
Date: Tue, 9 Mar 2021 09:52:35 -0500

I would wager that almost all of the OP's problem is:
  intel 2nd generation i3, from 'forever ago'.

yea that box is going to have problems doing anything current.
the WFH shift taught a bunch of folks this lesson: "If your wfh
machine is not a current machine you're gonna have a bad day"

---

From: Chris Morrow <[email-masked]>
Date: Tue, 9 Mar 2021 09:56:06 -0500

>   intel 2nd generation i3, from 'forever ago'.

to be very clear the manuals for that device are copyright 2012...
Also note:
  "Support for Windows 7 ended on January 14, 2020. If you are still
   using Windows 7, your PC may become more vulnerable to security risks."

as a user in the security field, I'd suggest that the OP knows full
well that they should
have upgraded away from win7 ~years ago and to a modem platform (and
modem system)

good luck with your paperweight.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 9 Mar 2021 16:03:29 +0100

If we really want to be able to run meetecho on e-waste, we have to control those video feeds.

I’m looking at 3*250 kbit/s speaker/chair postage-stamp videos plus a 100 kbit/s slide video feed.

The postage stamps would need to be re-encoded to the size shown and the slides should not be a video in the first place (see my tools-discuss posting).

Grüße, Carsten

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 9 Mar 2021 10:13:52 -0500

> The postage stamps would need to be re-encoded to the size shown and the slides should not be a video in the first place (see my tools-discuss posting).

Here is the point/problem.  The feed is everything, and let the endpoint 
deal with it.  Compared to some other stuff, that does much of the data 
sizing on the server.

Of course I expect us to experiment and we eat our own dogfood.  But 
then we learn, adjust, and experiment again at the next meeting.

If we want to open up our processes, we need to allow for those only 
able to get older hardware and having lower bandwidth.  Right now I have 
300Mb over fiber, so bandwidth is plentiful.  But I am cheap on old 
hardware.

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 9 Mar 2021 10:16:58 -0500

> good luck with your paperweight.

It is a 'throw away' system only for all the video conferences I have 
had to be on this past year.  It is on its own network behind its own 
firewall rules.

Real work is on Fedora32 (will upgrade when F34 released, I skip 
releases) and Win10 when I have to (e.g. TurboTax).

---

From: Jim Reid <[email-masked]>
Date: Tue, 9 Mar 2021 15:20:32 +0000

> On 9 Mar 2021, at 15:13, Robert Moskowitz <[email-masked]> wrote:
> 
> If we want to open up our processes, we need to allow for those only able to get older hardware and having lower bandwidth.

Some info on codec (negotiation) would help here - and which ones are supported in the common platforms. That way, if someone’s running on a steam computer with crufty s/ware they will have a better understanding of what to expect. Or just decide to switch off video because their computer can’t comfortably handle modern codecs.

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 9 Mar 2021 10:28:50 -0500

> Some info on codec (negotiation) would help here - and which ones are supported in the common platforms. That way, if someone’s running on a steam computer with crufty s/ware they will have a bette…

On 6man this morning with 5 videos, I hit 100%.  Almost paused some of 
them, then some videos went away and cpu went back down.

It is clearly showing the cost of multiple videos I do not see with 
other products.

---

From: Carlos Marcelo Martinez <[email-masked]>
Date: Tue, 9 Mar 2021 12:32:23 -0300

While I love modern hardware, and try (budget allowing; I’m writing this on an M1 Air) to use modern stuff, I live in a region where the Lenovo e120 referenced in this thread would be considered “still reasonably useful”.

During 2020 I have personally helped people run Zoom and access e-Learning platforms on similar and sometimes even older hardware. True, not using Win7 but Xubuntu 16 and 18 (‘cause I found  Xubuntu 20 to be too much for these boxes). I reinstalled and gave away several old systems I owned over the years that would definitely fall under the labels “e-waste” and “Core i3 from forever ago”.

Also a white, plastic Core2Duo MacBook I bought in 2008 reinstalled with Xubuntu 16 helped by oldest niece go through her first year of Law School during the pandemic. Yes, that’s a 13 year-old box, 4 years older than my own son, still doing useful work.

Here is a beautiful example of a very interesting and relevant topic for all the “diversity and inclusion” threads that sadly seems to be completely absent from the debate.

/Carlos

> On 9 Mar 2021, at 11:56, Chris Morrow <morrowc=[email-masked]> wrote:
>

---

From: Jonathan Morton <[email-masked]>
Date: Tue, 9 Mar 2021 17:39:19 +0200

> On 9 Mar, 2021, at 4:52 pm, Chris Morrow <morrowc=[email-masked]> wrote:
> 

I'm using a 2nd gen i7, also from "forever ago", without much trouble.  Actually I'm finding gather.town to be more of a resource hog than Meetecho, just moving little avatars around on a tile-based background..

Perhaps it helps that it's a Mac with a dGPU fitted.  Intelgrated graphics has always been "problematic" in a number of different ways.

 - Jonathan Morton

---

From: <[email-masked]>
Date: Tue, 9 Mar 2021 15:41:09 +0000

> On 6man this morning with 5 videos, I hit 100%.  Almost paused some of them, then some videos went away and cpu went back down.
>
> It is clearly showing the cost of multiple videos I do not see with other products.

It would be fair to point out that while 'other products' often have native applications (Zoom, Teams, etc.) Meetecho does not.

Ergo the point about video acceleration isn't simply one related to your hardware, or operating system, but also browser configuration. Things like vsync do not work for me in Firefox (and there are multiple rendering engines in Firefox, last I looked) even under Linux, with r600g 3d acceleration - Chrome is fine.

I'd be sure to try out Chromium/Chrome if you can, or be certain that Firefox is taking advantage of hardware-accelerated composition in your GPU.

Tom

---

From: Stephan Wenger <[email-masked]>
Date: Tue, 9 Mar 2021 15:57:31 +0000

Most HW accelerators can deal only with a single video stream at a time.
S.

    Tom

---

From: Ben Campbell <[email-masked]>
Date: Tue, 9 Mar 2021 11:12:33 -0600

(Jumping in at random, not responding to Stephan specifically)

On a counter-point: My first-gen airpods are getting _much_ better battery life (on order of 2x) with Meetecho than with other conferencing services. This seems extremely weird to me. I had similar results yesterday using latest production Safari on an M1 macbook pro, and today using latest Chrome on same machine.

Ben.

> On Mar 9, 2021, at 9:57 AM, Stephan Wenger <[email-masked]> wrote:
>

---

From: John Scudder <[email-masked]>
Date: Tue, 9 Mar 2021 17:36:36 +0000

On Mar 9, 2021, at 12:12 PM, Ben Campbell <[email-masked]<mailto:[email-masked]>> wrote:

Better silence suppression from Meetecho?

—John

---

From: Stephan Wenger <[email-masked]>
Date: Tue, 9 Mar 2021 18:05:58 +0000

I don’t believe Meetecho as *anything* to do with any of the behaviors observed.  AFAIK, Meetecho is a webrtc app, which uses the browser’s baked in codecs for all things media.
S.

From: 110attendees <[email-masked]> on behalf of John Scudder <jgs=[email-masked]>
Date: Tuesday, March 9, 2021 at 09:36
To: Ben Campbell <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [110attendees] Meetecho is a resource hog

—John

---

From: Ben Campbell <[email-masked]>
Date: Tue, 9 Mar 2021 12:17:04 -0600

> On Mar 9, 2021, at 11:36 AM, John Scudder <[email-masked]> wrote:
> 
> On Mar 9, 2021, at 12:12 PM, Ben Campbell <[email-masked] <mailto:[email-masked]>> wrote:
>> 

Could be. It was also pointed out to me offline that I usually use the native applications for the other conferencing tools, since they tend to have rather clunky WebRTC clients. So browser vs non-browser may be making a difference. Maybe I should experiment with the other tools’ WebRTC clients again.

---

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 9 Mar 2021 18:21:03 +0000

My Meetecho performance has been great. Few years old MBP using a Chromium-based browser. One session was using around 1.5% - 2% of CPU – so lightly used.

Jason

From: 110attendees <[email-masked]> on behalf of Ben Campbell <[email-masked]>
Date: Tuesday, March 9, 2021 at 1:18 PM
To: John Scudder <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [110attendees] Meetecho is a resource hog

On Mar 9, 2021, at 11:36 AM, John Scudder <[email-masked]<mailto:[email-masked]>> wrote:

---

From: Ben Campbell <[email-masked]>
Date: Tue, 9 Mar 2021 12:25:07 -0600

Yes—I should have added that the M1 MBP had not yet broken a sweat with Meetecho.

> On Mar 9, 2021, at 12:21 PM, Livingood, Jason <Jason_Livingood=[email-masked]> wrote:
> 
>> On Mar 9, 2021, at 11:36 AM, John Scudder <[email-masked] <mailto:[email-masked]>> wrote:
>>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/110attendees <https://www.ietf.org/mailman/listinfo/110attendees>

---

From: Chris Morrow <[email-masked]>
Date: Tue, 9 Mar 2021 13:32:18 -0500

I still maintain that older systems were not meant for today's
workloads and running known vulnerable software (and systems) is
detrimental to the whole of the system.
but...

On Tue, Mar 9, 2021 at 10:17 AM Robert Moskowitz
<[email-masked]> wrote:
> It is a 'throw away' system only for all the video conferences I have had to be on this past year.  It is on its own network behind its own firewall rules.
>

and it never sees ads on webex/zoom/etc in the browser which can/may
inject bad things into a well known vulnerable system?
you are taking your safety/security in your own hands here, you are
potentially exposing your customers and friends to eavesdropping and
all manner of bad things :(

> Real work is on Fedora32 (will upgrade when F34 released, I skip releases) and Win10 when I have to (e.g. TurboTax).

that's great, but the underlying security of your whole environment is
subject to the problems from the lowest common denominator.

> Robert Moskowitz
> C:      248-219-2059
> F:      248-968-2824
> E:      [email-masked]
>
> There's no limit to what can be accomplished if it doesn't matter who gets the credit

---

From: Randy Bush <[email-masked]>
Date: Tue, 09 Mar 2021 12:16:37 -0800

> control those video feeds.

640k of ram please

randy

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 9 Mar 2021 15:19:39 -0500

As it happens, I keep a couple of very low end Lenovo laptops around for
the sole purpose of checking out the resource requirements of apps.

Newest Lenovo Ideapad 14-inch Laptop, Intel Celeron N3050, 1.6 GHz, 2GB
DDR3L, 64GB SSD, 1366 X 768 HD, HDMI, 802.11AC, Webcam, Free 1 year office
365

That cost $239. But the free year of office paid for half of that.

As a general rule, I use those machines and the capabilities of whatever
the current Raspberry Pi machine runs at to provide a low end for what
resources I should support. If someone is trying to use something less
capable than that class of machine, they are talking about their problem,
not mine.

One really good thing about RaPi is that it pretty much ends all the silly
apocryphal discussions of retired VAXen still in service in parts of Africa.

Now that Starlink is flying, I am going to start becoming a lot less
sympathetic to complaints about bandwidth requirements as well...

---

From: Alexandre PETRESCU <[email-masked]>
Date: Tue, 9 Mar 2021 21:44:18 +0100

> control those video feeds.

Something could be controled in several ways.

During the meetecho sessions I noticed that the slide presentation runs
at about same bandwidth as the feed video of the person - around
250kbit/s or so.

But the slide image is so fixed whereas the human expression so rich in
movements.  They could use different bandwidths.  If slide bandwidth
were much lower, maybe my computer's ventilators would not turn on.

This is to say to keep the video feed of the person at the expense of
maybe something else.

Alex

> The postage stamps would need to be re-encoded to the size shown and 
> the slides should not be a video in the first place (see my 
> tools-discuss posting).
> 
> Grüße, Carsten
>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 9 Mar 2021 22:59:28 +0100

> Yes—I should have added that the M1 MBP had not yet broken a sweat with Meetecho.

Yeah, I need to migrate.

One of my favorite BBB machines (BBB = another WebRTC-only conferencing system) is a $300 Chromebook (15” screen, full HD).  Probably the closest to “it just works” that I’ve come to in the last 10 years (including adding a condenser microphone — real plug and play).   Need to try that box with meetecho…

Grüße, Carsten