Subject: [111attendees] So, what are jabber scribes actually doing, these days?

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 27 Jul 2021 15:45:09 -0500

I remember being a jabber scribe in face-to-face meetings, when people
asked questions in jabber that they needed someone to relay to the room
("mike: are you insane?"), but now that the jabber rooms for our meetings
are included as part of the Meetecho UI, ISTM that anyone in Meetecho can
see those questions, including the chairs, and it also seems that anyone in
Meetecho could just join the queue and ask their own questions.

So, I'm not curious about what jabber scribes MIGHT do, but I am curious
what jabber scribes are doing this week, and whether we actually need to
keep asking for them in meetings.

Best,

Spencer

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 27 Jul 2021 22:49:16 +0200

I was copying something i saw on other WG chair slides, namely
saying there is no jabber scribe because for this form of
meeting tools it is redundant.

Cheers
    Toerless

> -- 
> 111attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/111attendees

-- 
---
[email-masked]

---

From: Sean Turner <[email-masked]>
Date: Tue, 27 Jul 2021 17:22:32 -0400

Now that it’s integrated into meetecho - the only thing you need to do is have somebody watch the meetecho for @mic or as MT suggested changing the scribes name to “Mic” and relaying anything sent to the scribe.

Personally, now that there is slack (and clones). which the rest of the world uses, I basically don’t use Jabber anymore.

spt

> On Jul 27, 2021, at 16:49, Toerless Eckert <[email-masked]> wrote:
>

---

From: Yoav Nir <[email-masked]>
Date: Wed, 28 Jul 2021 00:25:09 +0300

I think the popular verb for what they’re doing is “channeling” so perhaps Jabber Medium.

> On 28 Jul 2021, at 0:22, Sean Turner <[email-masked]> wrote:
>

---

From: Jonathan Hoyland <[email-masked]>
Date: Wed, 28 Jul 2021 02:07:54 +0100

One key thing they are doing is speaking for people for whom meetings are
at 02:00am, and who don't wish to wake their families.

Regards,

Jonathan

On Tue, 27 Jul 2021 at 22:25, Yoav Nir <[email-masked]> wrote:

> > Now that it’s integrated into meetecho - the only thing you need to do
> is have somebody watch the meetecho for @mic or as MT suggested changing
> the scribes name to “Mic” and relaying anything sent to the scribe.
> >
> > Personally, now that there is slack (and clones). which the rest of the
> world uses, I basically don’t use Jabber anymore.
> >
> > spt
> >

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 28 Jul 2021 12:12:20 -0500

Hi, Sean,

On Tue, Jul 27, 2021 at 4:22 PM Sean Turner <[email-masked]> wrote:

> Now that it’s integrated into meetecho - the only thing you need to do is
> have somebody watch the meetecho for @mic or as MT suggested changing the
> scribes name to “Mic” and relaying anything sent to the scribe.
>

Thanks for the feedback. That's what I remember when I was chairing
face-to-face meetings, but wanted to push down a level or two.

What I thought, was that chairs needed to be looking at the mic queue.
which by default is toggled with the chat window, and might not have the
screen real estate to detach the chat in Meetecho, so you can move it to
another part of your screen (or another Display), or might not know you can
detach the chat window at all. If the chairs can see both (especially if
the meeting has more than one chair), ISTM that the chairs would know about
questions from jabber at the same time as everyone else.

Are there other reasons why we still need jabber scribes? (and Yoav's
suggestion to call them "jabber mediums", because they channel the words of
Those Who Are Not With Us, is brilliant).

> world uses, I basically don’t use Jabber anymore.

I'm only using it at IETF meetings (and checking that it still works). And
a fair number of attendees don't know that if they're in Meetecho, the chat
IS the jabber room - I've heard "I don't have a jabber client" as recently
as Monday.

I wonder if the people I've talked to who are reluctant to install a jabber
client, or forbidden by their IT people from installing a jabber client,
would have the same problem with downloading the Slack client. I have very
little experience with the Slack web interface, but wonder if it would be
usable enough for us to point people toward it.

What I really wish, was that we'd request Meetecho to process their jabber
feed, which doesn't have the unhelpful "has joined the room"/"has left the
room" messaging that makes watching Jabber clients a pain, and store the
results someplace. This is something I miss from having Meetecho archives,
since the jabber window doesn't appear in YouTube (I just checked MOPS for
yesterday, and it's not there - https://www.youtube.com/watch?v=wcxvSL2dXEo
).

But that's a side issue, and not relevant to whether we NEED a jabber
scribe.

Best,

Spencer

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 28 Jul 2021 12:18:50 -0500

Hi, Jonathan,

> at 02:00am, and who don't wish to wake their families.

Thanks! That's helpful information. I do think it's helpful to have a way
to communicate into the meeting by typing.

I did ask in my follow-up a few minutes ago whether chairs can actually
watch jabber in Meetecho, given enough screen space to detach the chat, or
whether they need someone who can pay closer attention.

Best,

Spencer

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Wed, 28 Jul 2021 15:37:00 -0300

Hi,

On 28 Jul 2021, at 14:12, Spencer Dawkins at IETF wrote:

> I wonder if the people I've talked to who are reluctant to install a 
> jabber client, or forbidden by their IT people from installing a 
> jabber client, would have the same problem with downloading the Slack 
> client. I have very little experience with the Slack web interface, 
> but wonder if it would be usable enough for us to point people toward 
> it. 

Slack's web interface is perfectly usable and fully featured. In fact 
the Slack "app" is nothing more than the web interface bottled inside 
this scourge of the Earth called Electron.

For those who don't know me, I work for LACNIC. As a data point, for 
those interested, I've run a 1500 member Slack workspace for LACNIC 34 
with little or no issues. I only had to kick out a couple of misbehaving 
participants.

I did the same thing for LACNIC 35 using Discord and the experience in 
general was much better. We are sticking to Discord for LACNIC 36. Not 
only it is actually free (we only paid 100 usd for a bot that adds some 
controls and some integrations) but the features are actually more 
geared to a conference or informal gathering and feels less "corporate" 
than Slack.

Nothing wrong with Slack, we actually de-commissioned our Jabber server 
2 years ago and moved the staff to Slack, but my recommendation for a 
conference is Discord.

regards

Carlos

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 28 Jul 2021 14:37:58 -0400

Spencer,

I chaired a session yesterday. I had a separate jabber session up on a
second screen (using a jabber client, not Meetecho) while I was running the
slides and the queue in Meetecho on my main screen. I also had a co-chair
monitoring the chat while I ran everything else. Kind of clucky that you
need a separate screen to see everything simultaneously, but the Meetecho
interface would probably need a major redesign to fit both the queue and
the chat simultaneously.

Getting back to your original question, I suspect that once we're back to
in-person meetings (or hybrid meetings where the chairs are local to the
session), the need for an in-person jabber reporter (if not scribe) will
return. With multiple chairs, a co-chair could take the role of jabber
reporter. Given that everyone remote now has complete access to the in-room
audio and video, I suspect that we no longer need a full-blown scribe
taking notes as the meeting progresses.

Cheers,
Andy

On Wed, Jul 28, 2021 at 1:19 PM Spencer Dawkins at IETF <
[email-masked]> wrote:

> Hi, Jonathan,
>
> On Tue, Jul 27, 2021 at 8:08 PM Jonathan Hoyland <
> [email-masked]> wrote:
>

---

From: Bob Hinden <[email-masked]>
Date: Wed, 28 Jul 2021 11:40:39 -0700

Andy,

> On Jul 28, 2021, at 11:37 AM, Andrew G. Malis <[email-masked]> wrote:
> 
> Spencer,
> 
> I chaired a session yesterday. I had a separate jabber session up on a second screen (using a jabber client, not Meetecho) while I was running the slides and the queue in Meetecho on my main screen. I also had a co-chair monitoring the chat while I ran everything else. Kind of clucky that you need a separate screen to see everything simultaneously, but the Meetecho interface would probably need a major redesign to fit both the queue and the chat simultaneously.

Meetecho has a feature where you can move the chat to a separate window.   It’s been there for a while.   This allows you to watch and the queue at the same time.

Bob

> 
> Getting back to your original question, I suspect that once we're back to in-person meetings (or hybrid meetings where the chairs are local to the session), the need for an in-person jabber reporter (if not scribe) will return. With multiple chairs, a co-chair could take the role of jabber reporter. Given that everyone remote now has complete access to the in-room audio and video, I suspect that we no longer need a full-blown scribe taking notes as the meeting progresses.
> 
> Cheers,
> Andy
> 
> 
> On Wed, Jul 28, 2021 at 1:19 PM Spencer Dawkins at IETF <[email-masked]> wrote:
> Hi, Jonathan,
> 
> On Tue, Jul 27, 2021 at 8:08 PM Jonathan Hoyland <[email-masked]> wrote:
> One key thing they are doing is speaking for people for whom meetings are at 02:00am, and who don't wish to wake their families.
> 
> Thanks! That's helpful information. I do think it's helpful to have a way to communicate into the meeting by typing.
> 
> I did ask in my follow-up a few minutes ago whether chairs can actually watch jabber in Meetecho, given enough screen space to detach the chat, or whether they need someone who can pay closer attention.
> 
> Best,
> 
> Spencer
> --

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 28 Jul 2021 14:41:25 -0400

Bob,

Thanks, I'll have to try that out!

Cheers,
Andy

On Wed, Jul 28, 2021 at 2:40 PM Bob Hinden <[email-masked]> wrote:

> Meetecho has a feature where you can move the chat to a separate window.
>  It’s been there for a while.   This allows you to watch and the queue at
> the same time.
>
> Bob
>
> >
> > Getting back to your original question, I suspect that once we're back
> to in-person meetings (or hybrid meetings where the chairs are local to the
> > One key thing they are doing is speaking for people for whom meetings
> are at 02:00am, and who don't wish to wake their families.
> >
> > Thanks! That's helpful information. I do think it's helpful to have a
> way to communicate into the meeting by typing.
> >

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 28 Jul 2021 20:54:10 +0200

So, i am trying to sort this stuff:

Q: Is it correct to assume that by now someone who is ONLY on jabber,
but not on meetecho has no reasonable expectation to participate in the
meeting becaus we have gotten rid of the "free" remote-only attendance,
and that is what we originally (AFAIK) had the jabber scribe function for.

Thee can be participants with audio send challenges that want to have thier
question relayed through the meetecho chat/jabber. That is a really
nice to have, but i think it is SHOULD, so i think it should be sufficient
to mention it this way during chair slides, but not mandate an official
function for this.

The ability for chairs to multitask all relevant functions present heavily
on the use of the "present uploaded slides" instead of screen-share. If
i am presenting slides as a chair from my notebook for a presenter, it
nees to be full-screen so it does not help to have multiple windows i
can not see. If i had a second screen on my notebook that might solve it.
But it would really be nice if one could join to the same session from
more than one computer (2nd notebook to monitor meetecho chat/queue).

The new upload slides feaure is cool though, and works pretty well!

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Watson Ladd <[email-masked]>
Date: Wed, 28 Jul 2021 20:30:06 -0700

> to mention it this way during chair slides, but not mandate an official

If you don't mandate a function it won't happen. It's an additional
volunteer, pretty easy thing to do. And at times today quite vital due
to some QoS issues on the transpacific links.

> more than one computer (2nd notebook to monitor meetecho chat/queue).

Charging chairs with this degree of multitasking isn't very   It's not
even the screen space, it's the attention: monitoring the audio and
jabber and queue and the clock is a lot of things to keep track of and
respond to, particularly in a smaller working group that might have
only one chair at the meeting.

> The new upload slides feaure is cool though, and works pretty well!

But alas not that well advertised or used in some of the meetings! It
did get some more usage later on.

---

From: John C Klensin <[email-masked]>
Date: Thu, 29 Jul 2021 09:09:34 -0400

--On Wednesday, July 28, 2021 12:12 -0500 Spencer Dawkins at
IETF <[email-masked]> wrote:

>...
> What I thought, was that chairs needed to be looking at the
> mic queue. which by default is toggled with the chat window,
> and might not have the screen real estate to detach the chat
> in Meetecho, so you can move it to another part of your screen
> (or another Display), or might not know you can detach the
> chat window at all. If the chairs can see both (especially if
> the meeting has more than one chair), ISTM that the chairs
> would know about questions from jabber at the same time as
> everyone else.

In addition to chair bandwidth, screen real estate, etc., there
is a more fundamental problem: with the current Meetecho setup,
it has impossible (or, at least non-obvious) to have both the
chat and participant frames open at the same time.    Without
the latter open, and a good deal of screen real estate and
attention to scrolling, it is not possible to see the queue or
figure out who is speaking if the speaker is not transmitting
video.  There are ways to solve the chat visibility part of the
problem.  The speaker recognition problem could be solved by
putting a small "now speaking"  line with a name somewhere near
the top center (or bottom center) of the screen.   And, modulo
those who need to be able to type rather than speak (as you
noted in your follow-up), some of the rest of the problem could
be solved by explaining to Meetecho who the official
Jabber-wstcher is and letting them put others in the queue.

<rant> Most of these suggestions have been made many times
before.  At least my experience had been that back in the days
when Meetecho was a trusted partner, these issues and the
tradeoffs got discussed among knowledgeable people and were
either implemented or, when rejected suggestions came up again,
there were clear explanations of why they were infeasible or bad
ideas.  I can't tell, but it certainly looks like we have
slipped Meetecho into "just a contractor" mode with decisions
being made by someone else, out of the view of those who would
prefer to technical work in the IETF than monitor every
administrative meeting and announcement and who obviously are
not trying to use these tools to get the work of the IETF done.
</rant>

    john

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 29 Jul 2021 15:20:39 +0200

On 2021-07-28, at 19:12, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> unhelpful "has joined the room"/"has left the room” messaging

Which is actually super helpful (was X already there when we discussed A, or do I have to repeat the intro?), except when it gets in the way of seeing the actual messages.

> store the results someplace

Sorry for lifting the secret…

https://jabber.ietf.org/jabber/logs/core/2021-07-28.html

etc.

> One key thing they are doing is speaking for people for whom meetings are at 02:00am, and who don't wish to wake their families.

Oh, so we need a TTS (text to speech) function in meetecho.
(Mac users can just use “say” :-), but then one needs to route the audio to Chrome’s input…)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 29 Jul 2021 15:23:42 +0200

On 2021-07-29, at 15:09, John C Klensin <[email-masked]> wrote:
> 
> impossible (or, at least non-obvious) to have both the
> chat and participant frames open at the same time.  

It’s much worse: You can’t have the important part of the participant frame (who is speaking) open at the same time you scroll for a potential attendee.
Fortunately, there is the jabber entry/exit trace…

The important part of the participant frame (who is speaking, are the chairs present, what is the queue — IN THAT ORDER) needs to be visible at all time.  But I’d rather have that, the participant list, and the chat visible all three, somewhere on the vast amounts of blank space that meetecho leaves on my window.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 29 Jul 2021 15:25:13 +0200

On 2021-07-29, at 15:09, John C Klensin <[email-masked]> wrote:
> 
> it certainly looks like we have
> slipped Meetecho into "just a contractor” mode

Well, they seem to react to at least half of my input, but they seem to be hesitant to destabilize the system during a meeting (which is 100 % understandable).

Grüße, Carsten

---

From: John C Klensin <[email-masked]>
Date: Thu, 29 Jul 2021 10:17:56 -0400

--On Thursday, July 29, 2021 15:23 +0200 Carsten Bormann
<[email-masked]> wrote:

> It's much worse: You can't have the important part of the
> participant frame (who is speaking) open at the same time you
> scroll for a potential attendee. Fortunately, there is the
> jabber entry/exit trace…

Sorry... saw and responded to Spencer's comments before reading
this.  And, yes.

> The important part of the participant frame (who is speaking,
> are the chairs present, what is the queue — IN THAT ORDER)
> needs to be visible at all time.  But I'd rather have that,
> the participant list, and the chat visible all three,
> somewhere on the vast amounts of blank space that meetecho
> leaves on my window.

Yes to that too.   I'm still (or again) using a separate Jabber
login to give me more control over that situation (and to take
advantage of having a lot of screen real estate, the ability to
at least somewhat control character sizes with that other
client, etc.  And, because people speak without turning on
video, burying the "who is speaking" information partway down
the participant frame rather than occupying a separate line in
the blank space to which you prefer seems, well, sub-optimal.  I
agree about the other parts of your "important" list too, but
"who is speaking" is the really critical bit.

best,
  john

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 29 Jul 2021 15:37:57 +0000

> chat and participant frames open at the same time.    

You can detach the chat window into a separate window.

On 29.07.21, 15:10, "111attendees on behalf of John C Klensin" <[email-masked] on behalf of [email-masked]> wrote:

        john

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 29 Jul 2021 15:43:38 +0000

Toerless, not sure what you mean: we have a fee waiver option for free participation, which is probably the most comfortable option if you want to actively participate.

However, if you are only on the live  audio stream  and jabber, or don't want to use your audio for any reason, e.g. because of technical problems or limitations, so far people didn't had problems to find someone to relay comments; it's just the case that we need this less often because remote participants can now much easier actively participate themselves.

On 28.07.21, 20:54, "111attendees on behalf of Toerless Eckert" <[email-masked] on behalf of [email-masked]> wrote:

    Cheers
        Toerless

    -- 
    ---
    [email-masked]

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 29 Jul 2021 11:43:25 -0400

> You can detach the chat window into a separate window.

And with 2 screen approach move it to your expanded real estate.

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: John C Klensin <[email-masked]>
Date: Thu, 29 Jul 2021 15:08:34 -0400

--On Thursday, July 29, 2021 11:43 -0400 Robert Moskowitz
<[email-masked]> wrote:

>>> In addition to chair bandwidth, screen real estate, etc.,
>>> there is a more fundamental problem: with the current
>>> Meetecho setup, it has impossible (or, at least non-obvious)
>>> to have both the chat and participant frames open at the
>>> same time.

>> You can detach the chat window into a separate window.

Tried doing that.  Discovered that it helps with some issues and
not others, but those problems are more unique to me than
general issues. 

> And with 2 screen approach move it to your expanded real

Of course.  But I am trying to stay focused on general issues
that I believe cause problems for many people (see Carsten's
recent note and my response) rather than on my special problems,
why I have those problems, the options I do and do not have (or
might be able to have) in my setup, and what might or might not
be effective in mitigating the specific issues I am having.

However, since you both brought up variations on that option and
because others might have similar issues, let me try to
generalize a bit (people who don't like my long messages should
stop reading here or skip to the last paragraph):

(1) If one were using a single, relatively small screen (size
measured in cm, inches, or relative to the visual perception
capabilities of the user), then detaching the chat window or
using a separate client is problematic because, if the other
information on the Meetecho screen is important, there is no
place to put the chat material without losing information.  The
same comment would apply if one had a large display or even two
or three of them but needed to extend the Meetecho window across
all of them in order to be able to see properly.

(2) Even if it is possible to get the chat frame out of the way,
having to scroll up and down in the participant frame in order
to tell who is speaking (if that person is not sending video),
who is in the queue and how long it is, etc., is problematic.
The worst part of that problem is the "who is speaking"
information, which could easily be displayed in the unused area
near the top of the Meetecho window or, perhaps better, to the
right where the speaker's image would appear if they were
sending video.  

(3) FWIW, the new "private conversation" facility in Meetecho
has become part of the problem: the relevant frame appears in
the lower right of the Meetecho window, uses small type, and, at
least AFAICT, cannot be moved or expanded.

(4) For more years than I can remember (but going back to when
we were still using overhead projectors), there have been
regular incidents of people using too-small type and trying to
squeeze too much information onto a page. I think that tends to
be worse in when the viewer is remote than in a room where "move
closer to the screen" is an issue.  Recent versions of Meetecho
aggravate those situations (rather than helping with them) by
showing slides projected (in at least some ways) in a fairly
small area of the screen, without the possibility of detaching
that area or selectively enlarging it.  One can expand the
picture to full screen, but that means all of the speaker
information (even for speakers sending video), queue
information, chair and participant information, even the ability
to get into the queue, etc., are blocked.  If the chat is off on
a separate screen that helps, but not much.  I'm not sure there
is a satisfactory technical solution for that which would not be
far more complicated (or dependent on over-restrictive
assumptions about user equipment) then it would be worth, but
the IESG and WG Chairs could be doing far more to push back on
the bad practices in the first place.  The LLC leadership could
be doing more too since some of the worst offenders I've seen so
far this week have been presented by LLC staff.

    ----

We (and I think that means the IETF and its leadership rather
than anything Meetecho staff are doing or resisting doing)
really need to think carefully about these issues and get them
under control rather than either sending out messages that imply
the the person raising particular issues is too ignorant to use
the tools properly (even when that is true, such ignorance is
often a sign of poor design or weak supporting materials).  And
we better do it before the first "hybrid" meetings because,
while the effective participation of the relatively small number
of active remote contributors prior to IETF 107 could perhaps be
safely ignored as an issue, hybrid nestlings are hard and things
better work for everyone.

best,
   john

---

From: Jay Daley <[email-masked]>
Date: Fri, 30 Jul 2021 07:21:31 +1200

John

> On 30/07/2021, at 1:09 AM, John C Klensin <[email-masked]> wrote:
> 
> 
> 
> problem.  

You can detach the chat window so that it is always visible.

Those participants who have their audio unmuted go to the top of the participant list, and are highlighted in green.  If they are speaking then there is a yellow pulse over their profile photo, which can apply to multiple people at once.  No scrolling needed.

> The speaker recognition problem could be solved by

No we have absolutely not pushed Meetecho into being "just a contractor", they are a valued partner and we work very well together.  If you have any doubts about that then ask them directly.  

It is disappointing that you have escalated a personal concern that you have with our services into such a strong criticism when that is entirely unsupported by any evidence.  

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 29 Jul 2021 21:32:28 +0200

> You can detach the chat window so that it is always visible.

No, I can’t.  The detached window is a separate browser window.  When I move that to some of the blank space on the main window (there is plenty of that), it vanishes behind that main window each time I interact with it.  So I essentially have to press the same number of buttons as before.

Grüße, Carsten

---

From: Jay Daley <[email-masked]>
Date: Fri, 30 Jul 2021 07:43:10 +1200

> On 30/07/2021, at 7:32 AM, Carsten Bormann <[email-masked]> wrote:
> 
> On 29. Jul 2021, at 21:21, Jay Daley <[email-masked] <mailto:[email-masked]>> wrote:
>> 

Umm … have you tried having the two windows side by side?

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 29 Jul 2021 19:45:50 +0000

The jabber scribe position can be useful as a signalling mechanism that contributions coming in via chat are still important.

I was scribe for a WG yesterday, and missed relaying a comment from Stephen; luckily the fact that the jabber chat was all in meetecho made it easy for someone else to pick it up.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 29 Jul 2021 21:52:54 +0200

> Umm … have you tried having the two windows side by side?

Yes, but then I can’t read the CodiMD window.

Increasing the number of windows that I have to juggle is not a winning strategy for focusing my attention on the content of the meeting.

Grüße, Carsten

---

From: "John Levine" <[email-masked]>
Date: 29 Jul 2021 16:29:45 -0400

According to Carsten Bormann  <[email-masked]>:
>-=-=-=-=-=-

Trying to arrange a set of panes that differ for each user (some look
at codimd, some at local copies of slides, some at documents for
reference, some at the people who are talking, ...) and fit them into
a fixed layout is a losing battle.

Perhaps you could invest in a bigger screen.  They're pretty cheap these days.

---

From: John C Klensin <[email-masked]>
Date: Thu, 29 Jul 2021 18:21:06 -0400

--On Friday, July 30, 2021 07:43 +1200 Jay Daley <[email-masked]>
wrote:

>> No, I can't.  The detached window is a separate browser
>> window.  When I move that to some of the blank space on the
>> main window (there is plenty of that), it vanishes behind
>> that main window each time I interact with it.  So I
>> essentially have to press the same number of buttons as
>> before.
> 

Jay,

I tried to explain this earlier and I don't know anything about
Chasten's situation and setup, but "put two windows side by
side" can imply, for at least some people "make the Meetecho one
small enough to make it unreadable".   The present setup in
RFCEFDP is a perfect example.  I also just noticed that, if the
MEETECHO window is shrunk significantly from the sides, that
central area with the slides / editing window disappears.

This is related, too, to your "don't need to scroll" program.
True if one is using Meetecho in more or less standard layout.
But, if one needs to fuss with the window size or position in
order to see and there are three or four people in queue, I get
myself, the queue, the chairs, and maybe one participant before
I need to start scrolling.    Or I can scroll down and set the
framing to see a few participants (including a speaker or two
who are having active discussion (like you and Peter as I'm
writing this) but then the queue is invisible unless I scroll
back up.

Perfectly reasonable for you to conclude that these are my
personal and private issues (although I don't think that would
be correct) and that there is no need for you, Meetecho, or the
community to be concerned, but then we might need to have a
conversation about diversity and reasonable accommodations.

best,
   john

---

From: Jay Daley <[email-masked]>
Date: Fri, 30 Jul 2021 10:37:40 +1200

> On 30/07/2021, at 10:21 AM, John C Klensin <[email-masked]> wrote:
> 
> 
> 

I didn’t say that, nor could anything I said be in any way misinterpreted as saying that.  

Yes accessibility concerns are very important to everyone responsible for our systems including the LLC, Meetecho and the Tools Team.  However, as there is a limit to how many interface elements can be simultaneously displayed on a single screen at a chosen text size, the only guaranteed solution is increased screen real estate.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 30 Jul 2021 00:56:01 +0200

The main issue IMHO is for chairs to ensur that they do not ned to share
non-PDF slides for participants because that requires them to go fullscreen,
and a single chair can not log in from a second notebook (access control
by meetecho).

---

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 30 Jul 2021 08:58:34 +1000

> It is disappointing that you have escalated a personal concern that you have with our services into such a strong criticism when that is entirely unsupported by any evidence.  

Jay, I agree with your sentiment here - this attitude to Meetecho is counterproductive.  They've done great work for the last couple of IETFs and the experience is improving each time.  I have particularly appreciated the embedded slide management, and I'm sure that will be even better next time too.

Regarding the specific interface issues that remain, I do think there's a question of "where do we propose improvements in a way that will be noticed"?  I've seen the suggestion made very many times that the "speaker" area (where the video shows) should have additional lines for each person sending anything, rather than that information being at the top of the participant list.  This is much more like the experience with other chat systems, for example Zoom shows either a photo or a blank item for somebody who isn't currently sending video, but they're otherwise treated "the same" as a person sending video in terms of real-estate and where to look for their presence by default.

Right now with meetecho, my eyes are normally at the video are when people are speaking, but if a non-video person is speaking I need to look across to the other side of the screen to see the audio indication.

And as was also suggested in this thread, you can't scroll the participant list to find someone to chat to, because they jump to the top when they are sending, then back to alphabetical position.  This is also a usability pain.  Separating "the list of participants" (which wouldn't move about) and "the list of people sending something" with the video and audio indications being together in one place would be a significant improvement.  And as an additional benefit, when you're looking at the chat window, you would still be able to see all the details of who is sending (including yourself - if you're sending then the indicator of your own audio should be the same as the indicator of everyone else's audio, rather than being in yet a third location up under your own name).

So those two names would appear in the right hand side, and also still have their name in the participant list, and the video feeds would each have a "here's what's being sent".  Chairs would always have a presence on the right, with whatever they were currently sending - and the "participants" tab would only have the list of participants, and not be a place you needed to go to see activity, so you could mostly keep the chat tab open.

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 30 Jul 2021 01:06:53 +0200

> a fixed layout is a losing battle.

Er, that was not what I was asking for.

I was asking that the information that meetecho manages is designed in such a way that it can stay it its window.  I have no idea why you think the other items need to be addressed by meetecho.  (I don’t even know why the superfluous function to replace the slides by a codimd iframe is in there, who wants to use that?)

Clearly, the participant names are unnecessarily large.  This causes a spacing where even the microphone line doesn’t fit on the screen and requires scrolling; I no longer can see who is speaking (as this is inexplicably below the microphone line).  So I need to run meetecho at 67 % scaling.  This means that the constant-width multi-purpose column is now wide enough that it would also be no problem to optionally fit the chat inside it.  These are all design options that need to be considered rationally.

> Perhaps you could invest in a bigger screen.  They're pretty cheap these days.

The screens are cheap.  The time I need to use to juggle all those windows is not.

Grüße, Carsten

---

From: Jay Daley <[email-masked]>
Date: Fri, 30 Jul 2021 11:14:41 +1200

Thanks Bron.  Personally I think that’s a great usability adjustment and will forward to the Meetecho team for them to consider.

Jay

> On 30/07/2021, at 10:58 AM, Bron Gondwana <[email-masked]> wrote:
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Fri, 30 Jul 2021 11:26:42 +1200

> On 30/07/2021, at 10:56 AM, Toerless Eckert <[email-masked]> wrote:
> 

> and a single chair can not log in from a second notebook (access control

Understood.  That’s been raised and discussed before but I can’t remember the outcome - I will raise again.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 30 Jul 2021 01:51:11 +0200

> Understood.  That’s been raised and discussed before but I can’t remember the outcome - I will raise again.

Thanks, I promise i won't share my password ;-))

Cheers
    toerless

-- 
---
[email-masked]

---

From: "John R. Levine" <[email-masked]>
Date: 29 Jul 2021 20:01:52 -0400

> Clearly, the participant names are unnecessarily large.  This causes a spacing where even the microphone line doesn’t fit on the screen and requires scrolling; I no longer can see who is speaking (…

I suppose we could ask Meetecho to offer a more compact style. I would 
prefer not to make the names much smaller since I find them hard enough to 
read as it is, but if they can do it by twiddling style sheets, or even 
better letting users twiddle their own style sheets, sure.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 30 Jul 2021 03:02:05 +0200

> and a single chair can not log in from a second notebook (access control

Actually, modern presentation programs can present in a window, and modern browsers can “screen”-share a window.
You won’t get the same number of pixels, but that is cut short by the video generation anyway.

But, apart from that observation, please nuke screen-sharing, indeed:-)

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 30 Jul 2021 03:19:42 +0200

Well, in a more productive IETF not driven just by slides, one might
want to actually show/discuss some hackathon stuff, in which case
a screen share is extremely helpfull. Likewis if one want to
do some online document editing workflow with sharing editor
and github window or the like. Aka: screen share is just not
necessary for what we mostly tend to do, so i am very happy
about the new meeetecho feature (thanks meetecho), but not the
fact that its so important to us ;-)

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Vittorio Bertola <[email-masked]>
Date: Fri, 30 Jul 2021 12:08:21 +0200 (CEST)

> Il 30/07/2021 01:14 Jay Daley <[email-masked]> ha scritto:
> 
>  

Bron's proposal may work, but as an alternative, I would also consider a dedicated "now speaking" part of the screen - either in the right side column above or below the small video feeds, or somewhere at the top of the screen - just listing the name(s) of those whose audio feed is currently being muxed and non-silent, with some delay not to make them disappear from the listing if they make a short pause (<2s or something like that) and not to make them appear just for a random one-off noise. There are almost never more than two of them, normally one, so you don't need a lot of screen estate. Those who have their audio turned on, but are not actually speaking, should not appear there - they should stay in the participants list.

This is because I am worried that in Bron's proposal you wouldn't easily tell those who are sending video but not speaking from those who are sending video and speaking, except by trying to look into their very small video and see if they move their mouth in sync with the English words being pronounced, which I tried to do a couple of times and wasn't easy. 

-- 
Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked] 
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 30 Jul 2021 08:47:29 -0400

Note that meetecho also has a flipchart feature for drawings.  I have 
plugged in my very old wacom tablet and used that for drawing on a 
flipchart.