Subject: [16ng] Follow up on 16ng WG session

From: "Ken Young" <[email-masked]>
Date: Thu, 9 Nov 2006 20:22:32 -0500

I had stated that I would follow up on 2 items from Tuesday's session.

First, I mentioned a DHCP relay option to identify port in a relay agent.  This is option 82 and this is covered in RFC3046.  This option was used by DSLAMs for the same purpose as proposed here.

Second, I wanted to follow up on why Proxy ARP is not required for the IPv4 CS.  The link layer elements are described below:

                                                 +-------+
                                                 |       |
       +-----+               +-----+             |       |
       | SS  |---------------| BS  |-------------|  AR   |
       +-----+               +-----+             |       |
                                                 |       |
                                                 +-------+

      +--------+      +-------------------+      +-------+
      |   IP   |      |         IP        |      |  IP   |
      +--------+      +--------+--+-------+      +-------+
      | 802.16 | ---> | 802.16 |  |  GRE  |      |  GRE  |
      +--------+      +--------+  +-------+      +-------+
                                  |  PHY  | ---> |  PHY  |
                                  +-------+      +-------+

Each SS is represented as a single unnumbered p2p link at the AR.  The SS has only it IP address and a default route pointing to the AR.  Since there is no subnet provisioned against the SS's IP interface, it will never ARP since there is no possibility of an SS sharing this link.  All communication must be directed through the AR.  As such, the AR has no need for Proxy ARP.

Hope this helps,
Ken
_______________________________________________
16ng mailing list
[email-masked]
http://eeca16.sogang.ac.kr/mailman/listinfo/16ng

---

From: "Daniel Park" <[email-masked]>
Date: Sat, 11 Nov 2006 04:10:22 +0900

Ken,

> First, I mentioned a DHCP relay option to identify port in a relay agent.  This is option 82 and this is covered in RFC3046.  This option was used by DSLAMs for the same purpose as proposed here.

[daniel] The 82 option is already applied for the WiMAX architecture.

> Second, I wanted to follow up on why Proxy ARP is not required for the IPv4 CS.  The link layer elements are described below:

[daniel] So far, that's correct. What I tried to raise in the room is
to ellaborate on the Proxy ARP clearer than now.

-- 

Daniel (Soohong Daniel Park)
Mobile Convergence Laboratory, SAMSUNG Electronics.
_______________________________________________
16ng mailing list
[email-masked]
http://eeca16.sogang.ac.kr/mailman/listinfo/16ng