Subject: Re: [16NG] Fw: I-DACTION:draft-madanapalli-16ng-ipv4-over-802-dot-16-ipcs-00.txt

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 12 Feb 2007 11:19:06 -0800 (PST)

Hi Syam,
  You mentioned P2P link here in this message but I could not see any text on this in the draft. Maybe a section should be added on the address and subnet mask assignment given the P2P nature of the link and the fact that such assignments are not commonly used.
  You recommended AR to ignore ARP Requests from MS, I am not sure if this is OK or a Reply would be needed according to ARP?

Regards,

Behcet

----- Original Message ----
From: Syam Madanapalli <[email-masked]>
To: "Narvaez, Paolo (Paolo)" <[email-masked]>
Cc: [email-masked]
Sent: Saturday, February 10, 2007 12:34:46 AM
Subject: Re: [16NG] Fw: I-DACTION:draft-madanapalli-16ng-ipv4-over-802-dot-16-ipcs-00.txt

Hi Paolo,

On 2/10/07, Narvaez, Paolo (Paolo) <[email-masked]> wrote:
>
> I have two general comments on this draft.
>
> 1. Section 7 assumes that ARP messages sent by the MS are received by
> the AR. The section states that ARP messages should be dropped by the
> AR. However, since ARP runs directly over Ethernet (there is no IP
> header) how can the 802.16 IPCS carry this type of packet over the air?

As mentioned the draft, ARP is not required for 802.16 because of the fact
that the MAC address is not required for identifying the destination.
There was a concern that an unmodified host may send ARP without knowing
that the underlying interface is 802.16, because of this I added the
above statement.

If we think there is no such possibility, then I will remove this text.

>
> 2. What is the subnet assignment? Can two MSs be on the same subnet? Or
> do we need to introduce some restrictions as in the IPv6-over-802.16
> draft.

The draft assumes the p2p link, so no two MSs can be on the same subnet.

Thanks,
Syam

>
> Regards,
> Paolo
>
>
>
>
> > -----Original Message-----
> > From: Daniel Park [mailto:[email-masked]]
> > Sent: Thursday, February 08, 2007 7:17 PM
> > To: [email-masked]
> > Subject: [16NG] Fw:
> > I-DACTION:draft-madanapalli-16ng-ipv4-over-802-dot-16-ipcs-00.txt
> >
> > IPv4CS document is now available at:
> > http://www.ietf.org/internet-drafts/draft-madanapalli-16ng-ipv
> > 4-over-802-dot-16-ipcs-00.txt
> >
> > Daniel (Soohong Daniel Park)
> > Mobile Convergence Laboratory, SAMSUNG Electronics.
> >
> > _______________________________________________
> > 16NG mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/16ng
> >
>
> _______________________________________________
> 16NG mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/16ng
>

_______________________________________________
16NG mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/16ng

_______________________________________________
16NG mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/16ng

---

From: "Narvaez, Paolo \(Paolo\)" <[email-masked]>
Date: Mon, 12 Feb 2007 14:06:26 -0600

How can the MS and AR send ARP requests and responses to each other?
These ARP messages have to go over IPCS and there is no IP packet in
this case.
 
If there is concern for a legacy IPv4 stack at the MS sending ARP
requests and perhaps even requiring ARP responses, why not recommend a
shim layer between the IPv4 stack and the 802.16 IPCS layer at the MS.
This layer would filter ARP requests arriving from the IPv4 stack and
respond with any MAC address. The IPCS classifier should never see ARP
messages, and they should never be sent over the air.
 
Regards,
Paolo

________________________________

	From: Behcet Sarikaya [mailto:[email-masked]] 
	Sent: Monday, February 12, 2007 2:19 PM
	To: Syam Madanapalli
	Cc: [email-masked]
	Subject: Re: [16NG]
Fw:I-DACTION:draft-madanapalli-16ng-ipv4-over-802-dot-16-ipcs-00.txt

	Hi Syam,
	  You mentioned P2P link here in this message but I could not
see any text on this in the draft. Maybe a section should be added on
the address and subnet mask assignment given the P2P nature of the link
and the fact that such assignments are not commonly used.
	  You recommended AR to ignore ARP Requests from MS, I am not
sure if this is OK or a Reply would be needed according to ARP?
	 
	Regards,
	 
	Behcet

	----- Original Message ----
	From: Syam Madanapalli <[email-masked]>
	To: "Narvaez, Paolo (Paolo)" <[email-masked]>
	Cc: [email-masked]
	Sent: Saturday, February 10, 2007 12:34:46 AM
	Subject: Re: [16NG] Fw:

	Hi Paolo,
	
	> header) how can the 802.16 IPCS carry this type of packet over
the air?
	
	As mentioned the draft, ARP is not required for 802.16 because
of the fact
	that the MAC address is not required for identifying the
destination.
	There was a concern that an unmodified host may send ARP without
knowing
	that the underlying interface is 802.16, because of this I added
the
	above statement.
	
	If we think there is no such possibility, then I will remove
this text.
	
	> do we need to introduce some restrictions as in the
IPv6-over-802.16
	
	The draft assumes the p2p link, so no two MSs can be on the same
subnet.
	
	Thanks,
	Syam

---

From: "Syam Madanapalli" <[email-masked]>
Date: Wed, 14 Feb 2007 13:28:18 +0530

Hi Bachet, Paolo,

In the next revision I will add an explicit section for the subnet model.
Please some inline text.

On 2/13/07, Narvaez, Paolo (Paolo) <[email-masked]> wrote:
>
>
>
> How can the MS and AR send ARP requests and responses to each other? These
> ARP messages have to go over IPCS and there is no IP packet in this case.

I agree with this, as there is no IP header, IPCS cannot classify these frames.

>
> If there is concern for a legacy IPv4 stack at the MS sending ARP requests
> and perhaps even requiring ARP responses, why not recommend a shim layer
> between the IPv4 stack and the 802.16 IPCS layer at the MS. This layer would
> filter ARP requests arriving from the IPv4 stack and respond with any MAC
> address. The IPCS classifier should never see ARP messages, and they should
> never be sent over the air.

This can be a solution. But can we leave this for implementors? And in
the draft
we just say ARP is not required and MUST not be sent over the air.

Thanks,
Syam

>   You mentioned P2P link here in this message but I could not see any text
> on this in the draft. Maybe a section should be added on the address and
> subnet mask assignment given the P2P nature of the link and the fact that
> such assignments are not commonly used.
>   You recommended AR to ignore ARP Requests from MS, I am not sure if this
> is OK or a Reply would be needed according to ARP?
>
> Regards,
>
> Behcet
>
>

---

From: Daniel Park <[email-masked]>
Date: Thu, 15 Feb 2007 08:16:38 +0900

>> ARP messages have to go over IPCS and there is no IP packet in this case.

So, we should discard ARP packets on the MS. 

>> never be sent over the air.

Interesting point. It does, however, not happen if the MS discard
ARP packets. But your mention seems one of alternatives from the
implementation point of view.

Daniel

---

From: Daniel Park <[email-masked]>
Date: Thu, 15 Feb 2007 08:30:58 +0900

>You mentioned P2P link here in this message but I could 
>not see any text on this in the draft. Maybe a section 
>should be added on the address and subnet mask assignment 
>given the P2P nature of the link and the fact that such 
>assignments are not commonly used.

In case of IPv4, DHCP server has to allocate a different
subnet address to each MS to provide P2P link model.

>You recommended AR to ignore ARP Requests from MS,
>I am not sure if this is OK or a Reply would be needed 
>according to ARP?

As I pointed out, I tend to discard ARP messages
on the MS iteself. What do you think ?

Daniel

---

From: "Narvaez, Paolo \(Paolo\)" <[email-masked]>
Date: Wed, 14 Feb 2007 17:49:08 -0600

> This can be a solution. But can we leave this for 
> implementors? And in the draft we just say ARP is not 
> required and MUST not be sent over the air.

I agree. There is no need to provide details of how the MS deals with
this issue. However, we cannot forbid ARPs over the air because ARP
packets over the air (IPCS) do not exist nor are they defined. It might
be more clear to say that the MS should not send any ARP-related
messages over the air.

Paolo

> From: Syam Madanapalli [mailto:[email-masked]] 
> Sent: Wednesday, February 14, 2007 2:58 AM
> To: Narvaez, Paolo (Paolo)
> Cc: Behcet Sarikaya; [email-masked]
> Subject: Re: [16NG] 
> > These ARP messages have to go over IPCS and there is no IP 
> packet in this case.
> 
> This can be a solution. But can we leave this for 
> implementors? And in the draft we just say ARP is not 
> required and MUST not be sent over the air.
> 
> 
> Thanks,
> Syam
> 
> >
> > Regards,
> > Paolo
> >
> >
> not see any 
> > text on this in the draft. Maybe a section should be added on the 
> > address and subnet mask assignment given the P2P nature of the link 
> >   You recommended AR to ignore ARP Requests from MS, I am 
> not sure if 
> > this is OK or a Reply would be needed according to ARP?
> >
> > Regards,
> >
> > Behcet
> >
> >
> > > 1. Section 7 assumes that ARP messages sent by the MS are 
> received 
> > > by the AR. The section states that ARP messages should be 
> dropped by 
> > > the AR. However, since ARP runs directly over Ethernet 
> (there is no 
> > > IP
> > As mentioned the draft, ARP is not required for 802.16 
> because of the 
> > fact that the MAC address is not required for identifying 
> the destination.
> > knowing that the underlying interface is 802.16, because of this I 
> > added the above statement.
> >
> > > 2. What is the subnet assignment? Can two MSs be on the 
> same subnet? 
> > > Or do we need to introduce some restrictions as in the 
> > > IPv6-over-802.16 draft.
> >