Subject: [16NG] Fw: I-D ACTION:draft-madanapalli-16ng-ipv4-over-802-dot-16-ipcs-00.txt

From: Daniel Park <[email-masked]>
Date: Fri, 09 Feb 2007 09:16:40 +0900

IPv4CS document is now available at:
http://www.ietf.org/internet-drafts/draft-madanapalli-16ng-ipv4-over-802-dot-16-ipcs-00.txt

Daniel (Soohong Daniel Park)
Mobile Convergence Laboratory, SAMSUNG Electronics.

_______________________________________________
16NG mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/16ng

---

From: Bruno Miguel Sousa <[email-masked]>
Date: Fri, 09 Feb 2007 11:36:27 +0000

Dears

Here is my contribution to this draft.

General comments:

I think the text is well written and easy to understand.
The overall operations of IPv4 (address assignment, multicast, ...)
are presented in the document.

Specific comments:

1)
The  sentences in the abstract:
"
   access.  IEEE has specified several service specific convergence
   sublayers (CS) for 802.16 which are used by upper layer protocols.
   The ATM CS and Packet CS are the two main service-specific
   convergence sublayers and these are a part of the 802.16 MAC which
   the upper layers interface to. 
"
I suggest to rewrite since 802.16 defines two service specific 
convergence sublayers.
The term several does not seem correct imho. The sentences present some 
repetition
when referring to upper layers. My suggestion:

IEEE has specified the service specific convergence sublayers (CS)
in the 802.16 MAC to be used by upper layer protocols.
The ATM CS and the Packet CS represent the two main
service specific convergence sublayers for 802.16.

2)
Some minor corrections.
"
   Unit (MTU) and address assignment procedures for transmitting _IPv4_
   packets over IP Convergence Sublayer (IPCS) of IEEE 802.16.  This
"

"
   be sent to MSs before they acquire IP addresses.  The figure below
   illustrates the network _architecture_.
"

IPv4 and not IPv6
"
   _IPv4_ packets are transmitted in Generic 802.16 MAC frames as shown in
   the following figure.
"

remove: is
"
   must be established.  This connection _is_ consists of 802.16 MAC
   transport connection between MS and BS and an L2 tunnel between BS
   and AR. 
"

remove being
"
   connection to the AR.  BS reconstructs the payload header if the PHS
   is in use before _being_ the packet is tunneled to the AR. 
"

3)
Section Maximum Transmission Unit
The value of 2038 is justified in the text.
In my opinion it is important to add references to justify the values 
1920 and 576.

For instance for the 576 value I would add a reference to the RFC 1122
to present the effective MTU to receive.

Kindly,
Bruno Sousa

---

From: "Narvaez, Paolo \(Paolo\)" <[email-masked]>
Date: Fri, 9 Feb 2007 16:41:07 -0600

I have two general comments on this draft.

1. Section 7 assumes that ARP messages sent by the MS are received by
the AR. The section states that ARP messages should be dropped by the
AR. However, since ARP runs directly over Ethernet (there is no IP
header) how can the 802.16 IPCS carry this type of packet over the air?

2. What is the subnet assignment? Can two MSs be on the same subnet? Or
do we need to introduce some restrictions as in the IPv6-over-802.16
draft.

Regards,
Paolo

> -----Original Message-----
> From: Daniel Park [mailto:[email-masked]] 
> Sent: Thursday, February 08, 2007 7:17 PM
> To: [email-masked]
> Subject: [16NG] Fw: 
> I-DACTION:draft-madanapalli-16ng-ipv4-over-802-dot-16-ipcs-00.txt
>

---

From: "Syam Madanapalli" <[email-masked]>
Date: Sat, 10 Feb 2007 11:21:08 +0530

Thanks Burno for the comments.

> service specific convergence sublayers for 802.16.

Yes, I will make this change in the next revision.

>    is in use before _being_ the packet is tunneled to the AR.

OK. Thanks.

> to present the effective MTU to receive.

OK. I will add this reference.

Regards,
Syam

---

From: "Syam Madanapalli" <[email-masked]>
Date: Sat, 10 Feb 2007 12:04:46 +0530

Hi Paolo,

> header) how can the 802.16 IPCS carry this type of packet over the air?

As mentioned the draft, ARP is not required for 802.16 because of the fact
that the MAC address is not required for identifying the destination.
There was a concern that an unmodified host may send ARP without knowing
that the underlying interface is 802.16, because of this I added the
above statement.

If we think there is no such possibility, then I will remove this text.

> do we need to introduce some restrictions as in the IPv6-over-802.16

The draft assumes the p2p link, so no two MSs can be on the same subnet.

Thanks,
Syam