Subject: [16NG] Fwd: Node Req: Issue 6: Support for RFC 5121: IP version 6 over WiMAX

From: "Daniel Park" <[email-masked]>
Date: Fri, 14 Nov 2008 15:12:46 +0900

FYI, in case you do not follow up IPv6 mailing list.

Daniel

---------- Forwarded message ----------
From: <[email-masked]>
Date: Fri, Nov 14, 2008 at 6:34 AM
Subject: Node Req: Issue 6: Support for RFC 5121: IP version 6 over WiMAX
To: [email-masked]

Daniel Park sent this issue in:

I'd request one more requirement for this bis. It is about 16ng
deliverable for IPv6 transmission over IPv6CS networks as RFC 5121. Due
to Convergence Sublayer characteristics of WiMAX networks, the below
requirement must be included in the Node Requirement. (For example:
globally unique prefix must be assigned to the WiMAX node, DAD
considerations, ND features, and etc described in RFC 5121)

4.X IP version 6 over WiMAX - RFC 5121

Nodes supporting IPv6 over WiMAX networks MUST implement

"Transmission of IPv6 via the IPv6 Convergence Sublayer
over IEEE 802.16 Networks" [RFC 5121].

--> I think this seems like a reasonable thing to add.

John
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------
_______________________________________________
16NG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/16ng

---

From: "Riegel, Maximilian (NSN - DE/Munich)" <[email-masked]>
Date: Fri, 14 Nov 2008 09:36:11 +0100

Daniel,
 
There are two ways to transfer IPv6 over WiMAX:
- IPv6 over WiMAX using IP-CS: RFC5121
- IPv6 over Ethernet carried over WiMAX.
 
It would be more clear to state the requirement:
 
Nodes supporting IPv6 via IP-CS over WiMAX networks MUST implement

Thanks
Max

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext Daniel Park
Sent: Friday, November 14, 2008 7:13 AM
To: [email-masked]
Subject: [16NG] Fwd: Node Req: Issue 6: Support for RFC 5121: IP version
6over WiMAX

Daniel

---------- Forwarded message ----------
From: <[email-masked]>
Date: Fri, Nov 14, 2008 at 6:34 AM
Subject: Node Req: Issue 6: Support for RFC 5121: IP version 6 over
WiMAX
To: [email-masked]

John

---

From: "Daniel Park" <[email-masked]>
Date: Fri, 14 Nov 2008 18:14:26 +0900

Max,

It looks good. Also, I think we can input EthCS to the IPv6 Node
Requirements after RFC publication.

Daniel

On Fri, Nov 14, 2008 at 5:36 PM, Riegel, Maximilian (NSN - DE/Munich) <
[email-masked]> wrote:

>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *ext Daniel Park
> *Sent:* Friday, November 14, 2008 7:13 AM
> *To:* [email-masked]
> *Subject:* [16NG] Fwd: Node Req: Issue 6: Support for RFC 5121: IP version
> 6over WiMAX
>

-- 
Daniel Park [at] Samsung Electronics
Standard Architect, blog.naver.com/natpt
_______________________________________________
16NG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/16ng

---

From: "Daniel Park" <[email-masked]>
Date: Tue, 18 Nov 2008 05:03:11 +0900

Brian (ccing 16ng list)

On Mon, Nov 17, 2008 at 12:12 PM, Brian E Carpenter <
[email-masked]> wrote:

> Daniel,
>
> On 2008-11-14 22:19, Daniel Park wrote:
> > John,
> >
> > I would make a minor change according to the valuable comments from the
> > WiMAX expert:
> >
> > - IPv6 over WiMAX using IPCS: RFC5121
> > - IPv6 over Ethernet carried over WiMAX: AD Evaluation (ID Status)
>
> Where does your suggested preference for the IPv6 CS come from?
> Does 16ng have a consensus on this preference?
>
> Since I can't imagine anyone *not* implementing the Ethernet CS,
> doesn't this make extra work for all implementors, compared
> with preferring the Ethernet CS for both IP versions?

We had long discussion on that before..:-) Yes, IPv6CS (RFC5121) comes from
16ng WG. And EthernetCS is too. Prebably, the consensus you mentioned above
means which CS is a mandatory or optional for IPv6 implementation or
both. Well, 16ng WG just leaves them to the business choice in WiMAX
networks since that is beyond scope of 16ng. As of today, obviously mobile
biz wants to implement IPv6CS only, and wired biz (looks like DSL) wants to
implemt EthernetCS. But, no one knows what happens tomorrow in WiMAX
networks.

Daniel

---

From: "Daniel Park" <[email-masked]>
Date: Tue, 18 Nov 2008 06:35:44 +0900

Confusing...definitely RFC5121 must be implemented for IPv6 over WiMAX
network. EthernetCS must be too. No need to decide which CS must be used for
WiMAX by 6man...?

Daniel

On Tue, Nov 18, 2008 at 5:20 AM, Brian E Carpenter <
[email-masked]> wrote:

> On 2008-11-18 09:03, Daniel Park wrote:
> > Brian (ccing 16ng list)
> >
> Then it seems to me there is no useful statement to be made
> in the node requirements document. If 16ng has no recommendation,
> I don't see how 6man can decide.
>
> Thanks
>
>   Brian
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Nov 2008 09:20:16 +1300

Thanks

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Nov 2008 10:49:03 +1300

> network. EthernetCS must be too. No need to decide which CS must be used for

My understanding is that in the IETF we try to avoid situations where
two ways of doing the same thing MUST be implemented. I hope that 16ng will
produce an applicability statement, but I don't see what we can usefully
say in the node requirements.

    Brian