Subject: [6lo] Milestones up for discussion

From: Ulrich Herberg <[email-masked]>
Date: Wed, 25 Sep 2013 11:20:34 -0700

Below are some milestones that Samita and I propose. Please provide
comments and suggestions.

January  2014  WG adoption of IPv6-over-foo documents
February 2014  WG review to determine adoption of:
                            1)   6lo MIB document(s)
                            2)   Generic header compression document
                            3)   Backbone Router document
                            4)   draft-thubert-roll-forwarding-frags-01.txt

March    2014 WG last call for adopted IPv6-over-foo I-Ds
April       2014 WG last call for adopted 6lo MIB document

June      2014 First draft of a generic guideline on IPv6-over-foo
                        Review the following drafts :
                        draft-bormann-6lowpan-roadmap-03.txt
                        draft-bormann-intarea-alfi-02.txt

July     2014 IESG submission of IPv6-over-foo and MIB documents
August  2014  WG adoption of  generic guideline/roadmap document
Sept   2014  WG LC for other WG adopted documents
Nov      2014 IESG submission of the other WG adopted documents
Nov      2014 Re-charter

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 25 Sep 2013 20:33:44 +0200

Two comments on that timeline:

-- I'm not sure all IP-over-foo documents are at the same level of advancement.
In particular, DECT-ULE may be a bit behind the others as DECT-ULE is still stabilizing.
We probably have to check with the authors to see whether Jan 2014 adoption is realistic.

-- GHC has been pretty much stable for a long time, and has already received some review in 6LoWPAN.  
I'm not sure what we are waiting for there.

Grüße, Carsten

---

From: Geoff Mulligan <[email-masked]>
Date: Wed, 25 Sep 2013 13:00:22 -0600

Ulrich,
   When are you arriving in Vancouver?  I have a conflict and likely 
won't be arriving until late on the 5th (we are hosting the SmartUSA 
Challenge kick off meeting at the White House on the 4th).

Are you staying the entire week?

     Geoff Mulligan
     Presidential Innovation Fellow
     Cyber-physical Systems
     SmartUSA Challenge

On 09/25/2013 12:20 PM, Ulrich Herberg wrote:
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo

---

From: Samita Chakrabarti <[email-masked]>
Date: Wed, 25 Sep 2013 19:32:15 +0000

Hi Carsten,

Please propose a tentative timeline for those two drafts (DECT-ULE and GHC) based on your experience in the wg before.
The milestones timelines are very rough estimates. Your input and suggestions will be valuable here as well as input from the working group.

Regards,
-Samita
-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Wednesday, September 25, 2013 11:34 AM
To: Ulrich Herberg
Cc: [email-masked]; Samita Chakrabarti
Subject: Re: [6lo] Milestones up for discussion

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 25 Sep 2013 22:49:43 +0200

> Please propose a tentative timeline for those two drafts (DECT-ULE and GHC) based on your experience in the wg before.

Hi Samita,

I really can't speak for DECT-ULE -- we need to ask the authors.  
Certainly, -03 (July 2013) isn't complete yet.
We'll have to make up our mind how complete documents should be before we adopt them as WG documents.

I happen to know that the lowpanz draft has already received a bit of review, so that should be ready for adoption in Vancouver.

Similarly think we should discuss adopting GHC in Vancouver, issue the call for adoption right after that, and be done with those two milestones in November 2013.

Depending on how much implementer feedback we want before WGLCing these, this could already be in January or drawn out a couple more months.  So IESG submission could be between February and, say, June.

Grüße, Carsten

---

From: Samita Chakrabarti <[email-masked]>
Date: Thu, 26 Sep 2013 00:35:46 +0000

Thanks for your suggestions.  

We will  take this input into revising the milestones.

-Samita

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Wednesday, September 25, 2013 1:50 PM
To: Samita Chakrabarti
Cc: Ulrich Herberg; [email-masked]
Subject: Re: [6lo] Milestones up for discussion

Hi Samita,

Grüße, Carsten

---

From: Anders Brandt <[email-masked]>
Date: Thu, 26 Sep 2013 06:34:23 +0000

Ulrich, Samita, 

I agree in the milestones proposed below.
With regards to this IP-over-foo draft: draft-brandt-6man-lowpanz-02,
I consider it to be in a mature state and ready for adoption.
(Will ask formally for adoption when 6lo has been formed)

Thank you,
  Anders Brandt

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Ulrich Herberg
> Sent: 25. september 2013 20:21
> To: [email-masked]
> Cc: Samita Chakrabarti
> Subject: [6lo] Milestones up for discussion
> 
> January  2014  WG adoption of IPv6-over-foo documents February 2014  WG
> review to determine adoption of:
>                             1)   6lo MIB document(s)