Subject: [6lo] Update from BT SIG

From: Brian Haberman <[email-masked]>
Date: Wed, 30 Apr 2014 09:36:40 -0400

All,
     We received the following e-mail from the BT SIG executive director
related to the IPv6 over BTLE draft.

Regards,
Brian

-------- Original Message --------
Subject: Progress Related to IETF Request
Resent-Date: Thu, 10 Apr 2014 15:10:44 -0700 (PDT)
Resent-From: [email-masked]
Resent-To: [email-masked], [email-masked],,
[email-masked], [email-masked], [email-masked]
Date: Thu, 10 Apr 2014 14:35:54 -0700
From: Mark Powell <[email-masked]>
To: [email-masked] <[email-masked]>,
[email-masked] <[email-masked]>
CC: Peter Cook <[email-masked]>

Dear Internet Engineering Task Force and IETF Internet Area Directors,

In December, 2012 the Bluetooth SIG received the following
correspondence from you, which in part stated:

"The development of this solution is technically advanced, with two
prototype implementations (by Nokia and by Marcel de Kogel as part of
his MSc thesis work - Marcel has made his implementation publicly
available). IETF standardization-wise the document is in the IESG
process, and hence in the late stages as well.

This solution has one major open item: it requires an allocation of a
new fixed L2CAP Channel Identifier (to distinguish IPv6 from other BT-LE
traffic).

As the IETF and BT SIG do not have official liaisons, we are approaching
you with this email to ask if, and how, it would be possible to have a
fixed channel identifier allocated for the IPv6 over Bluetooth
Low-Energy specification."

The Bluetooth SIG has responded to your request by doing the following:

1.       Accommodated for your request in the Bluetooth Core
Specification v4.1 by introducing a new L2CAP feature called Connection
Oriented Channels.

2.       The Internet Working Group is developing an "Internet Protocol
Support Service" (IPSS) and "Internet Protocol Support Profile" (IPSP).
       The Bluetooth SIG believes these specifications will meet your
requirements. IPSS does not allocate a fixed L2CAP channel for 6LoWPAN,
instead it proposes to use L2CAP Connection Oriented Channels.
       It is therefore recommended that the IETF reference these
specifications.

The Bluetooth SIG intends to perform interoperability testing on these
features this summer and fall. Final adoption of the specifications can
occur approximately six weeks after completing this interoperability
testing.

Best regards,

Mark Powell
Executive Director  |  Bluetooth Special Interest Group, Inc.
m: +1.425.999.7122  o: +1.425.691.3530 skype: mark.powell
e: [email-masked]<mailto:[email-masked]>  |
www.bluetooth.com<http://www.bluetooth.com/>  |
www.bluetooth.org<http://www.bluetooth.org/>  |
________________________________
CONFIDENTIAL: This email message and any information attached to it may
contain confidential information that is legally privileged. Any
unauthorized disclosure, use, copying, or distribution is strictly
prohibited. If you are not the intended recipient, please notify the
Author and destroy the original transmission without reading or saving.
Thank you.

---

From: "Savolainen Teemu (Nokia-CTO/Tampere)" <[email-masked]>
Date: Wed, 30 Apr 2014 14:30:50 +0000

Thank you Brian,

We have been updating the draft-ietf-6lo-btle to take into account below mentioned changes, i.e. switch to use Connection Oriented Channels and all it implies.

Updates have also been made to handle various offline comments received from BT SIG, including some branding related changes, and comments from Dave Thaler, and so on.

I plan to upload revised draft on Friday.

Best regards,

	Teemu

-----Original Message-----
From: 6lo [mailto:[email-masked]] On Behalf Of ext Brian Haberman
Sent: 30. huhtikuuta 2014 16:37
To: [email-masked]
Subject: [6lo] Update from BT SIG

All,
     We received the following e-mail from the BT SIG executive director related to the IPv6 over BTLE draft.

Regards,
Brian

-------- Original Message --------
Subject: Progress Related to IETF Request
Resent-Date: Thu, 10 Apr 2014 15:10:44 -0700 (PDT)
Resent-From: [email-masked]
Resent-To: [email-masked], [email-masked],, [email-masked], [email-masked], [email-masked]
Date: Thu, 10 Apr 2014 14:35:54 -0700
From: Mark Powell <[email-masked]>
To: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
CC: Peter Cook <[email-masked]>

In December, 2012 the Bluetooth SIG received the following correspondence from you, which in part stated:

"The development of this solution is technically advanced, with two prototype implementations (by Nokia and by Marcel de Kogel as part of his MSc thesis work - Marcel has made his implementation publicly available). IETF standardization-wise the document is in the IESG process, and hence in the late stages as well.

This solution has one major open item: it requires an allocation of a new fixed L2CAP Channel Identifier (to distinguish IPv6 from other BT-LE traffic).

As the IETF and BT SIG do not have official liaisons, we are approaching you with this email to ask if, and how, it would be possible to have a fixed channel identifier allocated for the IPv6 over Bluetooth Low-Energy specification."

1.       Accommodated for your request in the Bluetooth Core
Specification v4.1 by introducing a new L2CAP feature called Connection Oriented Channels.

2.       The Internet Working Group is developing an "Internet Protocol
Support Service" (IPSS) and "Internet Protocol Support Profile" (IPSP).
       The Bluetooth SIG believes these specifications will meet your requirements. IPSS does not allocate a fixed L2CAP channel for 6LoWPAN, instead it proposes to use L2CAP Connection Oriented Channels.
       It is therefore recommended that the IETF reference these specifications.

The Bluetooth SIG intends to perform interoperability testing on these features this summer and fall. Final adoption of the specifications can occur approximately six weeks after completing this interoperability testing.

Best regards,

Mark Powell
Executive Director  |  Bluetooth Special Interest Group, Inc.
m: +1.425.999.7122  o: +1.425.691.3530 skype: mark.powell
e: [email-masked]<mailto:[email-masked]>  | www.bluetooth.com<http://www.bluetooth.com/>  | www.bluetooth.org<http://www.bluetooth.org/>  | ________________________________
CONFIDENTIAL: This email message and any information attached to it may contain confidential information that is legally privileged. Any unauthorized disclosure, use, copying, or distribution is strictly prohibited. If you are not the intended recipient, please notify the Author and destroy the original transmission without reading or saving.
Thank you.