Subject: Re: [6lo] New Version Notification for draft-mariager-6lo-v6over-dect-ule-02.txt

From: <[email-masked]>
Date: Fri, 4 Apr 2014 14:45:17 +0000

Hello Peter, 

Thanks for this new and improved revision. It clarifies quite a few points from previous revisions.

Two comments:
- FAR could be defined in Section 1.2. It is indeed used in Section 3.2 without a definition. Alternately, the acronym could be just expanded in Section 3.2.
- Section 5 says: "The underlying algorithm for providing encryption and authentication is based on AES128.". "underlying" and "based on" seem redundant, unless you mean the underlying algorithm is not quite AES128?

Some remaining nits:
- Section 2.3: s/it can not be used derive/it can not be used to derive/
- Section 2.3: s/When such approach/With such an approach/
- Section 2.5: s/not considered/no consider/
- Section 2.5: s/this draft/this draft./
- Section 3: s/This functionality comprises of/This functionality comprises/
- Section 3.2: s/used\.Since/used. Since/
- Section 3.2: s/the PP/the PPs/
- Section 3.2: s/hear each other/hear one another/
- Section 3.2: s/to each other/to one another/
- Section 3.2.2, subsection 1: "irrespective of whether" followed by three options
- Section 3.2.3: s/a PPs/a PP/
- Section 3.2.3: s/section FP/section, the FP/
- Section 3.3: s/isolated network scenario/isolated network scenario,/
- Section 5: s/DECT ULE communication are/DECT ULE communications are/
- Section 6: s/It is proposed to used/It is proposed to use/

Best regards

Dominique

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] 
Envoyé : mercredi 2 avril 2014 22:49
À : Peter B.Mariager; Jens T. Petersen; Marco van de Logt; Marco van de Logt; Peter B. Mariager; Zach Shelby; BARTHEL Dominique IMT/OLPS; Jens Toftgaard Petersen; BARTHEL Dominique IMT/OLPS; Zach Shelby
Objet : New Version Notification for draft-mariager-6lo-v6over-dect-ule-02.txt

A new version of I-D, draft-mariager-6lo-v6over-dect-ule-02.txt
has been successfully submitted by Jens Toftgaard Petersen and posted to the IETF repository.

Name:		draft-mariager-6lo-v6over-dect-ule
Revision:	02
Title:		Transmission of IPv6 Packets over DECT Ultra Low Energy
Document date:	2014-04-02
Group:		Individual Submission
Pages:		15
URL:            http://www.ietf.org/internet-drafts/draft-mariager-6lo-v6over-dect-ule-02.txt
Status:         https://datatracker.ietf.org/doc/draft-mariager-6lo-v6over-dect-ule/
Htmlized:       http://tools.ietf.org/html/draft-mariager-6lo-v6over-dect-ule-02
Diff:           http://www.ietf.org/rfcdiff?url2=draft-mariager-6lo-v6over-dect-ule-02

Abstract:
   DECT Ultra Low Energy is a low power air interface technology that is
   defined by the DECT Forum and specified by ETSI.

   The DECT air interface technology has been used world-wide in
   communication devices for more than 15 years, primarily carrying
   voice for cordless telephony but has also been deployed for data
   centric services.

   The DECT Ultra Low Energy is a recent addition to the DECT interface
   primarily intended for low-bandwidth, low-power applications such as
   sensor devices, smart meters, home automation etc.  As the DECT Ultra
   Low Energy interface inherits many of the capabilities from DECT, it
   benefits from long range, interference free operation, world wide
   reserved frequency band, low silicon prices and maturity.  There is
   an added value in the ability to communicate with IPv6 over DECT ULE
   such as for Internet of Things applications.

   This document describes how IPv6 is transported over DECT ULE using
   6LoWPAN techniques.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Jens Toftgaard Petersen <[email-masked]>
Date: Mon, 7 Apr 2014 22:56:27 +0000

Hi Dominique,

Thank you very much for your very detailed and useful review of the text. I have implemented all your comments, which will be present in next draft of the document, see my notes below. 
Please let me know if anybody have further comments, questions or suggestions - both editorial and technical.

Best regards,
  Jens

-----Original Message-----
From: 6lo [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 4. april 2014 16:45
To: Peter Mariager; [email-masked]
Subject: Re: [6lo] New Version Notification for draft-mariager-6lo-v6over-dect-ule-02.txt

Hello Peter, 

Two comments:
- FAR could be defined in Section 1.2. It is indeed used in Section 3.2 without a definition. Alternately, the acronym could be just expanded in Section 3.2. (jens: FAR is added in section 1.2)
- Section 5 says: "The underlying algorithm for providing encryption and authentication is based on AES128.". "underlying" and "based on" seem redundant, unless you mean the underlying algorithm is not quite AES128? (jens: it is AES128, wording changed)

Some remaining nits:
- Section 2.3: s/it can not be used derive/it can not be used to derive/ (jens: done)
- Section 2.3: s/When such approach/With such an approach/ (jens: done)
- Section 2.5: s/not considered/no consider/ (jens: done)
- Section 2.5: s/this draft/this draft./ (jens: done)
- Section 3: s/This functionality comprises of/This functionality comprises/ (jens: done)
- Section 3.2: s/used\.Since/used. Since/ (jens: done)
- Section 3.2: s/the PP/the PPs/ (jens: done)
- Section 3.2: s/hear each other/hear one another/ (jens: done)
- Section 3.2: s/to each other/to one another/ (jens: done)
- Section 3.2.2, subsection 1: "irrespective of whether" followed by three options (jens: wording improved to emphasize the three options)
- Section 3.2.3: s/a PPs/a PP/ (jens: done)
- Section 3.2.3: s/section FP/section, the FP/ (jens: done)
- Section 3.3: s/isolated network scenario/isolated network scenario,/ (jens: done)
- Section 5: s/DECT ULE communication are/DECT ULE communications are/ (jens: done)
- Section 6: s/It is proposed to used/It is proposed to use/ (jens: done)

Best regards

Dominique

-----Message d'origine-----

Abstract:

The IETF Secretariat

_______________________________________________
6lo mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6lo