Subject: Re: [6lo] problematic *normative* references to RFC4541 (MLD snooping) from draft-ietf-6lo-btle and draft-ietf-6lo-dect-ule

From: "Savolainen Teemu (Nokia-TECH/Tampere)" <[email-masked]>
Date: Fri, 20 Feb 2015 21:06:13 +0000

We refer to that draft in occasion with intent to indicate power optimization possibility. So after looking at rfc 5692, the following change should work, right?
--
To avoid excess of unwanted multicast traffic being sent to 6LNs, the 6LBR SHOULD implement MLD Snooping feature [RFC4541].
-- to:
To avoid excess of unwanted multicast traffic being sent to 6LNs, the 6LBR can implement MLD Snooping feature [4541].
--
And that would then allow changing the reference to informative?

If nobody objects, I can publish -10 with that change.

Best regards,

Teemu

On Feb 20, 2015 9:31 PM, ext Gabriel Montenegro <[email-masked]> wrote:

Hello authors of draft-ietf-6lo-btle and draft-ietf-6lo-dect-ule,

Both of your drafts have problematic normative references to an informative document, namely RFC4541 (IGMP/MLD snooping).

Any document that aspires to become a proposed standard will have an issue if it has normative references to an informational document. This is what the IDnits say:

     (See RFCs 3967 and 4897 for information about using normative references

     to lower-maturity documents in RFCs)

As you’ll see, exceptions to this rule are possible. I’d think that an exception for this particular document of IGMP/MLD snooping would be harder than most.

So, I would urge you to reconsider if this needs to be a normative reference. Making it an informative reference would clear this potential roadblock.

Please take a look at the documents that reference RFC4541: http://datatracker.ietf.org/doc/rfc4541/referencedby/

You’ll notice no *standards track* RFC’s have normative references to it. A previous example of an IP-over-foo document that references it is rfc5692<http://datatracker.ietf.org/doc/rfc5692/> (I remember it as I was the co-chair for that WG). You might want to look at that example. In particular, you’ll notice that normative language (SHOULD, MAY, MUST, etc) was avoided when referring to it.

Ralph was the responsible AD for rfc5692 so he might have some more input on this.

Thanks,

Gabriel (with co-chair hat on)

---

From: Gabriel Montenegro <[email-masked]>
Date: Fri, 20 Feb 2015 21:39:48 +0000

Looks fine to me. It is not essential (it’s an optimization) so informative seems appropriate.

From: Savolainen Teemu (Nokia-TECH/Tampere) [mailto:[email-masked]]
Sent: Friday, February 20, 2015 13:06
To: Gabriel Montenegro
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [6lo] problematic *normative* references to RFC4541 (MLD snooping) from draft-ietf-6lo-btle and draft-ietf-6lo-dect-ule

Best regards,

Teemu
On Feb 20, 2015 9:31 PM, ext Gabriel Montenegro <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,

---

From: "Savolainen Teemu (Nokia-TECH/Tampere)" <[email-masked]>
Date: Mon, 23 Feb 2015 15:40:10 +0000

There didn’t seem to be any instant objections, so I posted the -10 as proposed.

Teemu

From: ext Gabriel Montenegro [mailto:[email-masked]]
Sent: 20. helmikuuta 2015 23:40
To: Savolainen Teemu (Nokia-TECH/Tampere)
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [6lo] problematic *normative* references to RFC4541 (MLD snooping) from draft-ietf-6lo-btle and draft-ietf-6lo-dect-ule

From: Savolainen Teemu (Nokia-TECH/Tampere) [mailto:[email-masked]]
Sent: Friday, February 20, 2015 13:06
To: Gabriel Montenegro
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [6lo] problematic *normative* references to RFC4541 (MLD snooping) from draft-ietf-6lo-btle and draft-ietf-6lo-dect-ule

Best regards,

Teemu

Thanks,