Subject: [6lo] EtherType for 6LoWPAN IPHC

From: Paul Duffy <[email-masked]>
Date: Thu, 25 Jun 2015 12:08:24 -0400

6lo-ers,

Per the recent thread re: EtherType for 6LoWPAN IPHC.

Is anyone willing to/planning to fund this?  IEEE will charge about $3K.

Cheers

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 25 Jun 2015 21:06:25 +0200

It might be interesting to carry 6LoWPAN in 802.11.
I occasionally hear noises that people want to compress IPv6 in
low-power WiFi.  One other way to do this would be something like
https://tools.ietf.org/html/draft-bormann-rohc-over-802-02

I haven't really researched this in the context of 6lo, so I would love
to hear from people who work with low-power WiFi.

Grüße, Carsten

Paul Duffy wrote:
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 26 Jun 2015 06:07:18 +0000

I Fully agree, Carsten.

I see also a possibility to support RFC 6282 over Ethernet, for routers connected to the backbone so as to terminate the compression there, keeping the AP an AP...

Au plaisir,
Pascal

> Le 25 juin 2015 à 21:06, Carsten Bormann <[email-masked]> a écrit :
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 26 Jun 2015 16:39:10 +0200

Hello Paul,

Thank you for the offer that should be considered carefully.  I think
the amount does not exceed what may average a in-person participation to
an IETF meeting, so it should be feasible.

I have three comments:

1. does this include definition of a proper LLC header to sit on top of
    15.4DataHeader?  Because, in our understanding, only this LLC may
    carry an EtherType.  A 15.4 DataHeader does not carry an EtherType.

2. is IEEE charging for EtherTypes?  Or is it charging for OUIs?  Or
    both?

3. any request should come via a formal way with a liaison.  A
    discussion on the email list may not be - yet - consensual enough.
    Consensus could be measured by level of adopting documents into RFCs
    on various tracks.

Alex

Le 25/06/2015 18:08, Paul Duffy a écrit :
> _______________________________________________ 6lo mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/6lo
>
>

---

From: Paul Duffy <[email-masked]>
Date: Fri, 26 Jun 2015 10:46:12 -0400

> an IETF meeting, so it should be feasible.

Thanks for volunteering.  Much appreciated. Here is the registration link.

https://standards.ieee.org/develop/regauth/ethertype/

>    15.4DataHeader?

No

> Because, in our understanding, only this LLC may

Correct. 15.4 provided no means for protocol dispatch.

> 2. is IEEE charging for EtherTypes?  Or is it charging for OUIs? Or

Both

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 26 Jun 2015 16:52:17 +0200

Le 26/06/2015 16:46, Paul Duffy a écrit :
>> Thank you for the offer that should be considered carefully.  I
>> think the amount does not exceed what may average a in-person
>> participation to an IETF meeting, so it should be feasible.
>

Thanks for the pointer.  Before doing that one needs to make sure that
EtherType is going to be used.

And for clarification - I dont volunteer, at least not for now.

>> I have three comments:
>>
>> 1. does this include definition of a proper LLC header to sit on
>> top of 15.4DataHeader?
>
> No

Ok, and how would that be achieved?

Would it be sufficient to write an Internet Draft with "Requirements for
an IEEE LLC Header on top of IEEE 802.15.4 Header"?

>> Because, in our understanding, only this LLC may carry an
>> EtherType.  A 15.4 DataHeader does not carry an EtherType.
>

So an LLC header is needed to carry this EtherType, right?

>> 2. is IEEE charging for EtherTypes?  Or is it charging for OUIs?
>> Or both?
>
> Both

Ok, thanks, good to know.

Alex

>> Consensus could be measured by level of adopting documents into
>> RFCs on various tracks.
>>
>> Alex
>>

---

From: Paul Duffy <[email-masked]>
Date: Fri, 26 Jun 2015 11:09:06 -0400

Apologies, I thought you volunteered ;)

For 15.4 protocol dispatch, look to IEEE 802.15.9's MP Information Element.

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 26 Jun 2015 17:17:20 +0200

> For 15.4 protocol dispatch, look to IEEE 802.15.9's MP Information Element.

Document please?

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 26 Jun 2015 17:25:44 +0200

Paul,

Can you please paste here the format of that Information Element, thank you.

Alex