Subject: [6lo] Fwd: New Version Notification for draft-raza-6lo-ipsec-02.txt

From: Shahid Raza <[email-masked]>
Date: Mon, 12 Oct 2015 12:18:47 +0200

Dear All,

A new version of the IPsec header compression draft is uploaded. It addresses the questions raised during the IETF93 and clarifies how this is different from ROHC and other compression schemes. On of the questions was why we need a different cipher suite? The answer is simple we neither propose any new cipher suit now require any change in the IPsec standard; our header compression is confined to 6LoWPAN networks and follows the standardized 6LoWPAN header compression mechanisms.

Regards
Shahid

> Begin forwarded message:
> 
> From: [email-masked]
> Date: 12 October 2015 at 12:09:09 GMT+2
> To: "Shahid Raza" <[email-masked]>, "Simon Duquennoy" <[email-masked]>, "Goeran Selander" <[email-masked]>
> Subject: New Version Notification for draft-raza-6lo-ipsec-02.txt
> 
> 
> A new version of I-D, draft-raza-6lo-ipsec-02.txt
> has been successfully submitted by Shahid Raza and posted to the
> IETF repository.
> 
> Name:		draft-raza-6lo-ipsec
> Revision:	02
> Title:		Compression of IPsec AH and ESP Headers for Constrained Environments
> Document date:	2015-10-12
> Group:		Individual Submission
> Pages:		11
> URL:            https://www.ietf.org/internet-drafts/draft-raza-6lo-ipsec-02.txt
> Status:         https://datatracker.ietf.org/doc/draft-raza-6lo-ipsec/
> Htmlized:       https://tools.ietf.org/html/draft-raza-6lo-ipsec-02
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-raza-6lo-ipsec-02
> 
> Abstract:
>   This document describes the header compression mechanisms for IPsec
>   [RFC4301] based on the encoding scheme standardized in [RFC6282]. The
>   IPsec Authentication Header (AH) and Encapsulated Security Payload
>   (ESP) headers are compressed using Next Header Compression (NHC)
>   defined in [RFC6282]. This document does not invalidate any encoding
>   schemes proposed in 6LoWPAN [RFC6282] but rather complements it with
>   compressed IPsec AH and ESP headers using the free bits in the IPv6
>   Extension Header encoding. Also, this document does not require any
>   changes in a conventional IPsec host on the Internet; the header
>   compression is applied only at the 6LoWPAN layer and is effective
>   within 6LoWPAN networks.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Shahid Raza <[email-masked]>
Date: Tue, 13 Oct 2015 16:11:00 +0200

Dear All,

Regards
Shahid

> Begin forwarded message:
> 
> From: [email-masked] <mailto:[email-masked]>
> To: "Shahid Raza" <[email-masked] <mailto:[email-masked]>>, "Simon Duquennoy" <[email-masked] <mailto:[email-masked]>>, "Goeran Selander" <[email-masked] <mailto:[email-masked]>>
> URL:            https://www.ietf.org/internet-drafts/draft-raza-6lo-ipsec-02.txt <https://www.ietf.org/internet-drafts/draft-raza-6lo-ipsec-02.txt>
> Status:         https://datatracker.ietf.org/doc/draft-raza-6lo-ipsec/ <https://datatracker.ietf.org/doc/draft-raza-6lo-ipsec/>
> Htmlized:       https://tools.ietf.org/html/draft-raza-6lo-ipsec-02 <https://tools.ietf.org/html/draft-raza-6lo-ipsec-02>
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-raza-6lo-ipsec-02 <https://www.ietf.org/rfcdiff?url2=draft-raza-6lo-ipsec-02>
> 
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> The IETF Secretariat
>