Subject: [6lo] questions about address protected ND: draft-sarikaya-6lo-ap-nd

From: Michael Richardson <[email-masked]>
Date: Wed, 17 Aug 2016 09:28:46 -0400

I feel that somewhere between sections 3 and section 4 there is some
as yet unwritten text that explains how to do the crypto-ID calculation,
and how the 6LBR would verify it.

I thought perhaps it leveraged more of SEND/CGA (3971/3972) than I thought, I
so glanced through those again, but I conclude that this is not the case.

Please confirm that there is simply unwritten text at this point, rather
than references I haven't followed.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 17 Aug 2016 13:50:20 +0000

It is largely unwritten Michael, 

That's ultimately a WG decision, and part of that decision is that we want to assess if the IPR on CGA is an issue or not. 
My take is that we should adopt the work if we agree on the overall idea, knowing that CGA is one way of getting there; and then refine this as a WG.

Makes sense?

Pascal

> -----Original Message-----
> From: Michael Richardson [mailto:[email-masked]]
> Sent: mercredi 17 août 2016 15:29
> To: [email-masked]; [email-masked]
> Subject: questions about address protected ND: draft-sarikaya-6lo-ap-nd
> 
> 
> I feel that somewhere between sections 3 and section 4 there is some as yet
> unwritten text that explains how to do the crypto-ID calculation, and how the
> 6LBR would verify it.
> 
> Please confirm that there is simply unwritten text at this point, rather than
> references I haven't followed.
> 
> 
> --
> Michael Richardson <[email-masked]>, Sandelman Software Works  -=
> IPv6 IoT consulting =-
> 
>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 17 Aug 2016 11:46:11 -0400

thanks for the reply.

    > That's ultimately a WG decision, and part of that decision is that we
    > want to assess if the IPR on CGA is an issue or not.

    > My take is that we should adopt the work if we agree on the overall
    > idea, knowing that CGA is one way of getting there; and then refine
    > this as a WG.

a) Hosnieh's proposals
   https://datatracker.ietf.org/doc/draft-rafiee-6man-ssas/

   might not suffer from the same IPR.

b) I wonder what is the expiry on the IPR. CGA is more than a decade old now.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 17 Aug 2016 15:50:14 +0000

Yes, Michael;

Last we discussed that (at IETF 96) people pointed that expiry would actually be the best protection, and that CGA being proven and implemented, it was the best approach. I'd like to see this confirmed (IANAL).

Cheers,

Pascal

> Sent: mercredi 17 août 2016 17:46
> To: Pascal Thubert (pthubert) <[email-masked]>
> Cc: [email-masked]; [email-masked]
> Subject: Re: questions about address protected ND: draft-sarikaya-6lo-ap-nd
> 
> 
> thanks for the reply.
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 17 Aug 2016 15:56:29 -0500

> b) I wonder what is the expiry on the IPR. CGA is more than a decade old now.

Date(s) granted or applied for (YYYY-MM-DD):
303951.01 - 2003/03/27
301073.02 - 2002/09/12

I think that these patents do not expire before 20 years.
But Microsoft grants royalty free licensing to all implementers.

Behcet