Subject: Re: [6lo] Adoption call for 6lo Applicability and Usecases

From: Xavier Vilajosana <[email-masked]>
Date: Wed, 5 Oct 2016 16:17:36 +0200

Dear Samita, all,

I support the adoption of this document. I consider necessary a use case
document that can be used as reference, presenting the current status and
technologies that support 6lo. I would like to see there the features of
6lo that are supported and those that are not for the different underlying
technologies, information about the current level of maturity and examples
of existing deployments.

I also support the inclusion of a use case describing the use of 6lo in the
context of 6TiSCH.

kind regards,
Xavi

2016-09-21 20:00 GMT+02:00 samita Chakrabarti <[email-masked]>:

> Hello Folks:
>
>
>
> We have discussed this document several times and Young-Geun Hong had
> presented this document several times at IETF and the WG also met
> separately to discuss the use cases and format of the document. We
> concluded that the purpose of this document is to show others how 6lo
> stacks can be used in different applications and on L2 constrained
> networks. The information can be used by external organizations as a
> guideline of examples for understanding whether their networks can be
> suitable to run 6lo stacks. Many have been co-authored/contributed to this
> document already.
>
>
>
> The latest version of the document is available here:
>
> https://datatracker.ietf.org/doc/draft-hong-6lo-use-cases/
>
>
>
>
>
>
>
> Please provide your opinion on the mailing list.
>
>
>
> The adoption call ends on October 7, 2016.
>
>
>
> Thanks,
>
> Gabriel and Samita
>
> 6lo-co chairs
>
>
>
>
>
>
>
>
>
>
>
>
>
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo
>
>

---

From: Samita Chakrabarti <[email-masked]>
Date: Thu, 6 Oct 2016 11:40:30 -0700

As a WG member, I support this draft to become a WG document.
I believe, this document will provide information on the usage and
requirements of using 6lowpan stacks over different Low-power L2 networks
-- which could be useful for the Internet Of Things Community to understand
how IPv6 adaptation might be possible for their L2 implementations.

 +1.

-Samita

On Wed, Oct 5, 2016 at 7:17 AM, Xavier Vilajosana <
[email-masked]> wrote:

> I also support the inclusion of a use case describing the use of 6lo in
> the context of 6TiSCH.
>
> kind regards,
> Xavi
>
>
>

---

From: AbdurRashidSangi <[email-masked]>
Date: Fri, 7 Oct 2016 03:59:57 +0000

Dear chairs and all,

I support this work to be adopted as a WG document.

Constrained  technologies are very well explained in context of deployment for last mile connectivity in IoT networks. This document is a useful reference to further work on different aspects of challenged technologies.

Regards,
Rashid Sangi,
Huawei, Beijing.
From:Samita Chakrabarti
To:Xavier Vilajosana,
Cc:lo,
Date:2016-10-07 02:40:54
Subject:Re: [6lo] Adoption call for 6lo Applicability and Usecases

As a WG member, I support this draft to become a WG document.
I believe, this document will provide information on the usage and requirements of using 6lowpan stacks over different Low-power L2 networks -- which could be useful for the Internet Of Things Community to understand how IPv6 adaptation might be possible for their L2 implementations.

 +1.

-Samita

On Wed, Oct 5, 2016 at 7:17 AM, Xavier Vilajosana <[email-masked]<mailto:[email-masked]>> wrote:
Dear Samita, all,

I support the adoption of this document. I consider necessary a use case document that can be used as reference, presenting the current status and technologies that support 6lo. I would like to see there the features of 6lo that are supported and those that are not for the different underlying technologies, information about the current level of maturity and examples of existing deployments.

I also support the inclusion of a use case describing the use of 6lo in the context of 6TiSCH.

kind regards,
Xavi

2016-09-21 20:00 GMT+02:00 samita Chakrabarti <[email-masked]<mailto:[email-masked]>>:
Hello Folks:

We have discussed this document several times and Young-Geun Hong had presented this document several times at IETF and the WG also met separately to discuss the use cases and format of the document. We concluded that the purpose of this document is to show others how 6lo stacks can be used in different applications and on L2 constrained networks. The information can be used by external organizations as a guideline of examples for understanding whether their networks can be suitable to run 6lo stacks. Many have been co-authored/contributed to this document already.

Thanks,
Gabriel and Samita
6lo-co chairs

_______________________________________________
6lo mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6lo

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 7 Oct 2016 06:56:43 +0000

I support the adoption, Samita, as I recognize the need and value;

at the same time this document is a lot less mature than others I have seen at adoption time, and I see a need for experts in various areas to contribute. I hope that the adoption will increase their motivation; maybe we'll try the pull method if we are lacking voluteers. Also I'd suggest we consider the detnet use case draft as a reference of what we want to achieve; Ethan is doing a fabulous editorial work there, and the group is not afraid of welcoming a wealth of authors from many fields:

Name:                  draft-ietf-detnet-use-cases

Revision:              11

Title:                      Deterministic Networking Use Cases

Document date:               2016-10-03

Group:                  detnet

Pages:                   79

URL:            https://www.ietf.org/internet-drafts/draft-ietf-detnet-use-cases-11.txt

Status:         https://datatracker.ietf.org/doc/draft-ietf-detnet-use-cases/

Htmlized:       https://tools.ietf.org/html/draft-ietf-detnet-use-cases-11

Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-detnet-use-cases-11

All the best,

Pascal

From: 6lo [mailto:[email-masked]] On Behalf Of samita Chakrabarti
Sent: mercredi 21 septembre 2016 20:00
To: 'lo' <[email-masked]>
Subject: [6lo] Adoption call for 6lo Applicability and Usecases

Hello Folks:

Thanks,
Gabriel and Samita
6lo-co chairs

---

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 7 Oct 2016 17:19:41 -0700

Thanks Pascal for your comments and pointers.
I agree about the improvement of maturity of the document and the
co-authors should consult your suggestions.

Regards,
-Samita

On Thu, Oct 6, 2016 at 11:56 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> at the same time this document is a lot less mature than others I have
> seen at adoption time, and I see a need for experts in various areas to
> contribute. I hope that the adoption will increase their motivation; maybe
> we’ll try the pull method if we are lacking voluteers. Also I’d suggest we
> consider the detnet use case draft as a reference of what we want to
> achieve; Ethan is doing a fabulous editorial work there, and the group is
> not afraid of welcoming a wealth of authors from many fields:
>
>
>
>
>
> URL:            https://www.ietf.org/internet-
> drafts/draft-ietf-detnet-use-cases-11.txt
>
> *From:* 6lo [mailto:[email-masked]] *On Behalf Of *samita
> Chakrabarti
> *Sent:* mercredi 21 septembre 2016 20:00
> *To:* 'lo' <[email-masked]>
> *Subject:* [6lo] Adoption call for 6lo Applicability and Usecases
>
>
>
> Hello Folks:
>
>
>

---

From: Yong-Geun Hong <[email-masked]>
Date: Sat, 8 Oct 2016 09:26:06 +0900

Dear Pascal, Samita, and others.

Thanks for valuable comments.

I also agree the comments and they will be helpful to improve this document.
We will apply these comments.

Best regards.

YongGeun.

---

From: Take Aanstoot <[email-masked]>
Date: Sat, 8 Oct 2016 11:20:47 +0200

Dear People,

Without the deep technical knowledge as you other people I want to give
some feedback from the field where we today are trapped in a nightmare of
standards, telco-standards and "standards". We work with wireless, plc and
rs485, knx, profibus, M-bus and what have you.

This is my first post to an IETF mailinglist so please if someone wants to
guide me on the proper way to submit parts of this if it is not totally
bogus.

The draft is a really nice oversight over 6lo in diverse use-cases, really
nice as a quick reference on where to continue. We (modio) will probably
make a flowchart thing based on this document and rfc6568 where you can put
in your use-case and based on that get to know what could be appropriate
6lo-solutions instead of today's old standards and de facto standards.

I am missing the following chapters, even though the standards are not
there yet I feel it should be mentioned so they will not be forgotten.

6loPLC, now primarily G3-PLC and Prime, needs a chapter in 3.foo and 6.foo

LPWAN on low frequency (somewhere between 60-600 Mhz).

People are testing nowadays in Europe on the following available
frequencies:
-2.4GHz, crowded, short range, crowded, worldwide, crowded, poor
penetration, crowded.
-868 MHz, getting crowded, only 20kHz, poor hardware support.
-433MHz (and in some countries other small bands between 398 - 465 MHz),
long range, reliable, few channels, frequency allocations are specific to
particular countries, 10kbit/s, still expensive modules.
27 and 40MHz HF, cheap, simple, long range, crowded, low data rates,
crowded, large antennas needed

For LPWAN to succeed we need more frequencies, both public ones and private
ones booked through your local radio frequency authority. This should be
named in the draft and also recommendations of what type of radio to run on
these frequencies.
It would be nice to state in this draft that in most part of the world
174-230 MHz VHF is more or less empty or run a very deprecated radio
broadcasting standard which will probably be decommissioned during the next
few years and that it would be nice to reserve a big part of it for IoT
use, both public and bookable/buyable private channels. That would be the
difference between happy go lucky LPWAN on existing channels and a
worldwide break through for reliable serious applications LPWAN.

5 Design space:
New bullet:
Update firmware requirements: Most 6 lo uses case will need a mechanism for
updating firmware. In these cases support for over the are updates are
required, probably in a broadcast mode when bandwith is low and the number
of identical devices is high.

Security Requirements: (Actual text: Some 6lo use case can transfer some
important and personal data between 6lo nodes.  In this case, high-level
security support is required.)
6lo will be used for important data between nodes, eventually someone will
also know how to make today's not important data very important. High level
security support is required.

6.4 use case of MS/TP
I can probably write something there if interest exists.

6.6 use case of LTE MTC
Mentions LTE MTC very briefly and then talks mostly about LoRa. Mayby
change topic.

Are you still with me?
Regards, Take

-- 
Take Aanstoot
CEO
Modio AB
+254 70 646 2344
+46 13 46 555 62
[email-masked]

---

From: Yong-Geun Hong <[email-masked]>
Date: Mon, 10 Oct 2016 11:28:23 +0900

Dear Take Aanstoot.

Thanks for your valuable comments.

See my response in line.

Best regards.

YongGeun.

> 6loPLC, now primarily G3-PLC and Prime, needs a chapter in 3.foo and 6.foo
[YongGeun] I remember that there was an internet draft of IPv6 over PLC and
a standardization activity in the 6lo WG.
                   Yes, we can consider possible link layer technologies
for 6lo and PLC could be a candidate.
                   It will be great to help to add relevant contents.

> For LPWAN to succeed we need more frequencies, both public ones and
> private ones booked through your local radio frequency authority. This
> should be named in the draft and also recommendations of what type of radio
> to run on these frequencies.
> [YongGeun] Personally, I agree your points.
                   As you know, new lpwan working group will be made and
lpwan working group is also related to this issues. So we need to discuss
how  to handle the issues.

>
> 5 Design space:
> New bullet:
> Update firmware requirements: Most 6 lo uses case will need a mechanism
> for updating firmware. In these cases support for over the are updates are
> [YongGeun] Great. We can add these design space in a next revision.

> I can probably write something there if interest exists.
 [YongGeun] Thanks for your help.

> Mentions LTE MTC very briefly and then talks mostly about LoRa. Mayby
[YongGeun] O.K. We will update this sections according to the current
status.

---

From: "samita Chakrabarti" <[email-masked]>
Date: Mon, 10 Oct 2016 15:50:03 -0700

Hi Take,

It is great to hear from you on the 6lo list. Input from practical deployment is quite valuable especially if your organization is considering  6lo stack. 

There are couple of ways to contribute:

1)      Providing suggested text on the draft and working with the co-authors and 6lo-chairs  to update the document

OR

2)      Writing a separate short draft with the suggested texts or use-case scenarios  which can be used as the input to the 6lo Applicability & usecase document

I know  we talked sometime ago off-line, if you have any further questions let me and Gabriel know.

Regards,

-Samita

From: Take Aanstoot [mailto:[email-masked]] 
Sent: Saturday, October 8, 2016 2:21 AM
To: Yong-Geun Hong <[email-masked]>
Cc: Samita Chakrabarti <[email-masked]>; Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
Subject: Re: [6lo] Adoption call for 6lo Applicability and Usecases

Dear People,

Without the deep technical knowledge as you other people I want to give some feedback from the field where we today are trapped in a nightmare of standards, telco-standards and "standards". We work with wireless, plc and rs485, knx, profibus, M-bus and what have you. 

This is my first post to an IETF mailinglist so please if someone wants to guide me on the proper way to submit parts of this if it is not totally bogus.

The draft is a really nice oversight over 6lo in diverse use-cases, really nice as a quick reference on where to continue. We (modio) will probably make a flowchart thing based on this document and rfc6568 where you can put in your use-case and based on that get to know what could be appropriate 6lo-solutions instead of today's old standards and de facto standards. 

I am missing the following chapters, even though the standards are not there yet I feel it should be mentioned so they will not be forgotten.

People are testing nowadays in Europe on the following available frequencies: 
-2.4GHz, crowded, short range, crowded, worldwide, crowded, poor penetration, crowded.

-433MHz (and in some countries other small bands between 398 - 465 MHz), long range, reliable, few channels, frequency allocations are specific to particular countries, 10kbit/s, still expensive modules.

27 and 40MHz HF, cheap, simple, long range, crowded, low data rates, crowded, large antennas needed

For LPWAN to succeed we need more frequencies, both public ones and private ones booked through your local radio frequency authority. This should be named in the draft and also recommendations of what type of radio to run on these frequencies. 

It would be nice to state in this draft that in most part of the world 174-230 MHz VHF is more or less empty or run a very deprecated radio broadcasting standard which will probably be decommissioned during the next few years and that it would be nice to reserve a big part of it for IoT use, both public and bookable/buyable private channels. That would be the difference between happy go lucky LPWAN on existing channels and a worldwide break through for reliable serious applications LPWAN.

5 Design space:

New bullet:

Update firmware requirements: Most 6 lo uses case will need a mechanism for updating firmware. In these cases support for over the are updates are required, probably in a broadcast mode when bandwith is low and the number of identical devices is high.  

Security Requirements: (Actual text: Some 6lo use case can transfer some important and personal data between 6lo nodes.  In this case, high-level security support is required.) 
6lo will be used for important data between nodes, eventually someone will also know how to make today's not important data very important. High level security support is required. 

6.4 use case of MS/TP

6.6 use case of LTE MTC

Mentions LTE MTC very briefly and then talks mostly about LoRa. Mayby change topic.

Are you still with me? 

Regards, Take

-- 

Take Aanstoot

CEO 

Modio AB
+254 70 646 2344
+46 13 46 555 62

[email-masked] <mailto:[email-masked]>

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Mon, 10 Oct 2016 21:05:27 -0300

I agree on the adoption of the document.
Regards,

                    Diego

2016-10-10 19:50 GMT-03:00 samita Chakrabarti <[email-masked]>:

> Hi Take,
>
>
>
> It is great to hear from you on the 6lo list. Input from practical
> deployment is quite valuable especially if your organization is considering
>  6lo stack.
>
> 1)      Providing suggested text on the draft and working with the
> co-authors and 6lo-chairs  to update the document
>
> OR
>
> 2)      Writing a separate short draft with the suggested texts or
> use-case scenarios  which can be used as the input to the 6lo Applicability
> & usecase document
>
>
>
> *From:* Take Aanstoot [mailto:[email-masked]]
> *Sent:* Saturday, October 8, 2016 2:21 AM
> *To:* Yong-Geun Hong <[email-masked]>
> *Cc:* Samita Chakrabarti <[email-masked]>; Pascal Thubert
> (pthubert) <[email-masked]>; [email-masked]
> *Subject:* Re: [6lo] Adoption call for 6lo Applicability and Usecases
>
>
>
> Dear People,
>

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125