Subject: [6lowpan] 6LoWPAN-ND - ID Context dissemination for battery-powered nodes

From: "Anders Brandt" <[email-masked]>
Date: Wed, 27 Jan 2010 12:46:04 +0100

Hi Zach et al.

I would like to propose a little add-on feature
for the distribution of updated context IDs for IP header compression:

A sleeping node may ask the router for a summary, say once every 6
hours.
In most cases, the summary is the same. Thus, a summary is sufficient.

I think you at some informal discussion suggested to use the code field
of the RS.

We could use it to indicate that the node just wants the summary -
not all 16 information options.

Result: Battery saved. Bandwidth saved.

Thus, the proposal is:

1) Use the code field of the RS to indicate the amount of info required.
  a)  Code = 0 (normal) means I want to have a full RS (all prefix
options)
  b)  Code = 1 means I want to get only the summary option

RFC4861 excerpt:
> 4.1.  Router Solicitation Message Format
> 
>   Hosts send Router Solicitations in order to prompt routers to
>   generate Router Advertisements quickly.
> 
>      0                   1                   2                   3
>      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>     |     Type      |     Code      |          Checksum             |
>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>     |                            Reserved                           |
>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>     |   Options ...
>     +-+-+-+-+-+-+-+-+-+-+-+-

Thanks,
  Anders

---

From: "Anders Brandt" <[email-masked]>
Date: Wed, 27 Jan 2010 14:13:42 +0100

Hi Zach et al.

While not sure what you end up doing in the next revision of ND, I have
got the impression that node registration is mandatory.

I suggest that use of the registration/confirmation mechanism is
optional
so that nodes must use it if a capable ER router is present but nodes
can
run happily without if there is no ER. The last text I saw did not say
so.

The extreme use case here is the "Home Control starter set" consisting
of a
remote control and three plug-in modules.
The remote control is the master of the network; used for inclusion of
the
three plug-in modules. A unique local IPv6 subnet is communicated to
each
module and then the remote control goes to sleep.

>From this moment the remote control only wakes up when a user presses a
button.
The modules will get the notion of the phrase "in space, no one can hear
you scream"...
Periodic use of node registration does not make sense in this use case.

Just my $0.05

- Anders

---

From: Zach Shelby <[email-masked]>
Date: Wed, 27 Jan 2010 16:19:26 +0200

Anders,

> got the impression that node registration is mandatory.

Here is a micro-summary:

The -08 version no longer differentiates Edge Routers and Routers when it comes to registration. Instead, the NR/NC exchange is only made link-locally between a node and the router its default router. That router may be an Edge Router. There is no longer the concept of an Extended LoWPAN or Whiteboard in this draft, and NR messages are not relayed.

Yes, this Node Registration must be performed for a node to use a router. This is important because that message exchange builds up the necessary information on both sides for address resolution, unreachability detection and for a node to check that its address is unique. 

> run happily without if there is no ER. The last text I saw did not say

Like I summarized above, there is no longer an ER role. Every router is capable of answering a registration.

This registration is soft, and must be refreshed periodically. But this does not mean an exchange every second or even hour. The current Binding Lifetime field can be from 10 seconds to a week. If we feel that is too short, we could easily extend that up to a month or so. 

We are also exploring a way for that binding refresh to be possible using other traffic, such as routing protocol signaling between routers, to avoid sending NRs when not necessary. 

> Periodic use of node registration does not make sense in this use case.

Is it a problem if a node needs to register once a week or month to tell that they are still alive with an NR? We could even make it possible to make an "indefinite binding time" for you if that makes sense in this kind of very limited, fixed case. 

Zach 

-- 
http://www.sensinode.com
http://zachshelby.org - My blog "On the Internet of Things"
http://6lowpan.net - New book - "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

Zach Shelby
Head of Research
Sensinode Ltd.
Kidekuja 2
88610 Vuokatti, FINLAND

This e-mail and all attached material are confidential and may contain legally privileged information. If you are not the intended recipient, please contact the sender and delete the e-mail from your system without producing, distributing or retaining copies thereof.

---

From: "Anders Brandt" <[email-masked]>
Date: Wed, 27 Jan 2010 16:13:20 +0100

An infinite period should work ok.

Thanks.

-----Oprindelig meddelelse-----
Fra: Zach Shelby [mailto:[email-masked]]
Sendt: on 27-01-2010 15:19
Til: Anders Brandt
Cc: 6lowpan
Emne: Re: 6LoWPAN-ND - Use of node registration should be optional
 
Anders,

Here is a micro-summary:

Zach 

Zach Shelby
Head of Research
Sensinode Ltd.
Kidekuja 2
88610 Vuokatti, FINLAND