Subject: [6lowpan] Clarification on HC-07 Next header

From: Jonathan Simon <[email-masked]>
Date: Wed, 14 Apr 2010 14:36:01 -0700

Forgive me if this is a stupid question - is the compressed UDP header
described in section 4.3 of HC-07 intended to always follow the IPv6
Extension Header in section 4.2, or replace it if no other extension header
is used?
-- 
Jonathan Simon, Ph. D
Director of Systems Engineering
Dust Networks
30695 Huntwood Ave
Hayward, CA 94544-7021
(510) 400-2936
(510) 489-3799 FAX
[email-masked]

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 15 Apr 2010 08:55:53 +0200

Hi Jonathan:

Replace is the answer. Section 4 referred in 3.1.1 includes UDP.
The trick is the series of 1s followed by a 0. The number of 1s indicate
what we are doing.
3 ones is a compressed next header for one of the headers listed.
4 ones is UDP. 
0, 1 and 2 ones are reserved so far. Probably for a transport, but could
be another sort of header.

Cheers,

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Jonathan Simon
> Sent: Wednesday, April 14, 2010 11:36 PM
> To: [email-masked]
> Subject: [6lowpan] Clarification on HC-07 Next header
> 
> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan