Subject: Re: [6lowpan] WGLC for 6lowpan HC draft

From: "Samita Chakrabarti" <[email-masked]>
Date: Tue, 1 Jun 2010 15:40:13 -0700

I support this fine document.

One question : is it mandatory to implement all HC encoding/decoding for all
the cases defined in this draft?  Does it plan to handle any error code when
one implementation supports the full draft and the other one partially and
the lowpan-hc encoded packet is not fully understood by the recipient.

Would like to see this point clarified in the draft.

Thanks,
-Samita

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Geoff Mulligan
> Sent: Monday, May 24, 2010 1:03 PM
> To: 6lowpan
> Subject: [6lowpan] WGLC for 6lowpan HC draft
> 
> As there some discussion and changes to the HC draft we will have one more
> LC for the HC draft.  I think think that we need 4 weeks so I proposed
that
> this LC will last one week.
> 
>   This note formally starts the WG Last Call for comments on draft-ietf-
> 6lowpan-hc-07, "Compression Format for IPv6 Datagrams in 6LoWPAN
Networks".
> 
> The document can be found at:
> http://www.ietf.org/id/draft-ietf-6lowpan-hc-07.txt
> 
> The document is intended to be submitted by this Working Group to the IESG
> for publication as a Standards Track document.
> 
> Please review the document carefully (one last time), and send your
comments
> to the 6lowpan list.  Please also indicate in your response whether or not
> you think this document is ready to go to the IESG.
> 
> This Last Call will end Wednesday May 31 2010 at 2359 UTC.
> 
>         Thanks,
>                 Geoff
> 
> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 10 Jun 2010 08:19:02 +0200

Hi Geoff:

I understand that the last call is now complete for HC. Do you think it
is ready for the IESG?

Pascal

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Geoff Mulligan
> Sent: Monday, May 24, 2010 10:03 PM
> To: 6lowpan
that
> The document is intended to be submitted by this Working Group to the
> IESG for publication as a Standards Track document.
> 
> comments to the 6lowpan list.  Please also indicate in your response
whether
> or not you think this document is ready to go to the IESG.
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 10 Jun 2010 08:25:13 +0200

Hi Samita:

For all I know, standards such as ISA100.11a or ZigbeeIP will pick and
choose tools from the IETF box and specify which exact part they need
and use, like what they put in the context info, etc...
For HC, they are free to define a subset of the draft that's required
for conformance and leave the rest out. 
For instance ISA100.11a does not derive the global addresses from EUI64
and only cares for stateful compression.
An implementation that wishes to play in many environments had better
support the whole thing though.

Pascal

> Behalf Of Samita Chakrabarti
> Sent: Wednesday, June 02, 2010 12:40 AM
> To: 'Geoff Mulligan'; '6lowpan'
> Subject: Re: [6lowpan] WGLC for 6lowpan HC draft
> 
> > As there some discussion and changes to the HC draft we will have
one
> > more LC for the HC draft.  I think think that we need 4 weeks so I
> > proposed
> that
> >   This note formally starts the WG Last Call for comments on
> > draft-ietf- 6lowpan-hc-07, "Compression Format for IPv6 Datagrams in
> > 6LoWPAN
> Networks".
> >
> > to the 6lowpan list.  Please also indicate in your response whether
or
> > not you think this document is ready to go to the IESG.
> >

---

From: "Samita Chakrabarti" <[email-masked]>
Date: Thu, 10 Jun 2010 08:44:02 -0700

Hi Pascal,

Thanks for the explanation. So, I understand that the respective SDOs can
pick and choose the features from IETF for interoperability of the SDO
certified/compliant product but from IETF document perspective, if one wants
to implement the HC draft without targeting a particular SDO, then should
all the features in HC draft be implemented?  

-Samita

> From: Pascal Thubert (pthubert) [mailto:[email-masked]]
> Sent: Wednesday, June 09, 2010 11:25 PM
> To: Samita Chakrabarti; Geoff Mulligan; 6lowpan
> Subject: RE: [6lowpan] WGLC for 6lowpan HC draft
> 
> Hi Samita:
> 
> choose tools from the IETF box and specify which exact part they need and
> use, like what they put in the context info, etc...
> For HC, they are free to define a subset of the draft that's required for
> conformance and leave the rest out.
and
> only cares for stateful compression.