Subject: [6tisch-security] future meetings

From: Michael Richardson <[email-masked]>
Date: Tue, 21 Jun 2016 12:57:29 -0400

I have created a doodle poll for a new meeting time.
4 said they preferred the current time, including the chairs (who are
motivated to be flexible...)
4 days provided various degrees of it not being a good time.

Here is a new doodle poll:
     https://doodle.com/poll/y8vgcnxca5dychke

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Thomas Watteyne <[email-masked]>
Date: Thu, 23 Jun 2016 07:06:15 +0200

Michael,
Thanks, I filed it in. THese choices are just for next week, I'm traveling
on Tuesday and Friday, but don't reflect my general availability over the
different other weeks.
Thomas

On Tue, Jun 21, 2016 at 6:57 PM, Michael Richardson <[email-masked]>
wrote:

> _______________________________________________
> 6tisch-security mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch-security
>

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 24 Jun 2016 16:19:19 +0200

All,
It's really important we get your feedback on the poll. Please fill it in.
Thanks,
Thomas

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: Michael Richardson <[email-masked]>
Date: Sun, 26 Jun 2016 20:49:57 -0400

Thomas Watteyne <[email-masked]> wrote:
    > All, It's really important we get your feedback on the poll. Please
    > fill it in.  Thanks, Thomas

Based upon current feedback, I've selected Wednesday at 11am EDT.
That's 1500UTC.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 27 Jun 2016 06:07:56 +0200

Thanks Michael for coordinating!

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: Göran Selander <[email-masked]>
Date: Mon, 27 Jun 2016 12:31:05 +0000

From the minutes of last 6tisch interim meeting:

>  [Pascal] it would be good to have text to see what we want to achieve in the security design team

+1

I have read the charter and what I believe are the relevant drafts, participated in the meetings and followed the mail discussion, but I still haven’t grasped the scope/requirements of the security work. I get the impression that there is more than one target deployment and find it difficult to weigh these different deployment requirements against each other.

I’m not necessary looking for a draft on security requirements, but just expanding on the charter would be very useful at least for me. Some examples of what such a text may cover (inspired by the discussion since last f2f meeting):

  *   Do we want to support only one set of initial bootstrap credentials (PSK/RPK/Certs) or are multiple allowed / is some disallowed?
  *   Do we want to support a common solution for bootstrapping independent of initial credentials, or different solutions for different initial credentials?
  *   Is only zero-touch going to be supported or are different deployment procedures allowed / is some disallowed?
  *   Can we summarise the bootstrap procedure in phases and describe what security is assumed/achieved in the start/end states of each phase?
  *   Do we want to support security bootstrap before IP?
  *   Do we want to support/require forward secrecy for certain keys obtained through the bootstrapping procedure ?

Göran

From: 6tisch-security <[email-masked]<mailto:[email-masked]>> on behalf of Thomas Watteyne <[email-masked]<mailto:[email-masked]>>
Date: Friday 24 June 2016 at 16:19
To: Michael Richardson <[email-masked]<mailto:[email-masked]>>
Cc: tisch-security <[email-masked]<mailto:[email-masked]>>
Subject: Re: [6tisch-security] future meetings

All,

On Thu, Jun 23, 2016 at 7:06 AM, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> wrote:
Michael,
Thanks, I filed it in. THese choices are just for next week, I'm traveling on Tuesday and Friday, but don't reflect my general availability over the different other weeks.
Thomas

On Tue, Jun 21, 2016 at 6:57 PM, Michael Richardson <[email-masked]<mailto:[email-masked]>> wrote:

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]<mailto:[email-masked]>  http://www.sandelman.ca/        |   ruby on rails    [

_______________________________________________
6tisch-security mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch-security

Thomas Watteyne, PhD

www.thomaswatteyne.com<http://www.thomaswatteyne.com>
_______________________________________

Thomas Watteyne, PhD

www.thomaswatteyne.com<http://www.thomaswatteyne.com>
_______________________________________

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 29 Jun 2016 16:03:33 +0200

I cannot find the link to the session we use for the 6TiSCH-security call.
Can someone send it to me?

On Mon, Jun 27, 2016 at 2:31 PM, Göran Selander <[email-masked]

> *>  [Pascal]* it would be good to have text to see what we want to
> achieve in the security design team
>
> +1
>
> I have read the charter and what I believe are the relevant drafts,
> participated in the meetings and followed the mail discussion, but I still
> haven’t grasped the scope/requirements of the security work. I get the
> impression that there is more than one target deployment and find it
> difficult to weigh these different deployment requirements against each
> other.
>
> I’m not necessary looking for a draft on security requirements, but just
> expanding on the charter would be very useful at least for me. Some
> examples of what such a text may cover (inspired by the discussion since
> last f2f meeting):
>
>    - Do we want to support only one set of initial bootstrap credentials
>    (PSK/RPK/Certs) or are multiple allowed / is some disallowed?
>    - Do we want to support a common solution for bootstrapping
>    independent of initial credentials, or different solutions for different
>    initial credentials?
>    - Is only zero-touch going to be supported or are different deployment
>    procedures allowed / is some disallowed?
>    - Can we summarise the bootstrap procedure in phases and describe what
>    security is assumed/achieved in the start/end states of each phase?
>    - Do we want to support security bootstrap before IP?
>    - Do we want to support/require forward secrecy for certain keys
>    obtained through the bootstrapping procedure ?
>
>
> Göran
>
>
>
> From: 6tisch-security <[email-masked]> on behalf of
> Thomas Watteyne <[email-masked]>
> To: Michael Richardson <[email-masked]>
> Cc: tisch-security <[email-masked]>
> On Thu, Jun 23, 2016 at 7:06 AM, Thomas Watteyne <[email-masked]
> > wrote:
>
>> Michael,
>> Thanks, I filed it in. THese choices are just for next week, I'm
>> traveling on Tuesday and Friday, but don't reflect my general availability
>> over the different other weeks.
>> Thomas
>>

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 29 Jun 2016 16:06:32 +0200

I found it. https://jitsi.tools.ietf.org/6tischSecurity. Call ongoing,
please join.

On Wed, Jun 29, 2016 at 4:03 PM, Thomas Watteyne <[email-masked]>
wrote:

> On Mon, Jun 27, 2016 at 2:31 PM, Göran Selander <
> [email-masked]> wrote:
>
>>    - Is only zero-touch going to be supported or are different
>>    deployment procedures allowed / is some disallowed?
>>    - Can we summarise the bootstrap procedure in phases and describe
>>    what security is assumed/achieved in the start/end states of each phase?
>> On Thu, Jun 23, 2016 at 7:06 AM, Thomas Watteyne <
>> [email-masked]> wrote:
>>
>>> Michael,

Thomas Watteyne, PhD

www.thomaswatteyne.com