Subject: [6tisch] on bundles and tracks

From: Thomas Watteyne <[email-masked]>
Date: Tue, 8 Apr 2014 19:22:53 -0700

[as agreed, CC'ing the 6TiSCH ML]

All,

To summarize the discussion below, we are debating the definition of
bundle, in particular the relationship between "bundle" and "track".

Allow me to summarize (jump in of I'm wrong or unclear).

Let's imagine the following topology:

A--\          /--D
    \        /
     B======C
    /        \
E--/          \--F

I tried to represent each track by a line. So we have two tracks:

   - track 1: A-B-C-D
   - track 2: E-B-C-F

This means that, between B and C, there are some cells belonging to track
1, and some to track 2.

The question is which definitions for bundle to use:

   - the bundle contains all cells trom track 1 and track 2; there is only
   one bundle between B and C
   - there are two bundles between B and C: one containing the cells from
   track 1, one containing the cells of track 2.

Votes are open!
Thomas

On Mon, Apr 7, 2014 at 1:57 AM, Nicola Accettura <[email-masked]>wrote:

> Ok also from my side.
> Nicola
>
>
> 2014-04-07 8:38 GMT+02:00 Maria Rita PALATTELLA <
> [email-masked]>:
>
>   Sure Thomas, no problem, you can share with the ML, unless what I said
>> was totally wrong :D (joking...)
>>
>> Maria Rita
>>
>>
>>
>>
>>
>> *From:* Grieco [mailto:[email-masked]]
>> *Sent:* Sunday, April 06, 2014 4:17 PM
>> *To:* Pascal Thubert (pthubert)
>> *Cc:* Prof. Diego Dujovne; Thomas Watteyne; Maria Rita PALATTELLA;
>> 'Nicola Accettura' ([email-masked])
>> *Subject:* Re: OTF events.pptx
>>
>>
>>
>> Yes. Thanks. Al
>>
>> --
>>
>> Luigi Alfredo Grieco, PhD
>>
>> Assistant Professor
>>
>> Department of Electrical and Information Engineering
>>
>> Politecnico di Bari
>>
>> Via Orabona 4 - 70125 - Bari - Italy
>>
>> +39 080 5963 911
>>
>> telematics.poliba.it/grieco
>>
>> Skype id: l.alfredo.grieco
>>
>> Mobile: +39 3346715672
>>
>>
>>
>>
>> Il giorno 6 Apr 2014, alle ore 06:15, "Pascal Thubert (pthubert)" <
>> [email-masked]> ha scritto:
>>
>>  Yes!
>>
>>
>>
>> Cheers,
>>
>>
>>
>> Pascal
>>
>>
>>
>> *From:* Prof. Diego Dujovne [mailto:[email-masked]<[email-masked]>]
>>
>> *Sent:* dimanche 6 avril 2014 05:11
>> *To:* Thomas Watteyne
>> *Cc:* Maria Rita PALATTELLA; Pascal Thubert (pthubert);
>> [email-masked]; 'Nicola Accettura' ([email-masked])
>> *Subject:* Re: OTF events.pptx
>>
>>
>>
>> Dear all,
>>
>>              It is OK for me.
>>
>> Regards,
>>
>>                      Diego
>>
>>
>>
>> 2014-04-05 21:37 GMT-03:00 Thomas Watteyne <[email-masked]>:
>>
>> All,
>>
>> This issue is more general than this private e-mail thread.
>>
>> Do you agree for me to CC the 6TiSCH ML? A quick "yes" is enough.
>>
>> Thomas
>>
>>
>>
>> On Fri, Apr 4, 2014 at 1:39 AM, Maria Rita PALATTELLA <
>> [email-masked]> wrote:
>>
>> Sorry Pascal,
>>
>> But it is not clear to me L
>>
>> How can we have only Bundle B at L2, if there are more than one track on
>> that link? We are not summing up bundles belonging to different tracks...so
>> how the node will know what bundle should consider, if we do not specify
>> the track?
>>
>> Maria Rita
>>
>>
>>
>> *From:* Pascal Thubert (pthubert) [mailto:[email-masked]]
>> *Sent:* Friday, April 04, 2014 10:28 AM
>> *To:* Maria Rita PALATTELLA; Thomas Watteyne
>>
>>
>> *Cc:* [email-masked]; Prof. Diego Dujovne (
>> [email-masked]); 'Nicola Accettura' ([email-masked])
>> *Subject:* RE: OTF events.pptx
>>
>>
>>
>> Hi Maria-Rita:
>>
>>
>>
>> I think it's a matter of perspective. A bundle is a concept that is
>> shared between 2 adjacent nodes and maybe known to a PCE/NME, but is
>> unknown from the rest of the world.
>>
>> From the perspective of either of these 2 nodes, there is a single bundle
>> B, and it is either a L3 (IP) link used for RPL traffic, or a L2 link
>> associated to one track, e.g. track 1 or track 2 but not both.
>>
>>
>>
>> Cheers,
>>
>>
>>
>> Pascal
>>
>>
>>
>> *From:* Maria Rita PALATTELLA [mailto:[email-masked]<[email-masked]>]
>>
>> *Sent:* vendredi 4 avril 2014 10:13
>> *To:* Pascal Thubert (pthubert); Thomas Watteyne
>> *Cc:* [email-masked]; Prof. Diego Dujovne (
>> [email-masked]); 'Nicola Accettura' ([email-masked])
>> *Subject:* RE: OTF events.pptx
>>
>>
>>
>> Uhmmm...
>>
>> But how do you distinguish bundle B on Track T1, from Bundle B on track2?
>>
>> I mean, a bundle will be identified by the couple of nodes (in the
>> example below C-D), and by the TrackID to which it belongs ...
>>
>> Am I missing something?
>>
>> Maria Rita
>>
>>
>>
>> *From:* Pascal Thubert (pthubert) [mailto:[email-masked]<[email-masked]>]
>>
>> *Sent:* Friday, April 04, 2014 10:09 AM
>> *To:* Thomas Watteyne; Maria Rita PALATTELLA
>> *Cc:* [email-masked]; Prof. Diego Dujovne (
>> [email-masked]); 'Nicola Accettura' ([email-masked])
>> *Subject:* RE: OTF events.pptx
>>
>>
>>
>> I do J
>>
>>
>>
>> Cheers,
>>
>>
>>
>> Pascal
>>
>>
>>
>> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
>> *On Behalf Of *Thomas Watteyne
>> *Sent:* vendredi 4 avril 2014 08:25
>> *To:* Maria Rita PALATTELLA
>> *Cc:* [email-masked]; Prof. Diego Dujovne (
>> [email-masked]); 'Nicola Accettura' ([email-masked]);
>> Pascal Thubert (pthubert)
>> *Subject:* Re: OTF events.pptx
>>
>>
>>
>> Maria Rita,
>>
>>
>>
>> I absolutely understand and agree with this. In fact, since we agree
>> that, between two nodes, there are as many bundles as tracks that go
>> through this node, then we could just talk about "bundle B" rather than
>> "bundle B on track T", the "on track T" part being redundant.
>>
>>
>>
>> Do we agree on that?
>>
>>
>>
>> Thomas
>>
>>
>>
>> On Thu, Apr 3, 2014 at 6:32 AM, Maria Rita PALATTELLA <
>> [email-masked]> wrote:
>>
>> Dear Thomas, you are not a pain at all ;) Don't worry!
>>
>> Let's consider the example  below.
>>
>> A==>\         /==>E
>>
>>      \       /
>>
>>       C====>D
>>
>>      /       \
>>
>> B==>/         \==>F
>>
>>
>>
>>
>>
>> And let's consider  two tracks: Track1: A-C-D-F and  Track2: B-C-D-E.
>>
>> The soft cells reserved between the node C and D do not belong to 1
>> single bundle, but to two different bundles: one along the track1, and one
>> along the Track2.
>>
>> Because cells belonging to different bundles (i.e., bundles along
>> different tracks, those on Track1 and those on Track2) are not summed up
>> together, we need to specify the TrackID.
>>
>> Otherwise we cannot know the specific bundle we are referring to.
>>
>> Hope this time I have explained things better.
>>
>>
>>
>> PS: sorry all again for having left the meeting yesterday before the end,
>> but I had to run and take my little boy, before they leave him outside the
>> nursery J Thanks for your understanding. Looking forward to reading the
>> minutes, and knowing about the rest of the discussion.
>>
>>
>>
>>
>> ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>> From: *Thomas Watteyne* <[email-masked]>
>> Date: 2014-04-03 0:33 GMT+02:00
>> Subject: Re: OTF events.pptx
>> To: Alfredo Grieco <[email-masked]>
>> Cc: "Prof. Diego Dujovne" <[email-masked]>, Maria Rita
>> Palattella <[email-masked]>, Nicola Accettura <
>> [email-masked]>, "Pascal Thubert (pthubert) ([email-masked])"
>> <[email-masked]>
>>
>> Alfredo, thanks.
>>
>>
>>
>> Now I get confused. *Maria Rita*, a bundle is already naturally
>> associated with one trackID, right? Why specifying "bundle B on track T",
>> isn't "bundle B" enough, if we know that bundle B is on track T?
>>
>>
>>
>> Sorry to be a pain, I'd really like us to converge on all of that
>> terminology...
>>
>>
>>
>> Thomas
>>
>>
>>
>> On Wed, Apr 2, 2014 at 9:03 AM, Alfredo Grieco <[email-masked]>
>> wrote:
>>
>> hi all,
>>
>> please find enclosed my updated slides after the today's otf call
>>
>> any comments ?
>>
>> cheers and thanks
>>
>> Al
>>
>> --
>> Luigi Alfredo Grieco, PhD
>> Assistant Professor
>> Dep. of Electrical and Information Engineering (DEI)
>> Politecnico di Bari
>> Via Orabona, 4
>> 70125 - Bari - Italy
>> Phone: +39 080 5963 911
>> url: telematics.poliba.it
>> mail: [email-masked]
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> --
>> DIEGO DUJOVNE
>> Académico Escuela de Ingeniería en Informática y Telecomunicaciones
>> Facultad de Ingeniería UDP
>> www.ingenieria.udp.cl
>> (56 2) 676 8125
>>
>>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 9 Apr 2014 08:48:18 +0000

Hi Thomas:

My understanding is that a bundle is a set of cells that together provide the resources for a direction of a link. In you example, there are two layer-2 links, thus two bundles.
Best effort IP traffic routed by B and for which C is the next hop router would be forwarded over a Layer-3 link between the B and C, and that will be yet another bundle.

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: mercredi 9 avril 2014 05:23
To: [email-masked]
Subject: [6tisch] on bundles and tracks

All,

To summarize the discussion below, we are debating the definition of bundle, in particular the relationship between "bundle" and "track".

A--\          /--D
    \        /
     B======C
    /        \
E--/          \--F

  *   track 1: A-B-C-D
  *   track 2: E-B-C-F
This means that, between B and C, there are some cells belonging to track 1, and some to track 2.

  *   the bundle contains all cells trom track 1 and track 2; there is only one bundle between B and C
  *   there are two bundles between B and C: one containing the cells from track 1, one containing the cells of track 2.
Votes are open!
Thomas

On Mon, Apr 7, 2014 at 1:57 AM, Nicola Accettura <[email-masked]<mailto:[email-masked]>> wrote:
Ok also from my side.
Nicola

2014-04-07 8:38 GMT+02:00 Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>>:

Sure Thomas, no problem, you can share with the ML, unless what I said was totally wrong :D (joking...)
Maria Rita

From: Grieco [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Sunday, April 06, 2014 4:17 PM
To: Pascal Thubert (pthubert)
Cc: Prof. Diego Dujovne; Thomas Watteyne; Maria Rita PALATTELLA; 'Nicola Accettura' ([email-masked]<mailto:[email-masked]>)
Subject: Re: OTF events.pptx

Yes. Thanks. Al

--
Luigi Alfredo Grieco, PhD
Assistant Professor
Department of Electrical and Information Engineering
Politecnico di Bari
Via Orabona 4 - 70125 - Bari - Italy
+39 080 5963 911<tel:%2B39%20080%205963%20911>
telematics.poliba.it/grieco<http://telematics.poliba.it/grieco>
Skype id: l.alfredo.grieco
Mobile: +39 3346715672<tel:%2B39%203346715672>

Il giorno 6 Apr 2014, alle ore 06:15, "Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>> ha scritto:
Yes!

Cheers,

Pascal

From: Prof. Diego Dujovne [mailto:[email-masked]]
Sent: dimanche 6 avril 2014 05:11
To: Thomas Watteyne
Cc: Maria Rita PALATTELLA; Pascal Thubert (pthubert); [email-masked]<mailto:[email-masked]>; 'Nicola Accettura' ([email-masked]<mailto:[email-masked]>)
Subject: Re: OTF events.pptx

Dear all,
             It is OK for me.
Regards,
                     Diego

2014-04-05 21:37 GMT-03:00 Thomas Watteyne <[email-masked]<mailto:[email-masked]>>:
All,
This issue is more general than this private e-mail thread.
Do you agree for me to CC the 6TiSCH ML? A quick "yes" is enough.
Thomas

On Fri, Apr 4, 2014 at 1:39 AM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Sorry Pascal,
But it is not clear to me :(
How can we have only Bundle B at L2, if there are more than one track on that link? We are not summing up bundles belonging to different tracks...so how the node will know what bundle should consider, if we do not specify the track?
Maria Rita

From: Pascal Thubert (pthubert) [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Friday, April 04, 2014 10:28 AM
To: Maria Rita PALATTELLA; Thomas Watteyne

Cc: [email-masked]<mailto:[email-masked]>; Prof. Diego Dujovne ([email-masked]<mailto:[email-masked]>); 'Nicola Accettura' ([email-masked]<mailto:[email-masked]>)
Subject: RE: OTF events.pptx

Hi Maria-Rita:

I think it's a matter of perspective. A bundle is a concept that is shared between 2 adjacent nodes and maybe known to a PCE/NME, but is unknown from the rest of the world.
>From the perspective of either of these 2 nodes, there is a single bundle B, and it is either a L3 (IP) link used for RPL traffic, or a L2 link associated to one track, e.g. track 1 or track 2 but not both.

Cheers,

Pascal

From: Maria Rita PALATTELLA [mailto:[email-masked]]
Sent: vendredi 4 avril 2014 10:13
To: Pascal Thubert (pthubert); Thomas Watteyne
Cc: [email-masked]<mailto:[email-masked]>; Prof. Diego Dujovne ([email-masked]<mailto:[email-masked]>); 'Nicola Accettura' ([email-masked]<mailto:[email-masked]>)
Subject: RE: OTF events.pptx

Uhmmm...
But how do you distinguish bundle B on Track T1, from Bundle B on track2?
I mean, a bundle will be identified by the couple of nodes (in the example below C-D), and by the TrackID to which it belongs ...
Am I missing something?
Maria Rita

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Friday, April 04, 2014 10:09 AM
To: Thomas Watteyne; Maria Rita PALATTELLA
Cc: [email-masked]<mailto:[email-masked]>; Prof. Diego Dujovne ([email-masked]<mailto:[email-masked]>); 'Nicola Accettura' ([email-masked]<mailto:[email-masked]>)
Subject: RE: OTF events.pptx

I do :)

Cheers,

Pascal

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: vendredi 4 avril 2014 08:25
To: Maria Rita PALATTELLA
Cc: [email-masked]<mailto:[email-masked]>; Prof. Diego Dujovne ([email-masked]<mailto:[email-masked]>); 'Nicola Accettura' ([email-masked]<mailto:[email-masked]>); Pascal Thubert (pthubert)
Subject: Re: OTF events.pptx

Maria Rita,

I absolutely understand and agree with this. In fact, since we agree that, between two nodes, there are as many bundles as tracks that go through this node, then we could just talk about "bundle B" rather than "bundle B on track T", the "on track T" part being redundant.

Do we agree on that?

Thomas

On Thu, Apr 3, 2014 at 6:32 AM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Dear Thomas, you are not a pain at all ;) Don't worry!
Let's consider the example  below.
A==>\         /==>E
     \       /
      C====>D
     /       \
B==>/         \==>F

And let's consider  two tracks: Track1: A-C-D-F and  Track2: B-C-D-E.
The soft cells reserved between the node C and D do not belong to 1 single bundle, but to two different bundles: one along the track1, and one along the Track2.
Because cells belonging to different bundles (i.e., bundles along different tracks, those on Track1 and those on Track2) are not summed up together, we need to specify the TrackID.
Otherwise we cannot know the specific bundle we are referring to.
Hope this time I have explained things better.

PS: sorry all again for having left the meeting yesterday before the end, but I had to run and take my little boy, before they leave him outside the nursery :) Thanks for your understanding. Looking forward to reading the minutes, and knowing about the rest of the discussion.

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
From: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>
Date: 2014-04-03 0:33 GMT+02:00
Subject: Re: OTF events.pptx
To: Alfredo Grieco <[email-masked]<mailto:[email-masked]>>
Cc: "Prof. Diego Dujovne" <[email-masked]<mailto:[email-masked]>>, Maria Rita Palattella <[email-masked]<mailto:[email-masked]>>, Nicola Accettura <[email-masked]<mailto:[email-masked]>>, "Pascal Thubert (pthubert) ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>
Alfredo, thanks.

Now I get confused. Maria Rita, a bundle is already naturally associated with one trackID, right? Why specifying "bundle B on track T", isn't "bundle B" enough, if we know that bundle B is on track T?

Sorry to be a pain, I'd really like us to converge on all of that terminology...

Thomas

On Wed, Apr 2, 2014 at 9:03 AM, Alfredo Grieco <[email-masked]<mailto:[email-masked]>> wrote:
hi all,

any comments ?

cheers and thanks

Al

--
Luigi Alfredo Grieco, PhD
Assistant Professor
Dep. of Electrical and Information Engineering (DEI)
Politecnico di Bari
Via Orabona, 4
70125 - Bari - Italy
Phone: +39 080 5963 911<tel:%2B39%20080%205963%20911>
url: telematics.poliba.it<http://telematics.poliba.it>
mail: [email-masked]<mailto:[email-masked]>

--
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125<tel:%2856%202%29%20676%208125>

---

From: Thomas Watteyne <[email-masked]>
Date: Thu, 10 Apr 2014 18:06:14 -0700

Is this equivalent to defining a bundle as the following tuple:

(souce MAC, destination MAC, trackID)?

Thomas

On Wed, Apr 9, 2014 at 1:48 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Hi Thomas:
>
>
>
> My understanding is that a bundle is a set of cells that together provide
> the resources for a direction of a link. In you example, there are two
> layer-2 links, thus two bundles.
>
> Best effort IP traffic routed by B and for which C is the next hop router
> would be forwarded over a Layer-3 link between the B and C, and that will
> be yet another bundle.
>
>
>
> Cheers,
>
>
>
> Pascal
>
>
>
> *From:* 6tisch [mailto:[email-masked]] *On Behalf Of *Thomas
> Watteyne
> *Sent:* mercredi 9 avril 2014 05:23
> *To:* [email-masked]
> *Subject:* [6tisch] on bundles and tracks
>
>
>
>    - the bundle contains all cells trom track 1 and track 2; there is
>    only one bundle between B and C
> I think it's a matter of perspective. A bundle is a concept that is shared
> between 2 adjacent nodes and maybe known to a PCE/NME, but is unknown from
> the rest of the world.
>
> I mean, a bundle will be identified by the couple of nodes (in the example
> below C-D), and by the TrackID to which it belongs ...
>
> Am I missing something?
>
> Maria Rita
>
>
>
> I absolutely understand and agree with this. In fact, since we agree that,
> between two nodes, there are as many bundles as tracks that go through this
> node, then we could just talk about "bundle B" rather than "bundle B on
> track T", the "on track T" part being redundant.
>
>
>
> Do we agree on that?
>
>
>
> Thomas
>
>
>
> The soft cells reserved between the node C and D do not belong to 1 single
> bundle, but to two different bundles: one along the track1, and one along
> the Track2.
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 11 Apr 2014 06:25:45 +0000

This works for me, Thomas.

I'll note that *inside an intermediate node*, a track is uniquely associated to a pair of bundles, IOW a bundle belongs to one track and there are 2 bundles for any given track, one bundle incoming, the other bundle outgoing. This stands true for an IP link as well, though for an IP link, the peer mac addresses are the same:

L3:
---
I understand that we use a well-known constant  as trackId for a L3 link, that I'll refer as NULLT.
So in your notation, an IP link between adjacent nodes A and B comprises 2 bundles,
(macA, macB, NULLT) and (macB, macA, NULLT).

L2:
---
For a normal track, the trackId is a globally unique, since it couples the IPv6 address of origin of the track and a locally unique label in that origin.
Along a track indexed by trackId=(sourceIPv6, localInstanceId), that has a segment ...A->B->C... , there are 2 bundles in node B,
incoming = (macA, macB, trackId) and outgoing = (macB, macC, trackId).

A bundle is useless until it is paired, so it could be good to name the pair of them, even if that's as simple as a "bundle pair". Also, we probably want to find a name for a bundle pair that is associated to a track (for switching over L2 links) vs. a bundle pair that is associated to an IP link (for forwarding over an L3 link).

Suggestions?

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: vendredi 11 avril 2014 03:06
To: Pascal Thubert (pthubert)
Cc: [email-masked]
Subject: Re: [6tisch] on bundles and tracks

Thomas

On Wed, Apr 9, 2014 at 1:48 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Thomas:

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Thomas Watteyne
Sent: mercredi 9 avril 2014 05:23
To: [email-masked]<mailto:[email-masked]>
Subject: [6tisch] on bundles and tracks

All,

A--\          /--D
    \        /
     B======C
    /        \
E--/          \--F

  *   track 1: A-B-C-D
  *   track 2: E-B-C-F

Yes. Thanks. Al

Cheers,

Pascal

Dear all,
             It is OK for me.
Regards,
                     Diego

Hi Maria-Rita:

Cheers,

Pascal

Uhmmm...

I do :)

Cheers,

Pascal

Maria Rita,

Do we agree on that?

Thomas

Thomas

any comments ?

cheers and thanks

Al