Subject: [6tisch] Support of flow label to carry the RPL information in data packets

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 15 Apr 2014 14:25:26 +0000

Dear all:

As some of you remember, the RPL specification has changed over time WRT to the location of the information that RPL places in the data packets. We started with the flow label but these were the days when what became RFC 6437 was being defined at 6MAN, so we shied away and defined the HbH technique that is now specified as RFC 6553.

We'll note that the RPL option defined in RFC 6553 takes 6 octets, and with the HbH hdr we end up with 8 extra octets. An extra IP-in-IP encapsulation is required on top of that unless both endpoints are in the same RPL domain. All this overhead may be acceptable when power is available and the PHY allows for larger frames, but in traditional battery-operated 15.4 with ~ 80 bytes usable per frame, my experience from integrating 6LoWPAN HC with ISA100.11a says that all these extra bytes will be on the way of the 6TiSCH adoption.

Still, both RFC 6550 and RFC 6552 are designed to allow for an alternate technique and in particular for the use of the flow label, as is elaborated in http://tools.ietf.org/html/draft-thubert-roll-flow-label-02 . Using the flow label reduces the cost of the RPL information dramatically, down to a level that is probably acceptable for the target SDOs.

So my plan for now is to move the flow label draft to 6MAN and prepare for a hot season, and I'm looking for support from both 6TiSCH and ROLL to back me up from the start.  Yes, you can help!

Please +1 if you agree we need this work to happen, and/or provide any suggestion.

Cheers,

Pascal

---

From: Michael Richardson <[email-masked]>
Date: Tue, 15 Apr 2014 10:31:28 -0400

Pascal Thubert (pthubert) <[email-masked]> wrote:
    > Still, both RFC 6550 and RFC 6552 are designed to allow for an alternate
    > technique and in particular for the use of the flow label, as is elaborated in
    > http://tools.ietf.org/html/draft-thubert-roll-flow-label-02 . Using the flow
    > label reduces the cost of the RPL information dramatically, down to a level
    > that is probably acceptable for the target SDOs.

    > So my plan for now is to move the flow label draft to 6MAN and prepare for a
    > hot season, and I?m looking for support from both 6TiSCH and ROLL to back me up
    > from the start.  Yes, you can help!

    > Please +1 if you agree we need this work to happen, and/or provide any

I think it's worthwhile to re-open the discussion at 6man.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-