Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF

From: Maria Rita PALATTELLA <[email-masked]>
Date: Wed, 2 Apr 2014 12:54:54 +0000

Thomas
[sorry for my late reply]
I have the feeling that you are confusing track with bundle.
Actually Pascal, Qin, and I have been discussing this on a different trend, related to OTF, on the ML. Anyway, I am copying below some text from Pascal that may help in clarifying :

[PASCAL] A bundle is really the collection of cells that put together create a half-duplex IP link between 2 nodes with a bandwidth that is:
(medium bandwidth) * (nb of cells in the bundle) / (number of cells in the slotframe).
We have chosen to extend that definition for a collection of cells that put together create a half-duplex hop for an end to end track.
Using the same term "bundle" is fine with me but if we have a track that passes between A and, the bundle for that track will be different from the bundle for the IP link between adjacent nodes A and B.
Cells in a bundle should be equivalent for 6top to place the next packet for the track onto the next cell in the bundle for that track, and conversely the next packet to be sent on the next cell in the bundle for the IP link.
I think we should not attempt to group together bundles to form a larger bundle. What purpose would that serve?

Thus, a track is a set of cells reserved along a e2e multi-hop path. In your example below, A-C-D-E is a track, B-C-D-F is another one, and you can have other two, by changing the final destination (E with F, and F with E) of the previous ones.
A bundle is just one hop along a track. But as explained by Pascal, not all the cells reserved between C and D will be part of the same bundle. Because we will have a bundle for each track.
So, in a network, for sure, we will have multiple concurrent tracks, because we will have several traffic flows, along different e2e paths.
OTF should provide support for managing the BDW reserved for each track, based on the current need. Some tracks, based on the QoS associated to them, may ask for OTF support, while others (having less QoS), could not need to use OTF...
In any case, based on the commands provided by 6top, OTF can check the statistics, per bundle, on a specific track...
Is it clearer now?

Maria Rita

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: Monday, March 24, 2014 7:33 AM
To: Qin Wang
Cc: Maria Rita PALATTELLA; Pascal Thubert (pthubert); Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked]); [email-masked]
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF

Maria Rita,

Could you elaborate a bit of what you envision OTF would be with multiple concurrent trackIDs? I'm particularly interested in understanding which entity would created, maintained and destroy tracks.

More generally, I need your help to understand the benefit of multiple tracks. Sorry :-(. If all tracks are administered by OTF, then I would argue the network offers a similar same level of QoS in the following cases:
- case 1. several tracks are installed, e.g. one for each node
- case 2. the network operates on one trackid, which carries the sum of traffic from the first case.

For example, let's assume the following topology

A==>\         /==>E
     \       /
      C====>D
     /       \
B==>/         \==>F

With two flows:
- A-C-D-E
- C-D-C-F

In case 1, there would be 2 independent tracks between C and D, each carrying half of the traffic.
In case 2, only one track carries all the traffic.

With OTF, the size of the bundle adapts to the traffic being transported. I would hence argue that the level of QoS is the same for both cases.

Thoughts?

Thomas

On Fri, Mar 21, 2014 at 7:37 AM, Qin Wang <[email-masked]<mailto:[email-masked]>> wrote:
Maria Rita and Pascal,

I agree the definition of bundle.

Thanks
Qin

On Friday, March 21, 2014 10:24 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Qin,
My understanding of bundle is closer to Pascal's one and it is strictly related to track.
A bundle is a set of cells reserved between two nodes, A and B, with the same scope, and thus on the same track.
I don't think we can mix up cells belonging to different tracks, even though scheduled between the same two neighbor nodes. This does not make sense to me, because when we will have a pkt in the queue, this will belong to a specific track, and thus it will be transmitted in one of the cells of the bundle that has been reserved for that specific track.
Do you see my point?
Maria Rita

From: Pascal Thubert (pthubert) [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Friday, March 21, 2014 2:50 PM
To: Qin Wang; Maria Rita PALATTELLA; Qin Wang ([email-masked]<mailto:[email-masked]>); Xavier Vilajosana ([email-masked]<mailto:[email-masked]>)
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [6tisch] tracks & soft cells reservation w/ OTF

Hi Qin:

A bundle is really the collection of cells that put together create a half-duplex IP link between 2 nodes with a bandwidth that is:
(medium bandwidth) * (nb of cells in the bundle) / (number of cells in the slotframe).

We have chosen to extend that definition for a collection of cells that put together create a half-duplex hop for an end to end track.

Using the same term "bundle" is fine with me but if we have a track that passes between A and, the bundle for that track will be different from the bundle for the IP link between adjacent nodes A and B.

Cells in a bundle should be equivalent for 6top to place the next packet for the track onto the next cell in the bundle for that track, and conversely the next packet to be sent on the next cell in the bundle for the IP link.

I think we should not attempt to group together bundles to form a larger bundle. What purpose would that serve?

PS; I'm ok to cc the ML; what about you all?

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: vendredi 21 mars 2014 14:31
To: Maria Rita PALATTELLA; Qin Wang ([email-masked]<mailto:[email-masked]>); Xavier Vilajosana ([email-masked]<mailto:[email-masked]>)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF

Hi Maria Rita,

Regarding to the Bundle and Track, my understanding is: bundle is a set of cells to a specific neighbor, i.e. representing a link of some BW; track is a set of cells to a specific neighbor and must be associated with a specific multi-hop path. In another word, from one-hop point of view, a bundle may correspond to more than one tracks. What do you think?

Thanks
Qin

On Friday, March 21, 2014 5:13 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Hi Qin, thanks for your detailed email.
I am afraid I am still missing something... concerning bundle and track...
When talking about CellList, you make a difference between getting stat. per bundle or per track.
But shouldn't a bundle be associated to a specific track, given that each cell (and, thus each cell in the bundle) has a TrackID?
Thanks
Maria Rita

From: Qin Wang [mailto:[email-masked]]
Sent: Thursday, March 20, 2014 6:35 PM
To: Maria Rita PALATTELLA; Qin Wang ([email-masked]<mailto:[email-masked]>); Xavier Vilajosana ([email-masked]<mailto:[email-masked]>)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF

Hi Maria Rita,

I agree that OTF should be able to play on specific Track.

The statistics data is in 4 data structure of MIB.
(1) In CellList. It is per cell statistics, from it upper layer can get per bundle or per track statistics.
(2) In MonitoringStatusList. It is per neighbor & slotframe statistics, from it upper layer can get per bundle overview of scheduling and its performance.
(3) In NeighborList. It is per neighbor statistics, from it upper layer can understand the connectivity of a pair of nodes.
(4) In QueueList. It is per Queue statistics, from it upper layer can know the traffic load.

OTF can combine those statistics to make decision. Make sense?

But, as we discussed before, we may need to clarify the feature of a Queue, corresponding to a slotframe, or a Track, or something else. According to my understanding, Queue should associate with Priority defined in QoS, instead of slotframe or Track. Let's start another thread to discuss the feature of Queue.

Thanks
Qin

On Thursday, March 20, 2014 11:25 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Hello Qin,
OTF will figure out if more or less BDW is needed by using the information that 6top provides, e.g., the stat. about BDW (allocated soft cells, overprovision cells, QoS, NQoS), traffic load on a link, queue length, avg time spent by a pkt in the queue...
Then, which approach shall we use? It is still not so clear to me...but I have the feeling that we should use the specific trackID, and not the Best-effort one. Am I wrong?
Thanks for helping in clarifying that!
Best regards,
Maria Rita

From: Qin Wang [mailto:[email-masked]]
Sent: Thursday, March 20, 2014 3:37 PM
To: Maria Rita PALATTELLA; Qin Wang ([email-masked]<mailto:[email-masked]>); Xavier Vilajosana ([email-masked]<mailto:[email-masked]>)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF

Hi Maira Rita,

I don't exactly know how OTF figures out the demand of add/delete softcells. In my mind, at least, there are two ways.

(1) The demand is from network point of view, e.g. nodeA wants to create/extend/reduce certain BW to nodeB multi-hop away, then a TrackID should be given. Along the path, OTF will ask 6top to allocate/de-allcoate softcells on the given TrackID.

(2) The demand is from the evaluation of local traffic. In this case, I would like to propose to use Best-effort trackID, i.e. TrackID=(0,0).

What do you think?

Thanks
Qin

On Thursday, March 20, 2014 6:50 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Dear Qin, Xavi (all)

OTF aims to dynamically allocate (de-allocate) soft cells based on the bandwidth (BDW) needed between two neighbor nodes.
After estimating the BDW (and thus the number of soft cells to be added/deleted), OTF delegates to 6top the actual (de)allocation operation.

Given that each soft cell assigned to two neighbor nodes belongs to a specific TRACK, I was wondering how OTF should deal with this.
I mean, shall we suppose that all the traffic in the network belongs to the same TRACK, in order to simply OTF operation?
At the same time, I believe it is not realistic to assume there is only one track, and thus, one flow in the network. But if we assume that we have more than one flow/track, then, we should have several  OTF instances, one for each track.

Do you think that OTF should check the BDW between two nodes per TRACK? Because if checking the overall BDW, then OTF cannot know, on which track the new soft cell should be added.

Looking forward to receiving your advices on how to deal with tracks and OTF soft cells reservation ...

Thank you in advance!

Best regards,
Maria Rita

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 2 Apr 2014 15:30:21 -0700

Maria Rita,

I agree completely with your definition of bundle, and in my definition I
also assume there is only bundle per track, I promise :)

My point is that, when using OTF to manage cells, do we want to have to
install multiple a tracks in the network (one per source node?), or can we
live with having, optionally, all traffic go through the same cells,
regardless of where it comes from and where it goes.

Thomas

On Wed, Apr 2, 2014 at 5:54 AM, Maria Rita PALATTELLA <
[email-masked]> wrote:

> Actually Pascal, Qin, and I have been discussing this on a different
> trend, related to OTF, on the ML. Anyway, I am copying below some text from
> Pascal that may help in clarifying :
>
>
>
> [PASCAL] A bundle is really the collection of cells that put together
> create a half-duplex IP link between 2 nodes with a bandwidth that is:
>
> We have chosen to extend that definition for a collection of cells that
> put together create a half-duplex hop for an end to end track.
>
> Using the same term "bundle" is fine with me but if we have a track that
> passes between A and, the bundle for that track will be different from the
> bundle for the IP link between adjacent nodes A and B.
>
> Cells in a bundle should be equivalent for 6top to place the next packet
> for the track onto the next cell in the bundle for that track, and
> conversely the next packet to be sent on the next cell in the bundle for
> the IP link.
>
> Thus, a track is a set of cells reserved along a e2e multi-hop path. In
> your example below, A-C-D-E is a track, B-C-D-F is another one, and you can
> have other two, by changing the final destination (E with F, and F with E)
> of the previous ones.
>
> A bundle is just one hop along a track. But as explained by Pascal, not
> all the cells reserved between C and D will be part of the same bundle.
> Because we will have a bundle for each track.
>
> So, in a network, for sure, we will have multiple concurrent tracks,
> because we will have several traffic flows, along different e2e paths.
>
> OTF should provide support for managing the BDW reserved for each track,
> based on the current need. Some tracks, based on the QoS associated to
> them, may ask for OTF support, while others (having less QoS), could not
> need to use OTF...
>
> In any case, based on the commands provided by 6top, OTF can check the
> statistics, per bundle, on a specific track...
>
> Is it clearer now?
>
>
>
> Maria Rita
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Thomas
> Watteyne
> *Sent:* Monday, March 24, 2014 7:33 AM
> *To:* Qin Wang
> *Cc:* Maria Rita PALATTELLA; Pascal Thubert (pthubert); Qin Wang (
> [email-masked]); Xavier Vilajosana ([email-masked]);
> [email-masked]
>
> *Subject:* Re: [6tisch] tracks & soft cells reservation w/ OTF
>
>
>
> Maria Rita,
>
>
>
> Could you elaborate a bit of what you envision OTF would be with multiple
> concurrent trackIDs? I'm particularly interested in understanding which
> entity would created, maintained and destroy tracks.
>
>
>
> More generally, I need your help to understand the benefit of multiple
> tracks. Sorry :-(. If all tracks are administered by OTF, then I would
> argue the network offers a similar same level of QoS in the following cases:
>
> With OTF, the size of the bundle adapts to the traffic being transported.
> I would hence argue that the level of QoS is the same for both cases.
>
>
>
> Thoughts?
>
>
>
> Thomas
>
>
>
> On Fri, Mar 21, 2014 at 7:37 AM, Qin Wang <[email-masked]> wrote:
>
> Maria Rita and Pascal,
>
>
>
> On Friday, March 21, 2014 10:24 PM, Maria Rita PALATTELLA <
> [email-masked]> wrote:
>
> Qin,
>
> I don't think we can mix up cells belonging to different tracks, even
> though scheduled between the same two neighbor nodes. This does not make
> sense to me, because when we will have a pkt in the queue, this will belong
> to a specific track, and thus it will be transmitted in one of the cells of
> the bundle that has been reserved for that specific track.
>
> Do you see my point?
>
> Maria Rita
>
>
>
>
>
> *From:* Pascal Thubert (pthubert) [mailto:[email-masked]]
> *Sent:* Friday, March 21, 2014 2:50 PM
> *To:* Qin Wang; Maria Rita PALATTELLA; Qin Wang ([email-masked]);
> Xavier Vilajosana ([email-masked])
> *Cc:* [email-masked]
> *Subject:* RE: [6tisch] tracks & soft cells reservation w/ OTF
>
>
>
> Hi Qin:
>
>
>
> A bundle is really the collection of cells that put together create a
> half-duplex IP link between 2 nodes with a bandwidth that is:
>
> We have chosen to extend that definition for a collection of cells that
> put together create a half-duplex hop for an end to end track.
>
>
>
> Using the same term "bundle" is fine with me but if we have a track that
> passes between A and, the bundle for that track will be different from the
> bundle for the IP link between adjacent nodes A and B.
>
>
>
>
>
> Cells in a bundle should be equivalent for 6top to place the next packet
> for the track onto the next cell in the bundle for that track, and
> conversely the next packet to be sent on the next cell in the bundle for
> the IP link.
>
>
>
> *From:* 6tisch [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Qin Wang
> *Sent:* vendredi 21 mars 2014 14:31
> *To:* Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier
> Vilajosana ([email-masked])
> *Cc:* [email-masked]
> *Subject:* Re: [6tisch] tracks & soft cells reservation w/ OTF
>
>
>
> Hi Maria Rita,
>
>
>
> Regarding to the Bundle and Track, my understanding is: bundle is a set of
> cells to a specific neighbor, i.e. representing a link of some BW; track is
> a set of cells to a specific neighbor and must be associated with a
> specific multi-hop path. In another word, from one-hop point of view, a
> bundle may correspond to more than one tracks. What do you think?
>
>
>
> Thanks
>
> Qin
>
>
>
> On Friday, March 21, 2014 5:13 PM, Maria Rita PALATTELLA <
> [email-masked]> wrote:
>
> But shouldn't a bundle be associated to a specific track, given that each
> cell (and, thus each cell in the bundle) has a TrackID?
>
> Thanks
>
> Maria Rita
>
>
>
> *From:* Qin Wang [mailto:[email-masked] <[email-masked]>]
> *Sent:* Thursday, March 20, 2014 6:35 PM
> *To:* Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier
> Vilajosana ([email-masked])
> *Cc:* [email-masked]
> *Subject:* Re: [6tisch] tracks & soft cells reservation w/ OTF
>
>
>
> Hi Maria Rita,
>
>
>
> (2) In MonitoringStatusList. It is per neighbor & slotframe statistics,
> from it upper layer can get per bundle overview of scheduling and its
> performance.
>
> (3) In NeighborList. It is per neighbor statistics, from it upper layer
> can understand the connectivity of a pair of nodes.
>
> But, as we discussed before, we may need to clarify the feature of a
> Queue, corresponding to a slotframe, or a Track, or something else.
> According to my understanding, Queue should associate with Priority defined
> in QoS, instead of slotframe or Track. Let's start another thread to
> discuss the feature of Queue.
>
>
>
> Thanks
>
> Qin
>
>
>
>
>
>
>
>
>
> On Thursday, March 20, 2014 11:25 PM, Maria Rita PALATTELLA <
> [email-masked]> wrote:
>
> Hello Qin,
>
> OTF will figure out if more or less BDW is needed by using the information
> that 6top provides, e.g., the stat. about BDW (allocated soft cells,
> overprovision cells, QoS, NQoS), traffic load on a link, queue length, avg
> time spent by a pkt in the queue...
>
> Then, which approach shall we use? It is still not so clear to me...but I
> have the feeling that we should use the specific trackID, and not the
> Best-effort one. Am I wrong?
>
> *From:* Qin Wang [mailto:[email-masked] <[email-masked]>]
> *Sent:* Thursday, March 20, 2014 3:37 PM
> *To:* Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier
> Vilajosana ([email-masked])
> *Cc:* [email-masked]
> *Subject:* Re: [6tisch] tracks & soft cells reservation w/ OTF
>
>
>
> Hi Maira Rita,
>
>
>
> I don't exactly know how OTF figures out the demand of add/delete
> softcells. In my mind, at least, there are two ways.
>
>
>
> (1) The demand is from network point of view, e.g. nodeA wants to
> create/extend/reduce certain BW to nodeB multi-hop away, then a TrackID
> should be given. Along the path, OTF will ask 6top to allocate/de-allcoate
> softcells on the given TrackID.
>
>
>
> (2) The demand is from the evaluation of local traffic. In this case, I
> would like to propose to use Best-effort trackID, i.e. TrackID=(0,0).
>
>
>
> What do you think?
>
>
>
> Thanks
>
> Qin
>
>
>
>
>
>
>
> On Thursday, March 20, 2014 6:50 PM, Maria Rita PALATTELLA <
> [email-masked]> wrote:
>
> Dear Qin, Xavi (all)
>
>
>
> OTF aims to dynamically allocate (de-allocate) soft cells based on the
> bandwidth (BDW) needed between two neighbor nodes.
>
> After estimating the BDW (and thus the number of soft cells to be
> added/deleted), OTF delegates to 6top the actual (de)allocation operation.
>
>
>
> Given that each soft cell assigned to two neighbor nodes belongs to a
> specific TRACK, I was wondering how OTF should deal with this.
>
> I mean, shall we suppose that all the traffic in the network belongs to
> the same TRACK, in order to simply OTF operation?
>
> At the same time, I believe it is not realistic to assume there is only
> one track, and thus, one flow in the network. But if we assume that we have
> more than one flow/track, then, we should have several  OTF instances, one
> for each track.
>
>
>
> Do you think that OTF should check the BDW between two nodes per TRACK?
> Because if checking the overall BDW, then OTF cannot know, on which track
> the new soft cell should be added.
>
>
>
> [email-masked]
> [email-masked]
> [email-masked]
> [email-masked]

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Thu, 3 Apr 2014 13:38:07 +0000

>>My point is that, when using OTF to manage cells, do we want to have to install multiple a tracks in the network (one per source node?), or can we live with having, optionally, all traffic go through the same cells, regardless of >> where it comes from and where it goes.

Thomas, by definition of track, if we have different traffic flows, coming from different source nodes, and going to different destination nodes, we will automatically have different tracks, even though they share the same intermediate hops.
(I guess you meant hops, and not cells...)

I guess the best-effort track can be the only one that can be shared by different flows. Maybe Qin can help in clarifying this.
Thanks!
Maria Rita

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: Thursday, April 03, 2014 12:30 AM
To: Maria Rita PALATTELLA
Cc: Qin Wang; Pascal Thubert (pthubert); Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked]); [email-masked]
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF

Maria Rita,

I agree completely with your definition of bundle, and in my definition I also assume there is only bundle per track, I promise :)

My point is that, when using OTF to manage cells, do we want to have to install multiple a tracks in the network (one per source node?), or can we live with having, optionally, all traffic go through the same cells, regardless of where it comes from and where it goes.

Thomas

On Wed, Apr 2, 2014 at 5:54 AM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Thomas
[sorry for my late reply]
I have the feeling that you are confusing track with bundle.
Actually Pascal, Qin, and I have been discussing this on a different trend, related to OTF, on the ML. Anyway, I am copying below some text from Pascal that may help in clarifying :

Maria Rita

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Thomas Watteyne
Sent: Monday, March 24, 2014 7:33 AM
To: Qin Wang
Cc: Maria Rita PALATTELLA; Pascal Thubert (pthubert); Qin Wang ([email-masked]<mailto:[email-masked]>); Xavier Vilajosana ([email-masked]<mailto:[email-masked]>); [email-masked]<mailto:[email-masked]>

Maria Rita,

A==>\         /==>E
     \       /
      C====>D
     /       \
B==>/         \==>F

With two flows:
- A-C-D-E
- C-D-C-F

Thoughts?

Thomas

Thanks
Qin

Hi Qin:

Pascal

Hi Maria Rita,

Thanks
Qin

Hi Maria Rita,

Thanks
Qin

Hi Maira Rita,

What do you think?

Thanks
Qin

Thank you in advance!

Best regards,
Maria Rita

---

From: Qin Wang <[email-masked]>
Date: Thu, 3 Apr 2014 06:55:17 -0700 (PDT)

Hi Maria Rita and Thomas,

According to trackID definition, i.e. trackID ::= (TrackOwnerAddr, InstanceID), there could be more than one tracks between a source node and a destination node. Right?

Thanks
Qin

 
Thomas, by definition of track, if we have different traffic flows, coming from different source nodes, and going to different destination nodes, we will automatically have different tracks, even though they share the same intermediate hops.
(I guess you meant hops, and not cells…)

From:[email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
 
Maria Rita,

 
Thomas
 
On Wed, Apr 2, 2014 at 5:54 AM, Maria Rita PALATTELLA <[email-masked]> wrote:
Thomas
[sorry for my late reply]
I have the feeling that you are confusing track with bundle. 
Actually Pascal, Qin, and I have been discussing this on a different trend, related to OTF, on the ML. Anyway, I am copying below some text from Pascal that may help in clarifying :
 
Using the same term “bundle” is fine with me but if we have a track that passes between A and, the bundle for that track will be different from the bundle for the IP link between adjacent nodes A and B.
 
Thus, a track is a set of cells reserved along a e2e multi-hop path. In your example below, A-C-D-E is a track, B-C-D-F is another one, and you can have other two, by changing the final destination (E with F, and F with E) of the previous ones.
A bundle is just one hop along a track. But as explained by Pascal, not all the cells reserved between C and D will be part of the same bundle. Because we will have a bundle for each track.
So, in a network, for sure, we will have multiple concurrent tracks, because we will have several traffic flows, along different e2e paths.
OTF should provide support for managing the BDW reserved for each track, based on the current need. Some tracks, based on the QoS associated to them, may ask for OTF support, while others (having less QoS), could not need to use OTF…
In any case, based on the commands provided by 6top, OTF can check the statistics, per bundle, on a specific track…
Is it clearer now?
 
Maria Rita
 
From:[email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: Monday, March 24, 2014 7:33 AM
To: Qin Wang
Cc: Maria Rita PALATTELLA; Pascal Thubert (pthubert); Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked]); [email-masked]

Maria Rita,

 
 
A==>\         /==>E
     \       /
      C====>D
     /       \
B==>/         \==>F
 
With two flows:
- A-C-D-E
- C-D-C-F

 
Thoughts?
 
Thomas

 
Thanks
Qin
 
On Friday, March 21, 2014 10:24 PM, Maria Rita PALATTELLA <[email-masked]> wrote:
Qin,
My understanding of bundle is closer to Pascal’s one and it is strictly related to track.
A bundle is a set of cells reserved between two nodes, A and B, with the same scope, and thus on the same track.
I don’t think we can mix up cells belonging to different tracks, even though scheduled between the same two neighbor nodes. This does not make sense to me, because when we will have a pkt in the queue, this will belong to a specific track, and thus it will be transmitted in one of the cells of the bundle that has been reserved for that specific track.
Do you see my point?
Maria Rita

From:Pascal Thubert (pthubert) [mailto:[email-masked]] 
Sent: Friday, March 21, 2014 2:50 PM
To: Qin Wang; Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked])
Cc: [email-masked]
Subject: RE: [6tisch] tracks & soft cells reservation w/ OTF
 
Hi Qin:

 
Using the same term “bundle” is fine with me but if we have a track that passes between A and, the bundle for that track will be different from the bundle for the IP link between adjacent nodes A and B.

 
PS; I’m ok to cc the ML; what about you all?
 
Pascal
 
From:6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: vendredi 21 mars 2014 14:31
To: Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked])
Cc: [email-masked]
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF
 
Hi Maria Rita,

Thanks
Qin
 
On Friday, March 21, 2014 5:13 PM, Maria Rita PALATTELLA <[email-masked]> wrote:
Hi Qin, thanks for your detailed email.
I am afraid I am still missing something… concerning bundle and track…
When talking about CellList, you make a difference between getting stat. per bundle or per track.
But shouldn’t a bundle be associated to a specific track, given that each cell (and, thus each cell in the bundle) has a TrackID?
Thanks
Maria Rita
 
From:Qin Wang [mailto:[email-masked]] 
Sent: Thursday, March 20, 2014 6:35 PM
To: Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked])
Cc: [email-masked]
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF
 
Hi Maria Rita,

 

Thanks
Qin

 
On Thursday, March 20, 2014 11:25 PM, Maria Rita PALATTELLA <[email-masked]> wrote:
Hello Qin,
OTF will figure out if more or less BDW is needed by using the information that 6top provides, e.g., the stat. about BDW (allocated soft cells, overprovision cells, QoS, NQoS), traffic load on a link, queue length, avg time spent by a pkt in the queue…
Then, which approach shall we use? It is still not so clear to me…but I have the feeling that we should use the specific trackID, and not the Best-effort one. Am I wrong?
Thanks for helping in clarifying that!
Best regards,
Maria Rita

 
From:Qin Wang [mailto:[email-masked]] 
Sent: Thursday, March 20, 2014 3:37 PM
To: Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked])
Cc: [email-masked]
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF
 
Hi Maira Rita,

 
 
What do you think?
 
Thanks
Qin

On Thursday, March 20, 2014 6:50 PM, Maria Rita PALATTELLA <[email-masked]> wrote:
Dear Qin, Xavi (all)

 
 
Looking forward to receiving your advices on how to deal with tracks and OTF soft cells reservation … 
 
Thank you in advance!
 
Best regards,
Maria Rita

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Thu, 3 Apr 2014 14:00:50 +0000

Yes Qin, I think so, in case, for instance, we have different flows, that needs different QoS.
Maria Rita

From: Qin Wang [mailto:[email-masked]]
Sent: Thursday, April 03, 2014 3:55 PM
To: Maria Rita PALATTELLA; Thomas Watteyne
Cc: Pascal Thubert (pthubert); Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked]); [email-masked]
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF

Thanks
Qin

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: Thursday, April 03, 2014 12:30 AM
To: Maria Rita PALATTELLA
Cc: Qin Wang; Pascal Thubert (pthubert); Qin Wang ([email-masked]<mailto:[email-masked]>); Xavier Vilajosana ([email-masked]<mailto:[email-masked]>); [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF

Maria Rita,

Thomas

Maria Rita

Maria Rita,

A==>\         /==>E
     \       /
      C====>D
     /       \
B==>/         \==>F

With two flows:
- A-C-D-E
- C-D-C-F

Thoughts?

Thomas

Thanks
Qin

Hi Qin:

Pascal

Hi Maria Rita,

Thanks
Qin

Hi Maria Rita,

Thanks
Qin

Hi Maira Rita,

What do you think?

Thanks
Qin

Thank you in advance!

Best regards,
Maria Rita

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 3 Apr 2014 17:03:52 +0000

Hello Qin and Maria-Rita:

I agree with you on the fact that there can be more than one track between node A and node B, just like there can be a voice and a video stream between 2 classical nodes. But that’s not for QoS reasons, it’s just that these are different reservations, eventually with a same QoS setting.

A bundle is really a set of resources that is associated to a virtual link between 2 nodes, either adjacent, or along a track. IMHO QoS queues should be handled above the LLC, that is before the notion of cells and bundles even exists, as opposed to having different bundles for different QoS values, which would mean really different links and not necessarily a good use of the cells.

Makes sense?

Pascal

From: Maria Rita PALATTELLA [mailto:[email-masked]]
Sent: jeudi 3 avril 2014 16:01
To: Qin Wang; Thomas Watteyne
Cc: Pascal Thubert (pthubert); Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked]); [email-masked]
Subject: RE: [6tisch] tracks & soft cells reservation w/ OTF

Cc: Pascal Thubert (pthubert); Qin Wang ([email-masked]<mailto:[email-masked]>); Xavier Vilajosana ([email-masked]<mailto:[email-masked]>); [email-masked]<mailto:[email-masked]>

Thanks
Qin

Maria Rita,

Thomas

Maria Rita

Maria Rita,

A==>\         /==>E
     \       /
      C====>D
     /       \
B==>/         \==>F

With two flows:
- A-C-D-E
- C-D-C-F

Thoughts?

Thomas

Thanks
Qin

Hi Qin:

Pascal

Hi Maria Rita,

Thanks
Qin

Hi Maria Rita,

Thanks
Qin

Hi Maira Rita,

What do you think?

Thanks
Qin

Thank you in advance!

Best regards,
Maria Rita

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Fri, 4 Apr 2014 08:32:40 +0000

Hello Pascal,

I do agree with you that we can have different kind of traffic (voice and video stream, as you said), between the same source and destination nodes, and thus, we will have different tracks. This is actually what I had in mind (but I talked about different kind of QoS – sorry - ).

Bundle will be associated to tracks, and then the pkt belonging to the flow on a given track will be put in a specific queue. The question was: how we decide in which queue the pkt should go? Then, we thought that we could associate queue to QoS, and do a mapping between tracks and QoS. In this way, pkt belongings to different tracks will be in the same queue, if the same QoS is offered to those tracks.

Does this make sense?

Maria Rita

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Thursday, April 03, 2014 7:04 PM
To: Maria Rita PALATTELLA; Qin Wang; Thomas Watteyne
Cc: Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked]); [email-masked]
Subject: RE: [6tisch] tracks & soft cells reservation w/ OTF

Makes sense?

Pascal

Thanks
Qin

Maria Rita,

Thomas

Maria Rita

Maria Rita,

A==>\         /==>E
     \       /
      C====>D
     /       \
B==>/         \==>F

With two flows:
- A-C-D-E
- C-D-C-F

Thoughts?

Thomas

Thanks
Qin

Hi Qin:

Pascal

Hi Maria Rita,

Thanks
Qin

Hi Maria Rita,

Thanks
Qin

Hi Maira Rita,

What do you think?

Thanks
Qin

Thank you in advance!

Best regards,
Maria Rita

---

From: Qin Wang <[email-masked]>
Date: Fri, 4 Apr 2014 06:39:05 -0700 (PDT)

Hi Pascal and Maira Rita,

I do agree that the definition and assignment of QoS belongs to upper layer, and more than one tracks from same source to same destination may be set same QoS.

To the question from Maria Rita, I think, 
(1) During queue configuration, each queue should be associated with a specific QoS.
(2) There must be a process to establish a track along a path, e.g, by SET the TrackList in the nodes along the path, and SET Qos of the track at same time. 
(3) Because TrackID is a parameter of Create.hardcell and Create.softcell, a scheduled cell should be associated with a specific Track, i.e. a specific queue. Thus, a incoming packet on a cell will go to the queue corresponding to the cell.

Make sense? If it is correct, we need to add QoS attribute to TrackList in YANG model.

Thanks
Qin 

On Friday, April 4, 2014 5:02 PM, Maria Rita PALATTELLA <[email-masked]> wrote:

Hello Pascal,

 
Does this make sense?
 
Maria Rita

 

Makes sense?
 
Pascal
 
From:Maria Rita PALATTELLA [mailto:[email-masked]] 

 

Thanks
Qin

 

Maria Rita,

 
Thomas

 
 
Maria Rita

 
Maria Rita,

 
 
A==>\         /==>E
     \       /
      C====>D
     /       \
B==>/         \==>F
 
With two flows:
- A-C-D-E
- C-D-C-F

 
Thoughts?
 
Thomas

 
Thanks
Qin

 
Hi Qin:

 

 
 
Pascal

Hi Maria Rita,

Thanks
Qin

 
Hi Maria Rita,

 

Thanks
Qin

 

 
 
Hi Maira Rita,

 
 
What do you think?
 
Thanks
Qin

 

 
 
Thank you in advance!
 
Best regards,
Maria Rita