Subject: [6tisch] Should IEEE802.15.4 PIB be part of 6top YANG model?

From: Qin Wang <[email-masked]>
Date: Thu, 3 Apr 2014 06:35:50 -0700 (PDT)

Hi all,

In the current version of draft-ietf-6tisch-6top-interface, there are two TODO sections, i.e.

3.2.  YANG model of the IEEE802.15.4 PIB

3.3.  YANG model of the IEEE802.15.4e PIB

The intention to have the two sections is to describe the part of  IEEE802.15.4(e) PIB, which are associated with 6top, but only need to be read/written directly by upper layer, in YANG model. 

According to the discussion in IETF89, there may be three ways to deal with this part:
(1) keep the two sections
(2) merge the two sections into one, like "YANG model of IEEE802.15.4"
(3) remove the two sections, i.e. 6top YANG model does not include IEEE802.15.4(e) PIB.

What do you think?

Thanks
Qin

---

From: Xavier Vilajosana <[email-masked]>
Date: Thu, 3 Apr 2014 15:59:20 +0200

Hi Qin,

I vote for 2), the next revision of 15.4 will include the amendment so will
be part of the 15.4 std.

I see some of the management functions just delegate calls to the 15.4 API,
however this can be beneficial to abstract upper layers from 15.4
management interfaces and provide a more concise and self-contained
management interface at L2.5.

my 5 cents ;)
X

2014-04-03 15:35 GMT+02:00 Qin Wang <[email-masked]>:

> The intention to have the two sections is to describe the part of
> IEEE802.15.4(e) PIB, which are associated with 6top, but only need to be
> read/written directly by upper layer, in YANG model.
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

---

From: Pat Kinney <[email-masked]>
Date: Thu, 3 Apr 2014 09:26:51 -0500

It seems to me that (2) is technically correct since the current IEEE 802.15.4 revision is merging the two anyway.

Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked]

On Apr 3, 2014, at 8:35 AM, Qin Wang <[email-masked]> wrote:

Hi all,

What do you think?

Thanks
Qin

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 8 Apr 2014 18:43:24 -0700

+1 on option 2)

On Thu, Apr 3, 2014 at 7:26 AM, Pat Kinney <
[email-masked]> wrote:

> It seems to me that (2) is technically correct since the current IEEE
> 802.15.4 revision is merging the two anyway.
>
> Pat
>
>   Pat Kinney
> *Kinney Consulting LLC*

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 9 Apr 2014 08:44:03 +0000

Agreed, option 2.

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: mercredi 9 avril 2014 04:43
To: Pat Kinney
Cc: Qin Wang; [email-masked]
Subject: Re: [6tisch] Should IEEE802.15.4 PIB be part of 6top YANG model?

+1 on option 2)

On Thu, Apr 3, 2014 at 7:26 AM, Pat Kinney <[email-masked]<mailto:[email-masked]>> wrote:
It seems to me that (2) is technically correct since the current IEEE 802.15.4 revision is merging the two anyway.

Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715<tel:%2B1.847.960.3715>
[email-masked]<mailto:[email-masked]>

On Apr 3, 2014, at 8:35 AM, Qin Wang <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

What do you think?

Thanks
Qin

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch