Subject: [6tisch] Yang model extension for OTF

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Thu, 10 Apr 2014 14:49:56 -0300

Dear all,
           In order to access the OTF module to select the algorithm and
pass external parameters, there is a proposal of using  and extension
to the YANG model, which may be used for other optional modules
as well.
           An example should be:

coap://[aaaa::1]/6t/ext/otf/alg

           Would it be possible to add this extension?

                                                   Diego

-- 
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Qin Wang <[email-masked]>
Date: Thu, 10 Apr 2014 17:32:34 -0700 (PDT)

Hi Diego,

According to my understanding, YANG model describes the data or functions accessed by some device via the network, one-hop or multi-hop away. If I'm right, then my question is who will call the OTF algorithm, upper layer or remotely?

Thanks
Qin 
On Friday, April 11, 2014 1:50 AM, Prof. Diego Dujovne <[email-masked]> wrote:
 
Dear all,

           An example should be: 

                                                   Diego 

_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch