Subject: [6tisch] bundle: hard or soft cells?

From: Maria Rita PALATTELLA <[email-masked]>
Date: Fri, 4 Apr 2014 09:38:23 +0000

Dear all,

While keeping in defining OTF, and its interaction with 6top, I have realized that there is something unclear about bundle and the type of cells that it includes (soft or hard), and maybe it is better we discuss on this.

According to the current definition in the terminology draft:

A Bundle is a group of equivalent scheduled cells, i.e. cells  identified by different [slotOffset, channelOffset], which are scheduled for a same purpose, with the same neighbor, with the same flags, and the same slotframe.

Based on that, we cannot have in a same bundle hard and soft cells together. Do you agree? Because they should have the same flags.

Moreover, in order to allow 6top to "play" with the bundle (e.g., allocate a specific cell within a bundle of overprovision cells), shouldn't bundle be by definition made ONLY by SOFT cells?

At the same time, if more HARD cells are scheduled for the same purpose, with the same neighbor, on the same slotframe, they should still create a bundle.

Maybe, we just need to clarify that we can have hard and soft bundle (like hard and soft cell), and that only soft bundle can include overprovision cells.

Does this make sense? What do you think?

Maria Rita

---

From: Qin Wang <[email-masked]>
Date: Fri, 4 Apr 2014 10:49:14 -0700 (PDT)

Hi Maria Rita,

To me, "for a same purpose" means serving same Track, "with same flag" means the Tx/Rx bits in LinkOptions flag, NORMAL/ADVERTISEMENT setting in LinkType flag are same. Of course, it is not the meaning by the current definition of bundle literally. But, I haven't seen the reason to split a "Link" according to CellType= SOFT or HARD.  

IMHO, if OTF wants to use the subset of softcells in a bundle, OTF can simply extract the subset by a filter. Maybe, in the future, some other algorithm only needs other subset of a bundle, that algorithm can extract the subset by using another filter. Make sense?

Thanks
Qin 

On Friday, April 4, 2014 6:07 PM, Maria Rita PALATTELLA <[email-masked]> wrote:

Dear all,

 

Moreover, in order to allow 6top to “play” with the bundle (e.g., allocate a specific cell within a bundle of overprovision cells), shouldn’t bundle be by definition made ONLY by SOFT cells?

 
 
Maria Rita

_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Mon, 7 Apr 2014 14:42:28 +0000

Dear Qin,
Thanks for your explanation. I am fine with keeping soft and hard cells together in a bundle, it doesn’t make sense to split the link, as you said.
If there is a way for filtering soft from hard cells, it is ok.
Maria Rita

From: 6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: Friday, April 04, 2014 7:49 PM
To: Maria Rita PALATTELLA; [email-masked]
Subject: Re: [6tisch] bundle: hard or soft cells?

Hi Maria Rita,

Thanks
Qin

On Friday, April 4, 2014 6:07 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Maria Rita

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch