Subject: [6tisch] generic interface extension

From: Qin Wang <[email-masked]>
Date: Thu, 17 Apr 2014 01:17:24 -0700 (PDT)

Hi All,

OTF authors found it is necessary to have some mechanism to extend 6top interface, i.e. data model. Considering the future, we think the extension mechanism should be generic, so that other extension modules (such as OTF) can be added to the interface when needed. We propose the generic extension mechanism as follows.

Parallel with the YANG model of 6top MIB and YANG model of IEEE802154, a extension of interface is added. The resource are defined as follows.
    -6t/6top/xxx. xxx points to the 6top MIB or rpc
    -6t/IEEE802154/yyy. yyy points to the IEEE802154 PIB 
    -6t/e/zzz. zzz points to extended interface, e.g. 6t/e/OTF

6top-interface draft only describes the mechanism to extend 6top interface, does not include the detail of extension. 

What do you think?

Thanks
Qin

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 17 Apr 2014 08:54:26 +0000

This is a great idea, Qin:

The idea of being able to plug services on 6top will enable a larger applicability to the concepts that you are putting in place.
I think it would be good to classify what is specific to the 4e MAC and what can be used for a more generic TSCH lower stack.

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: jeudi 17 avril 2014 10:17
To: [email-masked]
Subject: [6tisch] generic interface extension

Hi All,

What do you think?

Thanks
Qin

---

From: Qin Wang <[email-masked]>
Date: Thu, 17 Apr 2014 17:49:06 -0700 (PDT)

Hi Pascal,

I'm not sure I catch your meaning. Do you mean we need a generic interface for 4e MAC (i.e. TSCH)? Actually 6t/IEEE802154/yyy includes it, because we have agreed to merge YANG model of IEEE802.15.4 PIB and IEEE802.15.4e PIB into one.  Maybe I should make it more clear.

Do I miss something?

Thanks
Qin

On Thursday, April 17, 2014 4:54 PM, Pascal Thubert (pthubert) <[email-masked]> wrote:

 
Cheers,
 
Pascal
 
From:6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: jeudi 17 avril 2014 10:17
To: [email-masked]
Subject: [6tisch] generic interface extension
 
Hi All,

 
 
What do you think?
 
Thanks
Qin