Subject: Re: [6tisch] different slotframes lengths ?

From: Thomas Watteyne <[email-masked]>
Date: Thu, 3 Apr 2014 23:18:04 -0700

Dominique,

Different-lengths slotframes are very the norm in WirelessHART
implementations, and are described as follows in the IEEE802.15.4e standard
(section 5.1.1.5.4):

*A given network using timeslot-based access may contain several concurrent
slotframes of different sizes. Multiple slotframes may be used to define a
different communication schedule for various groups of nodes or to run the
entire network at different duty cycles by giving some devices many active
timeslots in a slotframe, and others few or none.*

*A network device may participate in one or more slotframes simultaneously,
and not all devices need to participate in all slotframes. By configuring a
network device to participate in multiple overlapping slotframes of
different sizes, it is possible to establish different communication
schedules and connectivity matrices that all work at the same time.*

*Slotframes can be added, removed, and modified while the network is
running. Even though this is the case, all slotframes are aligned to
timeslot boundaries, and timeslot 0 of the first repetition of every
slotframe is projected back to macASN = 0, which is determined by the PAN
coordinator (or other network device that starts the network). Because of
this, timeslots in different slotframes are always aligned, even though the
beginning and end of a particular repetition of that slotframe may not be
as illustrated in Figure 11d. When, for any given timeslot, a device has
links in multiple slotframes, transmissions take precedence over*
*receives, and lower slotframeHandle slotframes takes precedence over
higher slotframeHandle slotframes.*

I would to loose this flexibility.

Thomas

On Fri, Mar 28, 2014 at 9:14 AM, <[email-masked]> wrote:

>  Hello all,
>
>
>
> Considering we are still to agree on terminology when all nodes use one
> common slotframe length (which was the assumption hidden under Pascal's
> slides at the call today), I feel compelled to ask this question:
>
> Does anybody on this list intend to ever use nodes running different
> slotframe lengths in his/her 15.4e network?
>
> Answering this question may help gauge the effort still required to finish
> terminology J
>
> Best regards,
>
>
>
> Dominique
>
>
>
> _________________________________________________________________________________________________________________________
>
> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
> Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>
> This message and its attachments may contain confidential or privileged information that may be protected by law;
> they should not be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
> Thank you.
>
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

---

From: Pieter De Mil <[email-masked]>
Date: Fri, 4 Apr 2014 09:23:45 +0200

Exactly, being able to use different-lengths slotframes in a network is the feature of 802.15.4e that we don’t want to give up.

Best,
Pieter

On 04 Apr 2014, at 08:18, Thomas Watteyne <[email-masked]> wrote:

> Dominique,
> 
> Different-lengths slotframes are very the norm in WirelessHART implementations, and are described as follows in the IEEE802.15.4e standard (section 5.1.1.5.4):
> 
> A given network using timeslot-based access may contain several concurrent slotframes of different sizes. Multiple slotframes may be used to define a different communication schedule for various groups of nodes or to run the entire network at different duty cycles by giving some devices many active timeslots in a slotframe, and others few or none.
> 
> A network device may participate in one or more slotframes simultaneously, and not all devices need to participate in all slotframes. By configuring a network device to participate in multiple overlapping slotframes of different sizes, it is possible to establish different communication schedules and connectivity matrices that all work at the same time.
> 
> Slotframes can be added, removed, and modified while the network is running. Even though this is the case, all slotframes are aligned to timeslot boundaries, and timeslot 0 of the first repetition of every slotframe is projected back to macASN = 0, which is determined by the PAN coordinator (or other network device that starts the network). Because of this, timeslots in different slotframes are always aligned, even though the beginning and end of a particular repetition of that slotframe may not be as illustrated in Figure 11d. When, for any given timeslot, a device has links in multiple slotframes, transmissions take precedence over
> receives, and lower slotframeHandle slotframes takes precedence over higher slotframeHandle slotframes.
> 
> Considering we are still to agree on terminology when all nodes use one common slotframe length (which was the assumption hidden under Pascal’s slides at the call today), I feel compelled to ask this question:
> 
> Does anybody on this list intend to ever use nodes running different slotframe lengths in his/her 15.4e network?
> 
> Answering this question may help gauge the effort still required to finish terminology J
> 
> Best regards,
> 
>  
> 
> Dominique
> 
>  
>

---

From: <[email-masked]>
Date: Fri, 4 Apr 2014 07:31:41 +0000

Hello all,

Good feedback, thanks!
Then we need to get our terminology right, including in the context of multiple slotframe sizes.
Which, IMHO, is not the current situation.
Back to the coal mine...
Cheers

DOminique

De : Pieter De Mil [mailto:[email-masked]]
Envoyé : vendredi 4 avril 2014 09:24
À : Thomas Watteyne
Cc : BARTHEL Dominique IMT/OLPS; [email-masked]
Objet : Re: [6tisch] different slotframes lengths ?

Exactly, being able to use different-lengths slotframes in a network is the feature of 802.15.4e that we don't want to give up.

Best,
Pieter

On 04 Apr 2014, at 08:18, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> wrote:

Dominique,

Thomas

On Fri, Mar 28, 2014 at 9:14 AM, <[email-masked]<mailto:[email-masked]>> wrote:
Hello all,

Considering we are still to agree on terminology when all nodes use one common slotframe length (which was the assumption hidden under Pascal's slides at the call today), I feel compelled to ask this question:
Does anybody on this list intend to ever use nodes running different slotframe lengths in his/her 15.4e network?
Answering this question may help gauge the effort still required to finish terminology :)
Best regards,

Dominique

Thank you.

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Pat Kinney <[email-masked]>
Date: Fri, 4 Apr 2014 08:10:47 -0500

I am sorry that this reply is so late Dominique;

I believe that the current slotframe length of 15 ms is appropriate for the 250 kb/s at 2.4 GHz PHY, but the 802.15.4g PHYs have slower data rates with larger PSDUs.  For a typical data rate of 100 kb/s rate and a typical maximum length of 250 octets I would suggest an alternate duration of ~30 ms in addition to the 15 ms.

Thanks, Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked]

On Mar 28, 2014, at 11:14 AM, [email-masked] wrote:

Hello all,

Dominique

---

From: <[email-masked]>
Date: Fri, 4 Apr 2014 13:39:44 +0000

Hi Pat,

Thanks for your reply, this is useful information.

However, I meant frame length (or size or width, i.e. number of slots in a frame), as opposed to the length of one slot/cell.
I understand from the text quoted by Thomas that one does want the flexibility of running multiple frame lengths for duty_cycle and effective communication rate issues.
E.g. run some links with a frame length of 10 and allocate one timeslot to get a 10% duty_cycle and a 10% "datarate", and run other links with a frame length of 1.000 and allocate one timeslot to get .1% duty-cycle and datarate.
I was wondering if running all links on a 1.000 frame length and allocate 100 timeslot in a frame for the former links, and 1 timeslot to the latter ones, wouldn't do the same.
My thinking started from trying to understand the CDU matrix as a way to understand the time/frequency/space usage of a given network.
If we have multiple frames lengths, understanding this requires unrolling all the frames to the least common multiple of their lengths.
Hence the question, do we have a real need for all this?
I guess the question was answered, and we have to work on terminology to define those concepts.
Not sure what I just wrote makes sense to other than me ...

Dominique

De : Pat Kinney [mailto:[email-masked]]
Envoyé : vendredi 4 avril 2014 15:11
À : BARTHEL Dominique IMT/OLPS
Cc : [email-masked]
Objet : Re: [6tisch] different slotframes lengths ?

Thanks, Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked]<mailto:[email-masked]>

On Mar 28, 2014, at 11:14 AM, [email-masked]<mailto:[email-masked]> wrote:

Hello all,

Dominique

Thank you.

---

From: Pat Kinney <[email-masked]>
Date: Fri, 4 Apr 2014 08:50:57 -0500

thanks, you're right I misspoke...I will ask around about typical slotframe sizes and get back to this forum.

Pat

Pat Kinney
Kinney Consulting LLC

On Apr 4, 2014, at 8:39 AM, <[email-masked]> <[email-masked]> wrote:

Hi Pat,

However, I meant frame length (or size or width, i.e. number of slots in a frame), as opposed to the length of one slot/cell.
I understand from the text quoted by Thomas that one does want the flexibility of running multiple frame lengths for duty_cycle and effective communication rate issues.
E.g. run some links with a frame length of 10 and allocate one timeslot to get a 10% duty_cycle and a 10% “datarate”, and run other links with a frame length of 1.000 and allocate one timeslot to get .1% duty-cycle and datarate.
I was wondering if running all links on a 1.000 frame length and allocate 100 timeslot in a frame for the former links, and 1 timeslot to the latter ones, wouldn’t do the same.
My thinking started from trying to understand the CDU matrix as a way to understand the time/frequency/space usage of a given network.
If we have multiple frames lengths, understanding this requires unrolling all the frames to the least common multiple of their lengths.
Hence the question, do we have a real need for all this?
I guess the question was answered, and we have to work on terminology to define those concepts.
Not sure what I just wrote makes sense to other than me …
 
Dominique

 
 
Thanks, Pat
 
Pat Kinney
Kinney Consulting LLC

 
 
Hello all,

Dominique

---

From: <[email-masked]>
Date: Fri, 4 Apr 2014 13:51:39 +0000

Ooops, read 1,000 instead of 1.000
Wrong locale

Dominique

De : 6tisch [mailto:[email-masked]] De la part de [email-masked]
Envoyé : vendredi 4 avril 2014 15:40
À : Pat Kinney
Cc : [email-masked]
Objet : Re: [6tisch] different slotframes lengths ?

Hi Pat,

Dominique

Thanks, Pat

Pat Kinney
Kinney Consulting LLC

Hello all,

Dominique

Thank you.

Thank you.