Subject: [6tisch] Minutes 6top call today , 7AM Pacific, 10AM East, 4PM CET, 10PM CST

From: Xavier Vilajosana <[email-masked]>
Date: Tue, 22 Apr 2014 16:59:55 +0200

Dear all, find attached minutes and link to the recording of the 6top
discussion today.

regards,
Xavi

# Minutes Webex 22 April, 6top call 6TiSCH WG #

Recording:
https://cisco.webex.com/ciscosales/lsr.php?RCID=c9a14146f9b8420788c4bb1a1071847a

Note: timestamps in PDT.

Taking notes _(using Etherpad)_
-------------------------------

1. Xavi Vilajosana
1. Pascal Thubert

Attendance _(alphabetically)_
-----------------------------

1. Bryan Mclaughlin
1. Raghuram Sudhaakar
1. Pascal Thubert
1. Hannes Tschofening
1. Xavi Vilajosana
1. Qin Wang
1. Pouria Zand

Action items
------------

* QW to request an slot to present 6top to 6top negotiation at the next WG
meeting
* XV to send the OpenWSN CoAP link to RS
* RS to look at the block option from CoAP to determine overhead
* XV to present in next wg meeting the proposed mechanism.

Discussion
===========
[8:05] meeting starts
   Wrapping CoAP for 6top to 6top communication
   how to port to the draft

    2 interfaces, management and negotiation
    - discuss requirements

Qin: From a management interface is basic: SET AND GET
Qin: Negotiation requires a more complex interaction where several IEs are
exchanged
Qin: Use a CoAP to transport that information. The information will be
encoded in CBOR and embedded in an IE
Qin: Wrapper IE formed to transport that information (i.e encapsulate CoAP
meta packets)

Qin: RPC already defined

Qin: 6top to 6top negotiation by means of rpc. this is materialized in a
CoAP request to an URI like
6t/6top/sn (softcell-negotiation)

Qin: How to fragment? Do we use Block option from CoAP?

Raghu: 15.4e payload size limited, need fragments to transport the coap
packet in IE payload.
Raghu: What happens is fragment is lost? goal is a very minimal parser
Xavi: should look at block option, for sure solution for that

Xavi:  Packet reassembly from blocks. We assume that CoAP parser will be
able to reassemble blocks. Is there any concern on that assembly? should we
go deep on that study?
Qin:  If block option adds too much complexity to the parsing, then we can
limit the size of the Wrapper IE.

Raghu:  Critical point is to know the overhead in the header introduced by
the block option.

Xavi: In the interaction, how to handle errors?
Xavi: slide 11 what happens if fails, how is response sent from node A to
node B

   - Use CoAP error codes as payload of the response. Use Wrapper IE to
encapsulate them
   - This needs to be defined in the draft

Qin: needs more work
Raghu: payload of IE is used by COAP, full coap protocol including returned
codes

Qin: Open discussion. Is Observe extension also needed? What about the use
of URI-POrt.
The topic needs further investigation.

Qin: What draft should include what topic.

Suggestion to be confirmed in the ML after presentation:

6top Sublayer draft -- should include the wrapper IE
CoAP support will go to the CoAP draft. This will require a differentiated
section as this is to address 6top to 6top which is mainly for
decentralized scheduling.

[8:40] Meeting ends

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 22 Apr 2014 15:49:17 +0000

Thanks Xavi!

The minutes are uploaded to the Wiki https://bitbucket.org/6tisch/meetings/wiki/Home
And yes, we’ll book 10 minutes for 6top discussion at the next meeting April 25th

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Xavier Vilajosana
Sent: mardi 22 avril 2014 17:00
To: [email-masked]
Subject: [6tisch] Minutes 6top call today , 7AM Pacific, 10AM East, 4PM CET, 10PM CST

Dear all, find attached minutes and link to the recording of the 6top discussion today.

regards,
Xavi

Recording:

Note: timestamps in PDT.

1. Xavi Vilajosana
1. Pascal Thubert

1. Bryan Mclaughlin
1. Raghuram Sudhaakar
1. Pascal Thubert
1. Hannes Tschofening
1. Xavi Vilajosana
1. Qin Wang
1. Pouria Zand

Action items
------------

* QW to request an slot to present 6top to 6top negotiation at the next WG meeting
* XV to send the OpenWSN CoAP link to RS
* RS to look at the block option from CoAP to determine overhead
* XV to present in next wg meeting the proposed mechanism.

Discussion
===========
[8:05] meeting starts

Qin: From a management interface is basic: SET AND GET
Qin: Negotiation requires a more complex interaction where several IEs are exchanged
Qin: Use a CoAP to transport that information. The information will be encoded in CBOR and embedded in an IE
Qin: Wrapper IE formed to transport that information (i.e encapsulate CoAP meta packets)

Qin: RPC already defined

Qin: 6top to 6top negotiation by means of rpc. this is materialized in a CoAP request to an URI like
6t/6top/sn (softcell-negotiation)

Raghu: 15.4e payload size limited, need fragments to transport the coap packet in IE payload.
Raghu: What happens is fragment is lost? goal is a very minimal parser
Xavi: should look at block option, for sure solution for that

Xavi:  Packet reassembly from blocks. We assume that CoAP parser will be able to reassemble blocks. Is there any concern on that assembly? should we go deep on that study?
Qin:  If block option adds too much complexity to the parsing, then we can limit the size of the Wrapper IE.

Raghu:  Critical point is to know the overhead in the header introduced by the block option.

Xavi: In the interaction, how to handle errors?
Xavi: slide 11 what happens if fails, how is response sent from node A to node B

   - Use CoAP error codes as payload of the response. Use Wrapper IE to encapsulate them
   - This needs to be defined in the draft

Qin: needs more work
Raghu: payload of IE is used by COAP, full coap protocol including returned codes

Qin: Open discussion. Is Observe extension also needed? What about the use of URI-POrt.
The topic needs further investigation.

6top Sublayer draft -- should include the wrapper IE
CoAP support will go to the CoAP draft. This will require a differentiated section as this is to address 6top to 6top which is mainly for decentralized scheduling.

[8:40] Meeting ends