Subject: Re: [6tisch] Fwd: I-D Action: draft-ietf-6tisch-minimal-03.txt

From: Kees Trommel <[email-masked]>
Date: Fri, 07 Nov 2014 09:57:46 +0100

Hi,

This draft specifies that the enhanced beacon should include a
Channel Hopping IE with a Hopping Sequence ID equal to 0. Hopping
Sequence ID 0 is the default hopping sequence ID. So the actual
hopping sequence will not be included in the enhanced beacon.

Section 5.1.1a of the IEE802.25.4e standard defines an algorithm to
calculate a default hopping sequence ID.

I have the following questions regarding the default hopping
sequence:

1. Is it the intention that a minimal configuration uses the default
hopping sequence as defined in the IEE802.25.4e standard?

2. If the answer on 1. is yes:  The definition of the IEE802.25.4e
hopping sequence (in my opinion) is not unambiguous, so can you add
the actual default hopping sequence to this draft?

Regards,

Kees.

On Oct 27, 2014, at 12:20 AM, Xavier Vilajosana <xvilajosana

at eecs.berkeley.edu> wrote:

All, I just published the new version of minimal.
It includes a security section as discussed last call and some
changes to the default timing to be according to 15.4 tsch
default values.

regards,

Xavi

---------- Forwarded message
----------

From: <internet-drafts

at ietf.org>

Date: 2014-10-27 5:17 GMT+01:00

Subject: [6tisch] I-D Action:
draft-ietf-6tisch-minimal-03.txt

To: i-d-announce
at ietf.org

Cc: 6tisch at ietf.org

A New Internet-Draft is available from the on-line
Internet-Drafts directories.

This draft is a work item of the IPv6 over the TSCH mode
of IEEE 802.15.4e Working Group of the IETF.

Title           : Minimal 6TiSCH Configuration

Authors         : Xavier Vilajosana

Kris Pister

Filename        : draft-ietf-6tisch-minimal-03.txt

Pages           : 22

Date            : 2014-10-26

Abstract:

This document describes the minimal set of rules to
operate a

[IEEE802154e] Timeslotted Channel Hopping (TSCH)
network.  This

minimal mode of operation can be used during network
bootstrap, as a

fall-back mode of operation when no dynamic scheduling
solution is

available or functioning, or during early
interoperability testing

and development.

The IETF datatracker status page for this draft is:

https://datatracker.ietf.org/doc/draft-ietf-6tisch-minimal/

There's also a htmlized version available at:

http://tools.ietf.org/html/draft-ietf-6tisch-minimal-03

A diff from the previous version is available at:

http://www.ietf.org/rfcdiff?url2=draft-ietf-6tisch-minimal-03

Please note that it may take a couple of minutes from the
time of submission

until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:

ftp://ftp.ietf.org/internet-drafts/

_______________________________________________

6tisch mailing list

6tisch

at ietf.org

https://www.ietf.org/mailman/listinfo/6tisch

_______________________________________________

6tisch mailing list

6tisch

at ietf.org

https://www.ietf.org/mailman/listinfo/6tisch

---

From: Xavier Vilajosana <[email-masked]>
Date: Sat, 8 Nov 2014 06:27:10 +0100

Dear Kees,
thanks for your comments.

answering 1)
IMHO the fact that if default ch. hopping sequence is being used *may not
be* advertised in the EB it is not clear in the standard. And therefore I
opted to make the EB explicit (even only an ID and this being the default)
Page 11 of the 15.4e amendment indicates that:

*All hopping sequences are referred to by an ID, macHoppingSequenceID, with
ID = 0 denoting the default*
*sequence for a particular PHY (or PHY configuration if the PHY supports
more than one channel list).*

then page 92
*The full Hopping Sequence may be omitted to ensure that the frame does not
exceed aMaxPHYPacketSize.*
*In this case only the Hopping Sequence ID is carried, and the length of
the IE is 1 octet. When the length is*
*not equal to one, the additional fields are present. The element varies in
length depending upon the*
*numberOfChannels in use by the PHY. The channelPage and numberOfChannels
attributes can be used to*
*determine the size of the extendedBitmap, and the macHoppingSequenceLength
can be used to determine*
*the size of the macHoppingSequenceList.*
*The Channel Hopping IE may be used by any channel hopping PAN to
synchronize devices.*

My last point here is that this *may* might indicate optionality but the
case for the default id is not mentioned so I am not sure it can be elided
if default id (0)

answering 2) it seems a good point. Let us think about it.

regards,
Xavi

2014-11-07 9:57 GMT+01:00 Kees Trommel <[email-masked]>:

>  Hi,
>
> This draft specifies that the enhanced beacon should include a Channel
> Hopping IE with a Hopping Sequence ID equal to 0. Hopping Sequence ID 0 is
> the default hopping sequence ID. So the actual hopping sequence will not be
> included in the enhanced beacon.
>
> I have the following questions regarding the default hopping sequence:
>
> 2. If the answer on 1. is yes:  The definition of the IEE802.25.4e hopping
> sequence (in my opinion) is not unambiguous, so can you add the actual
> default hopping sequence to this draft?
>
> Regards,
>
> Kees.
>
> On Oct 27, 2014, at 12:20 AM, Xavier Vilajosana <xvilajosana at
> eecs.berkeley.edu <xvilajosana%20at%20eecs.berkeley.edu>> wrote:
>
>  All, I just published the new version of minimal. It includes a security
> section as discussed last call and some changes to the default timing to be
> according to 15.4 tsch default values.
>
>  regards,
> Xavi
>
> ---------- Forwarded message ----------
> From: <internet-drafts at ietf.org <internet-drafts%20at%20ietf.org>>
> Subject: [6tisch] I-D Action: draft-ietf-6tisch-minimal-03.txt
> To: i-d-announce at ietf.org <i-d-announce%20at%20ietf.org>
> Cc: 6tisch at ietf.org
>
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>  This draft is a work item of the IPv6 over the TSCH mode of IEEE
> 802.15.4e Working Group of the IETF.
>
>    This document describes the minimal set of rules to operate a
>    [IEEE802154e] Timeslotted Channel Hopping (TSCH) network.  This
>    minimal mode of operation can be used during network bootstrap, as a
>    fall-back mode of operation when no dynamic scheduling solution is
>    available or functioning, or during early interoperability testing
>    and development.
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> 6tisch at ietf.org <6tisch%20at%20ietf.org>
> 6tisch at ietf.org <6tisch%20at%20ietf.org>
> [email-masked]

---

From: Thomas Watteyne <[email-masked]>
Date: Sun, 9 Nov 2014 13:29:57 -1000

Kees, Xavi,

If the default hopping sequence isn't clear in IEEE802.15.4e-2012, this is
important information to the fed back to the IEEE802.15.4 TG. *@PatKinney*,
maybe you can chime in on whether the related text will be changed in
IEEE802.15.4-2015?

In any case, let's disambiguate the hopping sequence on this thread. We
could add an example in draft-ietf-6tisch-minimal, and maybe ask
IEEE802.15.4 to do the same.

I have created some quick Python code which I believe calculates the
default hopping sequence, see
https://gist.github.com/twatteyne/2e22ee3c1a802b685695.

Could someone (*Pat*? *Jonathan*?) double-check that it computes the right
sequence. I'm copy-pasting the output below.

Thomas

---

This script calculates the default channel hopping sequence for the
IEEE802.15.4e-2012 TSCH mode.

\author Thomas Watteyne
\date November 2014
\license http://opensource.org/licenses/BSD-3-Clause

=== Step a.

SHUFFLE is a macHoppingSequenceLength-sized array. The contents of this
array ar
e equivalent to the first macHoppingSequenceLength outputs of a 9-bit
linear fee
dback shift register (LFSR) with polynomial x9 + x5 + 1 and a starting seed
of 2
55. Each LFSR output is modulo macHoppingSequenceLength, so that each entry
of S
HUFFLE is between 0 and (macHoppingSequenceLength - 1), inclusive.

           5       9
   1 1 1 1 1 1 1 1 0 ( 255==0x0ff==b011111111)
   1 1 1 1 1 1 1 1 1 ( 511==0x1ff==b111111111) --> 15
   0 1 1 1 1 1 1 1 1 ( 510==0x1fe==b111111110) --> 14
   0 0 1 1 1 1 1 1 1 ( 508==0x1fc==b111111100) --> 12
   0 0 0 1 1 1 1 1 1 ( 504==0x1f8==b111111000) --> 8
   0 0 0 0 1 1 1 1 1 ( 496==0x1f0==b111110000) --> 0
   0 0 0 0 0 1 1 1 1 ( 480==0x1e0==b111100000) --> 0
   1 0 0 0 0 0 1 1 1 ( 449==0x1c1==b111000001) --> 1
   1 1 0 0 0 0 0 1 1 ( 387==0x183==b110000011) --> 3
   1 1 1 0 0 0 0 0 1 ( 263==0x107==b100000111) --> 7
   1 1 1 1 0 0 0 0 0 (  15==0x00f==b000001111) --> 15
   0 1 1 1 1 0 0 0 0 (  30==0x01e==b000011110) --> 14
   1 0 1 1 1 1 0 0 0 (  61==0x03d==b000111101) --> 13
   1 1 0 1 1 1 1 0 0 ( 123==0x07b==b001111011) --> 11
   1 1 1 0 1 1 1 1 0 ( 247==0x0f7==b011110111) --> 7
   1 1 1 1 0 1 1 1 1 ( 495==0x1ef==b111101111) --> 15
   1 1 1 1 1 0 1 1 1 ( 479==0x1df==b111011111) --> 15

SHUFFLE:  [15, 14, 12, 8, 0, 0, 1, 3, 7, 15, 14, 13, 11, 7, 15, 15]

=== Step b.

CHANNELS is a macHoppingSequenceLength-sized array that is initially
populated w
ith the monotonically increasing list of channels available to the PHY.

CHANNELS: [0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15]

=== Step c.

CHANNELS is shuffled as per Figure 7a. Elements may wind up being swapped
multip
le times in this process.

macHoppingSequenceList: *[5, 6, 12, 7, 15, 4, 14, 11, 8, 0, 1, 2, 13, 3, 9,
10]*

Script ended normally, press Enter to close.

On Friday, November 7, 2014, Xavier Vilajosana <
[email-masked]> wrote:

> *All hopping sequences are referred to by an ID, macHoppingSequenceID,
> with ID = 0 denoting the default*
> *The full Hopping Sequence may be omitted to ensure that the frame does
> not exceed aMaxPHYPacketSize.*
> *not equal to one, the additional fields are present. The element varies
> in length depending upon the*
> *determine the size of the extendedBitmap, and the
> macHoppingSequenceLength can be used to determine*
>> hopping sequence (in my opinion) is not unambiguous, so can you add the
>> actual default hopping sequence to this draft?
>>
>> Regards,
>>
>> Kees.
>>
>> eecs.berkeley.edu> wrote:
>>
>>  All, I just published the new version of minimal. It includes a
>> security section as discussed last call and some changes to the default
>> timing to be according to 15.4 tsch default values.
>>
>>  regards,
>> Xavi
>>
>> From: <internet-drafts at ietf.org>
>> To: i-d-announce at ietf.org
>> Cc: 6tisch at ietf.org
>>
>>
>>
>> 6tisch at ietf.org
>> 6tisch at ietf.org

---

From: Kees Trommel <[email-masked]>
Date: Mon, 10 Nov 2014 11:10:50 +0100

Thomas, Xavi,

Thanks, I cannot find anything in this script that would violate
the IEEE802.15.4e standard.

In this script you made the assumption that the hopping sequence
length is equal to the number of channels. I think this is
reasonable assumption but it is not defined in the IEEE802.15.4e
standard, so it would be good idea to put this assumption in the
draft too.

You are using channel numbers 0 - 15 and I assume that these are
the 16 2.5GHz channels. The IEEE802.15.4e standard define these as
channel numbers 11 - 26 of page 0. It is fine for me to keep the 0
- 15 channel numbering scheme but it would good to mention this
too. What about (future) support of other channels and pages
defined in the IEEE802.15.4e standard?

Kees.

On 11/10/14 00:29, Thomas Watteyne wrote:

Kees, Xavi,

If the default hopping sequence isn't clear in
IEEE802.15.4e-2012, this is important information to the fed
back to the IEEE802.15.4 TG. @PatKinney, maybe you can
chime in on whether the related text will be changed in
IEEE802.15.4-2015?

In any case, let's disambiguate the hopping sequence on
this thread. We could add an example in
draft-ietf-6tisch-minimal, and maybe ask IEEE802.15.4 to do
the same.

I have created some quick Python code which I believe
calculates the default hopping sequence, see https://gist.github.com/twatteyne/2e22ee3c1a802b685695.

Could someone (Pat? Jonathan?) double-check
that it computes the right sequence.
I'm copy-pasting the output below.

Thomas

---

This script
calculates the default channel hopping sequence for the

IEEE802.15.4e-2012
TSCH mode.

\author Thomas
Watteyne

\date November 2014

=== Step a.

SHUFFLE is a
macHoppingSequenceLength-sized array. The contents of this
array ar

e equivalent to the
first macHoppingSequenceLength outputs of a 9-bit linear
fee

dback shift register
(LFSR) with polynomial x9 + x5 + 1 and a starting seed of
2

55. Each LFSR output
is modulo macHoppingSequenceLength, so that each entry of
S

HUFFLE is between 0
and (macHoppingSequenceLength - 1), inclusive.

5       9

1 1 1 1 1 1 1 1 0
( 255==0x0ff==b011111111)

1 1 1 1 1 1 1 1 1
( 511==0x1ff==b111111111) --> 15

0 1 1 1 1 1 1 1 1
( 510==0x1fe==b111111110) --> 14

0 0 1 1 1 1 1 1 1
( 508==0x1fc==b111111100) --> 12

0 0 0 1 1 1 1 1 1
( 504==0x1f8==b111111000) --> 8

0 0 0 0 1 1 1 1 1
( 496==0x1f0==b111110000) --> 0

0 0 0 0 0 1 1 1 1
( 480==0x1e0==b111100000) --> 0

1 0 0 0 0 0 1 1 1
( 449==0x1c1==b111000001) --> 1

1 1 0 0 0 0 0 1 1
( 387==0x183==b110000011) --> 3

1 1 1 0 0 0 0 0 1
( 263==0x107==b100000111) --> 7

1 1 1 1 0 0 0 0 0
(  15==0x00f==b000001111) --> 15

0 1 1 1 1 0 0 0 0
(  30==0x01e==b000011110) --> 14

1 0 1 1 1 1 0 0 0
(  61==0x03d==b000111101) --> 13

1 1 0 1 1 1 1 0 0
( 123==0x07b==b001111011) --> 11

1 1 1 0 1 1 1 1 0
( 247==0x0f7==b011110111) --> 7

1 1 1 1 0 1 1 1 1
( 495==0x1ef==b111101111) --> 15

1 1 1 1 1 0 1 1 1
( 479==0x1df==b111011111) --> 15

SHUFFLE:  [15, 14,
12, 8, 0, 0, 1, 3, 7, 15, 14, 13, 11, 7, 15, 15]

=== Step b.

CHANNELS is a
macHoppingSequenceLength-sized array that is initially
populated w

ith the monotonically
increasing list of channels available to the PHY.

CHANNELS: [0, 1, 2,
3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15]

=== Step c.

CHANNELS is shuffled
as per Figure 7a. Elements may wind up being swapped
multip

le times in this
process.

macHoppingSequenceList:
[5, 6, 12, 7, 15, 4, 14, 11, 8, 0, 1,
2, 13, 3, 9, 10]

Script ended
normally, press Enter to close.

On Friday, November 7, 2014, Xavier Vilajosana <[email-masked]>
wrote:

Dear Kees,

answering 1)

IMHO the fact that if default ch. hopping sequence
is being used may not be advertised in the EB
it is not clear in the standard. And therefore I opted
to make the EB explicit (even only an ID and this
being the default)

All hopping sequences are referred to by an ID,
macHoppingSequenceID, with ID = 0 denoting the
default

sequence for a particular PHY (or PHY
configuration if the PHY supports more than one
channel list).

then page 92

The full Hopping Sequence may be omitted to
ensure that the frame does not exceed
aMaxPHYPacketSize.

In this case only the Hopping Sequence ID is
carried, and the length of the IE is 1 octet. When
the length is

not equal to one, the additional fields are
present. The element varies in length depending upon
the

numberOfChannels in use by the PHY. The
channelPage and numberOfChannels attributes can be
used to

determine the size of the extendedBitmap, and
the macHoppingSequenceLength can be used to
determine

the size of the macHoppingSequenceList.

The Channel Hopping IE may be used by
any channel hopping PAN to synchronize devices.

My last point here is that this may might
indicate optionality but the case for the default id is
not mentioned so I am not sure it can be elided if
default id (0)

answering 2) it seems a good point. Let us think
about it.

regards,

Xavi

2014-11-07 9:57 GMT+01:00 Kees
Trommel <[email-masked]>:

Hi,

This draft specifies that the enhanced beacon
should include a Channel Hopping IE with a
Hopping Sequence ID equal to 0. Hopping Sequence
ID 0 is the default hopping sequence ID. So the
actual hopping sequence will not be included in
the enhanced beacon.

Section 5.1.1a of the IEE802.25.4e standard
defines an algorithm to calculate a default
hopping sequence ID.

I have the following questions regarding the
default hopping sequence:

1. Is it the intention that a minimal
configuration uses the default hopping sequence
as defined in the IEE802.25.4e standard?

2. If the answer on 1. is yes:  The definition
of the IEE802.25.4e hopping sequence (in my
opinion) is not unambiguous, so can you add the
actual default hopping sequence to this draft?

Regards,

Kees.

On Oct 27, 2014, at 12:20 AM, Xavier Vilajosana
<xvilajosana

All, I just published the new
version of minimal. It includes a security
section as discussed last call and some
changes to the default timing to be
according to 15.4 tsch default values.

regards,

Xavi

----------
Forwarded message ----------

From: <internet-drafts at
ietf.org>

To: i-d-announce at
ietf.org

Cc: 6tisch at ietf.org

A New Internet-Draft is available from
the on-line Internet-Drafts
directories.

This draft is a work item of the IPv6
over the TSCH mode of IEEE 802.15.4e
Working Group of the IETF.

Title           : Minimal
6TiSCH Configuration

Authors         : Xavier
Vilajosana

Kris Pister

Filename        :

Pages           : 22

Date            : 2014-10-26

Abstract:

This document describes the minimal
set of rules to operate a

[IEEE802154e] Timeslotted Channel
Hopping (TSCH) network.  This

minimal mode of operation can be
used during network bootstrap, as a

fall-back mode of operation when no
dynamic scheduling solution is

available or functioning, or during
early interoperability testing

and development.

The IETF datatracker status page for
this draft is:

There's also a htmlized version
available at:

A diff from the previous version is
available at:

Please note that it may take a couple
of minutes from the time of submission

until the htmlized version and diff
are available at tools.ietf.org.

Internet-Drafts are also available by
anonymous FTP at:

6tisch mailing list

6tisch at ietf.org

6tisch mailing list

6tisch at ietf.org

6tisch mailing list

[email-masked]

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 10 Nov 2014 08:41:48 -1000

Kees,

In this script you made the assumption that the hopping sequence length is
> equal to the number of channels. I think this is reasonable assumption but
> it is not defined in the IEEE802.15.4e standard, so it would be good idea
> to put this assumption in the draft too.

Yes, that was my assumption in this code.

You are using channel numbers 0 - 15 and I assume that these are the 16
> 2.5GHz channels. The IEEE802.15.4e standard define these as channel numbers
> 11 - 26 of page 0. It is fine for me to keep the 0 - 15 channel numbering
> scheme but it would good to mention this too. What about (future) support
> of other channels and pages defined in the IEEE802.15.4e standard?

Correct, you should add 11 to the channel numbers in the code to use
channel numbers 11-26 in IEEE notation (2.405GHz-2.480GHz). AFAICT, there
is nothing in the hopping sequence of IEEE802.15.4e-TSCH which prevents the
use of (future) sets of channels.

*@all*, what do others think? Are details about the hopping sequence
something we need to add to draft-ietf-6tisch-minimal?

Thomas

On Mon, Nov 10, 2014 at 12:10 AM, Kees Trommel <[email-masked]>
wrote:

>  Thomas, Xavi,
>
> Thanks, I cannot find anything in this script that would violate the
> IEEE802.15.4e standard.
>
> In this script you made the assumption that the hopping sequence length is
> equal to the number of channels. I think this is reasonable assumption but
> it is not defined in the IEEE802.15.4e standard, so it would be good idea
> to put this assumption in the draft too.
>
> You are using channel numbers 0 - 15 and I assume that these are the 16
> 2.5GHz channels. The IEEE802.15.4e standard define these as channel numbers
> 11 - 26 of page 0. It is fine for me to keep the 0 - 15 channel numbering
> scheme but it would good to mention this too. What about (future) support
> of other channels and pages defined in the IEEE802.15.4e standard?
>
> Kees.
>
>
>  If the default hopping sequence isn't clear in IEEE802.15.4e-2012, this
> is important information to the fed back to the IEEE802.15.4 TG.
> *@PatKinney*, maybe you can chime in on whether the related text will be
> changed in IEEE802.15.4-2015?
>
>  Could someone (*Pat*? *Jonathan*?) double-check that it computes the
> right sequence. I'm copy-pasting the output below.
>
>  Thomas
>
>  ---
>
> dback shift register (LFSR) with polynomial x9 + x5 + 1 and a starting
> seed of 2
> 55. Each LFSR output is modulo macHoppingSequenceLength, so that each
> entry of S
>  CHANNELS is shuffled as per Figure 7a. Elements may wind up being
> swapped multip
>  macHoppingSequenceList: *[5, 6, 12, 7, 15, 4, 14, 11, 8, 0, 1, 2, 13, 3,
> 9, 10]*
>
>
>>  IMHO the fact that if default ch. hopping sequence is being used *may
>> not be* advertised in the EB it is not clear in the standard. And
>> therefore I opted to make the EB explicit (even only an ID and this being
>> the default)
>>  My last point here is that this *may* might indicate optionality but
>> the case for the default id is not mentioned so I am not sure it can be
>> elided if default id (0)
>>

---

From: Xavier Vilajosana <[email-masked]>
Date: Mon, 10 Nov 2014 21:15:28 +0100

Hi,

my 5 cents. After thinking about it I am in favour of adding the example as
the draft will be more self-contained and will facilitate the understanding
of how ch. hopping sequence is caluclated. (analogously to the OF0
example).

regards,
Xavi

2014-11-10 19:41 GMT+01:00 Thomas Watteyne <[email-masked]>:

>> In this script you made the assumption that the hopping sequence length
>> is equal to the number of channels. I think this is reasonable assumption
>> but it is not defined in the IEEE802.15.4e standard, so it would be good
>> idea to put this assumption in the draft too.
>>
>>  macHoppingSequenceList: *[5, 6, 12, 7, 15, 4, 14, 11, 8, 0, 1, 2, 13,
>> 3, 9, 10]*
>>
>>
>>> *numberOfChannels in use by the PHY. The channelPage and
>>> numberOfChannels attributes can be used to*

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 10 Nov 2014 10:17:29 -1000

Quick thought: does this discussion fit in draft-ietf-6tisch-minimal or
draft-ietf-6tisch-tsch? Both make sense to me.

On Mon, Nov 10, 2014 at 10:15 AM, Xavier Vilajosana <
[email-masked]> wrote:

> Hi,
>
> my 5 cents. After thinking about it I am in favour of adding the example
> as the draft will be more self-contained and will facilitate the
> understanding of how ch. hopping sequence is caluclated. (analogously to
> the OF0 example).
>
> regards,
> Xavi
>
>>>  If the default hopping sequence isn't clear in IEEE802.15.4e-2012,
>>> this is important information to the fed back to the IEEE802.15.4 TG.
>>> *@PatKinney*, maybe you can chime in on whether the related text will
>>> be changed in IEEE802.15.4-2015?
>>>
>>>  In any case, let's disambiguate the hopping sequence on this thread.
>>> We could add an example in draft-ietf-6tisch-minimal, and maybe ask
>>>  SHUFFLE is a macHoppingSequenceLength-sized array. The contents of
>>> this array ar
>>>>  *All hopping sequences are referred to by an ID,
>>>> macHoppingSequenceID, with ID = 0 denoting the default*
>>>> *sequence for a particular PHY (or PHY configuration if the PHY
>>>> supports more than one channel list).*
>>>>
>>>>  then page 92
>>>> *In this case only the Hopping Sequence ID is carried, and the length
>>>> of the IE is 1 octet. When the length is*
>>>> *not equal to one, the additional fields are present. The element
>>>> varies in length depending upon the*

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 10 Nov 2014 20:57:21 +0000

Hi Thomas:

I think:
- that the TSCH draft could discuss what is sub-defined in TSCH, indicate that we use the range 0-15, to address Kees’ points
- but then, the setting to be used in minimal, and pseudo code along the lines you produced should go in minimal to ensure interop. The pseudo code would be an appendix.

Makes sense?

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: lundi 10 novembre 2014 12:17
To: Xavier Vilajosana
Cc: Kees Trommel; [email-masked]
Subject: Re: [6tisch] I-D Action: draft-ietf-6tisch-minimal-03.txt

Quick thought: does this discussion fit in draft-ietf-6tisch-minimal or draft-ietf-6tisch-tsch? Both make sense to me.

On Mon, Nov 10, 2014 at 10:15 AM, Xavier Vilajosana <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

my 5 cents. After thinking about it I am in favour of adding the example as the draft will be more self-contained and will facilitate the understanding of how ch. hopping sequence is caluclated. (analogously to the OF0 example).

regards,
Xavi

2014-11-10 19:41 GMT+01:00 Thomas Watteyne <[email-masked]<mailto:[email-masked]>>:
Kees,

In this script you made the assumption that the hopping sequence length is equal to the number of channels. I think this is reasonable assumption but it is not defined in the IEEE802.15.4e standard, so it would be good idea to put this assumption in the draft too.

You are using channel numbers 0 - 15 and I assume that these are the 16 2.5GHz channels. The IEEE802.15.4e standard define these as channel numbers 11 - 26 of page 0. It is fine for me to keep the 0 - 15 channel numbering scheme but it would good to mention this too. What about (future) support of other channels and pages defined in the IEEE802.15.4e standard?

Correct, you should add 11 to the channel numbers in the code to use channel numbers 11-26 in IEEE notation (2.405GHz-2.480GHz). AFAICT, there is nothing in the hopping sequence of IEEE802.15.4e-TSCH which prevents the use of (future) sets of channels.

@all, what do others think? Are details about the hopping sequence something we need to add to draft-ietf-6tisch-minimal?

Thomas

On Mon, Nov 10, 2014 at 12:10 AM, Kees Trommel <[email-masked]<mailto:[email-masked]>> wrote:
Thomas, Xavi,

Thanks, I cannot find anything in this script that would violate the IEEE802.15.4e standard.

In this script you made the assumption that the hopping sequence length is equal to the number of channels. I think this is reasonable assumption but it is not defined in the IEEE802.15.4e standard, so it would be good idea to put this assumption in the draft too.

You are using channel numbers 0 - 15 and I assume that these are the 16 2.5GHz channels. The IEEE802.15.4e standard define these as channel numbers 11 - 26 of page 0. It is fine for me to keep the 0 - 15 channel numbering scheme but it would good to mention this too. What about (future) support of other channels and pages defined in the IEEE802.15.4e standard?

Kees.

If the default hopping sequence isn't clear in IEEE802.15.4e-2012, this is important information to the fed back to the IEEE802.15.4 TG. @PatKinney, maybe you can chime in on whether the related text will be changed in IEEE802.15.4-2015?

In any case, let's disambiguate the hopping sequence on this thread. We could add an example in draft-ietf-6tisch-minimal, and maybe ask IEEE802.15.4 to do the same.

I have created some quick Python code which I believe calculates the default hopping sequence, see https://gist.github.com/twatteyne/2e22ee3c1a802b685695.

Could someone (Pat? Jonathan?) double-check that it computes the right sequence. I'm copy-pasting the output below.

Thomas

---

\author Thomas Watteyne
\date November 2014

=== Step a.

SHUFFLE is a macHoppingSequenceLength-sized array. The contents of this array ar
e equivalent to the first macHoppingSequenceLength outputs of a 9-bit linear fee
dback shift register (LFSR) with polynomial x9 + x5 + 1 and a starting seed of 2
55. Each LFSR output is modulo macHoppingSequenceLength, so that each entry of S
HUFFLE is between 0 and (macHoppingSequenceLength - 1), inclusive.

           5       9

=== Step b.

CHANNELS is a macHoppingSequenceLength-sized array that is initially populated w
ith the monotonically increasing list of channels available to the PHY.

=== Step c.

CHANNELS is shuffled as per Figure 7a. Elements may wind up being swapped multip
le times in this process.

macHoppingSequenceList: [5, 6, 12, 7, 15, 4, 14, 11, 8, 0, 1, 2, 13, 3, 9, 10]

On Friday, November 7, 2014, Xavier Vilajosana <[email-masked]<mailto:[email-masked]>> wrote:
Dear Kees,
thanks for your comments.

answering 1)
IMHO the fact that if default ch. hopping sequence is being used may not be advertised in the EB it is not clear in the standard. And therefore I opted to make the EB explicit (even only an ID and this being the default)
Page 11 of the 15.4e amendment indicates that:

All hopping sequences are referred to by an ID, macHoppingSequenceID, with ID = 0 denoting the default
sequence for a particular PHY (or PHY configuration if the PHY supports more than one channel list).

then page 92
The full Hopping Sequence may be omitted to ensure that the frame does not exceed aMaxPHYPacketSize.
In this case only the Hopping Sequence ID is carried, and the length of the IE is 1 octet. When the length is
not equal to one, the additional fields are present. The element varies in length depending upon the
numberOfChannels in use by the PHY. The channelPage and numberOfChannels attributes can be used to
determine the size of the extendedBitmap, and the macHoppingSequenceLength can be used to determine
the size of the macHoppingSequenceList.
The Channel Hopping IE may be used by any channel hopping PAN to synchronize devices.

My last point here is that this may might indicate optionality but the case for the default id is not mentioned so I am not sure it can be elided if default id (0)

regards,
Xavi

2014-11-07 9:57 GMT+01:00 Kees Trommel <[email-masked]<mailto:[email-masked]>>:
Hi,

This draft specifies that the enhanced beacon should include a Channel Hopping IE with a Hopping Sequence ID equal to 0. Hopping Sequence ID 0 is the default hopping sequence ID. So the actual hopping sequence will not be included in the enhanced beacon.

Section 5.1.1a of the IEE802.25.4e standard defines an algorithm to calculate a default hopping sequence ID.

1. Is it the intention that a minimal configuration uses the default hopping sequence as defined in the IEE802.25.4e standard?
2. If the answer on 1. is yes:  The definition of the IEE802.25.4e hopping sequence (in my opinion) is not unambiguous, so can you add the actual default hopping sequence to this draft?

Regards,

Kees.

On Oct 27, 2014, at 12:20 AM, Xavier Vilajosana <xvilajosana at eecs.berkeley.edu> wrote:

All, I just published the new version of minimal. It includes a security section as discussed last call and some changes to the default timing to be according to 15.4 tsch default values.

regards,
Xavi

---------- Forwarded message ----------
From: <internet-drafts at ietf.org>
Date: 2014-10-27 5:17 GMT+01:00
Subject: [6tisch] I-D Action: draft-ietf-6tisch-minimal-03.txt
To: i-d-announce at ietf.org
Cc: 6tisch at ietf.org

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the IPv6 over the TSCH mode of IEEE 802.15.4e Working Group of the IETF.

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 10 Nov 2014 14:53:35 -1000

Pascal,

draft-ietf-6tisch-minimal should contain that it requires the default
channel hopping pattern. I think we agree on that.

The description of what the default channel hopping pattern is (this is
just a discussion about IEEE802.15.4e-2012, nothing 6TiSCH specific), might
end up in 6tisch/draft-ietf-6tisch-tsch.

What do others think?

Thomas

On Mon, Nov 10, 2014 at 10:57 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Hi Thomas:
>
>
>
> I think:
>
> - that the TSCH draft could discuss what is sub-defined in TSCH, indicate
> that we use the range 0-15, to address Kees’ points
>
> - but then, the setting to be used in minimal, and pseudo code along the
> lines you produced should go in minimal to ensure interop. The pseudo code
> would be an appendix.
>
>
>
> Makes sense?
>
>
>
> Pascal
>
>
>
> *From:* 6tisch [mailto:[email-masked]] *On Behalf Of *Thomas
> Watteyne
> *Sent:* lundi 10 novembre 2014 12:17
> *To:* Xavier Vilajosana
> *Cc:* Kees Trommel; [email-masked]
> *Subject:* Re: [6tisch] I-D Action: draft-ietf-6tisch-minimal-03.txt
>
>
>

---

From: Xavier Vilajosana <[email-masked]>
Date: Tue, 11 Nov 2014 05:18:57 +0100

Hi,

Thomas convinced me. As it is something 15.4 TSCH specific it seems
reasonable to have it at the tsch draft and indicate the use of the default
channel hopping sequence in minimal. Minimal won't be self-contained but it
is not alreday.

regards,
Xavi

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 10 Nov 2014 18:24:06 -1000

Xavi, thanks for your comments. What do others think?

On Mon, Nov 10, 2014 at 6:18 PM, Xavier Vilajosana <
[email-masked]> wrote:

>>> - that the TSCH draft could discuss what is sub-defined in TSCH,
>>> indicate that we use the range 0-15, to address Kees’ points
>>>

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Tue, 11 Nov 2014 15:50:59 +0000

Thomas, Xavi,
I do agree we should add the conceptual explanation of the default channel hopping sequence in the tsch draft, given that the draft is a sort of guidelines about how tsch works.
and at the same time we should  mention it in minimal draft and provide an example.
Maria Rita

From: 6tisch [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: Tuesday, November 11, 2014 5:24 AM
To: Xavier Vilajosana
Cc: Kees Trommel; Pascal Thubert (pthubert); [email-masked]
Subject: Re: [6tisch] I-D Action: draft-ietf-6tisch-minimal-03.txt

On Mon, Nov 10, 2014 at 6:18 PM, Xavier Vilajosana <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Thomas convinced me. As it is something 15.4 TSCH specific it seems reasonable to have it at the tsch draft and indicate the use of the default channel hopping sequence in minimal. Minimal won't be self-contained but it is not alreday.

regards,
Xavi

2014-11-11 1:53 GMT+01:00 Thomas Watteyne <[email-masked]<mailto:[email-masked]>>:
Pascal,

draft-ietf-6tisch-minimal should contain that it requires the default channel hopping pattern. I think we agree on that.

The description of what the default channel hopping pattern is (this is just a discussion about IEEE802.15.4e-2012, nothing 6TiSCH specific), might end up in 6tisch/draft-ietf-6tisch-tsch.

What do others think?

Thomas

On Mon, Nov 10, 2014 at 10:57 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Thomas:

I think:

Makes sense?

Pascal

From: 6tisch [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Thomas Watteyne
Sent: lundi 10 novembre 2014 12:17
To: Xavier Vilajosana
Cc: Kees Trommel; [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] I-D Action: draft-ietf-6tisch-minimal-03.txt

regards,
Xavi

Thomas

Kees.

Thomas

---

\author Thomas Watteyne
\date November 2014

=== Step a.

           5       9

=== Step b.

=== Step c.

answering 1)

then page 92

regards,
Xavi

Regards,

Kees.

On Oct 27, 2014, at 12:20 AM, Xavier Vilajosana <xvilajosana at eecs.berkeley.edu<http://eecs.berkeley.edu>> wrote:

regards,
Xavi

---------- Forwarded message ----------
From: <internet-drafts at ietf.org<http://ietf.org>>
Date: 2014-10-27 5:17 GMT+01:00
Subject: [6tisch] I-D Action: draft-ietf-6tisch-minimal-03.txt
To: i-d-announce at ietf.org<http://ietf.org>
Cc: 6tisch at ietf.org<http://ietf.org>

Abstract:

_______________________________________________
6tisch mailing list
6tisch at ietf.org<http://ietf.org>
https://www.ietf.org/mailman/listinfo/6tisch

_______________________________________________
6tisch mailing list
6tisch at ietf.org<http://ietf.org>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Kris Pister <[email-masked]>
Date: Tue, 11 Nov 2014 08:31:19 -0800

Given the rather obscure way that the default sequence is calculated, and
the readability of IEEE standards, it seems like a good idea to 
explicitly include
the default hop sequence in the minimal draft.  How about the following 
modification
to section 4.3.2 of the draft:
After the line "Channel Hopping Template ID (b0-b7) = 0x00" add

The default sequence for the 2.4GHz OQPSK PHY is
[5, 6, 12, 7, 15, 4, 14, 11, 8, 0, 1, 2, 13, 3, 9, 10]
per section 5.1.1a of [IEEE802154e].

ksjp

p.s. Thomas, I'm trusting that your python code is correct - I didn't check.

On 11/11/2014 7:50 AM, Maria Rita PALATTELLA wrote:
>
> Thomas, Xavi,
>
> I do agree we should add the conceptual explanation of the default 
> channel hopping sequence in the tsch draft, given that the draft is a 
> sort of guidelines about how tsch works.
>
> *From:*6tisch [mailto:[email-masked]] *On Behalf Of *Thomas 
> Watteyne
> *Sent:* Tuesday, November 11, 2014 5:24 AM
> *To:* Xavier Vilajosana
> *Cc:* Kees Trommel; Pascal Thubert (pthubert); [email-masked]
> On Mon, Nov 10, 2014 at 6:18 PM, Xavier Vilajosana 
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
> Hi,
>
> reasonable to have it at the tsch draft and indicate the use of the 
> default channel hopping sequence in minimal. Minimal won't be 
> self-contained but it is not alreday.
>
> regards,
> Xavi
>
> The description of what the default channel hopping pattern is (this 
> is just a discussion about IEEE802.15.4e-2012, nothing 6TiSCH 
> specific), might end up in 6tisch/draft-ietf-6tisch-tsch.
>
> What do others think?
>
> Thomas
>
> On Mon, Nov 10, 2014 at 10:57 AM, Pascal Thubert (pthubert) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
> Hi Thomas:
>
> I think:
>
> indicate that we use the range 0-15, to address Kees' points
>
> - but then, the setting to be used in minimal, and pseudo code along 
> the lines you produced should go in minimal to ensure interop. The 
> pseudo code would be an appendix.
>
> Makes sense?
>
> Pascal
>
> *From:*6tisch [mailto:[email-masked] 
> <mailto:[email-masked]>] *On Behalf Of *Thomas Watteyne
> *Cc:* Kees Trommel; [email-masked] <mailto:[email-masked]>
> Quick thought: does this discussion fit in draft-ietf-6tisch-minimal 
> or draft-ietf-6tisch-tsch? Both make sense to me.
>
> On Mon, Nov 10, 2014 at 10:15 AM, Xavier Vilajosana 
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
> Hi,
>
> my 5 cents. After thinking about it I am in favour of adding the 
> example as the draft will be more self-contained and will facilitate 
> the understanding of how ch. hopping sequence is caluclated. 
> (analogously to the OF0 example).
>
> regards,
>
> Xavi
>
> channel numbers 11-26 in IEEE notation (2.405GHz-2.480GHz). AFAICT, 
> there is nothing in the hopping sequence of IEEE802.15.4e-TSCH which 
> prevents the use of (future) sets of channels.
>
> length is equal to the number of channels. I think this is reasonable 
> assumption but it is not defined in the IEEE802.15.4e standard, so it 
> would be good idea to put this assumption in the draft too.
>
> You are using channel numbers 0 - 15 and I assume that these are the 
> 16 2.5GHz channels. The IEEE802.15.4e standard define these as channel 
> numbers 11 - 26 of page 0. It is fine for me to keep the 0 - 15 
> channel numbering scheme but it would good to mention this too. What 
> about (future) support of other channels and pages defined in the 
> IEEE802.15.4e standard?
>
> Kees.
>
>
>
>     this is important information to the fed back to the IEEE802.15.4
>     TG. *@PatKinney*, maybe you can chime in on whether the related
>     text will be changed in IEEE802.15.4-2015?
>
>     In any case, let's disambiguate the hopping sequence on this
>     thread. We could add an example in draft-ietf-6tisch-minimal, and
>     maybe ask IEEE802.15.4 to do the same.
>
>     I have created some quick Python code which I believe calculates
>     the default hopping sequence, see
>     Could someone (*Pat*? *Jonathan*?) double-check that it computes
>     the right sequence. I'm copy-pasting the output below.
>
>     Thomas
>
>     ---
>
>     macHoppingSequenceList: *[5, 6, 12, 7, 15, 4, 14, 11, 8, 0, 1, 2,
>     13, 3, 9, 10]*
>
>     On Friday, November 7, 2014, Xavier Vilajosana
>     <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>     Dear Kees,
>
>     IMHO the fact that if default ch. hopping sequence is being used
>     *may not be* advertised in the EB it is not clear in the standard.
>     And therefore I opted to make the EB explicit (even only an ID and
>     this being the default)
>
>     /All hopping sequences are referred to by an ID,
>     macHoppingSequenceID, with ID = 0 denoting the default/
>
>     /sequence for a particular PHY (or PHY configuration if the PHY
>     supports more than one channel list)./
>
>     then page 92
>
>     /The full Hopping Sequence may be omitted to ensure that the frame
>     does not exceed aMaxPHYPacketSize./
>
>     /In this case only the Hopping Sequence ID is carried, and the
>     length of the IE is 1 octet. When the length is/
>
>     /not equal to one, the additional fields are present. The element
>     varies in length depending upon the/
>
>     /numberOfChannels in use by the PHY. The channelPage and
>     numberOfChannels attributes can be used to/
>
>     /determine the size of the extendedBitmap, and the
>     macHoppingSequenceLength can be used to determine/
>
>     /the size of the macHoppingSequenceList./
>
>     /The Channel Hopping IE *may* be used by any channel hopping PAN
>     to synchronize devices./
>
>     My last point here is that this *may* might indicate optionality
>     but the case for the default id is not mentioned so I am not sure
>     it can be elided if default id (0)
>
>     Section 5.1.1a of the IEE802.25.4e standard defines an algorithm
>     to calculate a default hopping sequence ID.
>
>     1. Is it the intention that a minimal configuration uses the
>     default hopping sequence as defined in the IEE802.25.4e standard?
>     hopping sequence (in my opinion) is not unambiguous, so can you
>     add the actual default hopping sequence to this draft?
>
>     Regards,
>
>     Kees.
>
>     eecs.berkeley.edu <http://eecs.berkeley.edu>> wrote:
>
>     security section as discussed last call and some changes to the
>     default timing to be according to 15.4 tsch default values.
>
>     regards,
>     Xavi
>
>     From: <internet-drafts at ietf.org <http://ietf.org>>
>     To: i-d-announce at ietf.org <http://ietf.org>
>     Cc: 6tisch at ietf.org <http://ietf.org>
>
>
>
>     until the htmlized version and diff are available at
>     tools.ietf.org <http://tools.ietf.org>.
>
>     6tisch at ietf.org <http://ietf.org>
>         6tisch at ietf.org <http://ietf.org>
>     [email-masked] <mailto:[email-masked]>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 11 Nov 2014 18:21:27 +0000

I'm all for it : )

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Kris Pister
Sent: mardi 11 novembre 2014 08:31
To: [email-masked]
Subject: Re: [6tisch] I-D Action: draft-ietf-6tisch-minimal-03.txt

Given the rather obscure way that the default sequence is calculated, and
the readability of IEEE standards, it seems like a good idea to explicitly include
the default hop sequence in the minimal draft.  How about the following modification
to section 4.3.2 of the draft:
After the line "Channel Hopping Template ID (b0-b7) = 0x00" add

ksjp

From: 6tisch [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: Tuesday, November 11, 2014 5:24 AM
To: Xavier Vilajosana
Cc: Kees Trommel; Pascal Thubert (pthubert); [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] I-D Action: draft-ietf-6tisch-minimal-03.txt

regards,
Xavi

What do others think?

Thomas

I think:
- that the TSCH draft could discuss what is sub-defined in TSCH, indicate that we use the range 0-15, to address Kees' points
- but then, the setting to be used in minimal, and pseudo code along the lines you produced should go in minimal to ensure interop. The pseudo code would be an appendix.

Makes sense?

Pascal

regards,
Xavi

Thomas

Kees.

Thomas

---

\author Thomas Watteyne
\date November 2014

=== Step a.

           5       9

=== Step b.

=== Step c.

answering 1)

then page 92

regards,
Xavi

Regards,

Kees.

regards,
Xavi

---------- Forwarded message ----------
From: <internet-drafts at ietf.org<http://ietf.org>>
Date: 2014-10-27 5:17 GMT+01:00
Subject: [6tisch] I-D Action: draft-ietf-6tisch-minimal-03.txt
To: i-d-announce at ietf.org<http://ietf.org>
Cc: 6tisch at ietf.org<http://ietf.org>

Abstract:

6tisch mailing list

---

From: Xavier Vilajosana <[email-masked]>
Date: Tue, 11 Nov 2014 20:46:35 +0100

Hi,

I'll wait for others opinion and I'll add it to the draft.

regards,
Xavi

2014-11-11 19:21 GMT+01:00 Pascal Thubert (pthubert) <[email-masked]>:

>  I’m all for it : )
>
>
>
> Cheers,
>
>
>
> Pascal
>
>
>
> *From:* 6tisch [mailto:[email-masked]] *On Behalf Of *Kris Pister
> *Sent:* mardi 11 novembre 2014 08:31
> *To:* [email-masked]
>
> I do agree we should add the conceptual explanation of the default channel
> hopping sequence in the tsch draft, given that the draft is a sort of
> guidelines about how tsch works.
>
> *From:* 6tisch [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Thomas Watteyne

---

From: Alfredo Grieco <[email-masked]>
Date: Tue, 11 Nov 2014 20:48:12 +0100

+1. cheers. Al
Il giorno 11/nov/2014, alle ore 20:46, Xavier Vilajosana <[email-masked]> ha scritto:

> On Mon, Nov 10, 2014 at 6:18 PM, Xavier Vilajosana <[email-masked]> wrote:
> 
> Hi, 
> 
>  
> 
> On Mon, Nov 10, 2014 at 10:57 AM, Pascal Thubert (pthubert) <[email-masked]> wrote:
> 
> Hi Thomas:
> 
>  
> 
> I think:
> 
> On Mon, Nov 10, 2014 at 10:15 AM, Xavier Vilajosana <[email-masked]> wrote:
> 
> Hi, 
> 
>  
> 
> On Mon, Nov 10, 2014 at 12:10 AM, Kees Trommel <[email-masked]> wrote:
> 
> Thomas, Xavi,
> 
> On Friday, November 7, 2014, Xavier Vilajosana <[email-masked]> wrote:
> 
> Dear Kees,
> 

-- 
Luigi Alfredo Grieco, PhD 
Associate Professor
Dep. of Electrical and Information Engineering (DEI)
Politecnico di Bari
Via Orabona, 4
70125 - Bari - Italy
Phone: +39 080 5963 911
url: telematics.poliba.it
mail: [email-masked]