Subject: [6tisch] RPL instance in Minimal

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sat, 8 Nov 2014 15:18:25 +0000

Dear all:

At the last interim call (http://www.ietf.org/mail-archive/web/6tisch/current/msg02661.html) the question of the RPL instance came up for the minimal draft.

Should we recommend to use a particular instance or not?

Arguments on the table are: 
- We wish to limit interop issues so suggesting an instance by default could be a good idea
- Using a different instance requires signaling or config
- https://tools.ietf.org/html/draft-thubert-6lo-rpl-nhc-02 can elide instance 0 
- Some implementations do not support multi instance routing 
- We need an instance for time distribution

All in all, it appears that instance 0 will be used a lot and if we associate it with minimal, then we must make sure that non minimal time slots can also be associated to that same instance.

What do you think?

Pascal

---

From: Michael Richardson <[email-masked]>
Date: Sat, 08 Nov 2014 21:18:53 -0500

Pascal Thubert (pthubert) <[email-masked]> wrote:
    > All in all, it appears that instance 0 will be used a lot and if we
    > associate it with minimal, then we must make sure that non minimal time
    > slots can also be associated to that same instance.

    > What do you think?

yes.
6tisch MUST suppport Instance 0 for the initial process.
Once you have connectivity to PCE, the PCE can provision other things as
required ...

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Thomas Watteyne <[email-masked]>
Date: Sat, 8 Nov 2014 18:29:58 -0800

Pascal,
Instance 0 seems like a good idea, and your list of discussion point hint
at the same. What are the cons?
Thomas

On Saturday, November 8, 2014, Michael Richardson <[email-masked]>
wrote:

>
> Pascal Thubert (pthubert) <[email-masked] <javascript:;>> wrote:
> Michael Richardson <[email-masked] <javascript:;>>, Sandelman
> Software Works