Subject: [6tisch] Additional Comments for "draft-dujovne-6tisch-on-the-fly-04"

From: "Wang, Chonggang" <[email-masked]>
Date: Mon, 2 Feb 2015 14:30:29 +0000

Hi Diego,

I have a few additional comments on your draft: draft-dujovne-6tisch-on-the-fly-04

·         On page 3, section 2, paragraph 1, “For example, 6top might decide to add a cell if some queue of outbound frames is overflowing.”  Should “6top” change to “OTF”?

·         On page 3, section 2, paragraph 2, “These cells can be used for forwarding any packet in the queue, regardless of the specific track it belongs to.” As stated in draft-ietf-6tisch-architecture-04, OTF is used for Neighbor-to-neighbor Scheduling. However, Track is used for Hop-by-hop scheduling. Should soft cells allocated by OTF only forward packet that belong to best effort traffic, i.e., TrackID=00?

·         On page 4, bullet 2 for The OTF allocation policy, there is a OTFTHRESH for when decreasing number of scheduled cells, why not also put a threshold when increase number of cells? For example, add one or more soft cells when REQUIREDCELLS > (SCHEDULEDCELLS+OTFTHRESH)?

·         On page 5, paragraph 2, “If a bundle is already reserved between the same pair of neighbors, on the same track, this request translates into a bundle resize request.”. Should the “the same track” be specified as the track with TRACKID=00? Also, which entity “translate” the request, OTF or 6top?

·         On page 5, section 4, paragraph 1, “By using the DELETE.softcell command, and asking for deleting multiple softcells, OTF has 6top delete the entire best effort bundle.” Should OTF check if there is a softcell in the bundle before it has 6top delete the entire best effort bundle?

·         On page 6, section 5 paragraph 4, “Based on the quality of the link, e.g., LQI under threshold, OTF may ask 6top to delete some cells, in order to reserve them for better-connected links.” Is this feature duplicated with 6top? 6top may also reallocate soft cells to increase the link quality without letting upper layer know.

Thanks,
CG

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Mon, 2 Feb 2015 11:38:17 -0300

Chonggang,
                Thank you for these comments. We will take them
into consideration for the next version of the draft. (Coming soon!)
Regards,

                                         Diego Dujovne

2015-02-02 11:30 GMT-03:00 Wang, Chonggang <[email-masked]>
:

> ·         On page 3, section 2, paragraph 1, “For example, 6top might
> decide to add a cell if some queue of outbound frames is overflowing.”
>  Should “6top” change to “OTF”?
>
> ·         On page 3, section 2, paragraph 2, “These cells can be used for
> forwarding any packet in the queue, regardless of the specific track it
> belongs to.” As stated in draft-ietf-6tisch-architecture-04, OTF is used
> for Neighbor-to-neighbor Scheduling. However, Track is used for Hop-by-hop
> scheduling. Should soft cells allocated by OTF only forward packet that
> belong to best effort traffic, i.e., TrackID=00?
>
> ·         On page 4, bullet 2 for The OTF allocation policy, there is a
> OTFTHRESH for when decreasing number of scheduled cells, why not also put a
> threshold when increase number of cells? For example, add one or more soft
> cells when REQUIREDCELLS > (SCHEDULEDCELLS+OTFTHRESH)?
>
> ·         On page 5, paragraph 2, “If a bundle is already reserved
> between the same pair of neighbors, on the same track, this request
> translates into a bundle resize request.”. Should the “the same track” be
> specified as the track with TRACKID=00? Also, which entity “translate” the
> request, OTF or 6top?
>
> ·         On page 5, section 4, paragraph 1, “By using the
> DELETE.softcell command, and asking for deleting multiple softcells, OTF
> has 6top delete the entire best effort bundle.” Should OTF check if there
> is a softcell in the bundle before it has 6top delete the entire best
> effort bundle?
>
> ·         On page 6, section 5 paragraph 4, “Based on the quality of the
> link, e.g., LQI under threshold, OTF may ask 6top to delete some cells, in
> order to reserve them for better-connected links.” Is this feature
> duplicated with 6top? 6top may also reallocate soft cells to increase the
> link quality without letting upper layer know.
>
>
>
> Thanks,
>
> CG
>
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

-- 
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 3 Feb 2015 17:40:31 +0100

Diego,

Perhaps you track these different remarks directly at
https://bitbucket.org/6tisch/draft-dujovne-6tisch-on-the-fly/issues?
(since this is not a WG doc yet, we cannot use the built-in IETF tracker,
but the bitbucket one offers equivalent functionality).

Thomas

On Mon, Feb 2, 2015 at 3:38 PM, Prof. Diego Dujovne <
[email-masked]> wrote:

> 2015-02-02 11:30 GMT-03:00 Wang, Chonggang <
> [email-masked]>:
>
>>   Hi Diego,
>>
>>
>>
>> ·         On page 3, section 2, paragraph 2, “These cells can be used
>> for forwarding any packet in the queue, regardless of the specific track it