Subject: [6tsch] minutes WebEx 15 February 2013

From: Thomas Watteyne <[email-masked]>
Date: Fri, 15 Feb 2013 11:03:30 -0800

All,
Great call today. Please find the notes I took below. Don't hesitate to
update and resend this e-mail if I missed something.
Thomas

---

Present:
- 6tsch (someone from Poliba, couldn't hear who)
- Gennaro Boggia
- Marc Blanchet
- Normann Finn
- Pascal Thubert
- Qin Wang
- Raghuram Sudhaakar
- Robert Assimiti
- Sateesh Addepalli
- Thomas Watteyne
- Tina Tsou
- Tom Phinney
- Xavier Vilajosana

Agenda
======

1. [10min] Status/Discussion on draft-watteyne-6tsch-tsch-lln-context
2. [10min] Other potential early drafts, examples:
      - the 'sublayer' specification (Qin, Xavi, others?)
      - overall architecture document (Pascal, others?)
3. [30min] Preparing for the bar BOF;
      - [5min]  agree on date (Tuesday or Wednesday noon).  5min
      - [10min] bar BOF goals (sponsor?).
      - [15min] List goals, scope, dependencies (liaisons) for a 6TSCH group
4. [time permitting] misc topics based on ML discussions.

Minutes
=======

Meeting starts at 09.05 PST

1.
   - [Pascal] asks for status and update
   - [Thomas] 3 open issues on draft:
      . stressing requirements on security in section 3.1 (joining)
      . adding text on deterministic networks
      . extract gotcha: two ways of synchronizing
2.
   - [Pascal] Pascal to start architecture draft
   - [Pascal] second draft about sublayer, started by Qin and Xavi
   - [Normann] Offers to give a quick overview of work on deterministic
     Ethernet in 802.1 IEEE group.
        . Topology is not spanning tree, but rather IS-IS used to run the
          network
        . BW reservation scheme
        . time sync scheme based on 1588
        . already work with the 802.11 group to have 802.11 appear as "just
          another medium", possibly to be used with wireless meshes of APs.
        . Time scheduled transmission
        . Preempting transmission with higher priority frame (not
applicable to
          wireless).
        . working group used to be called Audio Vdeo Group (AVG), name
          changed to Time Sensitive Networks (TSN)
        . Interested in QoS, especially l3/l2 interaction.
3.
   - [Pascal] We have a draw between Tuesday and Wednesday noon for bar-Bof.
   - [Pascal] Let's hold it on Tuesday, so we can have an extra session of
     Wednesday noon if needed.
   - [Thomas] Allows us to be right after ROLL.
   - Pascal to e-mail ADs (in particular Ralph) to ask for room
   - [Pascal] Would Marc agree to helf 6tsch group out to run the bar BoF
and
     prepare for a successful BoF?
        . [Marc] Yes.
   - [Pascal] We have 1.5h during bar-BoF. We should try not to dwell too
much
      on technical issues, but rather discuss:
        . goals.
        . scope.
        . dependencies.
   - [Thomas] Let's publicize in ROLL
   - [Marc] we should use same room as ROLL, since meeting right after
   - [Thomas] We can use draft-watteyne-6tsch-tsch-lln-context to list
goals.
4.
   - [Thomas] Synchronization:
      . [Thomas] There are two mechanisms: EB and KA messages.
      . [Robert] EB can be used exclusively. Using EBs consumes less power
than
        KA.
      . [Thomas] Let's discuss this on ML.
   - [Thomas] Using time rather than ASN:
      . [Tom] Don't want per se to discuss this in 6tsch context, we can
carry
        on using ASN.
      . [Robert] It's an important discussion to have. Problems comes up in
        802.15.4g where multiple modulation/datarate settings cause packet
to
        be very different. If deriving slot length from worst case packet
        length, this results in lots of bandwidth waste.
      . [Robert] Can be done with extra IE.
      . [Thomas] Let's "keep an eye open" for cases where switching between
        ASN and time poses a problem, and maybe write up a document which
        explains how to do so later.
      . [Robert] Agreed.
      . [Tom] Agreed.
   - [Pascal] new "shim" layer draft.
      . [Pascal] this draft needs to contain:
         . the API towards IP
         . the API towards the existing TSCH
         . some text about the data flows
      . [Qin] Have started working on it. Will take those changes into
account.
      . [Xavi] Agreed. Will work on the draft in the coming week.

Meeting ends at 10.05 PST

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 15 Feb 2013 11:34:13 -0800

Updated version with Alfredo's name (thanks for the correction, Alfredo!)

On Fri, Feb 15, 2013 at 11:03 AM, Thomas Watteyne <
[email-masked]> wrote:

> - Alfredo Grieco