Subject: [6tsch] TDMA Like Link Protocol for L3 Wireless Sensor Adhoc Mesh with low cost out-of-band global synchronization

From: "Sateesh Addepalli (sateeshk)" <[email-masked]>
Date: Tue, 12 Feb 2013 20:00:30 +0000

Greetings All.
Great discussions on the various valuable topics.
Here are some quick thoughts I have.
One of things we need to keep in mind is Wireless Sensor networks will be energy constrained in nature.
Hence, I believe we need to keep following things need to be considered :
    1. A predictable network lifetime to between IP gateway and the sensor nodes
    2. An efficient Global synchronization technique with Out of band hardware based synchornization
    3. TDMA like link protocol as opposed to random access protocol in order to have  control over Layer 3 topology as well as end-to-end delay.

Thoughts and conversation over this are welcome.

Thanks
Sateesh Addepalli, Cisco Systems

---

From: "Sateesh Addepalli (sateeshk)" <[email-masked]>
Date: Tue, 12 Feb 2013 20:07:30 +0000

Greetings All.
Great discussions on the various valuable topics.
Here are some quick thoughts I have.
One of things we need to keep in mind is Wireless Sensor networks will be energy constrained in nature.
Hence, I believe we need to consider the following:
    1. A predictable network lifetime between IP gateway and the sensor nodes
    2. An efficient Global synchronization technique with Out of band hardware based synchornization
    3. TDMA like link protocol as opposed to random access protocol in order to have  control over Layer 3 topology as well as end-to-end delay.

Thanks

---

From: Tom Phinney <[email-masked]>
Date: Tue, 12 Feb 2013 13:34:08 -0700

I take issue with 2) below. History is full of
examples of "out of band" synchronization mechanisms that fell by
the wayside as technology changed. "In-band" synchronization is
the only way to go that is PHY neutral. TSCH inherently involves
tight time synch to align transmission slots in one node with
reception slots in others, with coordinated channel hopping. If
the L2 (data-link) protocol is designed with care, that is
sufficient to achieve synchronization to within the error bounds
necessary. The limiting factor on energy management here is the
stability of the local clock in each node (mote), together with
the protocol requirements for transmitting within a slot.

ANSI/ISA100.11a, which is being standardized internationally as
IEC 62734, manages this for devices that have long sleep periods
by offering a "slow hopping" mode in which a device that wakes
after a long sleep can transmit at any time within a multi-slot
interval in its shared schedule. An extra byte in the messaging
conveys its sense of which slot it is transmitting in to the
receiving device(s), permitting authenticated receipt and
acknowledgment even though the nonces used to cryptographically
protect each direction of transmission require knowledge of the
sender's specific choice of slot. A device that has slept
for an even longer interval than this synchronization mechanism can
support must listen for one (or, after extremely long outages, two)
messages from the synchronized portion of the system to establish
clock synch before it knows the current time relative to the shared
schedule as agreed by that synchronized portion of the system.

While it is attractive to look forward to the days of
software-defined radios that can listen to a GPS satellite broadcast
when initially deployed, or after extremely long outages, to gain an
approximate sense of the system's time, such signals are not
available in all environments. (Nor are such radios currently small
enough and power-efficient enough and low-enough cost to go into
each mote.) Use of the TSCH signaling that is always present when
the system is in operation seems to be the most efficient way to
maintain synchronization.

-Tom Phinney

On 2013.02.12 13:07, Sateesh Addepalli (sateeshk) wrote:

Greetings All.

One of things we need to keep in mind is Wireless
Sensor networks will be energy constrained in nature.

1. A predictable network lifetime between IP
gateway and the sensor nodes

2. An efficient Global synchronization technique
with Out of band hardware based synchornization

3. TDMA like link protocol as opposed to random
access protocol in order to have  control over Layer 3
topology as well as end-to-end delay.

Thanks

_______________________________________________
6tsch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tsch

---

From: "Sateesh Addepalli (sateeshk)" <[email-masked]>
Date: Tue, 12 Feb 2013 21:04:18 +0000

Tom,
 Thanks for your great insight.

 While I agree to having in-band synchronization,  I believe it  is still a loose synchronization in wireless sensor environment. Any loose synchronization degrades performance severely with increases node degree and traffic pattern.

 Proposal for low cost out of band global synchronization can still co-exist with in-band synchronization without effecting the physical layer.
 Furthermore,  my suggestion of out of band is not about using expensive GPS broadcast, rather using a highly localized broadcast channel carrying timing information .

 In essence, both in band and out of band shall co-exist to feed the PHY layer with a common clock. Depending on the deployment scenario one or both can be used.

Thanks
Sateesh

From: Tom Phinney <[email-masked]<mailto:[email-masked]>>
Reply-To: Tom Phinney <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 12, 2013 12:34 PM
To: <[email-masked]<mailto:[email-masked]>>
Subject: Re: [6tsch] TDMA Like Link Protocol for L3 Wireless Sensor Adhoc Mesh with low cost out-of-band global synchronization

I take issue with 2) below. History is full of examples of "out of band" synchronization mechanisms that fell by the wayside as technology changed. "In-band" synchronization is the only way to go that is PHY neutral. TSCH inherently involves tight time synch to align transmission slots in one node with reception slots in others, with coordinated channel hopping. If the L2 (data-link) protocol is designed with care, that is sufficient to achieve synchronization to within the error bounds necessary. The limiting factor on energy management here is the stability of the local clock in each node (mote), together with the protocol requirements for transmitting within a slot.

ANSI/ISA100.11a, which is being standardized internationally as IEC 62734, manages this for devices that have long sleep periods by offering a "slow hopping" mode in which a device that wakes after a long sleep can transmit at any time within a multi-slot interval in its shared schedule. An extra byte in the messaging conveys its sense of which slot it is transmitting in to the receiving device(s), permitting authenticated receipt and acknowledgment even though the nonces used to cryptographically protect each direction of transmission require knowledge of the sender's specific choice of slot. A device that has slept for an even longer interval than this synchronization mechanism can support must listen for one (or, after extremely long outages, two) messages from the synchronized portion of the system to establish clock synch before it knows the current time relative to the shared schedule as agreed by that synchronized portion of the system.

While it is attractive to look forward to the days of software-defined radios that can listen to a GPS satellite broadcast when initially deployed, or after extremely long outages, to gain an approximate sense of the system's time, such signals are not available in all environments. (Nor are such radios currently small enough and power-efficient enough and low-enough cost to go into each mote.) Use of the TSCH signaling that is always present when the system is in operation seems to be the most efficient way to maintain synchronization.

-Tom Phinney

Greetings All.

Thanks

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/6tsch

---

From: Kris Pister <[email-masked]>
Date: Tue, 12 Feb 2013 15:27:22 -0800

Sateesh - I agree with your items 1 and 3 below.  As far as predictable 
network lifetime is concerned, TSCH (which is strictly TDMA if you use 
only unicast links) provides pretty good deterministic power 
consumption/lifetime.  Theory, simulations, and direct measurement all 
match quite well in the networks that I've measured.

I agree with Tom on OoB global synchronization though.  Perhaps I don't 
understand what you mean by "highly localized broadcast channel" - maybe 
you could say more on what you had in mind there?

Regarding "loose synchronization" in TSCH networks, 0.1ms is easy to do 
and 1us RMS is demonstrated in commercial products.  That's super-loose 
by some standards, but plenty tight enough for crypto, deep radio duty 
cycles, etc.  By the nature of TSCH networks, the more connectivity and 
packets there are the better synchronization gets.  I'm not sure if I 
understand your statement that sync degrades with increased node degree 
and traffic, but I think that I disagree.

ksjp

On 2/12/2013 1:04 PM, Sateesh Addepalli (sateeshk) wrote:
>  While I agree to having in-band synchronization,  I believe it  is 
> still a loose synchronization in wireless sensor environment. Any 
> loose synchronization degrades performance severely with increases 
> node degree and traffic pattern.
>  Proposal for low cost out of band global synchronization can still 
> co-exist with in-band synchronization without effecting the physical 
> layer.
>  Furthermore,  my suggestion of out of band is not about using 
> expensive GPS broadcast, rather using a highly localized broadcast 
> channel carrying timing information .
>
>  In essence, both in band and out of band shall co-exist to feed the 
> PHY layer with a common clock. Depending on the deployment scenario 
> one or both can be used.
>
> Thanks
> Sateesh
>
> From: Tom Phinney <[email-masked] <mailto:[email-masked]>>
> Reply-To: Tom Phinney <[email-masked] <mailto:[email-masked]>>
> To: <[email-masked] <mailto:[email-masked]>>
> Subject: Re: [6tsch] TDMA Like Link Protocol for L3 Wireless Sensor 
> Adhoc Mesh with low cost out-of-band global synchronization
>
> I take issue with 2) below. History is full of examples of "out of 
> band" synchronization mechanisms that fell by the wayside as 
> technology changed. "In-band" synchronization is the only way to go 
> that is PHY neutral. TSCH inherently involves tight time synch to 
> align transmission slots in one node with reception slots in others, 
> with coordinated channel hopping. If the L2 (data-link) protocol is 
> designed with care, that is sufficient to achieve synchronization to 
> within the error bounds necessary. The limiting factor on energy 
> management here is the stability of the local clock in each node 
> (mote), together with the protocol requirements for transmitting 
> within a slot.
>
> ANSI/ISA100.11a, which is being standardized internationally as IEC 
> 62734, manages this for devices that have long sleep periods by 
> offering a "slow hopping" mode in which a device that wakes after a 
> long sleep can transmit at any time within a multi-slot interval in 
> its shared schedule. An extra byte in the messaging conveys its sense 
> of which slot it is transmitting in to the receiving device(s), 
> permitting authenticated receipt and acknowledgment even though the 
> nonces used to cryptographically protect each direction of 
> transmission require knowledge of the sender's specific choice of 
> slot. A device that has slept for an even longer interval than this 
> synchronization mechanism can support must listen for one (or, after 
> extremely long outages, two) messages from the synchronized portion of 
> the system to establish clock synch before it knows the current time 
> relative to the shared schedule as agreed by that synchronized portion 
> of the system.
>
> While it is attractive to look forward to the days of software-defined 
> radios that can listen to a GPS satellite broadcast when initially 
> deployed, or after extremely long outages, to gain an approximate 
> sense of the system's time, such signals are not available in all 
> environments. (Nor are such radios currently small enough and 
> power-efficient enough and low-enough cost to go into each mote.) Use 
> of the TSCH signaling that is always present when the system is in 
> operation seems to be the most efficient way to maintain synchronization.
>
> -Tom Phinney
>
>
>>     3. TDMA like link protocol as opposed to random access protocol 
>> in order to have  control over Layer 3 topology as well as end-to-end 
>> delay.
>>
>> [email-masked]://www.ietf.org/mailman/listinfo/6tsch
>
>