Subject: [6tsch] minutes WebEx 22 February 2013

From: Thomas Watteyne <[email-masked]>
Date: Fri, 22 Feb 2013 10:57:02 -0800

All,

You will find the minutes I took below. As usual, please resend on this
thread with modifications/additions.

Thomas

----

*** Time is in PST. ***

Present (alphabetically):
- Alfredo Grieco
- Dominique Barthel
- Kris Pister
- Maria Rita Palatella
- Michael Richarson
- Normann Finn
- Pascal Thubert
- Qin Wang
- Raghuram Sudhaakar
- Robert Assimiti
- svshah (please resend with full name)
- Tina Tsou
- Thomas Watteyne
- Tom Phinney
- Xavi Vilajosana

Agenda:
- Status on Orlando meetings [5min]
- Update on
http://tools.ietf.org/html/draft-watteyne-6tsch-tsch-lln-context-01
    . presentation changes
    . discussion on the draft
- time sync. [20min]
    . Summary of last week discussion. Talk on the multiroot case (over a
shared
      backbone). Also, start discussing a model if the backbone is 802.1 TSN
      deterministic ethernet.
- Drafts to come.
    . Archi [Pascal] [10min]
        . TOC
        . authors
    . 6tus [Qin and Xavi] [10min]
        . TOC
        . authors

Minutes:
- [09.07] meeting starts
- Orlando meeting update [Pascal]
    . bar BoF evolves into official meeting. We are going to have a working
      meeting. We are already starting the work. Meeting will look like a
normal
      meeting. We can organize it as a conference. Open discussion, but
progress
      on items.
    . Same meeting time on Tuesday and Wednesday, over lunch. Pascal tries
to
      arrange for pizzas.
        . Tuesday: prepare for BoF
        . Wednesday: present drafts, open technical discussion.
- Update LLN draft [Thomas]
    . presentation of changes
    . request to send comments
- Synchronization
    . If there are multiple DAG roots in the network, should they be
      synchronized?
    . consenus on the call. Motion adopted.
 - [09.24] 802.1 and TSN [Normann]
    . [Pascal] Goal:
        . IP abstraction the same across wireless and wired network
        . consistent with Ethernet semantics
    . [Normann]
        . slides highlight what WG is doing in the WiFi space. Active in
802.1,
          and WiFi
        . 802 is "Ethernet". 802.1 is "higher layers", bridging an up. WG
was called
          "audio video task group", now called TSN.
        . define a profile of IEEE1588. IEEE1588 is a toolbox, which can
provide
          time sync donw to 1us. Work in 802.11 to support time sync; maybe
not
          1us, but some sync.
        . Scheduled queuing. based on clock sync, you can set up so that
queues
          on a bridge can be tied to a time-of-day schedule. E.g., schedule
a
          certain class of service with 0 jitter at some part of the day.
        . 802.1 interworking standard. Idea is not to in spanning trees, but
          use IS-IS to help build schedule. Lots of interop demos. Every
frame
          takes the least-cost path through the network. Two modes:
            . MAC-in-MAC
            . 802.1Qbz to put WiFi in middle of network, not on edge. AP is
a
              bridge, not an intermediate. WiFi stations can be
interconnected
              by a combination of wireless and wires.
        . one of characteristics of a bridged topology control protocols is
          that it operates per VLAN. Some VLANs can be under control of RPL.
    . Clarifying questions.
        . [Pascal] how can time/schedules pass across boundary between
802.15.4
          and TSN world?
        . [Michael] Could IS-IS express some ETX (or other metric)?
        . [Thomas] We need to discuss 802.1 more, maybe at Orlando.
        . [Normann] Maybe will attend Tuesday meetings.
- [09.50] Presentation of 6tus adaptation layer [Xavi, Qin]
    . present slides
    . [Thomas] will get slot in Wednesday Orlando meeting to discuss this
- [10.10] meeting ends

---

From: "Shitanshu Shah (svshah)" <[email-masked]>
Date: Fri, 22 Feb 2013 18:59:37 +0000

Shitanshu Shah

From: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>
Date: Friday, February 22, 2013 10:57 AM
To: IETF 6TSCH <[email-masked]<mailto:[email-masked]>>
Subject: [6tsch] minutes WebEx 22 February 2013

All,

You will find the minutes I took below. As usual, please resend on this thread with modifications/additions.

Thomas

----

*** Time is in PST. ***

Agenda:
- Status on Orlando meetings [5min]
- Update on http://tools.ietf.org/html/draft-watteyne-6tsch-tsch-lln-context-01
    . presentation changes
    . discussion on the draft
- time sync. [20min]
    . Summary of last week discussion. Talk on the multiroot case (over a shared
      backbone). Also, start discussing a model if the backbone is 802.1 TSN
      deterministic ethernet.
- Drafts to come.
    . Archi [Pascal] [10min]
        . TOC
        . authors
    . 6tus [Qin and Xavi] [10min]
        . TOC
        . authors

Minutes:
- [09.07] meeting starts
- Orlando meeting update [Pascal]
    . bar BoF evolves into official meeting. We are going to have a working
      meeting. We are already starting the work. Meeting will look like a normal
      meeting. We can organize it as a conference. Open discussion, but progress
      on items.
    . Same meeting time on Tuesday and Wednesday, over lunch. Pascal tries to
      arrange for pizzas.
        . Tuesday: prepare for BoF
        . Wednesday: present drafts, open technical discussion.
- Update LLN draft [Thomas]
    . presentation of changes
    . request to send comments
- Synchronization
    . If there are multiple DAG roots in the network, should they be
      synchronized?
    . consenus on the call. Motion adopted.
 - [09.24] 802.1 and TSN [Normann]
    . [Pascal] Goal:
        . IP abstraction the same across wireless and wired network
        . consistent with Ethernet semantics
    . [Normann]
        . slides highlight what WG is doing in the WiFi space. Active in 802.1,
          and WiFi
        . 802 is "Ethernet". 802.1 is "higher layers", bridging an up. WG was called
          "audio video task group", now called TSN.
        . define a profile of IEEE1588. IEEE1588 is a toolbox, which can provide
          time sync donw to 1us. Work in 802.11 to support time sync; maybe not
          1us, but some sync.
        . Scheduled queuing. based on clock sync, you can set up so that queues
          on a bridge can be tied to a time-of-day schedule. E.g., schedule a
          certain class of service with 0 jitter at some part of the day.
        . 802.1 interworking standard. Idea is not to in spanning trees, but
          use IS-IS to help build schedule. Lots of interop demos. Every frame
          takes the least-cost path through the network. Two modes:
            . MAC-in-MAC
            . 802.1Qbz to put WiFi in middle of network, not on edge. AP is a
              bridge, not an intermediate. WiFi stations can be interconnected
              by a combination of wireless and wires.
        . one of characteristics of a bridged topology control protocols is
          that it operates per VLAN. Some VLANs can be under control of RPL.
    . Clarifying questions.
        . [Pascal] how can time/schedules pass across boundary between 802.15.4
          and TSN world?
        . [Michael] Could IS-IS express some ETX (or other metric)?
        . [Thomas] We need to discuss 802.1 more, maybe at Orlando.
        . [Normann] Maybe will attend Tuesday meetings.
- [09.50] Presentation of 6tus adaptation layer [Xavi, Qin]
    . present slides
    . [Thomas] will get slot in Wednesday Orlando meeting to discuss this
- [10.10] meeting ends

---

From: "Norman Finn (nfinn)" <[email-masked]>
Date: Fri, 22 Feb 2013 20:56:50 +0000

Corrections in-line.  (: I was talking pretty fast :)  Thanks.

-- Norm

From: "Shitanshu Shah (svshah)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, February 22, 2013 10:59 AM
To: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>, IETF 6TSCH <[email-masked]<mailto:[email-masked]>>
Subject: Re: [6tsch] minutes WebEx 22 February 2013

Shitanshu Shah

All,

Thomas

----

*** Time is in PST. ***

Agenda:

Minutes:
- [09.07] meeting starts
                               802.1AS defines a profile of IEEE 1588.  …
                               certain class of service with 0 jitter at some microsecond in the day.
                                     .  Same data plane as for spanning tree
                       <following point "802.1Qbz …" should be one level to the left.

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 22 Feb 2013 13:42:23 -0800

Shitanshu, Norman
Thanks!

On Fri, Feb 22, 2013 at 12:56 PM, Norman Finn (nfinn) <[email-masked]>wrote:

>   From: "Shitanshu Shah (svshah)" <[email-masked]>
> To: Thomas Watteyne <[email-masked]>, IETF 6TSCH <
> [email-masked]>
>   From: Thomas Watteyne <[email-masked]>
> To: IETF 6TSCH <[email-masked]>