Subject: [6tsch] Agenda for the May 3rd call

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 3 May 2013 06:07:18 +0000

A Oups in the title now fixed

This is the weekly Friday call...

From: [email-masked] [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: jeudi 2 mai 2013 19:51
To: [email-masked]
Cc: Thomas Watteyne ([email-masked])
Subject: [6tsch] Agenda for the May 2nd call

Dear all:

Recent exchanges on the ML, on 6TUS and on the PCEP discussion, indicate that we could use a next level of the architecture document that would zoom in the building blocks that we have identified so far, in order to see what they are made of:
- 6TUS has a scheduler for IP packets from L3, a slot negotiation protocol between peers, and G-MPLS switching layer that can either follow a track or punt the frame for 6LoWPAN processing;
- Centralized routing has a PCEP-like protocol to obtain a track (and destroy or update it?), an OAM protocol to validate a track is still good enough, a new link-state-like protocol to inform the PCE of links and (RPL's?) metrics;
- WiND has a proxy operation, and a registration/lookup function;
- RSVP has all that Xavi listed
- link/peering management has a discovery (EB, RPL) and a measurement (BFD?) functionality

All in all, we could easily spend 10 min on each just to agree on the subblocks within each main building block. Once we have that, we can probably respin an architecture doc and have a better evaluation of the workload ahead.

So I'd propose:

- update charter: security paragraph:                  5 mn
- link / peering management                             10 mn
- 6TUS building blocks                                     10 mn
- centralized routing building blocks                10 mn
- distributed routing building blocks                10 mn
- Wireless ND                                                   10 mn

As usual, please let us know if you wish to add an item, and remember that we plan to record and publish the session.

Cheers,

Pascal

Topic: 6TSCH Weekly
Date: Friday, April 26, 2013
Time: 8:00 am, Pacific Daylight Time (San Francisco, GMT-07:00)
Meeting Number: 206 802 913
Meeting Password: sixtus
Host Key: 121469

-------------------------------------------------------
To start the online meeting
-------------------------------------------------------
1. Go to https://ciscosales.webex.com/ciscosales/j.php?ED=219615007&UID=481905242&PW=NZTRkNDAwOTE1&RT=MiMyMw%3D%3D
2. Log in to your account.
3. Click "Start Now".
4. Follow the instructions that appear on your screen.

----------------------------------------------------------------
ALERT:Toll-Free Dial Restrictions for (408) and (919) Area Codes
----------------------------------------------------------------

The affected toll free numbers are: (866) 432-9903 for the San Jose/Milpitas area and (866) 349-3520 for the RTP area.

Please dial the local access number for your area from the list below:
- San Jose/Milpitas (408) area: 525-6800
- RTP (919) area: 392-3330

-------------------------------------------------------
To join the teleconference only
-------------------------------------------------------
1. Dial into Cisco WebEx (view all Global Access Numbers at
http://cisco.com/en/US/about/doing_business/conferencing/index.html
2. Follow the prompts to enter the Meeting Number (listed above) or Access Code followed by the # sign.

San Jose, CA: +1.408.525.6800 RTP: +1.919.392.3330

US/Canada: +1.866.432.9903 United Kingdom: +44.20.8824.0117

India: +91.80.4350.1111 Germany: +49.619.6773.9002

Japan: +81.3.5763.9394 China: +86.10.8515.5666

To check whether you have the appropriate players installed for UCF (Universal Communications Format) rich media files, go to https://ciscosales.webex.com/ciscosales/systemdiagnosis.php

http://www.webex.com

---

From: Thomas Watteyne <[email-masked]>
Date: Thu, 2 May 2013 23:31:06 -0700

Pascal,

Thanks for fixing the title, and for the very nice list.

I'd like to add the following thought. We need a way for the PCE to contact
the motes along a track to install the hard cells. That is, while PCEP can
be used for mote A to express a need for a track to mote D, and for the PCE
to indicate that this request has been satisfied, I don't see how PCEP
(alone) will install these resources. The discussion
will undoubtedly involve Xavi's idea of using a RSVP/NSIS-like for that.
The answer might be a cooperation between PCEP, RSVP/NSIS and 6tus.

Looking forward to this discussion!

Thomas

On Thu, May 2, 2013 at 11:07 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  A Oups in the title now fixed****
>
> ** **
>
> This is the weekly Friday call…****
>
> ** **
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Pascal Thubert (pthubert)
> *Sent:* jeudi 2 mai 2013 19:51
> *To:* [email-masked]
> *Cc:* Thomas Watteyne ([email-masked])
> *Subject:* [6tsch] Agenda for the May 2nd call****
>
> ** **
>
> Dear all:****
>
> * *
>
> Recent exchanges on the ML, on 6TUS and on the PCEP discussion, indicate
> that we could use a next level of the architecture document that would zoom
> in the building blocks that we have identified* *so far, in order to see
> what they are made of:****
>
> - 6TUS has a scheduler for IP packets from L3, a slot negotiation protocol
> between peers, and G-MPLS switching layer that can either follow a track or
> punt the frame for 6LoWPAN processing;  ****
>
> - Centralized routing has a PCEP-like protocol to obtain a track (and
> destroy or update it?), an OAM protocol to validate a track is still good
> enough, a new link-state-like protocol to inform the PCE of links and
> (RPL’s?) metrics;****
>
> - WiND has a proxy operation, and a registration/lookup function;****
>
> - RSVP has all that Xavi listed****
>
> - link/peering management has a discovery (EB, RPL) and a measurement
> (BFD?) functionality ****
>
> ** **
>
> All in all, we could easily spend 10 min* *on each* *just to agree on the
> subblocks within each* *main building block. Once we have that, we can
> probably respin an architecture doc and have a better evaluation of the
> workload ahead.****
>
> * *
>
> So I’d propose:****
>
> ** **
>
> * *
>
> *- update charter: security paragraph:                  5 mn*
>
> *- link / peering management                             10 mn*
>
> *- 6TUS building blocks                                     10 mn*
>
> *- centralized routing building blocks                10 mn*
>
> *- distributed routing building blocks                10 mn*
>
> *- Wireless ND                                                   10 mn*
>
> ** **
>
> As usual, please let us know if you wish to add an item, and remember that
> we plan to record and publish the session.****
>
> ** **
>
> Cheers,****
>
> ** **
>
> Pascal****
>
> ** **
>
> ** **
>
>
> Topic: 6TSCH Weekly
> 1. Go to
> https://ciscosales.webex.com/ciscosales/j.php?ED=219615007&UID=481905242&PW=NZTRkNDAwOTE1&RT=MiMyMw%3D%3D
> The affected toll free numbers are: (866) 432-9903 for the San
> Jose/Milpitas area and (866) 349-3520 for the RTP area.
>
> To check whether you have the appropriate players installed for UCF
> (Universal Communications Format) rich media files, go to
> https://ciscosales.webex.com/ciscosales/systemdiagnosis.php
>
> http://www.webex.com
>
> ****
>
> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 3 May 2013 06:36:14 +0000

Yes, Thomas,

I'm also unclear on whether and how PCEP installs states in intermediate routers.  CC'ing Julien (JP is not available today) in case he can shed some light either on the ML or the call today.
Note that we have only 10 minutes at this call and that the primary goal is to detail the architecture subblocks we need so that later we can figure what PCEP actually covers and what remains to be done.
I expect we'll dedicate sessions on that.

Pascal

From: Thomas Watteyne [mailto:[email-masked]]
Sent: vendredi 3 mai 2013 08:27
To: Pascal Thubert (pthubert)
Cc: [email-masked]
Subject: Re: [6tsch] Agenda for the May 3rd call

Pascal,

I'd like to add the following thought. We need a way for the PCE to contact the motes along a track to install the hard cells. That is, while PCEP can be used for mote A to express a need for a track to mote D, and for the PCE to indicate that this request has been satisfied, I don't see how PCEP (alone) will install these resources. The discussion will undoubtedly involve Xavi's idea of using a RSVP/NSIS-like for that.

Thomas

On Thu, May 2, 2013 at 11:07 PM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
A Oups in the title now fixed

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Pascal Thubert (pthubert)
Sent: jeudi 2 mai 2013 19:51
To: [email-masked]<mailto:[email-masked]>
Cc: Thomas Watteyne ([email-masked]<mailto:[email-masked]>)
Subject: [6tsch] Agenda for the May 2nd call

Dear all:

So I'd propose:

Cheers,

Pascal

Topic: 6TSCH Weekly

The affected toll free numbers are: (866) 432-9903<tel:%28866%29%20432-9903> for the San Jose/Milpitas area and (866) 349-3520<tel:%28866%29%20349-3520> for the RTP area.

San Jose, CA: +1.408.525.6800<tel:%2B1.408.525.6800> RTP: +1.919.392.3330<tel:%2B1.919.392.3330>

US/Canada: +1.866.432.9903<tel:%2B1.866.432.9903> United Kingdom: +44.20.8824.0117<tel:%2B44.20.8824.0117>

India: +91.80.4350.1111<tel:%2B91.80.4350.1111> Germany: +49.619.6773.9002<tel:%2B49.619.6773.9002>

Japan: +81.3.5763.9394<tel:%2B81.3.5763.9394> China: +86.10.8515.5666<tel:%2B86.10.8515.5666>

http://www.webex.com

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch

--
Thomas Watteyne, Ph. D
Sr. Networking Design Engineer
Dust Networks / Linear Technology
30695 Huntwood Ave
Hayward, CA 94544-7021
+1 (510) 400-2978
[email-masked]<mailto:[email-masked]>

This e-mail transmission, and any documents, files or previous e-mail messages attached to it may contain confidential information that is legally privileged. If you are not the intended recipient, or a person responsible for delivering it to the intended recipient, you are hereby notified that any disclosure, copying, distribution or use of any of the information contained in or attached to this transmission is STRICTLY PROHIBITED. If you have received this transmission in error, please immediately notify me by reply e-mail, or by telephone at (510) 400-2978, and destroy the original transmission and its attachments without reading or saving in any manner. Thank you.