Subject: [6tsch] scheduling of cells

From: mehdi sabzevari <[email-masked]>
Date: Fri, 13 Sep 2013 21:47:47 -0700 (PDT)

Hi All
I have a question about scheduling of cell as shared/dedicated, Previously thanks for your request. :)
 What is the best time(place) for scheduling a cell as shared/dedicated? Can it be scheduled by advertisement? or It should be schedule before communication of peers?

Regards
Mehdi

---

From: mehdi sabzevari <[email-masked]>
Date: Fri, 13 Sep 2013 21:56:01 -0700 (PDT)

Ohhhh... Excuse me
Previously thanks for your response. :)

Mehdi

________________________________
 From: mehdi sabzevari <[email-masked]>
To: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]> 
Sent: Saturday, September 14, 2013 9:17 AM
Subject: [6tsch] scheduling of cells

Hi All

Regards
Mehdi

_______________________________________________
6tsch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tsch

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 17 Sep 2013 19:24:02 -0700

Mehdi,

The IEEE802.15.4e standard [1] allows you to put information about the
cells to use in two places:
- as part of the the "TSCH Slotframe and Link" Information Element,
directly inside the Enhanced Beacon (EB). I believe the EB is what you call
advertisement. You can use this method indicate to a joining nodes a
minimal set of cells to contact the network, which will then install more
permanent cells.
- as part of an upper-layer protocol, which it what we are currently
discussing in the 6TiSCH group. This protocol would allow either a central
PCE, or a distributed scheduling entity to contact a node and give it the
list of cells to install.

This is hopefully clearly explained in
draft-watteyne-6tsch-tsch-lln-context [2]

As detailed in our charter [3], the 6TiSCH is cutting the problem in two
steps:
- in the first step, we only consider the minimal set of cells to enable
communication. This is detailed in draft-vilajosana-6tsch-basic [4], and
one could imagine that this cells are installed through the EBs
- in a second step, the PCE learns about the nodes in the network, and
installs the necessary cells using this higher-level protocol [5]. We are
currently discussing CoAP and CBOR as candidates for that protocol.

I hope this answers your question,
Thomas

[1] http://standards.ieee.org/getieee802/download/802.15.4e-2012.pdf
[2] http://tools.ietf.org/html/draft-watteyne-6tsch-tsch-lln-context-02
[3] https://datatracker.ietf.org/doc/charter-ietf-6tisch/
[4] http://tools.ietf.org/html/draft-vilajosana-6tsch-basic-01
[5] http://www.ietf.org/mail-archive/web/6tsch/current/msg01220.html

On Fri, Sep 13, 2013 at 9:56 PM, mehdi sabzevari
<[email-masked]>wrote:

>   ------------------------------
>  *From:* mehdi sabzevari <[email-masked]>
> *To:* "[email-masked]" <[email-masked]>; "[email-masked]" <
> [email-masked]>
> *Sent:* Saturday, September 14, 2013 9:17 AM
> *Subject:* [6tsch] scheduling of cells
>
> Hi All
>  What is the best time(place) for scheduling a cell as shared/dedicated?
> Can it be scheduled by advertisement? or It should be schedule before
> communication of peers?
>
>
> Regards
> Mehdi
>
>