Subject: Re: [6tsch] About the special type of event to ask PCE to create a track

From: Thomas Watteyne <[email-masked]>
Date: Tue, 3 Sep 2013 19:12:59 -0700

Qin,

Thanks for bringing that up. Allow me to answer in Pascal's place. We are
talking about the format of the packets exchanged between the ME and the
nodes. In the centralized case, these are application-level packets, i.e.
packet generated by an entity a couple of layer above 6top. That entity
talks with the PCE over the network, and with 6top through the API
(internal to the node) as defined in
http://tools.ietf.org/html/draft-wang-6tsch-6top-00#section-2.4.

If we agree on that, the question is whether the packet the node sends to
establish a new track is part of the event flow, or not. In both cases, it
would originate from this application-level entity, but possibly
transported in different ways.

Thomas

On Fri, Aug 30, 2013 at 11:01 AM, Qin Wang <[email-masked]> wrote:

> Hi Pascal,
>
> My understanding is that 6top is a passive role in dealing with cell/track
> reservation. In another word, the 6top in a node can report its state,
> including neighbor table, cell usage, and other statistics information, but
> can not make decision on if some cells/track should be added or removed,
> which should be the responsibility of PCE in centralized case or upper
> layer in distributed case. Thus, I can not see when the 5th flow will be
> used. Can you explain more?
>
> Thanks
> Qin
>
>
> On Sat, Aug 31, 2013 at 12:08 AM, Pascal Thubert (pthubert) <
> [email-masked]> wrote:
>
>> Dear all,
>>
>> We discussed at the call that the(PCEP?) request to ask for a track
>> establishment could be seen as an event, or could be a new flow.
>> At the call, I suggested that it could be a new, 5th flow. My arguments
>> are that this flow:
>> - Probably yields different data format. The demand carries and points,
>> end to end latency and bandwidth. That's quite specific.
>> - Probably yields a different flow. Events do not necessarily have a
>> response.
>> - Probably uses a different transport as well (PCEP vs. CoAP)
>>
>> What do you think?
>>
>> Pascal
>> _______________________________________________
>> 6tsch mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/6tsch
>>
>
>
> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch

 <https://www.ietf.org/mailman/listinfo/6tsch>

---

From: Qin Wang <[email-masked]>
Date: Thu, 5 Sep 2013 05:12:18 +0800

Hi Thomas,

Thanks for your explanation. You are saying the request packet from node is
generated by the upper layer of 6top, correct?

If so, since the request packet is generated by upper layer of 6top,
instead of 6top internal events like alarm, I think it is reasonable to add
the 5th control flow.

What do you think?

Qin

On Wed, Sep 4, 2013 at 10:12 AM, Thomas Watteyne <[email-masked]
> wrote:

>> My understanding is that 6top is a passive role in dealing with
>> cell/track reservation. In another word, the 6top in a node can report its
>> state, including neighbor table, cell usage, and other statistics
>> information, but can not make decision on if some cells/track should be
>> added or removed, which should be the responsibility of PCE in centralized
>> case or upper layer in distributed case. Thus, I can not see when the 5th
>> flow will be used. Can you explain more?
>>
>> Thanks
>> Qin
>>
>>

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 4 Sep 2013 14:29:54 -0700

I would agree that a 5th flow makes sense, especially because it allows us
to use different transport mechanisms for the report flow (CoAP?) and this
new flows (CoAP now? maybe PCEP later?).

Do what do we call this new flow? "Schedule update request" is a bit long.

Thomas

On Wed, Sep 4, 2013 at 2:12 PM, Qin Wang <[email-masked]> wrote:

> Hi Thomas,
>
> Thanks for your explanation. You are saying the request packet from node
> is generated by the upper layer of 6top, correct?
>
> On Wed, Sep 4, 2013 at 10:12 AM, Thomas Watteyne <
> [email-masked]> wrote:
>
>> Qin,
>>

---

From: Qin Wang <[email-masked]>
Date: Thu, 5 Sep 2013 06:10:00 +0800

Thomas,

I think "Flow" is a process to exchange messages for a given objective. For
example, action flow consists of a Action Request from ME to 6top, and a
Execution Confirm (Succ/Fail) from 6top to ME. But, "Schedule update
request" looks like one step of a process. I would like to suggest that the
5th flow is called "Schedule update flow", consists of a "Schedule update
request" from node to PCE, and something like "Track/cell installation"
from PCE to node.

Make sense?
Qin

On Thu, Sep 5, 2013 at 5:29 AM, Thomas Watteyne
<[email-masked]>wrote:

>>> Thanks for bringing that up. Allow me to answer in Pascal's place. We
>>> are talking about the format of the packets exchanged between the ME and
>>> the nodes. In the centralized case, these are application-level packets,
>>> i.e. packet generated by an entity a couple of layer above 6top. That
>>> entity talks with the PCE over the network, and with 6top through the API
>>> If we agree on that, the question is whether the packet the node sends
>>> to establish a new track is part of the event flow, or not. In both cases,
>>> it would originate from this application-level entity, but possibly
>>>>> At the call, I suggested that it could be a new, 5th flow. My
>>>>> arguments are that this flow:
>>>>> - Probably yields different data format. The demand carries and
>>>>> points, end to end latency and bandwidth. That's quite specific.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 5 Sep 2013 05:29:03 +0000

+1

Pascal

Le 5 sept. 2013 à 00:10, "Qin Wang" <[email-masked]<mailto:[email-masked]>> a écrit :

Thomas,

I think "Flow" is a process to exchange messages for a given objective. For example, action flow consists of a Action Request from ME to 6top, and a Execution Confirm (Succ/Fail) from 6top to ME. But, "Schedule update request" looks like one step of a process. I would like to suggest that the 5th flow is called "Schedule update flow", consists of a "Schedule update request" from node to PCE, and something like "Track/cell installation" from PCE to node.

Make sense?
Qin

On Thu, Sep 5, 2013 at 5:29 AM, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> wrote:
I would agree that a 5th flow makes sense, especially because it allows us to use different transport mechanisms for the report flow (CoAP?) and this new flows (CoAP now? maybe PCEP later?).

Thomas

On Wed, Sep 4, 2013 at 2:12 PM, Qin Wang <[email-masked]<mailto:[email-masked]>> wrote:
Hi Thomas,

Thanks for your explanation. You are saying the request packet from node is generated by the upper layer of 6top, correct?

If so, since the request packet is generated by upper layer of 6top, instead of 6top internal events like alarm, I think it is reasonable to add the 5th control flow.

What do you think?

Qin

On Wed, Sep 4, 2013 at 10:12 AM, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> wrote:
Qin,

Thanks for bringing that up. Allow me to answer in Pascal's place. We are talking about the format of the packets exchanged between the ME and the nodes. In the centralized case, these are application-level packets, i.e. packet generated by an entity a couple of layer above 6top. That entity talks with the PCE over the network, and with 6top through the API (internal to the node) as defined in http://tools.ietf.org/html/draft-wang-6tsch-6top-00#section-2.4.

If we agree on that, the question is whether the packet the node sends to establish a new track is part of the event flow, or not. In both cases, it would originate from this application-level entity, but possibly transported in different ways.

Thomas

On Fri, Aug 30, 2013 at 11:01 AM, Qin Wang <[email-masked]<mailto:[email-masked]>> wrote:
Hi Pascal,

My understanding is that 6top is a passive role in dealing with cell/track reservation. In another word, the 6top in a node can report its state, including neighbor table, cell usage, and other statistics information, but can not make decision on if some cells/track should be added or removed, which should be the responsibility of PCE in centralized case or upper layer in distributed case. Thus, I can not see when the 5th flow will be used. Can you explain more?

Thanks
Qin

On Sat, Aug 31, 2013 at 12:08 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

We discussed at the call that the(PCEP?) request to ask for a track establishment could be seen as an event, or could be a new flow.
At the call, I suggested that it could be a new, 5th flow. My arguments are that this flow:
- Probably yields different data format. The demand carries and points, end to end latency and bandwidth. That's quite specific.
- Probably yields a different flow. Events do not necessarily have a response.
- Probably uses a different transport as well (PCEP vs. CoAP)

What do you think?

Pascal
_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch
<https://www.ietf.org/mailman/listinfo/6tsch>

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 4 Sep 2013 23:21:58 -0700

Qin,

When a node makes a request for a schedule update to the PCE, the PCE will
have to update the schedule of all the nodes along the track. It might do
so using the Action flow. The 5th flow might only be used to (1) request
the update and (2) for the mote to request the status of its request and
(3) for the ME to indicate the success/failure of the request. As such, I
would not include "Track/cell installation" in the 5th flow, but rather in
the Action flow.

Thomas

On Wed, Sep 4, 2013 at 10:29 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  +1
>
> Pascal
>
> Le 5 sept. 2013 à 00:10, "Qin Wang" <[email-masked]> a écrit :
>
>   Thomas,
>
>  I think "Flow" is a process to exchange messages for a given objective.
> For example, action flow consists of a Action Request from ME to 6top, and
> a Execution Confirm (Succ/Fail) from 6top to ME. But, "Schedule update
> On Thu, Sep 5, 2013 at 5:29 AM, Thomas Watteyne <
>> I would agree that a 5th flow makes sense, especially because it allows
>> us to use different transport mechanisms for the report flow (CoAP?) and
>> this new flows (CoAP now? maybe PCEP later?).
>>
>>>  Thanks for your explanation. You are saying the request packet from
>>> node is generated by the upper layer of 6top, correct?
>>>
>>>>  If we agree on that, the question is whether the packet the node
>>>> sends to establish a new track is part of the event flow, or not. In both
>>>> cases, it would originate from this application-level entity, but possibly
>>>> On Fri, Aug 30, 2013 at 11:01 AM, Qin Wang <[email-masked]>wrote:
>>>>
>>>>> Hi Pascal,
>>>>>

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Thu, 5 Sep 2013 06:46:38 +0000

I agree too. If we want to cut the name shorter, maybe we can just call it " Schedule Flow" (removing the update).
In the end, we know that this flow will happen when a node asks the PCE to update its schedule, and add/remove cells/tracks. What do you think?
Maria Rita

From: [email-masked] [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, September 05, 2013 7:29 AM
To: Qin Wang
Cc: Thomas Watteyne; [email-masked]
Subject: Re: [6tsch] About the special type of event to ask PCE to create a track

+1

Pascal

Make sense?
Qin

Thomas

What do you think?

Qin

Thomas

Thanks
Qin

What do you think?

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 5 Sep 2013 07:02:01 +0000

Fine with me Maria Rita,

But note that there is also a flow that fits the name "schedule flow" that is stimulated by the Net mgt Entity in the admin console as opposed to the mt entity in the device.
Same thing, this creates a req to the PCE to install a track. Do we want to merge those 2 flows? - I think so.

Cheers,

Pascal

From: Maria Rita PALATTELLA [mailto:[email-masked]]
Sent: jeudi 5 septembre 2013 08:47
To: Pascal Thubert (pthubert); Qin Wang
Cc: Thomas Watteyne; [email-masked]
Subject: RE: [6tsch] About the special type of event to ask PCE to create a track

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, September 05, 2013 7:29 AM
To: Qin Wang
Cc: Thomas Watteyne; [email-masked]<mailto:[email-masked]>
Subject: Re: [6tsch] About the special type of event to ask PCE to create a track

+1

Pascal

Make sense?
Qin

Thomas

What do you think?

Qin

Thomas

Thanks
Qin

What do you think?

Pascal

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Thu, 5 Sep 2013 07:16:18 +0000

It makes sense for me. Even though they are generated by different entities, they are both addressed to the PCE, and they have the same final aim.
Maria Rita

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Thursday, September 05, 2013 9:02 AM
To: Maria Rita PALATTELLA; Qin Wang
Cc: Thomas Watteyne; [email-masked]
Subject: RE: [6tsch] About the special type of event to ask PCE to create a track

Fine with me Maria Rita,

Cheers,

Pascal

+1

Pascal

Make sense?
Qin

Thomas

What do you think?

Qin

Thomas

Thanks
Qin

What do you think?

Pascal