Subject: [6tsch] Fwd: 6TiSCH: about join priority in IEEE802.15.4e

From: Thomas Watteyne <[email-masked]>
Date: Tue, 17 Sep 2013 18:59:44 -0700

All,

Please find below an e-mail exchange I had with Jonathan Simon, co-editor
of the IEEE802.15.4e standard. He is confirming that driving the join
priority field in the enhanced beacons from an upper layer does not break
standards-compliance, which is great news.

His second point is also very interesting: we could use just the "integer"
portion of the rank in the join priority, so that the value announced is
roughly equivalent to a hop count.

Would that work?

Thomas

---------- Forwarded message ----------
From: Jonathan Simon <[email-masked]>
Date: Tue, Sep 17, 2013 at 10:14 AM
Subject: Re: 6TiSCH: about join priority in IEEE802.15.4e
To: Thomas Watteyne <[email-masked]>

Thomas -  The join priority was intended to be used in the way you
describe.  Note that join priority is described somewhat vaguely in the
text - the spec does not say what to use it for other beyond a MAC
management layer function of selecting a prospective parent, and no service
primitives are described to set or change it.   The spec does not use the
proscriptive "shall" or "must" language, and I certainly intended it as a
default in absence of other upper layer methods to manage it.

So as to 1), updating the join priority to reflect a node's actual position
in the network rather than its "birth" position is a good idea.
 WirelessHART has this capability.
For 2),  the important thing is that all devices in the network should be
using join priority in the same way to avoid confusion. Making the
objective function scale in integer hops seems intuitive and simple and
matches the default description, but if each device was n "hops" from its
parent, it would serve the same purpose.

Hope this answers your questions. Feel free to forward this to the 6TiSCH
group.

Jonathan
 --
Jonathan Simon, Ph. D
Director of Systems Engineering
Linear Technology, Dust Networks product group
30695 Huntwood Ave
Hayward, CA 94544-7021
(510) 400-2936
(510) 489-3799 FAX
[email-masked]

**LINEAR TECHNOLOGY CORPORATION**
*****Internet Email Confidentiality Notice*****
 This e-mail transmission, and any documents, files or previous
e-mail messages attached to it may contain confidential information that
is legally privileged. If you are not the intended recipient, or a
person responsible for delivering it to the intended recipient, you are
hereby notified that any disclosure, copying, distribution or use of any of
the information contained in or attached to this transmission is
STRICTLY PROHIBITED. If you have received this transmission in error,
please immediately notify me by reply e-mail, or by telephone at (510)
400-2936, and destroy the original transmission and its attachments without
reading or saving in any manner. Thank you.

On Sep 12, 2013, at 12:53 PM, Thomas Watteyne wrote:

Jonathan,

We are discussing the interaction between IEEE802.15.4e and the RPL routing
protocol in the 6TiSCH group (see minutes last call at [1]).

We have some questions about the "Join Priority" field in the IEEE802.15.4e
EB, in particular about how much an upper layer (6top [2]) can influence
its value. We want to make sure that we do not break compliance with the
IEEE802.15.4e standard.

For reference, this is the text in IEEE802.15.4e (p.90):

The 1-octet Join Priority field can be used by a joining device to select
among beaconing devices when multiple beacons are heard. The PAN
coordinator’s join priority is zero. A lower value of join priority
indicates that the device is the preferred one to connect to. The beaconing
device’s join priority is the lowest join priority heard when it joined the
network plus one.

We have the following discussions:

   1. After a node has joined, it might be moving to a different
   topological location. In that case, it should update the Join Priority it
   is announcing. Luckily, RPL maintains the node's rank, a concept very
   similar to join priority.
   *Question*: Can we have the 6top change the priority announced by
   IEEE802.15.4e to the RPL rank (or a number calculated from the RPL rank)
   after the node has joined?
   2. RPL is very flexible about how rank is calculated. Depending on the
   Objective Function used, the rank can be calculated differently. In
   particular, the difference of the rank between a node and routing parent
   can be different from 1.
   *Question*: Can the join priority announced by node and its parent be
   different by more than 1?

Your input is very welcome,

Thomas

[1] https://bitbucket.org/6tsch/meetings/wiki/130906_webex
[2] http://tools.ietf.org/html/draft-wang-6tsch-6top-00

---

From: Xavier Vilajosana Guillen <[email-masked]>
Date: Wed, 18 Sep 2013 07:41:03 -0700

Hi Thomas,

when you say the "the "integer" portion of the rank in the join priority,"
you mean the result of the DAGRank(rank) function?

Cheers
Xavi

On Tue, Sep 17, 2013 at 6:59 PM, Thomas Watteyne <[email-masked]
> wrote:

> So as to 1), updating the join priority to reflect a node's actual
> position in the network rather than its "birth" position is a good idea.
> 400-2936, and destroy the original transmission and its
> attachments without reading or saving in any manner. Thank you.
>
> We are discussing the interaction between IEEE802.15.4e and the RPL
> routing protocol in the 6TiSCH group (see minutes last call at [1]).
>
> We have some questions about the "Join Priority" field in the
> IEEE802.15.4e EB, in particular about how much an upper layer (6top [2])
> can influence its value. We want to make sure that we do not break
> compliance with the IEEE802.15.4e standard.
>
> device’s join priority is the lowest join priority heard when it joined
> the network plus one.
>
> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 18 Sep 2013 15:16:10 +0000

Hello Xavi

I hope so. As you point out, it is the intention of the DAGRank() is to obtain an octet that is monotonically incrementing with the depth.
So I agree it is a perfect match for the join priority and that is  what I documented in the latest architecture in the repo based on the last 2 calls.

https://bitbucket.org/6tsch/draft-thubert-6tsch-architecture/src/faeea553413ba1f5be89cf7d9edb549b837ebe27/draft-thubert-6tsch-architecture-03.txt?at=master#cl-667

I'd appreciate you have a look to review my text there : )

cheers,

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of Xavier Vilajosana Guillen
Sent: mercredi 18 septembre 2013 16:41
To: Thomas Watteyne
Cc: 6TSCH
Subject: Re: [6tsch] Fwd: 6TiSCH: about join priority in IEEE802.15.4e

Hi Thomas,

when you say the "the "integer" portion of the rank in the join priority," you mean the result of the DAGRank(rank) function?
Cheers
Xavi

On Tue, Sep 17, 2013 at 6:59 PM, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> wrote:
All,

Please find below an e-mail exchange I had with Jonathan Simon, co-editor of the IEEE802.15.4e standard. He is confirming that driving the join priority field in the enhanced beacons from an upper layer does not break standards-compliance, which is great news.

His second point is also very interesting: we could use just the "integer" portion of the rank in the join priority, so that the value announced is roughly equivalent to a hop count.

Would that work?

Thomas
---------- Forwarded message ----------
From: Jonathan Simon <[email-masked]<mailto:[email-masked]>>
Date: Tue, Sep 17, 2013 at 10:14 AM
Subject: Re: 6TiSCH: about join priority in IEEE802.15.4e
To: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>

Thomas -  The join priority was intended to be used in the way you describe.  Note that join priority is described somewhat vaguely in the text - the spec does not say what to use it for other beyond a MAC management layer function of selecting a prospective parent, and no service primitives are described to set or change it.   The spec does not use the proscriptive "shall" or "must" language, and I certainly intended it as a default in absence of other upper layer methods to manage it.

So as to 1), updating the join priority to reflect a node's actual position in the network rather than its "birth" position is a good idea.  WirelessHART has this capability.
For 2),  the important thing is that all devices in the network should be using join priority in the same way to avoid confusion. Making the objective function scale in integer hops seems intuitive and simple and matches the default description, but if each device was n "hops" from its parent, it would serve the same purpose.

Hope this answers your questions. Feel free to forward this to the 6TiSCH group.

Jonathan
--
Jonathan Simon, Ph. D
Director of Systems Engineering
Linear Technology, Dust Networks product group
30695 Huntwood Ave
Hayward, CA 94544-7021
(510) 400-2936<tel:%28510%29%20400-2936>
(510) 489-3799<tel:%28510%29%20489-3799> FAX
[email-masked]<mailto:[email-masked]>

**LINEAR TECHNOLOGY CORPORATION**
*****Internet Email Confidentiality Notice*****
 This e-mail transmission, and any documents, files or previous e-mail messages attached to it may contain confidential information that is legally privileged. If you are not the intended recipient, or a person responsible for delivering it to the intended recipient, you are hereby notified that any disclosure, copying, distribution or use of any of the information contained in or attached to this transmission is STRICTLY PROHIBITED. If you have received this transmission in error, please immediately notify me by reply e-mail, or by telephone at (510) 400-2936<tel:%28510%29%20400-2936>, and destroy the original transmission and its attachments without reading or saving in any manner. Thank you.

Jonathan,

We are discussing the interaction between IEEE802.15.4e and the RPL routing protocol in the 6TiSCH group (see minutes last call at [1]).

We have some questions about the "Join Priority" field in the IEEE802.15.4e EB, in particular about how much an upper layer (6top [2]) can influence its value. We want to make sure that we do not break compliance with the IEEE802.15.4e standard.

The 1-octet Join Priority field can be used by a joining device to select among beaconing devices when multiple beacons are heard. The PAN coordinator's join priority is zero. A lower value of join priority indicates that the device is the preferred one to connect to. The beaconing device's join priority is the lowest join priority heard when it joined the network plus one.

  1.  After a node has joined, it might be moving to a different topological location. In that case, it should update the Join Priority it is announcing. Luckily, RPL maintains the node's rank, a concept very similar to join priority.
Question: Can we have the 6top change the priority announced by IEEE802.15.4e to the RPL rank (or a number calculated from the RPL rank) after the node has joined?
  2.  RPL is very flexible about how rank is calculated. Depending on the Objective Function used, the rank can be calculated differently. In particular, the difference of the rank between a node and routing parent can be different from 1.
Question: Can the join priority announced by node and its parent be different by more than 1?
Your input is very welcome,

Thomas

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 18 Sep 2013 15:31:28 +0000

Less typos with this update actually:
https://bitbucket.org/6tsch/draft-thubert-6tsch-architecture/src/cc01e4a6089eb66151b823783f9cf1df78bc4c75/draft-thubert-6tsch-architecture-03.txt?at=master#cl-667
cheers,
Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: mercredi 18 septembre 2013 17:16
To: [email-masked]; Thomas Watteyne
Cc: 6TSCH
Subject: Re: [6tsch] Fwd: 6TiSCH: about join priority in IEEE802.15.4e

Hello Xavi

cheers,

Pascal

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Xavier Vilajosana Guillen
Sent: mercredi 18 septembre 2013 16:41
To: Thomas Watteyne
Cc: 6TSCH
Subject: Re: [6tsch] Fwd: 6TiSCH: about join priority in IEEE802.15.4e

Hi Thomas,

Would that work?

Thomas
---------- Forwarded message ----------
From: Jonathan Simon <[email-masked]<mailto:[email-masked]>>
Date: Tue, Sep 17, 2013 at 10:14 AM
Subject: Re: 6TiSCH: about join priority in IEEE802.15.4e
To: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>

Jonathan

Jonathan,

Thomas