Subject: [77attendees] Problems connecting to v6 only wireless

From: Zaid Ali <[email-masked]>
Date: Tue, 23 Mar 2010 17:01:59 -0700

I seem to be having trouble connecting to v6 only wireless. Anyone else
experiencing this? Dual stack seems to work fine.

Zaid

---

From: <[email-masked]>
Date: Wed, 24 Mar 2010 01:07:40 +0100

The normal problem is some operating systems are misguided and consider a network without ipv4 to be broken so when their dhcp attempt fails they move on  even if in the interim they have obtained a v6 address.

joel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Zaid Ali
Sent: Tuesday, March 23, 2010 5:02 PM
To: [email-masked]
Subject: [77attendees] Problems connecting to v6 only wireless

Zaid

_______________________________________________
77attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/77attendees

---

From: Zaid Ali <[email-masked]>
Date: Tue, 23 Mar 2010 17:19:29 -0700

I suspected this a little. Last year at IETF I could connect to v6 via my
mac but no DNS. This year it seems another problem !

Thanks,
Zaid

On 3/23/10 5:07 PM, "[email-masked]" <[email-masked]> wrote:

> The normal problem is some operating systems are misguided and consider a
> network without ipv4 to be broken so when their dhcp attempt fails they move
> on  even if in the interim they have obtained a v6 address.
> 
> joel
>

---

From: Hongyu Li <[email-masked]>
Date: Fri, 26 Mar 2010 01:13:48 +0800

Not sure what happens on a PC, but my MAC has no DNS as it can't do DHCPv6. There is some IPv6 addresses, but the system still reports that no internet connection.

Can anybody connect to the network via v6 only network from a MAC?

Hongyu

---

From: Philip Matthews <[email-masked]>
Date: Thu, 25 Mar 2010 14:06:15 -0700

I suggest you try the ietf-nat64 ssid instead.
It has the advantage that, if your destination has a AAAA record or is reachable via IPv6, you will use IPv6.
But if it does not, then the box will translate your packets to IPv4.

I have been using it on my Mac for a few days now. Unfortunately, MacOS 10.6.2 (which I am running) has some IPv6 bugs that make some websites not reachable, but many things work.

When using this:
* I suggest you reboot your Mac first to clear out any A records.
* You must use   2001:df8:0:72::1   as your DNS resolver   (configure in your Network Preferences)

- Philip